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1 Introduction

This paper discusses the benefits and ease of deployment an administrator or project lead can 
realize by deploying the IBM® Rational® ClearCase® Remote Client (CCRC) across an organization 
in a customized, standardized and user friendly manner.

Discussed will be many customizations and options that are not mandated, but that will serve as an 
example for users who want to deploy IBM Rational ClearCase in this fashion.

This paper does not replace the standard practices to install IBM Rational ClearCase. Instead it 
provides an alternative approach that allows for faster deployment of a common, customized client 
that benefits both the end user and the administrative staff of any organization.
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2 Current Clients and Installation Methods

Background

To better understand all the choices for ClearCase installation, some background on the various 
clients and typical needs are important. Using ClearCase Remote Client is not an exclusive client 
decision. ClearCase Remote Client can be used in conjunction or in parallel with any other existing 
ClearCase client.

For a comparison of the features of all the ClearCase clients, review technote 1233090.

● Native ClearCase Client

Sometimes referred to as the Full ClearCase Client (FCC), this client installation can be performed 
from media such as a DVD, but in most enterprise applications, FCC requires a network connection 
to a software release area. An installation of a FCC is really not just a client, it sometimes requires 
services and complex processes that can rival other robust server applications.

• ClearCase Remote Client 

The ClearCase Remote Client was developed to serve as a client that can access ClearCase servers 
in most network configurations, whether it be on a high speed LAN or a potentially latent WAN. 
Regardless of the connection type, ClearCase Remote Client still requires a predictable connection.

There are four choices for users who want to use the ClearCase Remote Client in their organization:
  

1. ClearCase Remote Client
2. ClearCase Remote Client for Eclipse
3. ClearCase Remote Client for Visual Studio. 
4. ClearCase Remote Client (Extension Offering) for Rational Desktop Tools (for example: 

Rational Software Architect, or others)

For the remainder of this document, we will focus on using the ClearCase Remote Client plug-in for 
the Eclipse SDK, but it is important to be aware of all ClearCase Remote Client versions to make 
the best choice in any situation.
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ClearCase Remote Client (also referred to the “standalone client”)

Meant to serve as an installable self contained client application, this client uses the Rich Client 
Platform (RCP technology). RCP is used by vendors to leverage Eclipse technologies and serve as a 
standalone application.

More details regarding RCP can be found at http://wiki.eclipse.org/Rich_Client_Platform.

The benefits of this client is that it is self contained, and once the archive file is downloaded locally and 
unpacked, the installation will handle installation of RCP, this client includes its own JRE as well.

The standalone version (at the time of this writing ClearCase 7.1.2.2 is the current release) does not support 
third party plug-in additions or customizations. 

Review technote 1224586 for a complete list of supported platforms and eclipse versions.

The standalone version of ClearCase Remote Client can be installed only once (like any typical application), 
yet the same client can support 1 client installed with a non Installation Manager Based installation ** (for 
example ClearCase 7.1.2.2 and ClearCase 7.0.1 can be installed on the same machine). 

If you do not have plans to customize or need integrations with other Eclipse plug-ins in the same interface, 
this client method is typical.

ClearCase Remote Client for Eclipse (also referred to as “plug-in”)

Throughout the remainder of this document, the focus will be on the usage of ClearCase Remote Client in 
conjunction with a standard open source Eclipse SDK.

Below are some of the benefits of using the ClearCase Remote Client plugged into a standard Eclipse SDK:

• Faster ClearCase deployment for customers already using the Eclipse SDK (or other Eclipse 
IDEs)

• Lightweight installation mechanism (Eclipse Base & JRE is already in place)
• Ability to leverage some existing Eclipse niceties**
• Support for wide array of platforms including Windows, Linux/GTK, Sun Solaris/GTK, HP-

UX/Motif, and IBM-AIX/Motif, Mac, Ubuntu Linux, etc..

** See http://wiki.eclipse.org/The_Official_Eclipse_FAQs for some common questions about Eclipse
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ClearCase Remote Client for Visual Studio (also referred to as “ccrc.net”)

The installation of ClearCase Remote Client into Visual Studio for 7.1 is handled through 
Installation Manager. The user performs a standard installation (identical to standalone ClearCase 
Remote Client) yet users are presented with the option during installation if they wish to enable the 
integration natively inside the Visual Studio development environment.
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3 Eclipse SDK and ClearCase Remote Client Plug-in Installation

Overview

In this section we will provide steps for installing the Eclipse SDK and will provide instructions to 
install the ClearCase Remote Client plug-in.  For this paper we will use Eclipse 3.6 and 7.1.2.2 
which is the latest currently supported combination of Eclipse and ClearCase Remote Client. 

Assumptions

To be able to take advantage of this method of deployment or distribution, there are a few things 
which are assumed (required):

• Each operating system platform that is planned for support should have its own 
deployment archive

• All clients will have a common, supported version of Java enabled on the host
• Users need to have a basic understanding of Eclipse
• Deployment requires the ability to extract an archived file

Install and Configure Eclipse SDK

1. Download Eclipse 3.6 for your platform(in this example Windows32Bit) from:  
          http://www.eclipse.org/downloads/packages/eclipse-classic-361/heliossr1

Eclipse packages different products based on capabilities needed by each user, for example 
if you are doing C++ development the Eclipse IDE for C++ developers will have CDT (C 
Development Toolkit and other C/C++ specific capabilities.

In our example we will use the default Eclipse which is generically applicable to most 
environments.

2. Download GEF 3.6 from:
http://www.eclipse.org/gef/download.php?
file=/tools/gef/downloads/drops/3.6.1/R201009132020/GEF-runtime-3.6.1.zip

3. Extract the files to some common path like c:\eclipse or /eclipse.
Note:  Remember the archive will have an eclipse directory, so that should be taken into 
account when extracting.

After extraction of Eclipse SDK you should have something like this:

Page 7 of 27 “ClearCase Support Whitepaper” 

http://www.eclipse.org/gef/download.php?file=/tools/gef/downloads/drops/3.6.1/R201009132020/GEF-runtime-3.6.1.zip
http://www.eclipse.org/gef/download.php?file=/tools/gef/downloads/drops/3.6.1/R201009132020/GEF-runtime-3.6.1.zip
http://www.eclipse.org/downloads/packages/eclipse-classic-361/heliossr1
http://www.ibm.com/software/rational


C:\eclipse
\plugins
\features
\configuration
\readme

Note:  Some Eclipse packages comprise the SDK with additional components, and may pre-
include GEF. 

4. Extract the contents of GEF runtime archive(GEF-runtime-3.6.1.zip) in your Eclipse 
directory:

GEF-runtime-3.6.1\features:

|
----org.eclipse.draw2d_3.6.1.v20100908-1100-4507w31211A2403131
----org.eclipse.gef_3.6.1.v20100908-1100-777B181A3Bz-6B663E7974242

GEF-runtime-3.6.1\plugins:

|
----org.eclipse.draw2d_3.6.1.v20100913-2020.jar
----org.eclipse.gef_3.6.1.v20100712-1224.jar

Must be moved into the same folders in your Eclipse directory.

In Eclipse 3.4 Eclipse changed the installer, for this paper we wish to have the capability to 
leverage the previous installer (what is common across more versions of Eclipse). 

To enable this, navigate to Window>Preferences>General>Capabilities and enable “Classic 
Update” as seen below (this is turned off by default).
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Click “Apply” then “OK”

Before Installing ClearCase Remote Client, confirm the successful installation and existence of the 
Graphical Editing Framework, this is needed by the ClearCase Version Tree.

Validate the install of GEF after restarting Eclipse.  Go to Help > Software Updates > Manage 
Configuration (figure 1).

Confirm that the Draw2D plug-in (required by ClearCase is present).
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Figure1
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Install ClearCase Remote Client Plug-In into Eclipse

1. Start Eclipse (example c:\eclipse\eclipse.exe)

2. Store the workspace** file created in the ./workspaces/default directory, this will create the 
folder structure in the same directory as the Eclipse SDK, and also will be a way of 
standardizing the workspaces for all users of this deployment archive. (figure 2)

Figure2

This entry and the choices a user has for workspace manipulation is controlled by:

{ECLIPSE INSTANCE}\configuration\.settings\org.eclipse.ui.ide.prefs (we will talk about 
preferences later).

This config file is worth noting as there are two (2) directives that can be modified if you choose to 
do so:

SHOW_WORKSPACE_SELECTION_DIALOG= 

* Set to “true” by default, this controls whether users see the workspace launcher (see 
above) to create Eclipse workspaces, if you wish to take the option to create new 
workspaces from user, set this to “false”, else the default is recommended.

RECENT_WORKSPACES=

This is a comma separated path list of the workspaces that have been created by the user. 
And would be see from the drop down below.
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• Note that the other ClearCase Remote Clients (when not using the plug-in) do not have the 
capabilities to create multiple workspaces.

All workspaces for Eclipse must be on local disk

Install and Configure ClearCase Remote Client as a Plug-in to Eclipse

In the next few steps we will walk through installing ClearCase Remote Client as a plug-in into the 
Eclipse SDK instance created previously.

To install a plug-in, go to Help > Software Updates > Find and Install…  (figure 3)

Figure3

Page 12 of 27 “ClearCase Support Whitepaper” 

http://www.ibm.com/software/rational


Since this is a new feature we will be installing, select “search for new features to install” (figure 
4).

Figure4

For simplicity, we will be installing ClearCase Remote Client from our 7.1.2.2 IBM Rational Change 
Management (CM) Server

Click on “New Remote Site…” (figure 5)

 

Figure5

For this we will use the following URL as our update path:

http://CMServerHostName/ccrc/update

This will ensure that we have a matching version to access this server, as each CM Server contains 
a Eclipse update site that can be used.
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Click “OK” and then Click “Finish”

When the following dialog below is displayed, select, “Rational ClearCase Remote Client for Eclipse” 
(figure 6)

Figure6

Click “Next”, and then accept the license terms and accept remaining defaults

Eclipse will verify that ClearCase Remote Client is being installed:
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Click “Install All”

After the installation completes, you will be prompted to restart.

Click “Yes”. it is always recommended to restart the workbench after installing a 
New plug-in. (figure 7)

Figure7

Once Eclipse restarts, select the previous workspace location, a good indication of ClearCase 
Remote Client being installed is the workbench start screen will change (see various help topics on 
ClearCase) and a “ClearCase” menu will be enabled:
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4 Setting up Tool Defaults for All Users

Now that you have a working ClearCase Remote Client instance plugged into Eclipse, we will make 
some changes to the environment to further assist with standard roll-out of this client. 

The suggested changes are not mandatory and can be modified to better fit your organization.

Eclipse preferences are the main way to customize or change the default behavior in Eclipse.
There are various Eclipse preferences that affect the appearance and capabilities for the user. Plug-
in providers can have their own preference settings and ClearCase Remote Client provides some 
key preferences that help you standardize your ClearCase Remote Client deployment.

If you have different needs inside your organization, preferences and settings can be exported 
using .epf files (File > Export > General > Preferences) and then imported to a default or another 
(override) instance of Eclipse. This allows preferences to be specific down to a team or role.
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Setting the default perspective to ClearCase 

An Eclipse perspective is a default layout of how Eclipse should present the capabilities of a specific 
plug-in. Each perspective contains a series of “views” (not to be confused with “ClearCase views”) 
which are windows or widgets that enable areas of functionality.

Views can be customized, and any perspectives view, can be added or combined with another. For 
example, any view from the ClearCase perspective can be added to the Java perspective.

For this paper we will assume that ClearCase work will be the main focus of the targeted users, for 
enterprises that have users with more in-depth Eclipse needs, this is to merely serve as an 
example.

Eclipse will always restart the last enabled or used perspective, but we will change the default 
perspective to ClearCase.

1. Click Window > Preferences to access view preferences.

To make ClearCase the default perspective, expand “General”, and select “Perspectives”.  Under 
“Available Perspectives”, highlight ClearCase and click on the “Make Default” button to the right. 
Then Click “Apply” and “OK”

Figure8
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Disabling CVS Capabilities

In Eclipse, CVS has a very pervasive existence in the menus when doing team development. To 
simplify the usage of ClearCase Remote Client, we will remove all CVS capabilities (optional). 

Under General >Capabilities, click “Advanced” and then select “Team”. Clear the “CVS support” 
option and then click “OK.” (figure 9)

Figure9
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Changing the Web Browser 

If you require a specific web browser for users to view web pages inside Eclipse, you can change 
the default (internal browser widget) to a specific browser of your choice.

Under General > Web Browser, click “Use external Web browser” and select the browser you want 
to use (in this example we are switching to Mozilla Firefox).  

Click “Apply” and then “OK”.  (figure 10)

Figure10

Having ClearCase Ignore Resources

If your company develops files that you do not want to be added to source control, you can set up 
defaults for Eclipse and ClearCase Remote Client to exclude these files when users are doing 
operations.

Adding a pattern (for example *.foo) will cause ClearCase Remote Client to exclude these file 
extensions when looking for files to add to source control.
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Under Team > ClearCase Remote Client there are various ClearCase Specific preferences that you 
can standardize.  Also, if certain users want to change these for certain use cases, they can do so 
(figure 11).

Figure11
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With ClearCase 7.1.2.2 there is a vast array of end user specific preferences that can aide end 
users and also provide some customizations for ClearCase Remote Client behaviors. Below are a 
few common preferences that may or may not apply to your usage of ClearCase (figure 12).

Figure12

It is strongly recommended to explore all of these preferences to determine which ones you would 
like to configure for your companies specific out of the box experience with ClearCase Remote 
Client.

For example, if you use a specific 3rd Party Diff/Merge tool, that tool could be stored in a common 
path (relative to Eclipse SDK on a users desktop) and you can deploy a common Diff/Merge tool 
configuration out to all users.

Enabling a Default Initial Appearance

The power of Eclipse is the ability to customize the appearance of the user interface (UI), yet in our 
example we want all users to see a unified UI when first starting up ClearCase Remote Client.
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Below is one example of how a default appearance could benefit end users. Remember that Eclipse 
and ClearCase Remote Client will startup with the same perspective and views enabled as last used 
(figure 14).

 

Figure14

In this example we have added the Help view and Cheat Sheet view to the ClearCase Perspective. 
The ClearCase views in this example are blank (we haven’t connected to a server or created any 
views).
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To add any view, go to Window > Show View and select the desired view. Think of this like a 
palette; Eclipse allows you to add what you think your end users might need. These views can be 
moved around inside the perspective.  For example, if you want the Help view on the left-hand side 
of the window, hold down the left mouse button on any tab (where the tabs text is) and drag and 
drop the view to the desired location.

You can always wipe the palette clean and start over with Window > Reset Perspective (this will 
return it to the factory default layout).

Specifying a Custom Splash Screen

When starting up the Eclipse 3.6.1 SDK, there is a default splash screen displayed:

Figure15

If you want to change this from the default Eclipse bitmap to a custom bitmap of your own, you 
can add an image called splash.bmp to the root directory of the Eclipse instance (for example, 
c:\eclipse).  Then, un-comment and modify the config.ini file in the configuration directory 
(c:\eclipse\configuration) as indicated below:

# The location of the splash screen file.  If this value is set at 
# system startup it is used  in favour of the osgi.splashPath 
# searching outlined above.  If the value is not set the searching is # done and this key is bound to 
the result of the search.
osgi.splashLocation = C:\\eclipse\\splash.bmp

In this example when Eclipse starts up, the following splash will be displayed (figure 16):
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Figure16

Tip: if you have one instance of the standalone version of ClearCase Remote Client installed, there 
are different language versions of the above image located in the following path (relative to where 
you might have installed ClearCase Remote Client):

{ClearCase 
Installation}\configuration\org.eclipse.equinox.launcher\com.ibm.rational.clearcase.standalone_7.1
.2.v201103150539\nl\en\splash.bmp

You can also find the same splash.bmp on the CM Server installation of ClearCase Remote Client:

{ClearCase 
Installation}\RemoteClient\configuration\org.eclipse.equinox.launcher\com.ibm.rational.clearcase.standalone_
7.1.2.v201012070126\nl\en
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Creating Desktop Icon[s]

If you want to create desktop icons for your users, you can create a windows shortcut on your 
desktop. The target of the shortcut will be: c:\eclipse\eclipse.exe

For an icon, you can use your own or point to one supplied with the installed product:

This is located (for example)at:

{ClearCase Installation}\RemoteClient\RCC.ico
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5 Package and Deployment

After all modifications, customizations and changes have been made, the packaging of this 
ClearCase Remote Client is simple:

1.) Compress the entire c:\eclipse directory.

2.) Copy the shortcut(s) from C:\Documents and Settings\All Users\Desktop to the archive 
(saving folder path info).

3.) (Optional) script the decompression or the disabling or enabling of a specific version if 
multiple versions have been installed previously.

To deploy this client, there is no installation required.  Merely Decompress the archive to disk and if 
the default path is taken (or mandated), all clients will have ClearCase Remote Client installed at 
c:\eclipse and each client will be identical.

Once a user starts using ClearCase Remote Client, there are a few files that are maintained in the 
users home directory (.ccase_wvreg and .server_reg) these files are used to store the location of 
local copyareas and server URL connections, respectively. If a user runs into a conflict or 
catastrophic issue occurs to the eclipse path, the directory can be deleted and redeployed.  This is 
possible because the Eclipse package is self contained.
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6 Conclusion

This paper is not meant to replace the standard practices used to install IBM Rational ClearCase. 
Consider it as an alternative approach that allows for faster deployment of a common customized 
client that benefits both the end user and the administrative staff of any organization.
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