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Start with Rational Performance Tester

Topics:

• Start now

Start now with performance testing with Rational Performance Tester.
Download and install the Rational Performance Tester  Starter Edition.

Related tasks
Putting more users into a test on page 20
Verifying the recorded baseline at playback on page 16
Setting performance requirements on page 16

https://www.ibm.com/developerworks/downloads/r/rpt/
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Start now
1. Download and install  Rational Performance Tester Starter Edition.
2. Start Rational Performance Tester.
3. Close the Welcome screen.
4. Click File > New > Performance Test Project..
5. Enter a project name, any name, in the New Project window; then, click Finish.

6. Click HTTP Test in New Test From Recording; then, click Next.

7. Enter a test name, any name. Then, click Next.

https://www.ibm.com/developerworks/downloads/r/rpt/
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8. Click on Microsoft Internet Explorer or your default browser. Then, click Finish.

9. Wait until the browser opens with Welcome to HTTP Test Recording.
10. Enter your company's home page in the address field. "YourCompany.com"
11. Open any other page from the home page.
12. Close the browser (all tabs) after that page loaded fully.,
13. Click Finish in the Domains Selection window.
14. Wait until the test generation completes.
15. Click Open test; then, click No in the Test Editor dialog box.
16. Click Run > Run; then, click Yes to Confirm Perspective Switch.
17. Maximize the lower left quadrant.
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18. Wait until the test completes. The indicator Complete must be green.
Ignore any correlation error message for now.

19. Click the tab with the timestamp.

20. Click Page Performance on the left side.
21. Review the graph of the Average Page Response Time for Run. See figure.

The response time of the first page is greater than the second page.
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Figure 1: Average Page Response Time for Run

Related concepts
Installation details on page 13
Rational Performance Tester on page 12
Performance testing on page 11
Testing workflow on page 15
Test results on page 23
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Performance testing

Topics:

• Rational Performance Tester

Skipping performance testing is not an option. Before your web application
goes live, you want to know whether your application meets the performance
requirements.

In most cases, you want to know how your application behaves when a certain
number of users connect to your application.

Afterward, when performance issues arise, you want to know the cause.
Performance testing helps you to discover what factor determines the rate, the
“bottleneck”.

Related tasks
Start now on page 6
Setting performance requirements on page 16
Putting more users into a test on page 20



Rational Performance Tester
Rational Performance Tester measures the network traffic between your client computer, and the application server.
Through virtual users, you emulate the network traffic. You can run tests with multiple users through performance
schedules.

To work with Rational Performance Tester, you don't need to know how to code.

Unlike functional tests, Rational Performance Tester tests do not depend on object recognition or the way you
manipulate the GUI. Rational Performance Tester works with standardized network protocols. As such, the tool
measures the time between the first byte out to the last byte in.

Rational Performance Tester can do the following network protocols.

• HTTP (browser-webserver traffic)
• Citrix
• SAP
• TN3270
• Socket
• SOA

Related tasks
Start now on page 6
Setting performance requirements on page 16
Verifying the recorded baseline at playback on page 16
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Installation details

The installation of Rational Performance Tester follows the same procedure as
other IBM Rational products like Rational Functional Tester.

To get Rational Performance Tester installed quickly, you can download and
install the  Rational Performance Tester Starter Edition.

Note:  You must have administrative (Windows) or root (Linux) privileges to
install Rational Performance Tester.

Watch the video How to install IBM Rational Performance Tester Starter
Edition to install the Rational Performance Tester Starter Edition.

You can also read the Installing Rational Performance Tester and Rational
Performance Tester Agent for a comprehensive description.

Related tasks
Start now on page 6

https://www.ibm.com/developerworks/downloads/r/rpt/
https://www.youtube.com/watch?v=4k3x55aJF8M
https://www.youtube.com/watch?v=4k3x55aJF8M
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.install.doc/topics/c_installingproduct.html
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.install.doc/topics/c_installingproduct.html
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Testing workflow

Topics:

• Setting performance
requirements

• Verifying the recorded baseline
at playback

You can follow the following workflow to work with Rational Performance
Tester.

1. Determine the requirements.

Make clear what you want. How many users your application must handle.
What the maximum response time of a request should be.

2. Create a performance test project.

3. Record a test.

Your computer issues requests to your application server,

4. Adjust the test to your requirements.

Edit the test in such a way that the test meets your needs. For example, set
verification points.

5. Playback the test.

Your computer issues the same requests that you recorded and captures the
responses from the server.

6. Assess the results.

Rational Performance Tester provides reports with graphs to support your
analysis. For the individual events of the playback, open the test log.

Related tasks
Start now on page 6

https://www.ibm.com/support/knowledgecenter/SSMMM5_8.6.0/com.ibm.rational.test.lt.common.doc/topics/tcreateproj.html
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.doc/topics/tcreatetest.html
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Setting performance requirements
You can set limits to the accepted response times or the number of times that verifications must pass. To set the
requirement so that the test fails when the test doesn't satisfy the requirement, select Standard.

1. Open the Performance Test perspective. Click Window > Open Perspective > Other ... > Performance Test
(default). Then click OK.

2. Follow the instructions in the following documents.
a) Defining performance requirements in tests. See figure.
b) Defining performance requirements in schedules

Figure 2: Performance requirements in tests

Related concepts
Start with Rational Performance Tester on page 5
Rational Performance Tester on page 12
Performance testing on page 11

Verifying the recorded baseline at playback
You can compare the following things in the playback actual with the recorded baseline through a verification point.

• Page title
• Response code
• Response size
• Response content

Image verification is available only for Citrix tests.

1. Open the Performance Test perspective. Click Window > Open Perspective > Other ... > Performance Test
(default). Then click OK.

2. Follow the instructions Verifying expected behavior.

https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.http.doc/topics/tcreateperfreq.html
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.doc/topics/tcreateperfreqsched.html
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.http.doc/topics/taddvptop.html
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Related concepts
Start with Rational Performance Tester on page 5
Rational Performance Tester on page 12
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User load simulation

Topics:

• Putting more users into a test
• Setting user load stages

When users connect to your application server, the users impose a load on
your server. Rational Performance Tester can simulate this situation through a
performance schedule. You run a test with multiple virtual users.

In the real world, users don't connect to your web server at the same time. In
a a performance schedule, you can simulate the situation that the total number
of users connect to your server in stages.

For more information, see Emulating workloads.

https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.doc/topics/trepwork.html
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Putting more users into a test
You can run tests with more users through a performance schedule. You can also add other options to run your test in
a schedule.

1. Open the Performance Test perspective. Click Window > Open Perspective > Other ... > Performance Test
(default). Then click OK.

2. Create a performance schedule. Click File > New > Performance Schedule.. Then, name the schedule and click
Finish

3. Highlight the first item in the Schedule Contents.
4. Select User Load in the Category dropdown box of Performance Schedule Details.

You can assign up to 5 users to an HTTP schedule in the Rational Performance Tester Starter Edition. If you want
to use more users, you need a separate virtual-users license.

Related concepts
Start with Rational Performance Tester on page 5
Performance testing on page 11

Setting user load stages
1. Open the Performance Test perspective. Click Window > Open Perspective > Other ... > Performance Test

(default). Then click OK.
2. Create a performance schedule. Click File > New > Performance Schedule.. Then, name the schedule and click

Finish
3. Highlight the schedule.
4. Select User Load in the Category dropdown box, the default. Then, click Add.
5. Click Create multiple stages in the Add User Stages window.

6. Compose your stages. Then, click OK.

The Performance Schedule Details shows the number of users over the subsequent stages. See figure.
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Figure 3: Increasing number of users in stages
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Test results

Rational Performance Tester creates execution reports and displays the reports
automatically after a run.

Each test result begins with the name of the schedule or test, and ends with
the timestamp of the run between square brackets.

The reports consist of figures and graphs that you can present to your
manager or customer.

For more information, see Viewing reports after a run.

If you want to see details about verification points and follow the course of
the test, use the test log.

To open the test log, right-click the executed test in the Test Navigator; then
click Display Test Log. For more information, see  Viewing test logs .

Related tasks
Start now on page 6

https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.doc/topics/tretrieverep.html
https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.common.doc/topics/topenexechist.html
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Glossary

Performance testing
Through performance testing, you measure the responsiveness and stability under a certain or various workloads.
Performance testing comes in different types.

Load testing Load testing is appropriate when you want to know
what your application does under a specific load. For
example, what are the response times when 100 users
send requests to your application at the same time?

Stress testing Stress testing indicates what load will cause your
application to fail.

Soak or endurance testing This test allows you to check what happens when your
application suffers a certain load for a long time. A great
way to see memory leaks.

Spike testing In spike testing you increase the number of users
suddenly with a significant amount. Then you see how
the application reacts.

Configuration testing What influences do different configurations have on your
application?

Most users of Rational Performance Testing choose for load testing.

Verification point
A verification point is a point that you mark in the recording. The recorder saves the properties of your mark. You see
a comparison of the recorded properties, or baseline, and the properties that Rational Performance Tester found during
playback, or actual.

EXAMPLE

You record an HTTP test against your company website. You arrive at a login page with title “Login” and you want to
make sure that the playback also arrives at this page. Then, you set a title verification point.

For details see Specifying the expected page title.
Performance schedule

A performance schedule or schedule is a set that consists of one or more user groups that contains one or more tests.
You can assign settings on all three levels. Highlight either the schedule, or user group, or test level. Then, discover
the options on the right side of the screen.

https://www.ibm.com/support/knowledgecenter/SSMMM5_9.0.1/com.ibm.rational.test.lt.http.doc/topics/tpagetitled.html
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Figure 4: Schedule options in categories
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