IBM InfoSphere Federation Server, Version 10.5

Using ODBC tracing information to troubleshoot connections to Microsoft SQL Server data sources

If you experience problems connecting to the data source, you can obtain ODBC tracing information to analyze and resolve the problems.

Symptom

However, activating a trace does impact system performance. You should turn off tracing after you have resolved the connectivity problems.

If you are unable to connect to the data source with the Microsoft SQL Server wrapper, running a trace might help you diagnose the problem.

Cause

The cause of the problem might be an error in the wrapper configuration.

Diagnosing the problem

To diagnose the problem on a federated server running Windows:
  1. In the Control Panel, open the Administrative Tools folder.
  2. Click Data Sources (ODBC) to open the ODBC Data Source Administrator window.
  3. Click the Tracing tab.
  4. Click Start Tracing Now to start the trace utility.
On a federated server running UNIX:
  1. Change the odbc.ini file.
    For example, if you use the DataDirect ODBC 3.x driver, find the example of the odbc.ini file in the client directory. The odbc.ini file contains a sample of the settings that are necessary to activate the trace files:
    [ODBC] 
    Trace=1 
    TraceFile=/home/user1/trace_dir/filename.xxx 
    TraceDll==ODBC_driver_directory/odbctrac.so 
    InstallDir=/opt/odbc

    To turn tracing on, set the first line to Trace=1. To turn tracing off, set the first line to Trace=0. The value of the TraceFile setting is the path and file name that the federated database instance has write access to.

Resolving the problem

Check the trace log file for problems.

On Windows, open the ODBC Data Source Administrator and click the Tracing tab. The path to the trace log file is shown in the Log File Path field.

On UNIX, open the odbc.ini file. The path to the trace log file is indicated by the TraceFile setting.



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