Admin Center troubleshooting

You might encounter some common issues when you troubleshoot Admin Center. Browse the list of issues to learn how to resolve them.

Server Config tool issues

Server information cannot be retrieved

If no error code is given, look at the network debugger or enable trace logs.

CWWKX7204E: Cannot connect to host host_name with the credentials provided.
Message:
localhost,C:/wlp,member1 stop operation resulted in an Exception: ConnectException caught while performing stopCluster operation on member localhost,C:/wlp,member1: java.net.ConnectException: 
CWWKX7204E: Cannot connect to host localhost with the credentials provided.
Cause:

The RPC credentials are invalid or SSH is not working.

Solution:

Ensure that the RPC user and password values for hostAuthInfo in the server configuration are correct. See Overriding Liberty server host information.

CWWKX0279E: The host path information for the host_name host is not available.
Message:
CWWKX0279E: The host path information for the localhost host is not available. 
The /sys.was.collectives/local/hosts/localhost/sys.host.paths node does not exist in the repository.
Cause:

The collective server must be running to join a member to the collective.

Solution:

Ensure that the collective controller server is started.

If the collective server is running, but the host path information is still not available, run the collective updateHost command with correct values for the --hostReadPath and --hostWritePath parameters. For information about updateHost, see CWWKX0261E or Registering host computers with a Liberty collective.

CWWKX0261E: The host authentication information for the host host_name is not available.
Message:
CWWKX0261E: The host authentication information for the host localhost is not available.
Cause:

The collective updateHost command was not run for the host on which the member resides.

Solution:

Run the collective updateHost command for the member host with either RPC or SSH information specified. Ensure that the command also has --hostReadPath and --hostWritePath parameters.

wlp/bin/collective updateHost memberHost --host=collectiveHost --port=controllerHTTPSPort 
--user=controllerAdmin --password=controllerAdminPassword --rpcUser=osUser --rpcUserPassword=osUserPassword 
--hostReadPath=serversPath --hostWritePath=serversPath

See Registering host computers with a Liberty collective.

CWWKX2003E: A write list for host host_name must be registered with the collective repository.
Message:
CWWKX2003E: A write list for host localhost must be registered with the collective repository.
Cause:

The collective updateHost command did not run with the --hostWritePath parameter.

Solution:

Run the collective updateHost command with the --hostWritePath parameter to specify the configuration files that the Server Config tool must access.

CWWKX2004E: The remote file location filePath is not within the registered allow list for server serverName.
Cause:

The member might not have been started yet, failed to publish to the controller, or one or more of the default readDir paths of remoteFileAccess were overwritten or removed.

Solution:

If remoteFileAccess is specified in the member server's config, ensure that it allows readDir access to the configuration files, including filePath. Ensure that the specified or default remoteFileAccess successfully published to the controller. The member server must be running for publishing to occur.

Error 500: The system cannot find the file specified.
Message:
Error 500: The system cannot find the file specified.
Cause:

The schema is not generated.

Solution:

Ensure that the server schema is generated. Also, ensure that the server is running or that the server contains the generated schema. You can manually generate the schema by using the wlp/bin/tools/ws-serverSchemagen.jar file. See Generating Liberty configurations schema from the command line.

Error 500: sh: java: Permission denied
Message:
Error 500: sh: java: Permission denied
Cause:

The Java™ path is not correct for the Java installation.

Solution:

See information about setting the Java path in Editing server configuration files in Admin Center and Setting the JAVA_HOME variable for Liberty collective members and controllers.

Explore tool issues

Server and application status needs to update more often
Admin Center periodically and frequently polls for changes. For more timely updates to server and application status in the Explore tool, add the websocket-1.1 or websocket-1.0 feature to the server configuration.
<featureManager>
   <feature>adminCenter-1.0</feature>
   <feature>websocket-1.1</feature>
</featureManager>

WebSocket provides a live view of the topology regardless of size.

Monitor view shows 0% CPU usage for JVMs that do not supply process CPU statistics.
The CPU Usage chart of the Admin Center Monitor view shows 0% CPU usage for JVMs that do not supply process CPU statistics. For information about the chart, see Monitoring metrics in Admin Center.