The IBM® Content
Classification server cannot start
after you run the installation program.
Symptoms
You run the Content Classification installation
program and it completes without any errors. But you cannot start
the server after the installation completes.
Causes
If Content Classification was
previously installed on the computer and manually removed (that is,
by manually deleting files rather than by running the installation
program to remove the files), the InstallAnywhere global registry
can become corrupted.
Resolving the problem
To resolve this problem, you must temporarily remove the
InstallAnywhere global registry file.
Important: Do not
permanently delete the current version of the InstallAnywhere global
registry file. If you delete this file, you might not be able to run
the installation programs for other products that are already installed
on the computer.
- Locate the InstallAnywhere global registry file.
- On Windows, the path
to the file is C:\Program Files\Zero G Registry\.com.zerog.registry.xml.
- On AIX®, Linux, or Solaris, the path to the file is /home/user_name/com.zerog.registry.xml.
If Content Classification was installed
by the root user, the path to the file is /var/.com.zerog.registry.xml.
- Rename the file. For example, rename it .com.zerog.registry.xml_backup.
- Manually delete any Content Classification files
that are on the computer. On AIX, Linux, or Solaris, ensure that
you also delete any log files that exist under the user home or root
directory.
- Run the Content Classification installer
and verify that the server can start after the installation completes.
- Delete the newly generated .com.zerog.registry.xml file.
- Change the name of the original file back to .com.zerog.registry.xml.
In the future, you must repeat this procedure before you run
any
Content Classification installation
program, for example, to install a fix pack or to remove the product.