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Resolving timeout errors and slow system response

If you receive timeout errors from the IBM® Content Classification server, or the system response time is very slow, try to determine the cause of the problem and the appropriate solution.

Symptoms

The Content Classification server returns timeout error messages, or the response time is very slow.

Causes

Timeout errors and slow system response time are typically due to one of the following problems:
  • Communication problems between the Content Classification client and server
  • Insufficient internal resources for the Content Classification server

Diagnosing the problem

First determine if there are any communication problems between the Content Classification client and server. Try turning off your firewall and retest to determine if the firewall is blocking communication.

For additional analysis, use a TCP trace tool of your choice to trace packet flow information between the client and server by listening to all round-trip transmissions. The tool should forward all traffic between the client and server while recording the contents from these transmissions in a log file. If you do not detect any communication problems, contact IBM Software Support to determine whether there are sufficient internal resources for the Content Classification server. Send the following information to IBM Software Support:

Resolving the problem

After IBM Software Support analyzes your data, you might be instructed to complete one or both of the following procedures.

Adding read-only decision plan and knowledge base processes

For each decision plan and knowledge base that runs on the server, there is a single read/write instance. A read/write instance is a server component that can handle read/write and read-only requests for a knowledge base or decision plan. If additional resources are required, read-only instances can be added. A read-only instance is a server component that can handle read-only requests. Read-only requests can be processed by the read/write instance or forwarded to a read-only instance depending on the current workload of the read/write instance. To provide scalability and enhance performance, you can configure the system to run any number of read-only instances of a specific knowledge base or decision plan on multiple computers. Add read-only knowledge base or decision plan processes so that there is at least one read-only process for each read/write process.

To add a read-only instance of a knowledge base or decision plan:

  1. Open the Management Console and select Knowledge bases or Decision plans in the console tree.

  2. In the list view on the right, right-click a knowledge base or decision plan and select Properties.

  3. In the Servers area of the properties window, click Add next to the list of read-only servers. Select a server from the list of available servers and specify a port number.

Configuring additional text extraction servers

To configure an additional text extraction server:

  1. In the Management Console, click Text extractors in the console tree and select Add.

  2. Specify the host name and port on which to run the additional text extraction server.

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