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Cannot export a knowledge base that has associated learning data

Classification Workbench returns an error when you try to restart transfer to the server of a knowledge base that has associated learning data.

Symptoms

In Classification Workbench, you try to export a knowledge base that has associated learning data or a decision plan that references a knowledge base that has associated learning data. Classification Workbench displays a message that a previous transfer did not complete successfully. After you click Restart Transfer, you again receive the message that a previous transfer did not complete successfully.

Causes

Another user might be simultaneously trying to export the same knowledge base to the server.

Resolving the problem

Check that no other user is trying to transfer the knowledge base and then click Restart Transfer again.
Important: If you click Cancel instead of clicking Restart Transfer, the knowledge base might no longer function correctly.

If the problem persists, manually transfer the associated learning data for the knowledge base to the server:

  1. Stop the read/write knowledge base process on the server.
  2. Manually copy the SARC file from the local directory Classification_Home\Classification Workbench\Projects_Unicode\knowledge_base_project_name\KBCache to the server directory Classification_Home\data\read_write_knowledge_base_name.
  3. Delete any TMP files in the server directory.
  4. Restart the knowledge base on the server.
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