IBM Support

Mustgather: Aquire Lock step hangs

Troubleshooting


Problem

A process uses the Acquire Lock / Release Lock steps. One of these steps hangs and the process remains in Executing state indefinitely.

Cause

The issue may be due to a stale lock from a previous execution, that was not released.


Diagnosing The Problem

If the steps in the section "Resolving the problem" do not resolve the issue, then perform the steps below:

1. Select Settings > Logging and add the following line:


log4j.logger.com.urbancode.ds.subsys.locking.LockManager=DEBUG


2. Reproduce the problem (there is no need to restart the server)


With these traces, you should see entries like this in the file deployserver.out:

2017-09-11 11:33:15,766 DEBUG WorkflowRuntime-5 com.urbancode.ds.subsys.locking.LockManager - Getting lockable for
name: TEST-IBM277-R90FKAU9
2017-09-11 11:33:15,766 DEBUG WorkflowRuntime-5
com.urbancode.ds.subsys.locking.LockManager - Created Lockable: TEST-IBM277-R90FKAU9
2017-09-11 11:33:15,766 DEBUG WorkflowRuntime-5
com.urbancode.ds.subsys.locking.LockManager - Creating request for lock with name TEST-IBM277-R90FKAU9 in request()...
2017-09-11 11:33:15,776 DEBUG WorkflowRuntime-5
com.urbancode.ds.subsys.locking.LockManager - Lock is not yet acquired, acquiring lock and continuing workflow
2017-09-11 11:33:15,816 DEBUG WorkflowRuntime-9
com.urbancode.ds.subsys.locking.LockManager - Found lock TEST-IBM277-R90FKAU9 for acquirer 9c52a196-2411-4f7b-84d1-9dcf86313d1f
2017-09-11 11:33:15,816 DEBUG WorkflowRuntime-9
com.urbancode.ds.subsys.locking.LockManager - Removing lock TEST-IBM277-R90FKAU9 with acquirer
2017-09-11 11:33:15,826 DEBUG WorkflowRuntime-9 com.urbancode.ds.subsys.locking.LockManager - No pending lock request
found for TEST-IBM277-R90FKAU9


3. Send the following files to IBM Support:

- <server>\var\log\deployserver.out

- output of clicking on "Download all logs" in the process execution page.

Resolving The Problem

You can identify and manually release the lock looking at the page:

Settings > Locks

as shown in the image below:



If you find a lock that should no longer be held, click on Release in the Actions column, next to the lock name.

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Document Information

Modified date:
17 June 2018

UID

swg2C1000339