IBM Support

TM1 10.2.2 Fix Pack 6 - New TM1 Server and Admin Server configuration parameters to support older clients (including Business Intelligence on Unix) and Transport Layer Security 1.2

Release notes


Abstract

As of TM1 10.2.2 Fix Pack 6 (FP6), all SSL-secured communication between client and server uses Transport Layer Security (TLS) 1.2. If older TM1 clients (prior to TM1 10.2.2 FP6) need to connect to either the TM1 Admin Server or TM1 server, you must enable such access in Tm1s.cfg (for TM1 server) and Cognos Configuration ( for TM1 Admin Server).

This is also applicable if TM1 is used as a data source for Business Intelligence on Unix.

Content

To allow clients prior to 10.2.2 FP6 to connect to a 10.2.2 FP6 TM1 server, add the following entry to the Tm1s.cfg file for the server:

SupportPreTLSv12Clients=T

After adding this parameter, you must restart the TM1 server.

If SupportPreTLSv12Clients is not present in the Tm1s.cfg file, or if SupportPreTLSv12Clients=F, clients prior to 10.2.2 FP6 cannot connect to a 10.2.2 FP6 TM1 Server

For full details on the Tm1s.cfg file, see http://www.ibm.com/support/knowledgecenter/SS9RXT_10.2.2/com.ibm.swg.ba.cognos.tm1_inst.10.2.2.doc/c_thetm1s.cfgfile_n150029.html.

To allow TM1 clients and TM1 servers prior to 10.2.2 FP6 to connect to a 10.2.2 FP6 TM1 Admin Server:

  1. Click Start > IBM Cognos TM1 > IBM Cognos Configuration.
  2. Click TM1 Admin Server on the Explorer tree in Cognos Configuration.
  3. Set the Support pre-TLS v1.2 clients property to True.
  4. Click File > Save.
  5. Click File > Exit.
  6. Click Yes if prompted to restart the TM1 Admin Server.

When either the TM1 server or the TM1 Admin Server is configured to allow connections from pre-TLS 1.2 clients, the connection to such clients is established using TLS 1.0.


Document information

More support for: Cognos TM1
TM1 Server

Software version: 10.2.2

Operating system(s): AIX, Linux, Solaris, Windows

Reference #: 7048181

Modified date: 26 July 2016


Translate this page: