IBM Support

System requirements for IBM Traveler 9.0.1.3 and later releases

Detailed system requirements


Abstract

This document provides minimum system, device and database requirements for the IBM Traveler 9.0.1.3 Server and later 9.0.1.x releases.

Content


Section Index & Quick Links:



Domino Server Support



Important: IBM Traveler 9.0.1.16 or later is required to run Domino 9.0.1 FP8 or later releases. See this technote for details: http://www.ibm.com/support/docview.wss?uid=swg21999188

IBM Traveler 9.0.1.3 and later running in standalone mode may be installed on any of the following:
    • IBM Domino 9.0.1 Enterprise Server
    • IBM Domino 9.0.1 Messaging Server
    • IBM Domino 8.5.3 Enterprise Server (with Domino 8.5.3 Upgrade Pack 1 installed)
    • IBM Domino 8.5.3 Messaging Server (with Domino 8.5.3 Upgrade Pack 1 installed)
IBM Traveler 9.0.1.3 and later running in high availability mode is only licensed to run on and may only be installed on the following:
    • IBM Domino 9.0.1 Enterprise Server
    • IBM Domino 8.5.3 Enterprise Server (with Domino 8.5.3 Upgrade Pack 1 installed)
Note: IBM Domino 9.0.1 FP10 and later requires IBM Traveler 9.0.1.20 or later do to Domino library changes.

Note: The xSP (Service Provider) configuration of IBM Domino Server is not supported for any IBM Notes Traveler configuration.


Important notes on running on an IBM Domino 8.5.3 server:


For detailed system requirements for IBM Domino, IBM Domino Administrator, IBM Domino Designer, IBM Notes, and IBM iNotes, see: http://www.ibm.com/support/docview.wss?rs=475&uid=swg27007909


Remote Mail Database Support


IBM Traveler server can connect to remote mail databases hosted by IBM Domino 7.0.2 servers or above. The remote mail server can be any operating system supported by IBM Domino.


Mail File Template Support


IBM Traveler server supports IBM Notes standard and IBM iNotes mail file templates, version 6.5 and above.



Server Hardware Requirements

Feature
Requirements
Disk Space Minimum of 10GB of free disk space for database and log files. Less than 10GB will display a warning at startup.
Memory The IBM Traveler server requires a minimum of 2 GB of free RAM. This is in addition to the memory required by the IBM Domino server itself. As more IBM Traveler users are registered with the service, the memory needed will increase and it is not uncommon for the total virtual memory required for IBM Traveler and Domino to exceed 4 GB of RAM.
Network Protocols IBM Traveler supports any network supported by a device that provides an HTTP/TCP or HTTPS/TCP connection between the device and the Traveler server. Examples include: GSM, GPRS, 802.11x, and WiFi. In addition, IBM Traveler can utilize Short Messaging Service (SMS), Google Cloud Messaging (GCM) and Apple Push Notification Service (APNS) for push notifications instead of HTTP/HTTPS for respective device platforms.

Please review the Capacity planning guidelines for IBM Traveler for additional information on sizing an IBM Traveler server based on the number of devices it is supporting.


Enterprise Database Requirements

IBM Traveler High Availability mode requires an enterprise database which is accessed by all IBM Traveler servers in a common service pool. The following enterprise databases are supported. See the database product documentation for information on their hardware, software and operating system requirements.

Important notes on using an enterprise database


Product
Notes
DB2 Enterprise Server and Workgroup Server Editions v9.7 fixpack 5 and higher level fixpacks
DB2 Enterprise Server and Workgroup Server Editions v10.1 and higher level fixpacks
DB2 Enterprise Server and Workgroup Server Editions v10.5 and higher level fixpacks A limited edition IBM DB2 10.5 Workgroup Server Edition is available for download from Passport Advantage if you are entitled to IBM Traveler 9.0.1.x releases. This limited entitlement edition is provided for customers who want to deploy an IBM Traveler High Availability server and elect to use the provided supported DB2 10.5 Workgroup Server Edition as their Relational Database Management System solution. This limited entitlement edition of DB2 does not support all DB2 features and capabilities. Please contact your IBM Sales representative for assistance if your deployment needs exceed the capabilities of the limited edition.
DB2 Enterprise Server and Workgroup Server Editions v11.1 and higher level fixpacks Supported by IBM Traveler 9.0.1.15 and later.
Microsoft SQL Server Enterprise Edition 2008 SP1 CU1 and higher level fixpacks
Microsoft SQL Server Enterprise Edition 2008 R2 SP1 CU1 and higher level fixpacks
Microsoft SQL Server Enterprise Edition 2012 and higher level fixpacks.
Microsoft SQL Server Enterprise Edition 2012 R2 and higher level fixpacks.
Microsoft SQL Server Enterprise Edition 2014 and higher level fixpacks. .
Microsoft SQL Server Enterprise Edition 2016 Supported by IBM Traveler 9.0.1.19 and later releases.



Server Operating Systems

Operating System
Notes
IBM i 6.1 POWER System
IBM i 7.1 POWER System
IBM i 7.2 POWER System
IBM i 7.3 POWER System Supported by IBM Traveler 9.0.1.10 and later releases.
Red Hat Enterprise Linux (RHEL) 5 Server for Intel (64-bit only) Only supported when running with IBM Domino 8.5.3
Red Hat Enterprise Linux (RHEL) 6 Server for Intel (64-bit only) 32 bit run time libraries are required for installation.
Red Hat Enterprise Linux (RHEL) 7 Server for Intel (64-bit only) 32 bit run time libraries are required for installation.
Requires Domino 9.0.1 FP2 or later.
Requires IBM Traveler 9.0.1.4 or later.
SUSE Linux Enterprise Server (SLES) 10 for Intel (64-bit only) Only supported when running with IBM Domino 8.5.3
SUSE Linux Enterprise Server (SLES) 11 SP1 for Intel (64-bit only) 32 bit run time libraries are required for installation.
SUSE Linux Enterprise Server (SLES) 12 for Intel (64-bit only) 32 bit run time libraries are required for installation.
Windows Server 2003 Enterprise Edition (64-bit only) Only supported when running with IBM Domino 8.5.3
Windows Server 2003 R2 Enterprise Edition (64-bit only) Only supported when running with IBM Domino 8.5.3
Windows Server 2008 R2 Standard Edition
Windows Server 2008 R2 Enterprise Edition
Windows Server 2012 Datacenter Edition
Windows Server 2012 Standard Edition
Windows Server 2012 R2 Datacenter Edition
Windows Server 2012 R2 Standard Edition
Windows Server 2016 Supported by IBM Traveler 9.0.1.16 and later releases.

Note: There may be some FP level requirements for the underlying Domino server. For detailed system requirements for the various Domino server versions see http://www.ibm.com/support/docview.wss?rs=475&uid=swg27007909


Web Browsers for Administration

IBM Traveler supports web based administration. The following web browsers are supported in this capacity:

  • Apple Safari 5.0 and higher
  • Mozilla Firefox 3.6 and higher
  • Microsoft Internet Explorer 7 and higher
  • Google Chrome 5 and higher

JavaScript and cookie support must be enabled in the web browser for the IBM Traveler web administration application to function properly.


Load Balancer or IP Sprayer

IBM Traveler running in High Availability mode requires a Load Balancer or IP sprayer located in front of the IBM Traveler server pool to provide a single URL entry point as well as to route requests evenly to each Domino HTTP servers in the Traveler HA pool. IBM has tested the following load balancers and IP sprayers. Note that support is not limited to the following products, most any IP Sprayer or Load Balancer should work as long as the documented guidelines are followed for these products.

  • IBM Mobile Connect v6.1.5
  • Apache HTTP Server v2.2.22
  • WebSphere Edge Server v7.0.0.18
  • F5 Load Balancer
Note: IBM Traveler recommended load balancing algorithm is a Round Robin strategy with no session affinity. See the IBM Traveler planning documentation for Proxy Servers, IP Sprayers and Load Balancers for a complete list of requirements and recommendations: http://www.ibm.com/support/knowledgecenter/SSYRPW_9.0.1/Plan_reverse_proxy.dita



Device Hardware Requirements



Feature
Applicable OS
Notes
Device Memory Android IBM Traveler for Android client requires approximately 10 MB of free storage on the device to install IBM Traveler.

File storage required for PIM and mail is not included in these estimates, varies widely, and depends on how much data is synchronized to the device. Note that during initial setup, you can choose to have some of the data stored on external storage.

Trace and log storage required is dependent upon the configuration setting. The default value is 2 MB.




Device Operating Systems and Applications





Supported Device Operating Systems
Supported Applications
Apple iOS 8.x Built in Mail, Calendar and Contacts applications running on Apple iOS devices using the Microsoft Exchange ActiveSync Protocol.
Apple iOS 9 and later Note: iOS 11.x is supported with IBM Traveler server 9.0.1.18 and later and IBM Verse for iOS 9.4.4 and later.

RECOMMENDED: IBM Verse application for Apple devices: https://itunes.apple.com/us/app/ibm-verse/id949952976?ls=1&mt=8

Built in Mail, Calendar and Contacts applications running on Apple iOS devices using the Microsoft Exchange ActiveSync Protocol.

IBM Companion application when using the built in Mail application: https://itunes.apple.com/us/app/ibm-notes-traveler-companion/id346633404?mt=8

IBM To Do application when using either the IBM Verse application or the built in Mail application: https://itunes.apple.com/us/app/ibm-notes-traveler-to-do/id582651945?mt=8
Android OS 4.3 and later IBM Verse application for Android devices: https://play.google.com/store/apps/details?id=com.lotus.sync.traveler
BlackBerry 10.0, 10.1, 10.2 OS Built in mail, calendar and contacts applications running on BlackBerry 10 devices (version 10.0.10.85 and later) using the Microsoft Exchange ActiveSync protocol.
BlackBerry 10.2.1, 10.3.0 OS Built in mail, calendar, contacts, and to do applications running on BlackBerry 10 devices (version 10.2.1.1925 and later) using the Microsoft Exchange ActiveSync protocol.
Windows Phone 7.5, 7.8, 8, 8.1 Built in mail, calendar and contacts applications running on Windows Phone devices using the Microsoft Exchange ActiveSync protocol.

IBM Traveler Companion application on Windows Phone 8 and 8.1 devices: https://www.microsoft.com/en-us/store/p/companion/9nblggh08k01?rtc=1

Windows RT, 8 Pro, and 8.1 Pro Tablets Built in mail, calendar and contacts applications running on Windows 8 and 8.1 Tablets using the Microsoft Exchange ActiveSync protocol.
Windows 10 Pro Tablet Built in mail, calendar and contacts applications running on Windows 10 Pro tablets using the Microsoft Exchange ActiveSync protocol.

Note: Other devices, clients or applications capable of Exchange ActiveSync or SyncML synchronization are not supported by IBM Traveler at this time. On Android in particular, IBM only supports the Verse application, see this technote for more details http://www-01.ibm.com/support/docview.wss?uid=swg27049546. The IBM Traveler team continually evaluates additional devices and applications for potential support in future releases.

Related information

IBM Traveler Product Documentation
IBM Traveler Recomended Maintenance
Domino Server Recommended Maintenance

Document information

More support for: IBM Traveler
Administration

Software version: 9.0.1

Operating system(s): IBM i, Linux, Windows

Software edition: All Editions

Reference #: 7045363

Modified date: 14 November 2017


Translate this page: