IBM Support

Prerequisites for IBM Content Collector for SAP Applications Version 4.0

Product documentation


Abstract

This document gives a detailed overview of the hardware prerequisites and the software prerequisites of IBM Content Collector for SAP Applications Version 4.0.

Content

Product requirements for IBM Content Collector for SAP Applications

 

IBM Content Collector for SAP Applications, which is abbreviated to 'Content Collector for SAP' in the following sections, consists of the following components: Collector Server, a plug-in for IBM Content Navigator, and an API.

Legend
Term Description
x86 Intel 32-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers
x86-64 AMD Opteron (AMD64) and Intel Xeon (EM64T) 64-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers
POWER IBM POWER-based processors, including IBM System p and eServer pSeries servers.
SPARC Sun UltraSPARC processors

Hardware requirements

AIX

Hardware requirements Minimum
Processor POWER
System memory (RAM) 1 GB
Hard disk space
  • 300 MB for the installation
  • Runtime space depends on size of files to archive, trace, and log

Linux

Hardware requirements Minimum
Processor x86_64
System memory (RAM) 1 GB
Hard disk space
  • 300 MB for the installation
  • Runtime space depends on size of files to archive, trace, and log

Solaris Operating Environment

Hardware requirements Minimum
Processor SPARC
System memory (RAM) 1 GB
Hard disk space
  • 300 MB for the installation
  • Runtime space depends on size of files to archive, trace, and log

Windows

Hardware requirements Minimum
Processor x86-64
System memory (RAM) 1 GB
Hard disk space
  • 300 MB for the installation
  • Runtime space depends on size of files to archive, trace, and log


SAP prerequisites

Supported versions of SAP

  • SAP ECC5.0 or later
  • SAP R/3 Release 4.6B (see Note)
  • SAP R/3 Release 4.6C (see Note)
  • SAP R/3 Release 4.7 (see Note)

Notes:

  • ICCSAP does not support a particular SAP database. It is certified for the SAP ArchiveLink interface. SAP is still keeping ArchiveLink, like any other application, independent of the database underneath the ERP or BW system, regardless of whether it is Oracle, DB2, SQL Server or HANA.
    Further on, S4HANA contains the same KPro and ArchivLink stack as the other ERP versions.
  • In general, all SAP versions and all SAP applications are supported that contain SAP ArchiveLink. Due to the Unicode limitations in older SAP releases, full support for SAP is limited to SAP ECC5.0 or later. You can use SAP R/3 Release 4.6B, Release 4.6C, and Release 4.7 if you want to perform only those tasks that require the standard SAP ArchiveLink functions according to the SAP specification. Content Collector for SAP enhancements, such as the index transfer, are not supported by those releases.

Important: Support requests must be reproducible on SAP ECC5.0 or later.

Required SAP components

Collector Server requires the following additional SAP components, which are available from the SAP Service Marketplace. For all supported operating systems, you need the 64-bit version of the SAP component.

  • SAP Java Connector (JCo) Release 3.0.1 or later
  • SAP RFC SDK
    The version that you must install depends on your operating system. See SAP note 413708 for the details.
  • SAP Cryptographic Library
    This library is used as a security provider for the SAP ArchiveLink interface.


Repositories

Supported repositories

You can use the following repositories:

  • IBM Content Manager:
    • IBM Content Manager Enterprise Edition V8.4.3 or V8.5
    • IBM Content Manager for z/OS V8.4 or V8.5
  • Content Manager OnDemand:
    • Content Manager OnDemand for Multiplatforms V8.5, V9.0, or V9.5
    • Content Manager OnDemand for z/OS V8.5, V9.0, or V9.5
    • Content Manager OnDemand for i5/OS V6.1
    • Content Manager OnDemand for i V7.1
  • FileNet P8:
    • Content Manager V5.0.0, V5.1.0, V5.2.0, or V5.2.1
    • Image Services V4.1.2 or V4.2
  • Tivoli Storage Manager V6 or V7

Connector required on Collector Server for the supported repositories

The following table shows which connector is required on Collector Server for which supported archive system:

Repository Connector on Collector Server Notes
IBM Content Manager Enterprise Edition V8.4.3 IBM Content Manager V8 connector Included in IBM Information Integrator for Content V8.4 (Use Setup Type Connector).
IBM Content Manager for z/OS V8.4
IBM Content Manager Enterprise Edition V8.5 Included in IBM Content Manager Enterprise Edition V8.5 (Select component Connectors).
IBM Content Manager for z/OS V8.5
Content Manager OnDemand for Multiplatforms V8.5 Content Manager OnDemand for Multiplatforms V8.5 (64-bit) For all versions, install the server package of Content Manager OnDemand for Multiplatforms V8.5 on the system where Collector Server is to be installed. The server package contains the connector between Content Manager OnDemand and Collector Server. You do not have to configure the installed server package.
Content Manager OnDemand for z/OS V8.5
Content Manager OnDemand for i5/OS V6.1 or for i V7.1
Content Manager OnDemand for Multiplatforms V9.0 Content Manager OnDemand for Multiplatforms V9.0.0.1 (64-bit) Install the server package of Content Manager OnDemand for Multiplatforms V9.0 on the system where Collector Server is to be installed. The server package contains the connector between Content Manager OnDemand and Collector Server. You do not have to configure the installed server package.
Content Manager OnDemand for z/OS V9.0
Content Manager OnDemand for Multiplatforms V9.5 Content Manager OnDemand for Multiplatforms V9.5 (64-bit) Install the server package of Content Manager OnDemand for Multiplatforms V9.5 on the system where Collector Server is to be installed. The server package contains the connector between Content Manager OnDemand and Collector Server. You do not have to configure the installed server package.
Content Manager OnDemand for z/OS V9.5
FileNet Content Manager V5.0.0 or V5.1.0
  • Content Engine Client API
  • Process Engine Client API
The APIs must be installed on the same system as Collector Server. In addition, the P8_CLASSPATH keyword in the server configuration profile must specify the JAR files that contain the respective APIs.
FileNet Content Manager V5.2.0 or V5.2.1 Content Engine Client API Content Engine Client API must be installed on the same system as Collector Server. In addition, the P8_CLASSPATH keyword in the server configuration profile must specify the JAR files that contain the API.

Important:

  • Starting with FileNet Content Manager V5.2.0, you need only the Content Engine Client API because Process Engine Client is integrated in Content Engine Client.
  • If you want to use BC-ILM 3.0, you must install FileNet Content Manager V5.2.0 or V5.2.1.
FileNet Image Services V4.1.2 or V4.2
  • Content Engine Client API
  • Process Engine Client API
FileNet Image Services repositories must be connected through a FileNet Content Manager repository, and federated by using Content Federation Services for Image Services (CFS-IS).
Tivoli Storage Manager V6 Tivoli Storage Manager Client API V6 (64-bit)  
Tivoli Storage Manager V7 Tivoli Storage Manager Client API V7 (64-bit)  

Additional software

IBM Content Navigator V2.0.3 and future fix packs or V3.0.0 and future fix packs.

Notes:

  • IBM Content Navigator is bundled with IBM Content Manager, Content Manager OnDemand, or FileNet P8.
  • IBM Content Navigator is not supplied with Tivoli Storage Manager. Therefore, install the IBM Content Navigator version that is bundled with Content Collector for SAP. The required database and web application server are bundled with ICCSAP as well. Please refer the Program Licence Agreement for any usage limitations.

IBM Content Navigator requires the following software:

  • A relational database
  • A web application server, such as IBM WebSphere Application Server or Oracle Weblogic Server

    If you want to use Operation Feature of Content Collector for SAP, which uses the task manager component of IBM Content Navigator, the web application server must support the Java Platform, Enterprise Edition (Java EE) 6.


Software requirements

Collector Server

The following table shows the operating systems where Collector Server can be installed:

Operating system Other software Notes
  • AIX 6.1 or 7.1
  • Red Hat Enterprise Linux Server 6.0 or 7.0
  • SUSE Linux Enterprise Server 11 or 12
  • Solaris 10 or 11 Operating Environment (SPARC only)
  • Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, or Windows Server 2016

All the operating systems must be in 64-bit mode.

  • See Connector for the list of connectors that are required for the individual repositories
  • SAP Java Connector (JCo) 3.0.1 or later
  • SAP RFC library
  • SAP Cryptographic library
  • To install Collector Server on SUSE Linux Enterprise Server 12, IBM Installation Manager 1.8.3 is required.
  • Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.

API

The API requires the installation of Collector Server. The following table shows the operating systems where the API can be installed:

Operating system Other software, including the latest service packs Notes
  • Windows Server 2008 R2, Windows Server 2012, or Windows Server 2012 R2
  • Windows 7 Professional Edition, Enterprise Edition, or Ultimate Edition
  • Windows 8 Professional Edition or Enterprise Edition
Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.

Product Alias/Synonym

iccsap
icc sap
icc for sap
icc4sap
iccforsap
cssap
acsap

Document information

More support for: Content Collector for SAP Applications

Software version: 4.0.0, 4.0.0.1

Operating system(s): AIX, Linux, Solaris, Windows

Reference #: 7043206

Modified date: 06 December 2017


Translate this page: