System Requirements for Rational ClearCase

Detailed system requirements


Abstract

The list below identifies the supported releases of IBM Rational ClearCase from which you can select system requirements in different levels and organization of detail.

Content

The detailed system requirements information are the complete lists of hardware requirements, supported operating systems, prerequisites and optional supported software, with component-level details and operating system restrictions.

Tab navigation


System Requirements
by type

Requirement by type

Operating System: This report provides a list of operating systems supported by the product.

Software: This report provides a list of prerequisites and optional supported software for the product.

Hardware: This report provides the hardware requirements (such as disk space, memory and processing) for the product.

by platform

Requirement by platform

The complete list of hardware requirements, prerequisites and optional supported software with component-level details and operating system restrictions for the platform you select.

by component

Requirement by component

The complete list of supported operating systems, prerequisites and optional supported software organized by the functional units of the product.

Related requirements
  • Ubuntu 12.04 kernel issue with ClearCase 8.0.1:

    For Ubuntu 12.04 LTS, do not use Kernel 3.5. This kernel is not a LTS and is not supported by ClearCase. Even though Ubuntu will try to upgrade the kernel to 3.5, you must keep using kernel 3.2.x to be able to use ClearCase.

System Requirements
by type

Requirement by type

Operating System: This report provides a list of operating systems supported by the product.

Software: This report provides a list of prerequisites and optional supported software for the product.

Hardware: This report provides the hardware requirements (such as disk space, memory and processing) for the product.

by platform

Requirement by platform

The complete list of hardware requirements, prerequisites and optional supported software with component-level details and operating system restrictions for the platform you select.

by component

Requirement by component

The complete list of supported operating systems, prerequisites and optional supported software organized by the functional units of the product.

Related requirements
  • Ubuntu 12.04 kernel issue with ClearCase 8.0:

    For Ubuntu 12.04 LTS, do use Kernel 3.5. This kernel is not a LTS and is not supported by ClearCase. Even though Ubuntu will try to upgrade the kernel to 3.5, you must keep using kernel 3.2.x to be able to use ClearCase.



Important notes for all versions:
  • NFS Support

    For a given platform, IBM supports the NFS implementations that the platform supports.

    If you use non-ClearCase access, see the IBM Rational ClearCase Administrator's Guide for a description of the limitations associated with use of NFS and potential workarounds.

  • Basic software requirements

    When installing ClearCase on Linux, note that it may be necessary to have the kernel headers installed. Attempting to run the installation without the kernel headers installed could result in errors if precompiled MVFS modules are not available for the running kernel.

  • Required operating system patches

    Typically, correct Rational ClearCase operation depends on your having installed a number of required or recommended operating system patches. These are available from your operating system vendor. The operating system patches are cumulative. Therefore, if you install a more recent patch, it will include the fix required for Rational ClearCase. See the detailed reports above for a list of patches recommended or required for all hosts on which Rational ClearCase software runs.

    In addition to the patches listed, which fix problems known to affect ClearCase functionality, you may require other operating system vendor patches to keep your systems functioning properly. Refer to the appropriate vendor web site for information on where to obtain these patches.

    Some layered software packages (operating system components that may not be installed by default) may be required. Refer to the reports above for further details.

Related information

Software Product Compatibility Reports
V.R.M.F. Maintenance Stream Delivery Vehicle glossary

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational ClearCase
Documentation

Software version:

8.0, 8.0.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

7036569

Modified date:

2014-10-24

Translate my page

Machine Translation

Content navigation