System requirements for InfoSphere Optim pureQuery Runtime for Linux, UNIX, and Windows, Version 3.2

Product documentation


Abstract

Before installing IBM® InfoSphere Optim™ pureQuery Runtime for Linux®, UNIX®, and Windows®, Version 3.2, verify that your system and your data sources meet these requirements.

Content

The system requirements for IBM InfoSphere Optim pureQuery Runtime for Linux, UNIX, and Windows, Version 3.1.1 are at http://www.ibm.com/support/docview.wss?uid=swg27024175.

The system requirements for IBM Optim pureQuery Runtime for Linux, UNIX, and Windows, Version 2.2.1 and Version 2.2.1.1 are at http://www.ibm.com/support/docview.wss?uid=swg27019749.

Hardware requirements

Memory: Minimum of 128 MB RAM

Disk space: This table shows the minimum disk space that is required for each of the supported platforms. Additional disk space is required for the resources that you develop.

Platform Minimum disk space (in MB)
AIX® 287
HP-UX® 327
Linux® 238
Linux on IBM System p™ 261
Linux on IBM System z 255
Solaris Operating Environment® 312
Windows® 264


Operating system requirements

The following table shows the operating systems that are supported by IBM InfoSphere Optim pureQuery Runtime for Linux, UNIX, and Windows, Version 3.2:

Tab navigation

Supported platforms


AIX 32-bit 64-bit Notes
AIX 6.1 POWER System and future OS fix packs
N
Y
AIX 7.1 POWER System and future OS fix packs
N
Y

Supported platforms


HP-UX 32-bit 64-bit Notes
HP-UX 11i v2 IA64 and future OS fix packs
N
Y
HP-UX 11i v3 IA64 and future OS fix packs
N
Y

Supported platforms

Operating system 32-bit 64-bit Notes
Linux on System x (x86)
Red Hat Enterprise Linux (RHEL) 5 (x86-32 and x86-64) and future OS fix packs
Y
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) 5 Desktop editions (x86-32 and x86-64) and future OS fix packs
Y
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) 5 Advanced Platform (x86-32 and x86-64) and future OS fix packs
Y
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) Desktop 6 (x86-32 and x86-64) and future OS fix packs
Y
Y
v6.0 - v6.1
Red Hat Enterprise Linux (RHEL) Server 6 (x86-32 and x86-64) and future OS fix packs
Y
Y
v6.0 - v6.1
SUSE Linux Enterprise Desktop (SLED) 10.0 (x86-32 and x86-64) and future OS fix packs
Y
Y
SUSE Linux Enterprise Desktop (SLED) 11.0 (x86-32 and x86-64) and future OS fix packs
Y
Y
SUSE Linux Enterprise Server (SLES) 10 (x86-32 and x86-64) and future OS fix packs
Y
Y
SUSE Linux Enterprise Server (SLES) 11 (x86-32 and x86-64) and future OS fix packs
Y
Y
Linux on POWER System
Red Hat Enterprise Linux (RHEL) 5 POWER System and future OS fix packs
N
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) 5 Advanced Platform POWER System and future OS fix packs
N
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) Server 6 POWER System and future OS fix packs
N
Y
v6.0 - v6.1
SUSE Linux Enterprise Server (SLES) 10 POWER System and future OS fix packs
SUSE Linux Enterprise Server (SLES) 11 POWER System and future OS fix packs
N
Y
Linux on System z
Red Hat Enterprise Linux (RHEL) 5 System z and future OS fix packs
N
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) 5 Advanced Platform System z and future OS fix packs
N
Y
v5.0 - v5.5
Red Hat Enterprise Linux (RHEL) Server 6 System z and future OS fix packs
N
Y
v6.0 - v6.1
SUSE Linux Enterprise Server (SLES) 10 System z and future OS fix packs
N
Y
SUSE Linux Enterprise Server 11 for IBM System z
N
Y

Supported platforms


Solaris Operating Environment 32-bit 64-bit Notes
Solaris 10 SPARC and future OS fix packs
N
Y
Solaris 10 x86-64 and future OS fix packs
N
Y

Supported platforms

Operating system 32-bit 64-bit Notes
Windows 8
Windows 7 Professional (x86-32 and x86-64) and future OS fix packs
Y
Y
Toleration
Windows 7
Windows 7 Enterprise (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 7 Professional (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 7 Ultimate (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 2003
Windows Server 2003 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 2008
Windows Server 2008 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 R2 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 R2 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista
Windows Vista Business (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista Enterprise (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista Ultimate (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows XP
Windows XP SP2 Professional (x86-32 and x86-64) and future OS fix packs
Y
Y


Software requirements for Java development


Java environment
Java® Runtime Environment 1.5.0 compatible or higher except when running the pureQuery Generator utility. The Generator utility requires Java Runtime Environment 1.6.0 compatible or higher.

Client software
The following data server client versions are supported:

Client software Notes
IBM Data Server Driver for JDBC and SQLJ Version 3.57 Minimum version required. See Notes for other requirements.
IBM Data Server Driver for JDBC and SQLJ Version 4.7 Minimum version required. See Notes for other requirements.
Oracle JDBC Driver 10g 10.2 Requires one of the following:
ojdbc5.jar
datadirect 4
Oracle JDBC Driver 11g 11.1 Requires one of the following:
ojdbc5.jar
ojdbc6.jar
datadirect 4
Oracle JDBC Driver 11g 11.2.0.1.0 Requires one of the following:
ojdbc5.jar
ojdbc6.jar
datadirect 4

Notes:

For client applications that connect to DB2 for System i or DB2 for z/OS databases:

  • For client applications that connect directly to DB2 for System i or DB2 for z/OS databases, use DB2 Connect, Version 9.7 for making database connections. (APAR IZ50393 or later is recommended.)
  • For client applications that connect to DB2 for System i or DB2 for z/OS databases via a gateway, the gateway can be DB2 Connect Enterprise Edition, Version 8.2 or later.

Data source requirements
For the development of Java applications, IBM Optim pureQuery Runtime for Linux, UNIX, and Windows Version 3.2 supports the following data sources:

Database platform Notes
DB2 for Linux, UNIX, and Windows
DB2 Advanced Enterprise Server Version 10.1
DB2 Enterprise Server Version 10.1
DB2 Workgroup Server Version 10.1
DB2 Enterprise Server Version 9.5 and future fix packs (overview) (support)
DB2 Enterprise Server Version 9.7 and future fix packs (overview) (support)
DB2 pureScale Feature for Enterprise Server Version 9.8 and future fix packs
DB2 for i
DB2 for i 6.1 and future fix packs IBM System i V6.1 R1 requires PTF SI41400 and SI41401
DB2 for i 7.1 and future fix packs IBM System i V7.1 R1 requires PTF SI41398 and SI41399
DB2 for z/OS
DB2 for z/OS 9.1 and future fix packs (overview) (support)
DB2 for z/OS 10.1 and future fix packs (overview) (support)
Informix
Informix Dynamic Server Enterprise Edition 11.50 and future fix packs (overview) (support) Only supported for Java and DB2 CLI (not .NET).
IBM Informix 11.70 and future fix packs (overview) (support) Informix Dynamic Server 11.7.
Oracle
Oracle Database 10g Standard/Enterprise Edition Release 1
Oracle Database 10g Standard/Enterprise Edition Release 2
Oracle Database 11g Standard/Enterprise Edition Release 1


Application servers


The product supports the following WebSphere Application Servers:

Application server Notes
WebSphere Application Server v7.0 and future fix packs (overview) (support)
WebSphere Application Server 8.0 and future fix packs (overview) (support)
WebSphere Application Server 8.5 and future fix packs (overview) (support)
Web Application Server Express 8.5 and future fix packs (overview) (support)
Web Application Server for Developers 8.5 and future fix packs (overview) (support)
Web Application Server for z/OS 8.5 and future fix packs (overview) (support)
WebSphere Application Server Network Deployment v6.0 and future fix packs (overview) (support) Requires manual configuration.
WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) Requires manual configuration.
WebSphere Application Server Network Deployment 8.0 and future fix packs (overview) (support) Requires manual configuration.


Requirements for .NET development

With Optim pureQuery Runtime Version 2.1 or later, a .NET application can be enabled with pureQuery client optimization.


Supported operating systems
The product supports the following operating systems for .NET® applications:

Operating system 32-bit 64-bit
Windows 7
Windows 7 Enterprise (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 7 Professional (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 7 Ultimate (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 2003
Windows Server 2003 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2003 R2 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows 2008
Windows Server 2008 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 Enterprise Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 R2 Datacenter Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 R2 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Server 2008 Standard Edition (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista
Windows Vista Business (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista Enterprise (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows Vista Ultimate (x86-32 and x86-64) and future OS fix packs
Y
Y
Windows XP
Windows XP SP2 Professional (x86-32 and x86-64) and future OS fix packs
Y
Y

Software requirements for .NET development

  • IBM Data Server Clients for ODBC, CLI, .NET V9.7.6, or later
  • For applications that connect to DB2 for System i or DB2 for z/OS databases:
    • For client applications that connect directly to DB2 for System i or DB2 for z/OS databases, use DB2 Connect, Version 9.7 for database connections.
    • For client applications that connect to DB2 for System i or DB2 for z/OS databases via a gateway, the gateway can be DB2 Connect Enterprise Edition, Version 8.2 or later.

Data source requirements

For the development of .NET applications, IBM Optim pureQuery Runtime for Linux, UNIX, and Windows Version 2.2.1 or later supports the following data sources through DB2 Connect:

Data source Notes
DB2 for Linux, UNIX, and Windows
DB2 Advanced Enterprise Server Version 10.1
DB2 Enterprise Server Version 10.1
DB2 Workgroup Server Version 10.1
DB2 Enterprise Server Version 9.5 and future fix packs (overview) (support)
DB2 Enterprise Server Version 9.7 and future fix packs (overview) (support)
DB2 pureScale Feature for Enterprise Server Version 9.8 and future fix packs
DB2 for i
DB2 for i5/OS 6.1 and future fix packs IBM System i V6.1 R1 requires PTF SI41400 and SI41401
DB2 for i5/OS 7.1 and future fix packs IBM System i V7.1 R1 requires PTF SI41398 and SI41399
DB2 for z/OS
DB2 for z/OS 9.1 and future fix packs (overview) (support)
DB2 for z/OS 10.1 and future fix packs (overview) (support) Requires DB2 Connect Version 9.7 Fix Pack 3a or later


Requirements for ODBC and DB2 CLI applications

With Optim pureQuery Runtime Version 2.1 or later, a DB2 call level interface (CLI) application can be enabled with pureQuery client optimization.

Software requirements

The product supports the following connectivity products:

Connectivity product Notes
IBM Data Server Driver Package, Version 9.7 Fix Pack 3 or later
IBM Data Server Driver for ODBC and CLI, Version 9.7 Fix Pack 3 or later
IBM Data Server Runtime Client, Version 9.7 Fix Pack 3 or later
IBM Data Server Client, Version 9.7 Fix Pack 3 or later


Data source requirements
The product supports the following data sources:

Data source Notes
DB2 for Linux, UNIX, and Windows
DB2 Advanced Enterprise Server Version 10.1
DB2 Enterprise Server Version 10.1
DB2 Workgroup Server Version 10.1
DB2 Enterprise Server Version 9.5 and future fix packs (overview) (support)
DB2 Enterprise Server Version 9.7 and future fix packs (overview) (support)
DB2 for z/OS
DB2 for z/OS 9.1 and future fix packs (overview) (support)
DB2 for z/OS 10.1 and future fix packs (overview) (support) Requires DB2 Connect Version 9.7 Fix Pack 3a or later
Informix
Informix Dynamic Server Enterprise Edition 11.50 and future fix packs (overview) (support)
IBM Informix 11.70 and future fix packs (overview) (support) Informix Dynamic Server 11.7


Requirements for SQL Management repository

With Optim pureQuery Runtime Version 2.2.0.3 or later, you can create an SQL Management repository in a database. The repository can store pureQuery configuration information, pureQueryXML data, and captured SQL data. The following database platforms can be used to create a repository:

Data source Notes
DB2 Linux, UNIX, and Windows
DB2 Advanced Enterprise Server Version 10.1
DB2 Advanced Enterprise Server Version 9.7 and future fix packs (overview) (support)
DB2 Enterprise Server Version 10.1
DB2 Enterprise Server Version 9.5 and future fix packs (overview) (support)
DB2 Enterprise Server Version 9.7 and future fix packs (overview) (support)
DB2 pureScale Feature for Enterprise Server Version 9.8 and future fix packs Toleration only. Support only for DB2 Version 9.7 features.
DB2 Workgroup Server Version 10.1
DB2 Workgroup Server Version 9.5 and future fix packs (overview) (support)
DB2 Workgroup Server Version 9.7 and future fix packs (overview) (support)
DB2 for i
DB2 for i 7.1 and future fix packs Toleration only. Support only for DB2 for i5/OS V5R4 features.
DB2 for i 6.1 and future fix packs Toleration only. Support only for DB2 for i5/OS V5R4 features.
DB2 for z/OS
DB2 for z/OS 9.1 and future fix packs (overview) (support)
DB2 for z/OS 10.1 and future fix packs (overview) (support)
Oracle
Oracle Database 10g Standard/Enterprise Editions Release 1
Oracle Database 10g Standard/Enterprise Editions Release 2
Oracle Database 11g Standard/Enterprise Editions Release 1


Virtualization

The following table shows the virtualization software and operating systems supported by IBM InfoSphere Optim pureQuery Runtime for Linux, UNIX, and Windows, Version 3.2:

AIX Linux Windows
IBM PowerVM Hypervisor (LPAR, DPAR, Micro-Partition) any supported version
Y
IBM PR/SM any version
Y
IBM z/VM Hypervisor 6.1
Y
VMware ESXi 5.0
Y
Y
VMWare vSphere 5.0
Y
Y


Other requirements

  • If you use the pureQuery StaticBinder utility to bind the SQL statements in annotated methods to a data source, you can minimize the StaticBinder utility loading dependencies with the Apache BCEL library. The Apache BCEL JAR file is not shipped with pureQuery Runtime. The BCEL library is available from the Apache project website.
  • The license for IBM DB2 10.1 for Linux, UNIX, and Windows, Advanced Enterprise Server Edition (DB2 AESE) now includes entitlement to InfoSphere Optim pureQuery Runtime for Linux, UNIX, and Windows. This entitlement can be used only with the DB2 data server included with DB2 AESE. Use of the pureQuery Runtime technology with any other DB2 data servers will require purchase of additional licenses for pureQuery Runtime technology.

Rate this page:

(0 users)Average rating

Document information


More support for:

InfoSphere Optim pureQuery Runtime for Linux, UNIX and Windows

Software version:

3.2

Operating system(s):

AIX, HP-UX, Linux, Linux pSeries, Linux zSeries, Solaris, Windows

Reference #:

7036430

Modified date:

2013-06-13

Translate my page

Machine Translation

Content navigation