Detailed System Requirements for v9.1 of the IBM InfoSphere Optim workstation and IBM InfoSphere Optim server

Detailed system requirements


Abstract

This document describes the system requirements for v9.1 of the IBM® InfoSphere® Optim™ workstation and IBM InfoSphere Optim server.

Content

Hardware considerations

Software requirements

IBM Tivoli License Manager

Supported character sets

Hardware considerations

The following are minimum requirements; actual hardware capacity for acceptable performance depends upon many factors, including but not limited to:

  • data volume
  • service level agreement
  • access to non-relational data
  • the number of open dialogs
  • the number of database tables that are active
  • memory demands from other active applications and services

Optim workstation

  • Intel (for example, Intel Pentium i5, i7)
  • 1 – 2 Cores
  • 1.7 GHz minimum or faster
  • 2 GB RAM
  • 1 GB disk for Optim Software installation
  • 10BaseT or 100BaseT network connection

Optim server

Note that sizing for the Optim server depends upon a number of factors and plans should be reviewed by an Optim specialist prior to deployment.

AIX® HP-UX or HP-Itanium Linux Microsoft Windows Solaris

IBM POWER5, 2.0 GHz, or POWER6, 3.0 GHz
Recommended: IBM POWER 7, 3.5 GHz or IBM Blade

PA-RISC or HP BladeSystem (Dual or Quad Core)

Intel Xeon or AMD Opteron

Intel Xeon or AMD Opteron

Sun SPARC Enterprise or newer, or Sun Blade

2 – 4 Cores or more depending on workload

>2 – 4 Cores or more depending on workload

>2 – 4 Cores or more depending on workload

>2 – 4 Cores or more depending on workload

>2 – 4 Cores or more depending on workload

2.0 GHz
Recommended: Highest processor speed

2.0 GHz
Recommended: Highest processor speed

2.0 GHz
Recommended: Highest processor speed

2.0 GHz
Recommended: Highest processor speed

2.0 GHz
Recommended: Highest processor speed

2 – 4 GB RAM per CPU Core

2 – 4 GB RAM per CPU Core

2 – 4 GB RAM per CPU Core

2 – 4 GB RAM per CPU Core

2 – 4 GB RAM per CPU Core

1 GB disk for Optim software installation

1 GB disk for Optim software installation

1 GB disk for Optim software installation

1 GB disk for Optim software installation

1 GB disk for Optim software installation

One 100 Mbit Network Interface Card (NIC). Recommended: 1 GBPS with TCP/IP connectivity networked on an enterprise class network, such as LAN operating at 1000 MBPS.

One 100 Mbit Network Interface Card (NIC). Recommended: 1 GBPS with TCP/IP connectivity networked on an enterprise class network, such as LAN operating at 1000 MBPS.

One 100 Mbit Network Interface Card (NIC). Recommended: 1 GBPS with TCP/IP connectivity networked on an enterprise class network, such as LAN operating at 1000 MBPS.

One 100 Mbit Network Interface Card (NIC). Recommended: 1 GBPS with TCP/IP connectivity networked on an enterprise class network, such as LAN operating at 1000 MBPS.

One 100 Mbit Network Interface Card (NIC). Recommended: 1 GBPS with TCP/IP connectivity networked on an enterprise class network, such as LAN operating at 1000 MBPS.

Minimum one Dual Port Fibre Channel Card, 4 Gb or 8 Gb for SAN

Minimum one Dual Port Fibre Channel Card, 4 Gb or 8 Gb for SAN

Minimum one Dual Port Fibre Channel Card, 4 Gb or 8 Gb for SAN

Minimum one Dual Port Fibre Channel Card, 4 Gb or 8 Gb for SAN

Minimum one Dual Port Fibre Channel Card, 4 Gb or 8 Gb for SAN

Software requirements

Platform considerations

Open data manager

To install the Optim server or workstation on the database server, client software for the database management system is required. Optim is a 32-bit application, and requires 32-bit DBMS clients. Optim must be installed on a 32-bit platform or on a 64-bit platform that supports 32-bit applications.

Platform considerations

Platform Server Workstation Comments

AIX v5.3

Yes

No

AIX v6.1

Yes

No

AIX v7.1

Yes

No

HP-UX 11i v2

Yes

No

Open Data Manager is not supported on this platform in conjunction with the end of service life for PA-RISC. After v9.1 of the Optim solutions, HP-UX is not supported.

HP-UX 11i v3

Yes

No

Open Data Manager is not supported on this platform in conjunction with the end of service life for PA-RISC. After v9.1 of the Optim solutions, HP-UX is not supported.

HP-UX 11i v2 on Itanium

Yes

No

Supported for DB2® for Linux, UNIX, and Windows and Oracle databases. After v9.1 of the Optim solutions, HP-UX is not supported.

HP-UX 11i v3 on Itanium

Yes

No

Supported for DB2® for Linux, UNIX, and Windows and Oracle databases. After v9.1 of the Optim solutions, HP-UX is not supported.

Red Hat Enterprise Linux 3

Yes

No

Red Hat Enterprise Linux 3 is not supported after v9.1 of the Optim solutions, in conjunction with the end of service life.

Red Hat Enterprise Linux 4

Yes

No

Red Hat Enterprise Linux 5

Yes

No

Red Hat Enterprise Linux 6

Yes

No

SUSE Linux Enterprise Server 9

Yes

No

Open Data Manager is not supported on this platform.

SUSE Linux Enterprise Server 10

Yes

No

Open Data Manager is not supported on this platform.

SUSE Linux Enterprise Server 11

Yes

No

Open Data Manager is not supported on this platform.

Solaris 9

Yes

No

Solaris 10

Yes

No

Windows XP Professional

Yes

Yes

The workstation and connecting servers must use the same version of Optim software.

Windows Server 2003

Yes

Yes

The workstation and connecting servers must use the same version of Optim software.

Windows 2003 R2

Yes

Yes

The workstation and connecting servers must use the same version of Optim software.

Windows Vista

Yes

Yes

  • Features in Windows Kernel Version 6.0 (Windows Vista) restrict the installation of Optim so that it must be installed under full Windows Administrator authority. See special installation instructions for these platforms.
  • The workstation and connecting servers must use the same version of Optim software.

Windows 7

Yes

Yes

  • Features in Windows Kernel Version 6.1 (Windows 7) restrict the installation of Optim so that it must be installed under full Windows Administrator authority. See special installation instructions for these platforms.
  • The workstation and connecting servers must use the same version of Optim software.

Windows Server 2008

Yes

Yes

  • Features in Windows Kernel Version 6.0 (Windows 2008) restrict the installation of Optim so that it must be installed under full Windows Administrator authority. See special installation instructions for these platforms.
  • The workstation and connecting servers must use the same version of Optim software.

Windows Server 2008 R2

Yes

Yes

  • Features in Windows Version 6.1 (Windows 2008 R2) restrict the installation of Optim so that it must be installed under full Windows Administrator authority. See special installation instructions for these platforms.
  • The workstation and connecting servers must use the same version of Optim software.

Open data manager

Note: If using Oracle heterogeneous services with open data manager to federate archived data with data in your database, only one LOB per table can be federated. This is because Oracle maps SQL_LONGVARBINARY as LONG when using heterogeneous services and LONG data types have known restrictions, including a limit of one LONG per table.

An uncompress utility is a prerequisite to the installation of Open Data Manager on most platforms. Where required, the utility is in the /usr/bin directory in the following packages.

When Open Data Manager is installed on Windows, it requires Microsoft .NET Framework 3.5 Service Pack 1 as a prerequisite. This software can be obtained from Microsoft.

Platform Package Description

AIX

bos.rte.archive

Base Operating System Runtime, Archive Commands

HP-UX

OS-Core.CMDS-MIN and PHCO_26898.CMDS-MIN

Minimum HP-UX commands with Patch (11.11)

Linux

ncompress

Fast compression and decompression utilities

Solaris

SUNWesu

Extended System Utilities

Windows

not required

IBM Tivoli License Manager

If you use IBM Tivoli License Manager, use the following manual process to activate it for data sources that do not reside on an Optim server or on a z/OS system:

  • Locate the set of *.swtag files residing at:
    Optim Root\properties\version\
  • Copy the *.swtag files to:
    \\server root\IBM\InfoSphere\Optim\ITLM on the server hosting the data source.

Supported character sets

The Optim solutions support Unicode databases in all supported database management systems. See information about supported character sets for all supported databases.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Optim
Solutions

Software version:

9.1

Operating system(s):

AIX, HP Itanium, HP-UX, Linux, Solaris, Windows, i5/OS

Reference #:

7036209

Modified date:

2014-08-19

Translate my page

Machine Translation

Content navigation