System requirements for IBM i2 Analyst's Notebook Premium

Product documentation


Abstract

This document provides details of the system requirements for IBM i2 Analyst's Notebook Premium.

Content

System requirements

Prerequisite software

Multicultural support





Legend
Icon Description
Supported Supported
Δ Added or changed information since the last release, modification, or fix pack. This mark in the far left column indicates new or changed information in the row.
x86 Systems with processors that support the x86 instruction set.
x86-64 Systems with processors that support the x86-64 instruction set.


Hardware requirements

These are the minimum desktop hardware requirements for IBM i2 Analyst's Notebook Premium:

  • 2 GHz quad core processor
  • 4 GB RAM
  • At least 1 GB free disk space for installation.

Operating systems

IBM i2 Analyst's Notebook Premium supports the following desktop operating systems.

Operating system x86 x86-64 POWER Notes
Δ Windows 8 Professional/Enterprise Supported on x86 Supported on x86-64
Windows 7 Professional/Enterprise/Ultimate Supported on x86 Supported on x86-64
Microsoft Windows Vista Business/Enterprise/Ultimate Supported on x86 Supported on x86-64

SP1 or later

Microsoft Windows XP Professional Supported on x86 Supported on x86-64

SP3 or later for x86.

SP2 or later for x86-64

IBM i2 Analyst's Notebook Premium supports the following server operating systems offering thin client environments.

Operating system x86 x86-64 POWER Notes
Δ Microsoft Windows Server 2012 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server 2008 R2 Supported on x86 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server 2008 Supported on x86 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server Standard/Enterprise 2003 SP2 or later Supported on x86 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server Standard/Enterprise 2003 R2 or later Supported on x86 Supported on x86-64

Terminal Services enabled

Note: All server operating systems are also supported with Citrix MetaFrame Presentation/Xen App Server 5.0 or later.

Virtualization support

IBM i2 Analyst's Notebook Premium is supported in the following virtual machine environments that have been tested:

  • Citrix XenServer
  • VMWare Workstation 6.5 or later
  • VMWare ESX Server 3 or later
  • Microsoft Hyper-V R1

Software requirements

IBM i2 Analyst's Notebook Premium requires the following software prerequisites:

Prerequisite software Notes
Microsoft .NET Framework 3.5 SP1 and 4.0 IBM i2 Analyst's Notebook Premium requires full, not "client profile," installations of .NET Framework 3.5 SP1 and .NET Framework 4.
Microsoft Visual C++ IBM i2 Analyst's Notebook Premium requires Microsoft Visual C++ 2005 SP 1 ATL Security Update.
Microsoft Windows Installer 4.5 If the installation system is running Windows Vista or Windows Server 2008.
A PDF viewer The documentation provided with IBM i2 Analyst's Notebook Premium is in Adobe PDF format.
Google Earth 5.0 or later. IBM i2 Analyst's Notebook Premium can map items to Google Earth 5.0 or later. Google Earth is not currently supported on Terminal Service-enabled server environments. Note that in this environment only one user at a time can use Google Earth.
Microsoft Office IBM i2 Anlyst's Notebook Premium can work with documents created by the following versions of Microsoft Office: Office 2000 (all editions), Office XP (all editions), Office 2003 (all editions), Office 2003 (all editions), Office 2007 (all editions) and Office 2010 (all editions). Note: Microsoft removed mainstream support for Office 2000 on 30 June 2004, and for Office XP on 11 July 2006. Customers are encouraged to prepare and start their upgrade plans as soon as possible.
Δ Microsoft Excel Importing data from a spreadsheet that has the format .xslx requires Microsoft Excel 2007 or later, or its equivalent compatibility pack to be installed.
Δ Microsoft PowerPoint Exporting Snapshots to PowerPoint requires Microsoft PowerPoint 2007 or later, or its equivalent compatibility pack.
Microsoft Silverlight 5

Client Browsers

IBM i2 Analyst's Notebook Premium requires one of the following browsers:

Browser Notes
Δ Microsoft Internet Explorer V10

You must enable JavaScript in the browser.

Microsoft Internet Explorer V9.x

You must enable JavaScript in the browser.

Microsoft Internet Explorer V8.x

You must enable JavaScript in the browser.

Microsoft Internet Explorer V7.x

You must enable JavaScript in the browser.

Mozilla Firefox V3.6.x

You must enable JavaScript in the browser.

Mozilla Firefox V3.5.x

You must enable JavaScript in the browser.

Multicultural support

IBM i2 Analyst's Notebook Premium is developed in US English. IBM supports this product in the English language on the following regional versions of the supported operating systems:

Language group/Language Language collection Support status
Arabic Complex script Supported
Armenian Complex script Unsupported
Baltic Basic Supported
Central Europe Basic Supported
Cyrillic Basic Supported
Dhivehi Complex script Unsupported
Galician Basic Unsupported
Georgian Complex script Unsupported
Greek Basic Unsupported
Gujarati Complex script Unsupported
Hebrew Complex script Unsupported
Indic Complex script Unsupported
Japanese East Asian Supported
Kannada Complex script Unsupported
Korean East Asian Supported
Kyrgyz Basic Unsupported
Mongolian (Cyrillic) Basic Unsupported
Punjabi Complex script Unsupported
Simplified Chinese East Asian Supported
Syriac Complex script Unsupported
Telgu Complex script Unsupported
Thai Complex script Unsupported
Traditional Chinese East Asian Supported
Turkic Basic Supported
Vietnamese Complex script Unsupported
Western Europe and USA Basic Supported

Change history
History Date Change
Release January 2014 Created for IBM i2 Analyst's Notebook Premium 8.9.7


System requirements

Prerequisite software

Multicultural support





Legend
Icon Description
Supported Supported
Δ Added or changed information since the last release, modification, or fix pack. This mark in the far left column indicates new or changed information in the row.
x86 Systems with processors that support the x86 instruction set.
x86-64 Systems with processors that support the x86-64 instruction set.


Hardware requirements

These are the minimum desktop hardware requirements for IBM i2 Analyst's Notebook Premium:

  • 2 GHz quad core processor
  • 4 GB RAM
  • At least 1 GB free disk space for installation.

Operating systems

IBM i2 Analyst's Notebook Premium supports the following desktop operating systems.

Operating system x86 x86-64 POWER Notes
Windows 7 Professional/Enterprise/Ultimate Supported on x86 Supported on x86-64
Microsoft Windows Vista Business/Enterprise/Ultimate Supported on x86 Supported on x86-64

SP1 or later

Microsoft Windows XP Professional Supported on x86 Supported on x86-64

SP3 or later for x86.

SP2 or later for x86-64

IBM i2 Analyst's Notebook Premium supports the following server operating systems offering thin client environments.

Operating system x86 x86-64 POWER Notes
Microsoft Windows Server 2008 R2 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server 2008 Supported on x86 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server Standard/Enterprise 2003 SP2 or later Supported on x86 Supported on x86-64

Terminal Services enabled

Microsoft Windows Server Standard/Enterprise 2003 R2 or later Supported on x86 Supported on x86-64

Terminal Services enabled

Note: All server operating systems are also supported with Citrix MetaFrame Presentation/Xen App Server 5.0 or later.

Virtualization support

IBM i2 Analyst's Notebook Premium is supported in the following virtual machine environments that have been tested:

  • Citrix XenServer
  • VMWare Workstation 6.5 or later
  • VMWare ESX Server 3 or later
  • Microsoft Hyper-V R1

Software requirements

IBM i2 Analyst's Notebook Premium requires the following software prerequisites:

Prerequisite software Notes
Microsoft .NET Framework 3.5 SP1 or 4.0 The version of .NET you require will depend on the operating system you are running. These versions are included with the product. IBM i2 Analyst's Notebook Premium requires full, not "client profile," installations of .NET Framework 3.5 SP1 and .NET Framework 4.
Microsoft Visual C++ IBM i2 Analyst's Notebook Premium requires Microsoft Visual C++ 2005 SP 1 ATL Security Update.
Microsoft Windows Installer 4.5 If the installation system is running Windows Vista or Windows Server 2008.
A PDF viewer The documentation provided with IBM i2 Analyst's Notebook Premium is in Adobe PDF format.
Google Earth 5.0 or later. IBM i2 Analyst's Notebook Premium can map items to Google Earth 5.0 or later. Google Earth is not currently supported on Terminal Service-enabled server environments. Note that in this environment only one user at a time can use Google Earth.
Microsoft Office IBM i2 Anlyst's Notebook Premium can work with documents created by the following versions of Microsoft Office: Office 2000 (all editions), Office XP (all editions), Office 2003 (all editions), Office 2003 (all editions), Office 2007 (all editions) and Office 2010 (all editions). Note: Microsoft removed mainstream support for Office 2000 on 30 June 2004, and for Office XP on 11 July 2006. Customers are encouraged to prepare and start their upgrade plans as soon as possible.
Microsoft Silverlight 5

Client Browsers

IBM i2 Analyst's Notebook Premium requires one of the following browsers:

Browser Notes
Δ Microsoft Internet Explorer V9.x

You must enable JavaScript in the browser.

Microsoft Internet Explorer V8.x

You must enable JavaScript in the browser.

Microsoft Internet Explorer V7.x

You must enable JavaScript in the browser.

Mozilla Firefox V3.6.x

You must enable JavaScript in the browser.

Mozilla Firefox V3.5.x

You must enable JavaScript in the browser.

Multicultural support

IBM i2 Analyst's Notebook Premium is developed in US English. IBM supports this product in the English language on the following regional versions of the supported operating systems:

Language group/Language Language collection Support status
Arabic Complex script Supported
Armenian Complex script Unsupported
Baltic Basic Supported
Central Europe Basic Supported
Cyrillic Basic Supported
Dhivehi Complex script Unsupported
Galician Basic Unsupported
Georgian Complex script Unsupported
Greek Basic Unsupported
Gujarati Complex script Unsupported
Hebrew Complex script Unsupported
Indic Complex script Unsupported
Japanese East Asian Supported
Kannada Complex script Unsupported
Korean East Asian Supported
Kyrgyz Basic Unsupported
Mongolian (Cyrillic) Basic Unsupported
Punjabi Complex script Unsupported
Simplified Chinese East Asian Supported
Syriac Complex script Unsupported
Telgu Complex script Unsupported
Thai Complex script Unsupported
Traditional Chinese East Asian Supported
Turkic Basic Supported
Vietnamese Complex script Unsupported
Western Europe and USA Basic Supported

Change history
History Date Change
Release November 2012 Created for IBM i2 Analyst's Notebook Premium 8.9.3


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

i2 Analyst's Notebook Premium

Software version:

8.9.3, 8.9.5, 8.9.7

Operating system(s):

Windows

Reference #:

7036199

Modified date:

2014-01-30

Translate my page

Machine Translation

Content navigation