QMF Version 10 system requirements

Detailed system requirements


Abstract

This page lists the minimum versions of prerequisite products for QMF Version 10 by QMF product family component. QMF Classic Edition and QMF Classic Edition VUE include QMF for TSO and CICS only; QMF Enterprise Edition and QMF Enterprise Edition VUE include all four product components in the menu below.

Content

Tab navigation







QMF for TSO and CICS requirements

Hardware:

Any System z® processor

Software:

Operating system:

z/OS® Version 1.10 or higher

(For more specific information about QMF for TSO/CICS® compatibility with various z/OS releases, see QMF for TSO/CICS Compatibility with z/OS.)

Database functions:

QMF for TSO and CICS must be installed and started in one of the following DB2® for z/OS databases:

  • DB2 10 for z/OS (5605-DB2, any mode)
  • DB2 Version 9.1 for z/OS (5635-DB2, any mode)
  • DB2 UDB for z/OS Version 8 Release 1.5 (5625-DB2, New Function Mode)

Once installed, QMF for TSO and CICS can connect to any database in the IBM DB2 family.

Database requirements for QMF VUE editions:

  • If you purchased QMF for TSO and CICS as part of QMF 10 Classic Edition VUE, QMF for TSO/CICS must be installed and started in a DB2 10 for z/OS VUE database (5697-P31).
  • If you purchased QMF for TSO and CICS as part of QMF 10 Enterprise Edition VUE, QMF for TSO/CICS can be installed and started in either a DB2 Version 9.1 for z/OS VUE database (5697-P12) or a DB2 10 for z/OS VUE database (5697-P31).

For information about whether QMF PTFs need to be applied for QMF to operate properly with the version of DB2 that you are using, see DB2 Information Management Tools and DB2 10 for z/OS Compatibility and select the appropriate tab for the DB2 release in question.

Panel display:

  • GDDM (GDDM is a base element of z/OS)

Charting functions:

  • GDDM-PGF 2.1.3 (5668-812)

If operating under CICS:

  • CICS Transaction Server for z/OS Version 3 Release 1 or higher (5655-M15)

For SMP/E installation requirements, see the appropriate program directory for your QMF edition and language on the QMF Library page.


QMF High Performance Option (HPO) requirements

Hardware:

Any System z processor

Software:

Operating system:

z/OS Version 1.10 or higher

Database functions:

QMF HPO must be installed in a DB2 for z/OS Version 8.1 (or higher) database. If you purchased QMF HPO as part of QMF 10 Enterprise Edition VUE, QMF HPO must be run against a DB2 10 for z/OS VUE (5697-P31) or DB2 Version 9.1 for z/OS VUE database (5697-P12). For information about whether QMF HPO PTFs need to be applied for HPO to operate properly with the version of DB2 that you are using, see DB2 Information Management Tools and DB2 10 for z/OS Compatibility and select the appropriate tab for the DB2 release in question.

For SMP/E installation requirements, see the appropriate program directory for your QMF edition and language on the QMF Library page.


QMF for Workstation requirements

Hardware and memory:

  • Approximately 275 MB of disk space (single language installation)
  • Minimum of 256 MB of RAM
  • Network connectivity

Software:

Operating systems:

QMF for Workstation can be installed on any of the following operating systems:

  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Red Hat Enterprise Linux WS 5
  • SuSE Linux 10 and 11
  • Mac OS 10.5 and 10.6

Database functions:

QMF for Workstation can run against any of the following databases:

  • DB2 10 for z/OS
  • DB2 10 for z/OS VUE
  • DB2 Version 9.1 for z/OS
  • DB2 Version 9.1 for z/OS VUE
  • DB2 UDB for z/OS Version 8
  • DB2 Server for VSE and VM V7.3 and V7.4
  • DB2 for iSeries V5.4, V6.1, and V7.1
  • DB2 for Linux, UNIX, and Windows V9.1, V9.5, and V9.7
  • Informix Dynamic Server (IDS) Version 9.n, 10, and V11
  • Model 204 V7R1 for z/OS
  • Model 204 V7R1 for z/VM

Database connectivity requires an appropriate JDBC driver for each type of database accessed.

For information about whether QMF for Workstation fix packs need to be applied for QMF to operate properly with the version of DB2 that you are using, see DB2 Information Management Tools and DB2 10 for z/OS Compatibility and select the appropriate tab for the DB2 release in question.

Optional software:

The following optional functions require additional support:

  • OLAP support requires InfoSphere Warehouse V9.5.2 or higher or other MDX-based OLAP servers with support for XMLA connectivity.
  • Adobe Flash Player 10.1.51 or higher on the client is required if deploying visual dashboards using the optional Flash output format.
  • Exporting result sets to Microsoft Excel requires a minimum level of Excel 2003.

QMF for WebSphere requirements

Hardware:

Approximately 200 MB hard disk space

Software:

Application server:

QMF for WebSphere supports most popular application servers, including the following:

  • WebSphere Application Server Version 6.1, 7, or 8, running on any platform supported by WebSphere Application Server
  • Tomcat 4.n to 5.5

Web browsers:

One of the following Web browsers (with JavaScript support enabled) is required on each user machine:

  • Microsoft Internet Explorer V7.0 or higher
  • Firefox 3.0 or higher
  • Apple Safari V5.1 or higher
  • Google Chrome

Database functions:

QMF for WebSphere can run against any of the following databases:

  • DB2 10 for z/OS
  • DB2 10 for z/OS VUE
  • DB2 Version 9.1 for z/OS
  • DB2 Version 9.1 for z/OS VUE
  • DB2 UDB for z/OS Version 8
  • DB2 Server for VSE and VM V7.3 and V7.4
  • DB2 for iSeries V5.4, V6.1, and V7.1
  • DB2 for Linux, UNIX, and Windows V9.1, V9.5, and V9.7
  • Informix Dynamic Server (IDS) Version 9.n, 10, and V11
  • Model 204 V7R1 for z/OS
  • Model 204 V7R1 for z/VM

Database connectivity requires an appropriate JDBC driver for each type of database accessed.

For information about whether QMF for WebSphere fix packs need to be applied for QMF to operate properly with the version of DB2 that you are using, see DB2 Information Management Tools and DB2 10 for z/OS Compatibility and select the appropriate tab for the DB2 release in question.

Optional software:

The following optional functions require additional support:

  • OLAP support requires InfoSphere Warehouse V9.5.2 or higher or other MDX-based OLAP servers with support for XMLA connectivity.
  • Java Runtime Environment (JRE) 1.6 or higher is required if deploying dashboards that use the optional Java Applet.
  • Adobe Flash Player 10.1.51 or higher on the client is required if deploying visual dashboards using the optional Flash output format.
  • Exporting result sets to Microsoft Excel requires a minimum level of Excel 2003 on the user machine where the web browser is running.

Rate this page:

(0 users)Average rating

Document information


More support for:

DB2 Query Management Facility

Software version:

10.1

Operating system(s):

Linux, Windows, z/OS

Software edition:

All Editions

Reference #:

7025148

Modified date:

2012-05-18

Translate my page

Machine Translation

Content navigation