InfoSphere Federation Server Version 10.1 data source requirements

Product documentation


Abstract

The supported data sources of IBM® InfoSphere™ Federation Server are shown in the following tables.

Content

When configuring a wrapper, a software layer (driver, SDK, or standalone program) is required that handles the vendor-specific communication with the data source. This layer may be built in to InfoSphere Federation Server, provided by IBM on the media with InfoSphere Federation Server, or in some cases, provided by the vendor of the data source or other third party.


The first table shows which data sources require vendor-supplied software to complete the wrapper. This software must be acquired separately and installed on the same system as IBM InfoSphere Federation Server for the data sources that you want to access.

The second table shows the availability of wrappers on 32-bit and 64-bit operating systems. Certain wrappers are not available on all operating systems due to the availability of dependent data source software.

Table 1. Supported data sources, versions, and software requirements.

Data Source
Supported Versions
Additional dependent data source software
BioRS 5.2, 5.3 None
CA-Datacom 10, 11 Classic Federation Server for z/OS
CA-IDMS 16, 17 Classic Federation Server for z/OS
DB2 for Linux®, UNIX®, and Windows® 8.1.x, 8.2.x, 9.1, 9.5, 9.7, 9.8, 10.1 None
DB2 for z/OS® 7.x, 8.x, 9.x, 10.x None1
DB2 for System i® 5.2, 5.3, 5.4, 6.1, 7.1 None1
DB2 Server for VSE and VM 7.2, 7.4 None1
Flat files N/A None
IMS 10.1, 11.1 Classic Federation Server for z/OS
Informix® Informix 11.1, 11.5, 11.7, 12.10 Informix Client SDK version 3.0 or higher
JDBC 3.0 or later JDBC drivers and manager comply with JDBC 3.0 or later
Microsoft® Excel 2000, 2002, 2003, 2007 None2
Microsoft SQL Server Microsoft SQL Server 2000 SP4, 2005, 2008, 2008R2 None3
MQ MQ7 None4
Netezza 4.6, 5.0, 6.0 Netezza ODBC driver
ODBC 3.0 or later ODBC driver5
OLE DB 2.7, 2.8 None
Oracle 10g, 10gR2, 11g, 11gR1, 11gR2 Oracle NET client 10.0 - 10.1, 10.2.0.1 with patch 3807408, 10.1.0.3 with patch 3807408, 11.1.0.6.0
Sybase Sybase ASE 12.5, 15.0, 15.5 Sybase Open Client 12.5 - 15.5
Teradata 2.5, 2.6, 12, 13 Shared Common Components for Internationalization for Teradata (tdicu) version 1.01 or later, Teradata Generic Security Services (TeraGSS) version 6.01 or later, and the software on the following operating systems:
  • For Windows: Teradata client TTU 8.0 or later and the Teradata API library CLIv2 4.8.0 or later
  • For UNIX and Linux: Teradata Call-Level Interface Version 2 CLIv2 Release 4.8.0 or later
VSAM CICS® Transaction Server V3.1, V3.2, V4.1

Native VSAM access for the supported z/OS levels

Transactional VSAM access with DFSMS Transactional VSAM Services (DFSMStys) at the supported z/OS levels
Classic Federation Server for z/OS
Web Services WSDL 1.0, 1.1
SOAP 1.0, 1.1
None
XML XML1.0, XML1.1 None
1 DB2 Connect is included as a supporting program for the purpose of accessing this data source.

2 IBM recommends connecting to Excel as an ODBC source. The requirements are then the same as shown for ODBC in this table.

3 IBM-branded DataDirect ODBC driver, which is included with the product, is recommended for connections on Linux/Unix. For Windows, IBM recommends using the ODBC driver manager and ODBC driver from Microsoft.

4 Required MQ software is included as a supporting program.

5 ODBC can be used to access RedBrick, InfoSphere Classic Federation, Netezza, and a wide variety of other data sources. An IBM-branded DataDirect driver manager and ODBC drivers are included with the product for connections on Linux/Unix. However, ODBC drivers provided by the vendors are needed for specific data sources, such as MySQL. For Windows, IBM recommends using the ODBC driver manager from Microsoft and the ODBC driver from data source vendors

Table 2. Availability of wrappers on 32-bit and 64-bit operating systems.

This table shows whether or not a wrapper is available on a certain operating system. It does not imply anything about the availability of data server or client software on that platform. To access the data source, the wrapper must be available on the operating system where Federation Server runs.

Hardware architecture
X86-32 *
X86-32

X86-64
X86-64
Power
Itanium ®
Power
Sparc
zSeries ®
Operating system
Linux
RHEL
SUSE
Windows
Linux
RHEL
SUSE
Windows
AIX ®
HP-UX
Linux
RHEL
SUSE
Solaris
Linux
RHEL
SUSE
Data Source
BioRS
Y
Y
Y
Y
Y
Y
Y
Y
Y
DB2 for Linux, UNIX, and Windows
Y
Y
Y
Y
Y
Y
Y
Y
Y
DB2 for z/OS
Y
Y
Y
Y
Y
Y
Y
Y
Y
DB2 for iSeries
Y
Y
Y
Y
Y
Y
Y
Y
Y
DB2 Server for VSE and VM
Y
Y
Y
Y
Y
Y
Y
Y
Y
Informix
Y
Y
Y
Y
Y
Y
Y
Y
JDBC
Y
Y
Y
Y
Y
Y
Y
Y
Y
Microsoft Excel
Y
Y
Microsoft SQL Server
Y
Y
Y
Y
Y
Y
Y
Y
MQ
Y
Y
Y
Y
Y
Y
Y
Y
Netezza
Y
Y
Y
Y
Y
Y
ODBC
Y
Y
Y
Y
Y
Y
Y
Y
OLE DB
Y
Y
Y
Y
Oracle
Y
Y
Y
Y
Y
Y
Y
Y
Y
Script
Y
Y
Y
Y
Y
Y
Y
Y
Y
Sybase
Y
Y
Y
Y
Y
Y
Y
Y
Teradata
Y
Y
Y
Y
Y
Y
Y
Web Services
Y
Y
Y
Y
Y
Y
Y
Y
Y
XML
Y
Y
Y
Y
Y
Y
Y
Y
Y
* The data sources available on Linux X86-32 apply to DB2 Developer Edition only.

Rate this page:

(0 users)Average rating

Document information


More support for:

InfoSphere Federation Server

Software version:

10.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

7024461

Modified date:

2014-12-10

Translate my page

Machine Translation

Content navigation