Prerequisites for IBM Content Collector Version 3.0

Product documentation


Abstract

This document details the system requirements for IBM Content Collector Version 3.0.

Content

Product requirements for IBM Content Collector

 

Legend

x86 Intel 32-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers.
X86-64 64-bit AMD Opteron (AMD64) and Intel Xeon (EM64T) processors, including IBM System x and BladeCenter servers

Hardware requirements

IBM Content Collector server

The following table contains the minimum and the recommended hardware requirements for the server where IBM Content Collector is installed.

Hardware requirements Minimum Recommended
Processor 2 dual-core processors
x86 or x86-64
2 six-core processors
x86 or x86-64
Processor speed 2.5 GHz > 3 GHz
System memory (RAM) 4 GB 8 GB
Hard disk Hard drive with sufficient capacity 2 enterprise class hard drives with 10000 RPM or better
Disk space For IBM Content Collector program package, prerequisite software, temporary data, and log information 150 GB > 150 GB
For each IBM Content Collector server that is intended to run an SMTP Receiver instance 750 GB redundant storage

If multiple Content Collector servers are deployed in a scale-out setup to archive documents from SMTP email systems, this storage must be on a fast NAS device and shared between all Content Collector servers.
1 TB redundant storage
For IBM Connections archiving 10 GB redundant storage

If multiple Content Collector servers are deployed in a scale-out setup to archive IBM Connections documents, this storage must be on a fast NAS device and shared between all Content Collector servers.
> 10 GB

Supported virtualization environments for IBM Content Collector are VMware ESX and ESXi 4.0, 4.1, and 5.1.


Client workstations

The hardware capacity of connected client workstations must be sufficient to run the supported client applications:

For more information, see the client software documentation.

Software prerequisites

Prerequisites for the IBM Content Collector server

The following section describes the operating system and other software that is required on the system where IBM Content Collector Server is installed.

Operating system


IBM Content Collector can be installed on servers with one of the following operating systems:

Operating systems Editions Architectures Fixes
Windows Server 2008
  • Standard Edition
  • Enterprise Edition
  • 32-bit (x86)
  • 64-bit (x86-64)
Service Pack 2
Windows Server 2008 R2
  • Standard Edition
  • Enterprise Edition
  • 64-bit (x86-64)
Service Pack 1

IBM Content Collector does not support Server Core installations.

Required software


The following software must be installed on the server where IBM Content Collector is installed.

Important:

  • On a 64-bit operating system, IBM Content Collector Server runs in 32-bit compatibility mode. Therefore, IBM Content Collector Server requires the 32-bit version of all software prerequisites.
  • For performance reasons, do not colocate the IBM Content Collector Server and the archive system on one server in a production environment. This setup can be used for testing or demonstration purposes, but it is not officially supported.
  • The server where IBM Content Collector is installed must not have the role of a domain controller.
Software Required for which scenarios Notes
DB2 Information Integrator for Content Required for IBM Content Manager V8.x repositories See IBM Content Manager 8.x.
FileNet Content Engine Enterprise Manager SnapIn and Java client Required for IBM FileNet P8 repositories See IBM FileNet P8.
IBM FileNet IDM Desktop 4.0.x Required for IBM FileNet Image Services repositories
Microsoft .NET Framework 4.0 Always required
Microsoft Windows Communication Foundation (WCF) or Microsoft Web Services Enhancements (WSE) 3.0 with KB943508 Required if you want to use the FileNet P8 Connector If WSE is installed, it will be used. Otherwise, WCF is required.
Lotus Domino 8.5.2 FP2 or 8.5.3 server
IBM Domino 9.0 or 9.0.1 server
Required if you want to archive Lotus Notes documents The Lotus Domino server provides a Lotus Notes API for processing Lotus Notes documents.
Microsoft Outlook 2010 Service Pack 1 (or later) or Microsoft Outlook 2007 Service Pack 2 (or later) Required if you want to archive email from Microsoft Exchange servers The Microsoft Outlook client provides the Messaging API (MAPI) for email processing.
Microsoft Windows DST update KB 955839 Required if you are converting dates to UTC
OLE-DB and JDBC drivers Required if the database management system resides on a different server The OLE-DB and JDBC drivers for the database management system for the Content Collector configuration database are required on the system where the IBM Content Collector server is installed.
Database management system client Required if the database management system resides on a different server

IBM Domino 9.0 and 9.0.1 are supported starting with IBM Content Collector 3.0 Fix Pack 4.


Database management system for the IBM Content Collector configuration database

The configuration database of IBM Content Collector can be created in the following database management systems:

Archive system (repository software) Possible database management systems for configuration database
IBM DB2 Content Manager 8.4.2 Enterprise Edition Fix Pack 3
  • IBM DB2 9.1 Fix Pack 8
  • IBM DB2 9.5 Fix Pack 5
  • IBM DB2 9.7 Fix Pack 7
IBM Content Manager Enterprise Edition 8.4.3 and IBM Content Manager Enterprise Edition 8.4.3 Fix Pack 1 and Fix Pack 2
  • IBM DB2 9.1 Fix Pack 8
  • IBM DB2 9.5 Fix Pack 6
  • IBM DB2 9.7 Fix Pack 7
IBM Content Manager Enterprise Edition 8.4.3 Fix Pack 3
  • IBM DB2 9.1 Fix Pack 8
  • IBM DB2 9.5 Fix Pack 6
  • IBM DB2 9.7 Fix Pack 7
  • IBM DB2 10.1 Fix Pack 2
IBM Content Manager for z/OS A configuration database on a z/OS system is not supported. Use a local database on the Windows server that hosts IBM Content Collector, or reuse a remote DB2 server on Linux, Windows, or AIX.
IBM FileNet P8 Content Engine 4.5.1 Fix Pack 7 (or later)
  • IBM DB2 9.1 Fix Pack 8
  • IBM DB2 9.5 Fix Pack 5
  • IBM DB2 9.7 Fix Pack 7
  • Oracle 10g 10.2.0.x (minimum version: 10.2.0.2)
  • Oracle 11g R1 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2005 Service Pack 3
  • Microsoft SQL Server 2008 Service Pack 1 (or later)
IBM FileNet P8 Content Engine 5.0.0.1, 5.1 Fix Pack 2, or 5.2
  • IBM DB2 9.5 Fix Pack 5
  • IBM DB2 9.7 Fix Pack 7
  • IBM DB2 10.1 Fix Pack 2
  • Oracle 10g 10.2.0.x (minimum version: 10.2.0.2)
  • Oracle 11g R1 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2008 Service Pack 1 (or later)
  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2012
IBM FileNet Image Services 4.1.2
  • IBM DB2 9.1 Fix Pack 6
  • IBM DB2 9.5 Fix Pack 3
  • IBM DB2 9.7
  • Oracle 10g 10.2.0.x (minimum version: 10.2.0.2)
  • Oracle 11g 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2005 Service Pack 1
  • Microsoft SQL Server 2008 Service Pack 1 (or later)

IBM Content Manager 8.4.3 Fix Pack 2 and Fix Pack 3 are supported starting with IBM Content Collector 3.0 Fix Pack 2. IBM FileNet P8 Content Engine 5.2 is supported starting with IBM Content Collector 3.0 Fix Pack 3. IBM DB2 10.1 and Microsoft SQL Server 2012 in connection with IBM FileNet P8 are supported only with IBM FileNet P8 Content Engine 5.1.0.1 or later and starting with IBM Content Collector 3.0 Fix Pack 2.

If the database management system server is installed on a different machine than IBM Content Collector Server, you must install a database management system client on the IBM Content Collector server machine. IBM Content Collector Server requires the 32-bit version of the database management system client even when running on a 64-bit operating system.

IBM Content Collector does not support a local 64-bit configuration database.


How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for IBM Content Manager, IBM FileNet P8, and IBM DB2 for Linux, UNIX, and Windows.
You can purchase Oracle from www.oracle.com and Microsoft SQL Server from www.microsoft.com.


Web server applications

IBM WebSphere Application Server


IBM Content Collector requires IBM WebSphere Application Server to run the Configuration Web Service and to perform search and restore operations. Typically, there is no need to check for compatible versions because IBM Content Collector comes with an embedded version of WebSphere Application Server Version 8.0. Note, however, that if you use an Oracle 10g database with WebSphere Application Server Version 8.0, the Oracle 11g JDBC driver is required.

If you decide not to use the embedded WebSphere Application Server, you can use an existing WebSphere Application Server. IBM Content Collector supports the 32-bit base edition of IBM WebSphere Application Server for Windows. The Network Deployment edition or editions for other operating systems are not supported. Always install the latest fix pack. The following versions are supported:

  • 6.1.0.41 or later
  • 7.0.0.17 or later
  • 8.0.0.2 or later

If you use an existing WebSphere Application Server, make sure that the following prerequisites that are required for IBM Content Collector Server are also installed on the separate WebSphere Application Server:

  • Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package
  • Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package ATL Security Update
  • Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package

How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for WebSphere Application Server.

IBM Content Collector web application browsers


The IBM Content Collector web applications support the following browsers:

Browsers Versions
Mozilla Firefox
  • 10.0.7, 17.0.x, or 24 Extended Support Release (ESR)
  • 16, 17, or 19
Microsoft Internet Explorer
  • 8
  • 9

Mozilla Firefox 10.0.7 ESR, 16, or higher is required starting with IBM Content Collector 3.0 Fix Pack 2.


How to get:

You can obtain Mozilla Firefox from www.mozilla.com and Microsoft Internet Explorer from www.microsoft.com.


Collection source systems

Lotus Domino

Server and clients


The following table describes the supported versions of Lotus Domino for Domino mail servers and the supported versions of Lotus Notes for Notes mail clients:

Server software Client software Other software requirements Notes
  • Lotus Domino 8.0.2
  • Lotus Domino 8.5
  • Lotus Domino 8.5.1
  • Lotus Domino 8.5.2
  • Lotus Domino 8.5.3
  • IBM Domino 9.0
  • IBM Domino 9.0.1
  • Lotus Notes 8.0.2
  • Windows Vista (32-bit)
  • Mozilla Firefox 10 Extended Support Release (ESR)
  • Mozilla Firefox 10
  • Mozilla Firefox 11
  • Microsoft Internet Explorer 8
  • Microsoft Internet Explorer 9
On Mac OS X, Lotus Notes 8.5.1 Fix Pack 2 or higher is required.

Offline repositories, collecting additional archiving information, and automatic document retrieval is not supported for Lotus Notes clients on Mac OS.
  • Lotus Notes 8.5
  • Lotus Notes 8.5.1
  • Lotus Notes 8.5.2
  • Lotus Notes 8.5.3
  • IBM Notes 9.0
  • IBM Notes 9.0.1
  • Windows Vista (32-bit and 64-bit)
  • Windows 7 Service Pack 1 (32-bit and 64-bit)
  • Mac OS X 10.6.x (32-bit and 64-bit) (minimum version 10.6.2)
  • Mac OS X 10.7.x (32-bit and 64-bit) (minimum version 10.7.3)
  • Lotus iNotes 8.0.2
  • Lotus iNotes 8.5
  • Lotus iNotes 8.5.1
  • Lotus iNotes 8.5.2
  • Lotus iNotes 8.5.3
  • IBM iNotes 9.0
  • IBM iNotes 9.0.1
Lotus iNotes must have been configured when the Domino server was initially configured.

IBM Content Collector supports the latest fix packs of the server and client software. IBM Domino 9.0 and 9.0.1 and IBM Notes 9.0 and 9.0.1 are supported starting with IBM Content Collector 3.0 Fix Pack 4. IBM iNotes 9.0 and 9.0.1 is supported starting with IBM Content Collector 3.0.0.4 Interim Fix 003.

If you want to use the IBM Content Collector Offline Repository in Lotus Notes, the following packages are required on the workstation that runs the Lotus Notes client, depending on the version of IBM Content Collector that was used to enable the Domino template:

Content Collector version used to enable Domino template Required package on client workstation
IBM Content Collector 2.2 (or earlier) Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update
IBM Content Collector 3.0 Microsoft Visual C++ 2010 Redistributable Package

How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for Lotus Domino.

Notes Client Extension


The Notes Client Extension can be installed on the following operating systems:

  • Windows Vista (32-bit and 64-bit)
  • Windows 7 Service Pack 1 (32-bit and 64-bit)

Virtualization


The following table describes the supported virtualization methods and software versions for running a Lotus Notes client on Citrix:

Virtualization Method Required software
Virtual desktop Lotus Domino/Lotus Notes 8.5.3
Citrix XenDesktop 5.5
Application installed on server Lotus Domino/Lotus Notes 8.5.3
Citrix XenApp 6.0
Application streamed to server Lotus Domino/Lotus Notes 8.5.3
Citrix XenApp 6.0
Application streamed to client Lotus Domino/Lotus Notes 8.5.3
Citrix XenApp 6.0



Microsoft Exchange

Server


The following table describes the supported versions of Microsoft Exchange Server:

Server software Notes
  • Microsoft Exchange Server 2007 Standard and Enterprise Edition with Service Pack 2, Service Pack 3, or Service Pack 3 Update Rollup 9
  • Microsoft Exchange Server 2010 Standard and Enterprise Edition with Service Pack 1 Update Rollup 6, Service Pack 2 Update Rollup 3 or 4, or Service Pack 3
  • You must not install Microsoft Exchange Server on the IBM Content Collector server.
  • If you encounter MAPI_E_CALL_FAILED problems with Exchange Server 2010, upgrade to Service Pack 2 Update Rollup 3 or request an interim update for Service Pack 1 from Microsoft for KB2674185.

Microsoft Exchange Server 2007 with Service Pack 3 Update Rollup 8 and Microsoft Exchange Server 2010 with Service Pack 2 Update Rollup 4 are supported starting with IBM Content Collector 3.0 Fix Pack 2. Microsoft Exchange Server 2007 with Service Pack 3 Update Rollup 9 and Microsoft Exchange Server 2010 with Service Pack 3 are supported starting with IBM Content Collector 3.0 Fix Pack 3.

See technote 1648828 for information about how to set up journal forwarding from Microsoft Exchange Online to IBM Content Collector.

How to get:

You can purchase Microsoft Exchange Server from www.microsoft.com.


Outlook Extension


Before you add the IBM Content Collector Outlook Extension to a client workstation, ensure that the required software is installed on that workstation:

Operating system Client application Other software requirements Notes
  • Windows 7 Professional Service Pack 1 (32-bit or 64-bit)
  • Windows 7 Ultimate Service Pack 1 (32-bit or 64-bit)
  • Windows Vista Business (32-bit) with Service Pack 2
  • Windows Vista Enterprise (32-bit) with Service Pack 2
  • Windows XP Professional SP3 or later (32-bit)
  • Microsoft Outlook 2007 Service Pack 2 or Service Pack 3
  • Microsoft Outlook 2010 RTM or Service Pack 1 (32-bit)
  • .NET Framework 4.0 (or later)
You can install the IBM Content Collector Outlook Extension irrespective of the language in which Outlook is installed.

An Outlook logon profile containing the parameters for the connection to the Exchange server must exist.
  • Mozilla Firefox 10 ESR, 10, or 11
  • Microsoft Internet Explorer 8 or 9

Microsoft Outlook 2007 Service Pack 3 and Microsoft Outlook 2010 Service Pack 1 are supported starting with IBM Content Collector 3.0 Fix Pack 2.


Virtualization


The following table describes the supported virtualization methods and software versions for running Outlook Extension on Citrix:


Virtualization Method Required software
Virtual desktop Microsoft Outlook 2010
Citrix XenDesktop 5.5
Application installed on server Microsoft Outlook 2010
Citrix XenApp 6.0
Application streamed to server Microsoft Outlook 2007
Citrix XenApp 6.0
Application streamed to client Microsoft Outlook 2007
Citrix XenApp 6.0


Outlook Web App (OWA)


Outlook Web App (OWA) Extension

To install the IBM Content Collector Outlook Web App Extension on the Exchange server, the following requirements must be met:

Exchange Server version (required) Other software requirements Notes
Microsoft Exchange Server 2007 Service Pack 1 (or later) or Microsoft Exchange Server 2010 .NET Framework 4.0 Full Profile The OWA Extension must be installed on the Exchange Server that has the Client Access Server (CAS) role.

Outlook Web App (OWA) Service

Apart from the Outlook Web App Extension that is installed on the Exchange server, the Outlook Web App Service is installed on top of a Microsoft Internet Information Service (IIS) Server. The following table lists the operating system and other requirements for the OWA Service.

Operating system for the Outlook Web App Service (required) Other software requirements
  • ​Windows Server 2003 Service Pack 2
  • Windows Server 2003 R2 (64-bit) Service Pack 2
  • Windows Server 2008 Service Pack 2
  • Windows Server 2008 R2 Service Pack 1
Microsoft IIS Server 6 or 7
.NET Framework 4.0.30319

In the Internet Information Service (IIS) Manager:

  • Set the Web Service Extension ASP.NET V4.0.30319 to Allowed.
  • Set the identity of the application pool where the OWA service resides to NetworkService.
  • Set the .NET Framework version to v4.0
  • Disable the forms authentication method for the OWA Service (afuowa) after the installation. IBM Content Collector OWA Service does not support forms authentication in Microsoft IIS 7.0.

How to get:

You can purchase Microsoft IIS Server and .NET Framework from www.microsoft.com.


Outlook Web App (OWA) client

To be able to use the Outlook Web App functions, clients require the following software on their workstations:

Software prerequisites for OWA clients
.NET Framework 2.0 (or later)
Microsoft Internet Explorer 8 or 9

The following restrictions apply:

  • IBM Content Collector OWA support does not work with if the option "Use the blind and low vision experience" in the OWA settings is used.
  • IBM Content Collector OWA support works only with OWA Premium Mode.
  • IBM Content Collector OWA support on Exchange 2010 supports only the Internet Explorer browser and not Apple Safari, Mozilla Firefox, and so on although Microsoft OWA 2010 supports other browsers.

Microsoft SharePoint

The following table describes the supported versions of Microsoft SharePoint:

Microsoft SharePoint Notes
Microsoft Office SharePoint Server 2007 with Service Pack 2 or Service Pack 3 (Standard or Enterprise edition)
Microsoft Windows SharePoint Services 3.0 with Service Pack 2 or Service Pack 3
Microsoft SharePoint Server 2010 RTM or with Service Pack 1 (Standard or Enterprise edition)
Microsoft SharePoint Foundation 2010 RTM or with Service Pack 1
Microsoft SharePoint Server 2013 (Standard or Enterprise edition)



  • Only functionality that is also provided by Microsoft SharePoint 2007 and 2010 is supported.
  • Microsoft SharePoint Server 2013 is supported starting with IBM Content Collector 3.0.0.2 Interim Fix 003.


How to get:

You can acquire Microsoft SharePoint from www.microsoft.com.


IBM Connections

The following table describes the supported versions of IBM Connections:

IBM Connections Notes
IBM Connections 3.0.1 Fix Pack 1

IBM Connections 4.0.1
  • Only data sources that are available in IBM Connections 3.0 are supported.
  • IBM Connections 4.0.1 is supported starting with IBM Content Collector 3.0 Fix Pack 2.

Documents from IBM Connections can be archived in the following archive systems:

  • IBM Content Manager Enterprise Edition (all supported versions)
  • IBM FileNet P8 Content Engine 5.1 or later with IBM Content Search Services

How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for IBM Connections.


File system support

The following table describes supported file systems.

File system Notes
NTFS V3.1

Depending on the repository capabilities, the maximum supported file size is up to 30 GB.
Novell Netware V6.5 SP 8

Restriction: If IBM Content Collector is installed on Windows 2008, Novell Client 2 SP1 IR 6 or later must be installed.


Archive servers

IBM Content Manager

Repository software


The following table describes the supported operating systems and the connector that is required on the IBM Content Collector server:

Archive system (repository software) Operating system Required connector on IBM Content Collector Server Notes
IBM Content Manager Enterprise Edition V8.4.2 with Fix Pack 3, V8.4.3, and V8.4.3 with Fix Pack 1, Fix Pack 2, or Fix Pack 3 that use the following database management system:
  • IBM DB2 V9.1 Fix Pack 8 Enterprise Server Edition
  • IBM DB2 V9.5 Fix Pack 5 Enterprise Server Edition
  • IBM DB2 V9.7 Fix Pack 7 Enterprise Server Edition
  • V8.4.3 Fix Pack 3 only: IBM DB2 10.1 Fix Pack 2 Enterprise Server Edition
  • AIX
  • Linux
  • Windows
DB2 Information Integrator for Content V8.4.2 with Fix Pack 3, V8.4.3, or V8.4.3 with Fix Pack 1, Fix Pack 2, or Fix Pack 3 Use the Setup Type Connector.

Support for IBM Content Manager V8.4 on Linux requires a Linux 32-bit system on an Intel platform or Linux for System z.
IBM Content Manager for z/OS Version V8.4.2, V8.4.3, and V8.4.3 with Fix Pack 1
  • z/OS
DB2 Information Integrator for Content V8.4.2 with Fix Pack 3, V8.4.3, or V8.4.3 with Fix Pack 1 IBM Content Manager for z/OS can be used as a repository for files and Microsoft SharePoint documents. Email documents are supported starting with V8.4.3 Fix Pack 1. Text search is not supported.

IBM Content Manager 8.4.3 Fix Pack 2 and Fix Pack 3 are supported starting with IBM Content Collector 3.0 Fix Pack 2. IBM DB2 10.1 Enterprise Server Edition is supported only with IBM Content Manager 8.4.3 Fix Pack 3.

Important: The version and fix pack level of DB2 Information Integrator for Content should match the version and fix pack level of IBM Content Manager.



How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for IBM Content Manager.
DB2 Information Integrator for Content is included in Content Manager Enterprise Edition.


Text-search function


To enable the text-search function (full-text search) for a Content Manager archive system, the IBM Content Collector indexer for text search must be installed. The indexer for text search requires IBM Content Manager Enterprise Edition and the following software:

Net Search Extender
The required version depends on the version of DB2 that is used by IBM Content Manager.
Additional Net Search Extender e-fixes (required) Notes
AIX Power 5.3 and 6.1 IBM Net Search Extender 9.1 for DB2 V9.1 Fix Pack 8 IBM Net Search Extender and the required fix packs and e-fixes must be installed on the IBM Content Manager server.
Linux or Linux for System z (RHEL) 4.0, 5.0, and 6.0
Linux (SLES) 10 and 11
Windows Server 2003, 2008 and 2008 R2
AIX Power 5.3 and 6.1 IBM Net Search Extender 9.5 for DB2 V9.5 Fix Pack 5 Windows

IC58821
IP22989
Linux or Linux for System z (RHEL) 4.0, 5.0, and 6.0
Linux (SLES) 10 and 11
Windows Server 2003, 2008 and 2008 R2
AIX Power 5.3 and 6.1 IBM Net Search Extender 9.7 for DB2 V9.7 Fix Pack 4
Linux or Linux for System z (RHEL) 4.0, 5.0, and 6.0
Linux (SLES) 10 and 11
Windows Server 2003, 2008 and 2008 R2

How to get:

You can download IBM Content Manager fix packs and Net Search Extender e-fixes from the following websites:


IBM FileNet P8

Repository software


The following table describes the supported operating systems and the FileNet APIs that are required for the IBM Content Collector server:

Archive system (repository software) Operating system Required APIs on IBM Content Collector Server Notes
IBM FileNet P8 Content Engine 4.5.1 Fix Pack 7 (or later) using one of the following database management systems:
  • IBM DB2 V9
  • Oracle 10g 10.2.0.x (minimum version: 10.2.0.2)
  • Oracle 11g R1 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2005 SP3
  • Microsoft SQL Server 2008 SP1 (or later)
  • AIX
  • HP-UX
  • Linux
  • Solaris
  • Windows
Microsoft Windows Communication Foundation (WCF) or Microsoft Web Services Enhancements (WSE) 3.0 with KB943508 If WSE is installed, it will be used. Otherwise, WCF is required.

Follow the instructions in technote 1440428 to ensure that you have the required fixes for Microsoft Web Services Enhancements 3.0​​.
.NET Clients The .NET Clients component is provided through the FileNet P8 Content Engine installer.
IBM FileNet P8 Content Engine 5.0.0.1, 5.1 Fix Pack 2, or 5.2 using one of the following database management systems:
  • IBM DB2 V9
  • Oracle 10g 10.2.0.x (minimum version: 10.2.0.2)
  • Oracle 11g R1 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2008 SP2 (or later)
  • Microsoft SQL Server 2008 R2
Java Clients (Other Applications) The Java Clients component is provided through the FileNet P8 Content Engine Client installer.
IBM Content Foundation V5.2 using one of the following database management systems:
  • IBM DB2 V9
  • Oracle 11g R1 11.1.0.x (minimum version: 11.1.0.6)
  • Oracle 11g R2 11.2.0.x (minimum version: 11.2.0.3)
  • Microsoft SQL Server 2008 SP2 (or later)
  • Microsoft SQL Server 2008 R2
  • AIX
  • Linux
  • Solaris
  • Windows
IBM Content Platform Engine Client
IBM FileNet Image Services 4.1.2
  • AIX
  • HP-UX
  • Solaris
  • Windows
IBM FileNet Image Services can only be used as a repository for files. It is not suitable for email. Text search and retrieving archived content through stub links is not supported.
IBM FileNet P8 Content Engine 5.2 and IBM Content Foundation V5.2 are supported starting with IBM Content Collector 3.0 Fix Pack 3.

Important: The fix pack level of the Content Engine of IBM Content Collector Server must match the fix pack level of the Content Engine server for both the .NET Clients and the Java Clients components.

How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for FileNet P8.

Text-search function


The text-search function (full-text search) for FileNet archive systems with IBM Legacy Content Search Engine requires Autonomy IDOL K2.

The text-search function (full-text search) for FileNet archive systems with IBM Content Search Services requires the following FileNet P8 components:


FileNet P8 components Required on which server Operating system Notes
IBM FileNet P8 Content Engine 5.1 with IF001 or later, 5.1 Fix Pack 2, or 5.2 FileNet P8 server
  • AIX
  • HP-UX
  • Linux
  • Solaris
  • Windows
Interim Fixes are available on Fix Central.
IBM FileNet P8 Content Search Engine Client 5.1 Fix Pack 2 or Content Search Services Client option of 5.2 FileNet P8 server
  • AIX
  • HP-UX
  • Linux
  • Solaris
  • Windows
IBM FileNet P8 Content Search Services 5.1 with IF001 or later, or 5.2 Content Search Services server
  • AIX
  • Linux
  • Windows
Interim Fixes are available on Fix Central.
Java Clients (Other Applications) 5.1 Fix Pack 2 or 5.2
  • Content Search Services server
  • IBM Content Collector server
  • AIX
  • HP-UX
  • Linux
  • Solaris
  • Windows
The Java Clients component is provided through the FileNet P8 Content Engine Client installer.
.NET Clients 5.1 Fix Pack 2 or 5.2 IBM Content Collector server
  • AIX
  • HP-UX
  • Linux
  • Solaris
  • Windows
The .NET Clients component is provided through the FileNet P8 Content Engine installer.

The text-search function (full-text search) for IBM Content Foundation requires the Content Search Services component.

Legacy restore


Legacy restore provides access to documents that were archived with IBM CommonStore for Lotus Domino or IBM CommonStore for Exchange Server. Legacy restore supports the same archive systems as the CommonStore products and has the same system requirements to connect to these archive systems as the CommonStore products:

System requirements for IBM CommonStore for Lotus Domino
System requirements for IBM CommonStore for Exchange Server

There are some limitations when using IBM Content Collector Legacy Restore instead of the CommonStore products, including the following restrictions:

  • IBM Content Collector Legacy Restore provides read-only access to documents, but no write access.
  • For documents that are stored in Content Manager OnDemand, search is not supported.
  • Multi-part document model item types in Content Manager 8 are not supported.

The following table describes the supported operating systems for IBM Content Collector Legacy Restore:

Operating system Service Pack/Release
Windows Server 2008 Standard Edition (32-bit)
Windows Server 2008 Enterprise Edition (32-bit)

Optional software

The following table describes the software that is required if you want to use optional functions of IBM Content Collector:

Function Software
Use IBM eDiscovery Manager to search and collect archived documents IBM eDiscovery Manager V2.2.1.1
Use IBM Content Classification to classify documents IBM InfoSphere Classification Module V8.7
IBM Content Classification V8.8
Declare records against documents in a FileNet P8 archive system IBM Enterprise Records V4.5, V5.1, V5.1.1

How to get:

Go to the IBM Support Portal at http://www.ibm.com/support and search for IBM Content Classification and IBM Enterprise Records.



Rate this page:

(0 users)Average rating

Document information


More support for:

Content Collector
All Content Collector products

Software version:

3.0

Operating system(s):

Windows 2008 server

Reference #:

7024229

Modified date:

2013-11-13

Translate my page

Machine Translation

Content navigation