SPSS Statistics 20.0 Fix Pack 1 Fix List

Release notes


Abstract

A comprehensive list of defect corrections for the SPSS Statistics 20.0 Fix Pack 1. Details of the fixes are listed below under the tab for the respective Fix Pack. If you have questions about a particular defect, please contact Customer Support.

Note: each successive Fix Pack is comprehensive and contains the material from the earlier Fix Packs for that Release, as well as all Interim Fixes made available since the previous Fix Pack or full Release. In other words, when multiple Fix Packs are available, you would not need to apply Fix Pack 1 before applying Fix Pack 2.

Also, these lists may contain some internal defect numbers. This was necessitated to provide a complete list of corrected defects as we continue to transition our internal defects to APARs. Future Fix Lists will only contain APAR references.

Content

SPSS Statistics 20.0 FP1 Downloads

SPSS Statistics 20.0 FP1

Issues corrected since SPSS Statistics 20.0 Release
Number Description
PM42912 GENLINMIXED with repeated measures could cause the application to close suddenly. That has been fixed.
PM46926 A problem with sorting Multiple Response Sets in the Custom Tables user interface has been corrected.
PM46090 In the Data Editor, values smaller than .000001 were displayed with scientific notation. That has been fixed.
PM49760 Opening an Excel 2007 (xlsx) file in the application could result in incorrect order for the variable names, and mislabeled data. That has been fixed.
PM45315 Opening an Excel 2007 (xlsx) file in the application could result in extra cases when the file contained values with embedded line breaks.
PM42569 A problem where NPTESTS could produce Boxplots with incorrect Whiskers and Outlier/Extremes has been corrected.
PM45090 Using OMS to export Text output from REPORT could result in an empty PDF file. That has been fixed.
PM43640 Statistics tables output (.SPW) deployed to Collaboration and Deployment Services as PDF or RTF could have missing elements or elongated cells. That has been fixed.
PM44049 Scripting SetHeaderText and SetFooterText methods now work correctly.
PM45037 When computing a variable with non-integer values, the measurement level could be incorrectly set to nominal. Those variables are now set to scale measurement level.
PM45801 The limits for saving variable labels to SAS 9+ files were too low. They have been increased to conform to the SAS 9 limits.
PM42860 When the data contain invisible control characters, GENLINMIXED could produce internal errors. That has been fixed.
ECM00153700 When using the German User Interface Language, the Curve Estimation user interfaces now allows you to save predicted values, residuals, and prediction intervals.
PM43261 Opening an Excel 2007 (xlsx) file that contained a mix of short strings and longer numbers could result in some columns being truncated. That has been fixed.
PM43849 Opening an Excel 2007 (xlsx) file that contained a mixture of blank and decimal values in a column could result in the decimal values being read as "0". That has been fixed.
PM43017 Saving data with very small numbers as an Excel 2007 (xlsx) file could result in a loss of numeric precision. That has been fixed.
PM49340 Performance of Copy and Paste from Excel to the Data Editor has been improved.
PM43863 Reading CSV text data that used comma as the decimal separator could cause decimal numbers to be read as integers. That has been fixed.
PM42783 When using the a data file that contains Czech Language, value labels for the BREAK variables may not be displayed correctly after a second AGGREGATE. That has been fixed.
PM45951 In the Custom Tables user interface, making changes to 'Summary Statistics' could sometimes reset the value of 'Totals and Subtotals Appear' option. That has been fixed.
ECM00150912 When exiting Windows without first closing the application, an exception error could occur. That has been fixed.
PM44150 A problem with Output Page Attributes not printing a Filename in the Header/Footer when requested has been corrected.
PM50199 When working in the Locale's writing system, exporting OMS output to an XML file could result in headings with incorrect characters. When connected to a Statistics Server, the application could also close suddenly. Both problems have been fixed.
ECM00168712 PMML exported from preparing data for modeling (ADP) now contains sufficient information to score DefineFunction according to the PMML standard. This worked correctly for scoring done by SPSS components, but not for scoring mechanisms developed by third parties.
PM44612 A problem with opening large SAS data files while running on 64-bit Windows has been corrected.
PM53039 Generalized Linear Models (GENLIN) could fail to save variables and could cause the application to close suddenly when the offset variable had negative values. That has been fixed.
PM54600 Under some conditions, CROSSTABS could report missing values when there were none. That has been fixed.
PM51738 On RedHat Linux the ADD VALUE LABELS command could sometimes overwrite existing value labels instead of adding new labels. That has been fixed.
PM52583 When working in the Locale's writing system, exporting Excel output to locations that contain Japanese characters now works.
PM54277 Under some conditions, very large tables created with CTABLES syntax could fail to create output. That has been fixed.
PM52487 Tables that were saved in an output file can display "Table 1" instead of the correct table title. That has been fixed for output files created with version 20.0.0.1 and later.
PM51603 When working in Japanese locale on Mac OS, the File Save As dialog could fail to appear for data windows. That has been fixed.
ECM00161393 When working in Polish locale, Polish characters are now displayed correctly when you open a data file.
ECM00161562 In the Data Editor Variable View, adding a new variable and then pressing enter or the down arrow key now moves to the next row as expected.
PM49520 When opening an Excel 2007 (xlsx) file into the Data Editor, data in columns with General format were truncated. That has been fixed.
PM52737 When opening an Excel 2007 (xlsx) file that contains variable names in the first row and one or more of those variable names is blank, none of your variables names were used in the Data Editor. That has been fixed.
PM51094 On Mac OS, time formats are now correctly preserved when you open an Excel xls file in the Data Editor.
PM51405 Opening an Excel 2007 (xlsx) file that contains long string values now works as expected in the Data Editor.
PM52958 Saving a numeric variable with lots of precision (e.g., 13 decimal places) as an Excel 2007 (xlsx) file could result in a loss of numeric precision. That has been fixed.
PM47693 Problems exporting formatted text blocks using the "SPSS Statistics - Integration Plug-In for Python" have been fixed.
PM47695 Problems exporting formatted text blocks using the "SPSS Statistics - Integration Plug-In for Python" have been fixed.
PM53654 When a Pie Chart was created with a template that used custom colors, the chart was sometimes incomplete when it was exported in EMF format. That has been fixed.
PM51361 Validation of SPSS Statistics XML Schemas by URL now works correctly.
PM52286 Under some conditions, Dendograms created by Hierarchical Cluster Analysis could format axis labels incorrectly. That has been fixed.
ECM00160753 In Chinese User Interface Languages, a translation error for some saved variable names in Generalized Linear Models and Generalized Estimating Equations caused an error. That has been fixed.
PM52740 With Output and User Interface Language set to Japanese, the translation of the ANOVA table title was incorrect. That has been fixed.
PM54527 On Mac OS, A Network license problem was resolved so that now Commuter licenses are correctly displayed and can be checked out.
ECM00161921 When the license about to expire, a warning message now appears in the Output Viewer.
PM46534 The license activation utility, licenseactivator.exe, now correctly recognizes PROXYHOST and PROXYPORT as valid arguments.
PM46659 When "Display all map features in the Visualization" was not checked, Maps were resized to be too small. That has been fixed.
PM49745 When using an OMS command to route several tables to a Statistics data (sav) file, the values in the resulting data file could be incorrectly aligned. That has been fixed.
PM53104 Using OMS to save XML files to locations that contain Hebrew characters now works.
PM52314 When exporting charts in EMF format, the size of the exported file is now similar to the file size from earlier releases.
PM53054 Under some conditions, centered Custom Table titles were not aligned correctly. That has been fixed.
PM52435 A problem authenticating Collaboration and Deployment Services users with Active Directory profiles was fixed.
PM52503 Layered Statistics tables output (.SPW) deployed to Collaboration and Deployment Services sometimes did not pivot correctly. That has been fixed.
PM47177 Custom Tables could display incorrect results when working in the Locale's writing system mode and using data, variable names, or value labels that contain non-English characters. That has been fixed.
PM48764 Output with long pivot tables now display titles correctly when exported to Word.
PM49448 Under some data conditions on 64-bit Windows, the combination of SPLIT FILE and the Means procedure could cause the application to close suddenly. That has been fixed.
PM55054 Various problems with resizing and hiding columns using the SPSSInc Modify Tables Command, and then exporting the resulting table to HTML were fixed.
PM50254 Various problems with resizing and hiding columns using the SPSSInc Modify Tables Command, and then exporting the resulting table to HTML were fixed.
PM52836 Pivot Table font sizes now export to Excel correctly.
PM47175 When Pivot Tables are created, all options that affect the table formatting are now correctly saved with the table, including Custom Currency formats.
PM52977 Pivot Table font sizes were sometimes displayed and rendered inconsistently. That has been fixed.
PM53077 After applying Interim Fix 20.0.0.0.7, tables created with the OLAP Cubes procedure were missing most column headings. That has been fixed.
PM53295 Changing Pivot Table font sizes for the Layer now works as expected.
PM54218 A problem with the Group/Ungroup feature for Pivot Tables was fixed.
PM47727 On Windows, the Production Facility sometimes could not display the Background Job status. That has been fixed.
PM50093 On Windows, the Production Facility sometimes could not display the Background Job status. That has been fixed.
PM51667 Performance for jobs run in the Production Facility has been improved, and is now comparable to earlier releases.
PM48493 A problem where some Python Scripts could cause the application to close suddenly was fixed.
PM46921 When working in non-English locales, the spssaux.py module which is installed with the "SPSS Statistics - Integration Plug-In for Python", could fail to run. That has been fixed.
PM51862 When the data included an MR Set with an extended ASCII character in the set name, the Python dataset class could fail. That has been fixed.
PM46705 A problem where some Python scripts would not print output into the Output Viewer was fixed.
PM46908 A problem with Pivot Table label indexing in Python scripts was fixed.
PM47603 A problem with Python Scripting and MoveToRow was fixed.
PM51766 Text inserted into the Output Viewer with Python could fail to export to HTML. That has been fixed.
PM52390 A Linux Statistics Server which automatically started on reboot could fail to allow clients to connect. That has been fixed.
ECM00162806 Problems with Polish characters and the Production Facility were fixed.
PM49989 A problem where the Data->Aggregate menu would sometimes fail to open while in Distributed Mode was fixed.
PM54272 Statistics Server running on Windows sometimes issued a message about APPCRASH when the application was exited. That has been fixed.
PM50001 Statistics tables output (.SPW) deployed to Collaboration and Deployment Services could fail to display. That has been fixed.
PM52431 The Time Series Modeler user interface now pastes correct syntax when the Options tab is used to define a Forecast Period.

Related information

Download the SPSS Statistics 20.0 Fix Pack 1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

SPSS Statistics

Software version:

20.0

Operating system(s):

Platform Independent

Reference #:

7023959

Modified date:

2012-11-19

Translate my page

Machine Translation

Content navigation