System Requirements for WebSphere MQ V7.1 for z/OS

Product documentation


Abstract

This document contains system requirements for WebSphere MQ V7.1 for z/OS

Content

WebSphere MQ for z/OS 7.1

Tab navigation

  • z/OS - selected tab,

Tab navigation



Hardware Requirements
Group Notes
System z

Language Environment support provided by z/OS:

  • C/C++
  • DFSMS / DFP
  • High Level Assembler
  • ICSS
  • ISPF
  • JES
  • Security Server
  • SMP/E
  • TCP/IP
  • TSO/E
  • VTAM (only TCP/IP supported with the JMS Client and WebSphere MQ Java Classes)

WebSphere MQ for z/OS V7.1 runs on any IBM System z server that supports z/OS V1.11 with enough storage to meet the combined requirements of the programming prerequisites, WebSphere MQ for z/OS, the access methods, and the application programs.

Secure Sockets Layer (SSL) support requires:

  • z/OS Cryptographic Services Security Level 3 (FMID JCPT3B1)

Shared Queue support requires:

  • DB2 at the minimum level specified below
  • Coupling Facility (CF) Level 9
  • Resource Recovery Services (RRS) activated

Virtualization

Defect support is available for virtualization environments where they relate to releases of this platform already supported by WebSphere MQ. Unless stated elsewhere in the system requirements WebSphere MQ has not been specifically tested in virtualization environments.

WebSphere MQ support is therefore unable to assist in issues related to configuration and setup, or issues that are directly related to the virtualization environment itself.

Operating Systems
Operating System Notes
z/OS Platform listing of supported OS
z/OS 1.11 System z and future OS versions and fix packs

The Program Directory shipped with the product contains the latest level of information, particularly concerning APAR and PTF levels of supported products.

IBM WebSphere MQ for z/OS Value Unit Edition is only supported in a zNALC LPAR

Optional Supported Software
Group Product Notes
Application Servers
Where a WebSphere MQ client application is running in one of the listed transaction manager environments, it is recommended that you contact the transaction manager vendor in the first instance for support.

For more detailed information about using WebSphere MQ with application servers see the WebSphere MQ resource adapter statement of support document.

The use of the WebSphere MQ classes for JMS in enterprise JavaBeans, Servlets and message-driven beans is fully supported. The WebSphere MQ base classes for Java are supported with restrictions - for more details see Using WebSphere MQ Java Interfaces in J2EE/JEE Environments
WebSphere Application Server for z/OS 6.1 and future releases, mod levels and fix packs (overview) (support)

See this document for more information.

WebSphere Application Server for z/OS 7.0 and future releases, mod levels and fix packs (overview) (support)

See this document for more information.

WebSphere Application Server for z/OS 8.0 and future fix packs (overview) (support)

See this document for more information.

Application Servers for the WebSphere MQ Bridge for HTTP WebSphere Application Server for z/OS 7.0 and future releases, mod levels and fix packs (overview) (support)
WebSphere Application Server for z/OS 8.0 and future releases, mod levels and fix packs (overview) (support)
Connectors CICS Transaction Server for z/OS V3.1 and future releases, mod levels and fix packs (overview) (support)
CICS Transaction Server for z/OS V4.1 and future releases, mod levels and fix packs (overview)
CICS Transaction Server for z/OS V4.2 and future releases, mod levels and fix packs (overview)
CICS Transaction Server for z/OS V5.1 and future releases, mod levels and fix packs (overview)
Databases DB2 for z/OS 9.1 and future releases, mod levels and fix packs (overview) (support)
DB2 for z/OS 10.1 and future releases, mod levels and fix packs (overview) (support)
DB2 for z/OS 11.1 and future releases, mod levels and fix packs
DB2 Universal Database for z/OS 8.1 and future releases, mod levels and fix packs
IMS 10 and future releases, mod levels and fix packs (overview) (support)
IMS 11 and future releases, mod levels and fix packs (overview) (support)
IMS 12 and future releases, mod levels and fix packs
IMS 13 and future releases, mod levels and fix packs
Java Technology IBM Runtime Environment, Java Technology Edition 5.0 and future releases, mod levels and fix packs

31-bit and 64-bit are supported.

IBM Runtime Environment, Java Technology Edition 6.0 and future fix packs

31-bit and 64-bit are supported.

IBM Runtime Environment, Java Technology Edition 7.0 and future fix packs

31-bit and 64-bit are supported.

Programming Language Enterprise COBOL for z/OS 3.4 and future releases, mod levels and fix packs (overview) (support)

Support is provided for any COBOL compiler that generates calls to WebSphere MQ using the standard linkage convention.

Enterprise PL/I for z/OS 3.7 and future releases, mod levels and fix packs (overview) (support)

Support is provided for any PL/I compiler that generates calls to WebSphere MQ using the standard linkage convention.

z/OS XL C/C++ 1.11 and future releases, mod levels and fix packs (overview) (support)

To take advantage of functionality introduced in V7 from a C application, you must use a compiler that supports the long integer type.


Notes

Original publication date

2011/10/5

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere MQ
Install / Migration

Software version:

7.1

Operating system(s):

z/OS

Reference #:

7023056

Modified date:

2011-10-03

Translate my page

Machine Translation

Content navigation