SPSS Statistics 20.0 GA Fix List

Release notes


Abstract

A comprehensive list of defect corrections for SPSS Statistics 20 GA. Details of the fixes are listed below. If you have questions about a particular defect, please contact Customer Support.

Content

SPSS Statistics 20 Upgrade Download

Note: This list contains both APARS and internal defect numbers. This was necessitated to provide a complete list of corrected defects as we continue to transition our internal defects to APARs. Future Fix Lists will contain only APAR references.

SPSS Statistics 20.0 GA

PM38288 Requests for chi-square statistics in Crosstabs for a table larger than 2x2 now gives correct Exact significance on all platforms.
ECM00154716 On Mac OS, applying a template from Chart Builder or to Legacy graphics could cause the application to close suddenly. That has been fixed.
ECM00157620 On Mac OS, redundant Network License Managers could fail after a few minutes. That has been fixed.
ECM00152842 Requests for a Non-Parametric > Related Samples test using the McNemar's test now produces the correct frequency counts in the Model Viewer.
ECM00156621 When Collaboration and Deployment Services connected to some Statistics Servers, the connection sometimes could not be made. That has been fixed.
ECM00151101 A pushed installation on Windows sometimes failed to launch. That has been fixed.
ECM00153259 When the data being analyzed contain no system missing values, Codebook now does not report counts for system missing values.
ECM00154795 When used in non-English locales, the Scoring Wizard could produce incorrect predicted values for Multilayer Perceptron Neural Network models. That has been fixed.
PM37492 When scoring a TwoStep Cluster XML file the cluster assignments for some cases did not match the cluster assignments from the procedure. That has been fixed.
ECM00152150 A specific CROSSTABS command could cause the application to close suddenly. That has been fixed.
ECM00151852 Opening a Microsoft Access database repeatedly could cause the application to close suddenly. This problem can be corrected by installing a recent version of the Microsoft Access database driver, for example 14.00.4760.1000.
ECM00155883 Incorrect handling of comma vs. dot decimal separators could cause Excel import to import incorrect values. That has been fixed.
ECM00153391 SAVE TRANSLATE subcommand /TEXTOPTIONS DECIMAL DOT and COMMA now work as they did in earlier releases.
ECM00157354 NPTESTS could fail on a Turkish locale when variables contain certain Turkish characters. That has been fixed.
ECM00156011 With some data, the GLMM procedure could cause the application to close suddenly. That has been fixed.
ECM00152521 CROSSTABS would not produce the Mantel-Haenszel statistics for certain string variables. That has been fixed.
ECM00155057 With some data, the MIXED procedure would not produce EMMEANS when they should have been calculated. That has been fixed.
ECM00152653 A CROSSTABS request that contained some string variables could cause the application to close suddenly. That has been fixed.
ECM00153330 Repeated Output Management System (OMS) requests could cause the application to close suddenly. That has been fixed.
ECM00154274 Complex CTABLES requests with post-computes could cause the application to close suddenly. That has been fixed.
ECM00156545 A CTABLES request with MISSING=EXCLUDE could cause a post-computed category to be dropped when it should not be. That has been fixed.
ECM00160959 CTABLES requests with combinations of empty cells could cause post-computed categories to be incorrect. That has been fixed.
ECM00153359 Replace All in the Data Editor could sometimes fail to replace certain string values. That has been fixed.
PM37868 With "Display Value Labels" on in the Data Editor, typing a data value could sometimes cause the value to be entered twice into the cell. That has been fixed.
PM38758 Copy and Paste in the Data Editor is now as fast as it was in previous releases.
PM36208 Sorting cells in the Data Editor and then switching from Data to Variable view could cause the wrong values to be displayed. That has been fixed.
PM41610 When creating a new dataset and changing a field from Numeric to String with a user-defined missing value, Statistics would not save the dataset. That has been fixed.
ECM00152777 On Mac OS, double-clicking a data file now opens the file only once.
ECM00151713 Opening SAS files could result in an error message and truncation of characters. That has been fixed.
ECM00152655 Opening Data Collection files now opens the variables creation order.
ECM00155960 When using the Spanish User Interface Language, Date and Time variables are now created correctly.
ECM00156184 When using the Japanese User Interface Language, Generalized Linear Models and the Generalized Estimating Equations user interfaces now include all supported Link functions.
ECM00157140 When connected to a Statistics Server, Save As now correctly adds an extension to the user-provided filename.
ECM00153271 Problems with the Define Multiple Response Sets user interface and variables with identical value labels have been corrected.
ECM00152367 With Standard SPSS Look-and-feel and Windows Desktop fonts are set to Extra Large, the buttons on the Compute user interface now display correctly.
ECM00152992 Using SAVE TRANSLATE to save Excel data on Windows 7 with /MISSING = RECODE specified could cause the application to close suddenly. That has been fixed.
PM37587 The Select Cases user interface for "Select based on time or case range" now reads date-based user entries correctly.
PM40237 A user-created custom menu item that should save data from the Data Editor directly into Microsoft Excel failed with an error message. That has been fixed.
ECM00154676 With long string variables that have value labels, charts created from Chart Builder could have extra data points. That has been fixed.
ECM00156952 GGRAPH syntax to create a Polar chart that includes "close()" did not handle missing values correctly. That has been fixed.
ECM00156669 The "Go to case" menu in the Chart Editor for Boxplots did not work correctly. That has been fixed.
ECM00153286 Using a DEFINE command to specify a macro that opens a dataset containing double-byte characters as variable names can cause the application to close suddenly. That has been fixed.
ECM00152067 A Network license problem was resolved so that now Commuter licenses correctly enable all purchased modules.
ECM00152534 A Network license problem was resolved so that now Missing Values Analysis licenses are only used for procedures that support Missing Values Analysis.
ECM00152779 The Network License Manager allocated 100% of the available licenses to Commuter licenses. That has been fixed.
ECM00155138 The Database Wizard sometimes prompted for login credentials when it should have presented a File Browse user interface. That has been fixed.
ECM00153160 On locales that use commas instead of dots as a decimal separator, Automatic Linear Modeling Model Viewer output could contain dots when it should have contained commas. That has been fixed.
ECM00152758 When requesting Nonparametric Tests (NPTESTS) with SPLIT FILE, the Model Viewer output was missing some split groups. That has been fixed.
PM39780 Statistics Server running on ZLinux could import DB2 integer fields incorrectly. That has been fixed.
ECM00151188 When Exporting Data to an Informix database using the Database Wizard, "Replace values in existing fields" and "Add new fields to an existing table" did not work correctly. That has been fixed.
ECM00154290 When opening a Microsoft Access database with the Database Wizard and using "Prompt for values", some strings were not quoted correctly. That has been fixed.
ECM00157350 When exporting to an Excel file using the Database Wizard some data could be truncated. This has been fixed.
ECM00153379 Using SAVE TRANSLATE to save Stata data sometimes failed to produce the file. That has been fixed.
ECM00156076 Saving SAS files to locations that contain Japanese characters now works.
ECM00152825 Making Output Page Attributes the default now works as expected.
ECM00152515 Incorrect handling of comma vs. dot decimal separators when pasting values from Pivot Tables to a new data file was fixed.
ECM00151411 Exporting an Output file to PowerPoint now exports all output including the Pivot Tables.
ECM00152791 Accented characters in Output files now print correctly.
ECM00152946 Output with long tables now display completely on all pages when printed and when exported to PDF.
PM36756 Output with wide pivot tables now fits on one page when exported to PDF.
ECM00153725 Copy Special for Pivot Tables now makes all appropriate Paste formats available, and the default persists.
PM36359 Copying a Graph to EMF format could cause the application to close suddenly. That has been fixed.
PM42210 When exporting Pivot Tables with percentage values to Excel or Word, the percentages could be converted into decimals. That has been fixed.
ECM00155577 ECM00154907 Custom dialog packages (.SPD) deployed to Collaboration and Deployment Services could fail to run. That has been fixed.
ECM00155557 An error in the installation instructions for the Statistics Adapters for Collaboration and Deployment Services was corrected.
ECM00156502 Problems with empty rows and columns in Pivot Tables have been fixed.
ECM00153916 A problem with Exact Tests significance results from Crosstabs running on 64-bit Windows has been corrected.
ECM00152321 A problem with Python Scripting and DataCellArrays for two tables at the same time was fixed.
ECM00152175 The Rake Weight Programmability Extension available from IBM developerWorks failed with certain data. That has been fixed.
ECM00153088 Statistics Server running on ZLinux could fail to end client processes when it should. That has been fixed.
ECM00153591 A pushed installation of "SPSS Statistics - Integration Plug-In for Python" sometimes failed to run correctly. That has been fixed.
ECM00157734 When opening Text Data, the Text Import Wizard sometimes did not create enough variables when data were blank on the first row. That has been fixed.
ECM00156267 The Time Series Modeler user interface now pastes incorrect syntax when a Transfer Function Delay is requested.
ECM00161849 Chart Templates now apply data value labels correctly to Pie charts.
ECM00155083 ECM00152647 Creating a clustered bar chart from the Crosstab procedure with string variables could cause the application to close suddenly. That has been fixed.
ECM00156149 Problems changing marker color in scatterplots have been fixed.
ECM00150647 GENLIN Parameter Estimates output now shows the user-specified fixed negative binomial distribution ancillary parameter.
ECM00152091 Exporting an Output file to Excel failed to export when the Excel file contains formulas. That has been fixed.
ECM00153338 A problem opening some Excel files on Mac OS has been corrected.
ECM00151401 Legacy graphs sometimes did not sort categories correctly by statistic. That has been fixed.
ECM00152829 ECM00148467 Help buttons did not work for the dialogs accessed from the File->Repository menu. That has been fixed.
ECM00148313 A problem with the Statistics Data File Driver and Tableau has been fixed.
ECM00151240 A problem with the Database Wizard import of data from FileMaker Pro was fixed.
ECM00152173 When saving data as Tab- or Comma-delimited data, lines could be broken across rows incorrectly. That has been fixed.
PM40168 A problem where COM ISpssItem.GetChild returned a null value when it should not have has been corrected.
PM39180 The Traffic Light sample script now colors Pivot Table cells correctly.
ECM00157101 At sites with several releases of the application, the Commuter License utility could fail to check out the license for the preferred number of days. That has been fixed.
ECM00145369 Confidence intervals and significance tests (Z) are provided for covariance parameters in Generalized Linear Mixed Models (GENLINMIXED).
PM40198 In the Syntax Editor, a highlighted block of syntax could sometimes be deleted after it was run using "Run->Selection". That has been fixed.
PM36691 Problems with online Help when the user account was set to a roaming profile were corrected.
ECM00152262 Problems with Find and Replace in the Data Editor have been corrected.
ECM00145468 A sporadic problem where charts could not be drawn in the Automatic Linear Modeling Model Viewer has been corrected.
ECM00153132 After applying the 18.0.3 patch, exporting to PowerPoint could fail on Windows 7 systems. That has been fixed.
ECM00155106 After applying the 18.0.3 patch, scripts could fail on Windows systems. That has been fixed.
PM38687 Under some conditions, the Text Import Wizard removed leading spaces. That has been fixed.
ECM00154114 In non-English User Interface Languages, the Visual Binning user interface pasted syntax with incorrect decimal delimiters. That has been fixed.
ECM00153687 Under some conditions, computed categories would not display in Custom Tables. That has been fixed.
ECM00153723 Copying blank cells from Excel and pasting into the Data Editor could result in pasted values of "0". That has been fixed.
PM41858 Using the mouse to change rows in the Data Editor (by clicking in a cell in the next row) could cause ? to temporarily display in the previous row. That has been fixed.
ECM00139499 Accessing an ODBC data source with Polish characters in username and password now works as expected.
ECM00153402 A Statistics Client sometimes could not connect to a zLinux Statistics Server. That has been fixed.
PM38525 Deleting the Legend now allows the chart to resize correctly.
PM40480 In the Chart Editor, using Properties->Variables to change Element Type of the chart now works as expected.
ECM00147228 Oneway ANOVA output now displays the correctly-translated title when Output Language is not English.
PM37862 You can now print directly from the Generalized Linear Mixed Models Model Viewer and the Automatic Linear Modeling Model Viewers, and the documentation has been updated.
ECM00154456 Order for displayed labels in the TwoStep Cluster Model Viewer views is now consistent.
ECM00154485 Editing a Database Query (.spq) that contains Polish characters now works as expected.
ECM00154844 A problem with the alignment of Text Output for Traditional Chinese was corrected.
ECM00154904 Text in a Log File sometimes did not print or export correctly. That has been fixed.
PM41152 Performance reading a large dataset from a Text file has been improved.
PM39489 Scripting CaptionText Property now works correctly.
PM38851 On a Linux 64-bit Statistics Server, syntax files could cause the application to close suddenly when they included VALUE LABELS commands. That has been fixed.
PM42146 Using Ctrl+V to paste in the Syntax Editor could cause the text to be pasted twice. That has been fixed.
PM40124 When creating charts with a GGRAPH command, and using SPLIT FILE, the subtitle containing the split information could appear in the center of the page, instead of at the top of the page as expected. That has been fixed.
ECM00153207 Minor tick marks now display on charts when requested in the Chart Editor.
ECM00150309 Merge Files->Add Cases failed to create the new file when the external data file contained "[]" characters. That has been fixed.
ECM00155179 Converting large numbers (16-digit) to strings could result in the last digit being lost. That has been fixed.
ECM00156493 The Partial Least Squares Regression (PLS) extension command handled weights incorrectly. That has been fixed.
ECM00155339 Neural Networks Multilayer Perceptron (MLP) Predicted Probabilities did not agree with the calculation described in the online Help. That has been fixed, the online Help was correct.
ECM00154053 Aggregate could produce incorrect results when the input data were hexadecimal. That has been fixed.
ECM00154897 (question to Vladimir if we changed the code)
ECM00152988 Custom Tables table builder could display comma instead of dot for summary statistics. That has been fixed.
ECM00150439 Deleting variables in the Data Editor could result in the deleted variable's name still being displayed. That has been fixed.
PM36673 Copy and Paste in the Data Editor is now as fast as it was in previous releases.
ECM00152328 Under some conditions, the DATASET COPY command could mark the original file as having been modified. That has been fixed.
ECM00154932 With some combinations of blank cells, copying columns of data from Excel 97 into and pasting into the Data Editor could paste incorrectly. That has been fixed.
ECM00157819 In rare cases, Run Pending Transformations was not enabled in the Data Editor when it should have been. That has been fixed.
ECM00151147 The documentation for CASESTOVARS /RENAME and /SEPARATOR subcommands has been improved.
ECM00149491 The Multiple Correspondence Analysis user interface now accepts smallest possible positive value for convergence criterion.
ECM00156957 The Visual Binning user interface now accepts cutpoints with positive values less than 1.0.
ECM00156058 Changes to custom dialogs are now consistently saved.
ECM00153756 The Database Wizard "Limit retrieved cases" step now allows unlimited cases to be retrieved.
ECM00155024 Documentation for Correlations and Imputed Missing Data was clarified.
ECM00150994 The Survival procedure now creates a correct Log Survival Plot with a log of the variable on the y-axis.
PM38227 A problem with Scatterplot Spikes to Fit Line in the Chart Editor was corrected.
PM39918 In the Chart Editor, using Properties->Variables to change Style of the cluster variable in a clustered bar chart now works as expected.
ECM00156180 The Algorithms documentation for Crosstabs now includes the algorithms for the column proportion tests (PROP and BPROP).
ECM00150767 ECM00151557 ECM00145538 ECM00154814 Various problems with Japanese translations in the user interface and output have been corrected.
ECM00152261 The Network License Manager sometimes issued an irrelevant warning about look-and-feel. That has been fixed.
ECM00155051 A problem with Hardware Keys not being recognized was fixed.
PM39990 On Mac OS, for redundant Network License Managers, LSHOST variable was not correctly created during installation. That has been fixed.
PM41760 On Mac OS, A Network license problem was resolved so that now Commuter licenses can be successfully checked out.
ECM00150895 The Database Wizard Results panel sometimes did not display the entire SQL statement. That has been fixed.
ECM00153122 When editing an existing query in the Database Wizard, changes made directly to the SQL statement were sometimes not saved. That has been fixed.
ECM00150359 Using the Statistics Data File Driver to import a Statistics dataset (*.sav) into Excel or Access 2007 did not bring in Missing Values when they were defined as ranges. That has been fixed.
ECM00151259 Custom Colors can now be selected in the Viewer tab of the Edit->Options user interface.
ECM00156436 Copy Special default format now persists across sessions.
ECM00153509 The case of letters in variable names is now preserved when saving a data file to Stata.
ECM00152678 A problem moving a Log item in the Outline Pane of the Output Viewer was corrected.
ECM00155297 ECM00157179 In Print Preview and when Exporting to PowerPoint, inserted long titles are now automatically wrapped.
ECM00154709 When printing layered Pivot Tables, a bank page would sometimes appear between the layers. That has been fixed.
ECM00157606 A combination of copy, paste and entering a "%" could cause values in Pivot Table cells to disappear. That has been fixed.
ECM00157064 When exporting Pivot Tables to Excel, the formatting of large numbers is now preserved.
ECM00154945 On RedHat Linux, the production facility sometimes issued an irrelevant warning about a missing file. That has been fixed.
PM40090 On 64-bit Windows, scripts would sometimes fail to run with an "ERROR : (16305) No error" message. That has been fixed.
ECM00156423 Running a script on Pivot Table output could cause some table headings to automatically realign to the center. That has been fixed.
PM38820 Running a very large stepwise Regression in Distributed Mode, could cause the application to close suddenly.
ECM00151991 ECM00151440 Problems setting the value of SPSS_COMMUTE_MAX_LIFE have been fixed.
ECM00152077 In the Syntax Editor, splitting the Window could cause the 'Go to previous/next error in syntax' toolbar buttons to disable. That has been fixed.
PM37999 Changes to "Syntax Color Coding: Quotes" on the Syntax Editor Tab of the Edit->Options user interface now persist.
ECM00152036 On the Syntax Editor Tab of the Edit->Options user interface, the "Automatically open Error Tracking pane" checkbox now works correctly.
PM36879 When opening Text Data, the Text Import Wizard sometimes failed to import some values with Fixed Width and multiple-line case data. That has been fixed.
ECM00143470 Problems with the display of the toolbar buttons on the Open Data user interface were corrected.
ECM00155243 Missing Value handling on Pie Charts from Frequencies now works as described in the documentation.
PM39387 ROC Curve chart X-axis now displays 0 at the origin, instead of displaying a margin.
ECM00153511 A problem with the display of Panel Charts when Category Order is changed in the Chart Editor has been corrected.
ECM00154281 Drag-and-drop of a reference line in the Chart Editor now works as expected when date variable is used in the chart.
ECM00150912 Logging off of Windows without first exiting the application could cause an unknown software exception. That has been fixed.
ECM00148204 Entering data into a large file while that file was being saved could cause cases to display incorrectly. That has been fixed.
ECM00154080 Under some circumstances, date values used as break variables may display as asterisks in the output because there is not enough space to display the date value. Documentation has been updated to describe corrective actions.
ECM00157039 "Display variable names" on the right-click menu in the Define Multiple Response Sets user interface now works as expected.
ECM00156983 The Algorithms documentation for TSMODEL now includes the algorithms for the transfer functions.
ECM00153543 Syntax documentation for MATRIX DATA was clarified.
ECM00154968 A word was missing in the Overview Help Topic for TREE. That has been fixed.
ECM00154356 Information about LSERVOPTS was added to the Network License Manager Administrator's Guide.
ECM00153789 Instructions for specifying the Data Direct Script have been corrected in the IBM SPSS Statistics Administrator's Guide.
ECM00152727 After selecting a subset of data in the Data Editor window, question marks could appear where the values were Cut. That has been fixed.
PM39305 With a very long syntax command, there could be a delay between when the syntax was run and when an error message was produced. The delay has been fixed.
ECM00153410 A spelling error in the Algorithms Help for the RANK procedure has been corrected.
ECM00154801 An error in the formula for DISCRIMINANT standardized canonical discriminant function coefficients has been corrected.
ECM00157525 Help topics which discuss "Offset" terms have been clarified.
ECM00151106 A problem where "Help->Topics->Data Preparation Option->Introduction to Data Preparation" displayed the wrong topic has been corrected.
ECM00155170 A problem where online documentation for AREG, ARIMA and EXSMOOTH was not available has been corrected.
ECM00146623 A problem with the Spanish translation of the word "split" has been corrected.
ECM00153765 Some Analyze menu items displayed the Multiple Imputation icon when they should not have. That has been corrected.
ECM00154237 On the General Tab of the Edit->Options user interface, the "Scroll to new output" checkbox now works correctly.
ECM00152646 A version number error in the About box for the Statistics Adapters for Collaboration and Deployment Services was corrected.
ECM00155783 The documentation for scripting and Excel formats (.biff vs. biff5) was clarified.
ECM00154556 A shortcut that launched 'statisticsb.exe' is no longer installed.
ECM00154804 accessibility.properties is now available to all users. It is in the installation directory.
ECM00154311 A syntax file where comments have been added using the Syntax Editor 'Toggle Comment Selection' icon to comment out a command can now be Saved (instead of having to use Save As).
ECM00152882 On the Syntax Editor Tab of the Edit->Options user interface, the "Paste syntax from selection or cursor" item now correctly pastes for Generalized Linear Mixed Models and Automatic Linear Modeling.
PM40772 When opening Text Data with fixed width, the Text Import Wizard preview window stopped at 2850 columns even when the data were wider. That has been fixed.
ECM00152216 The Algorithms documentation for CATREG now includes the algorithms computing Standard Error Beta when Bootstrapping is used.

Related information

Download SPSS Statistics 20 Upgrade
SPSS Statistics 20 Release Notes
SPSS Statistics 20 Documentation

Original publication date

2011/7/20

Rate this page:

(0 users)Average rating

Document information


More support for:

SPSS Statistics

Software version:

Not Applicable

Operating system(s):

Platform Independent

Reference #:

7022284

Modified date:

2011-08-16

Translate my page

Machine Translation

Content navigation