IBM OpenPages GRC Platform Version 6.0.1 Software Requirements

Product documentation


Abstract

This document describes the software prerequisites for IBM® OpenPages® GRC Platform Version 6.0.1.

Content

This document describes the software that must be installed in the IBM OpenPages GRC Platform Version 6.0.1 environment before starting the installation process. This document also describes the software that will be installed during the installation process, either by the IBM OpenPages GRC Platform Installer or third-party installers. Several optional applications that can be integrated into the OpenPages environment are also listed.

Software to Be Installed Before the OpenPages Installation Process

In a Microsoft® Windows® / Oracle® WebLogic Server environment install these software components before starting the OpenPages installation.

Although OpenPages environments denoted as compatible may also be tested, testing may be limited or support may be based on compatibility statements from IBM OpenPages partners and third-party vendors.

Software Requirements: Windows-based Server Systems

Server Software requirements
All servers All servers in the OpenPages environment should have the following Compatible software installed before starting the OpenPages installation:
  • Microsoft Windows Server® 2008 R2 and later Service Packs (64-bit operating system)
  • Microsoft Internet Explorer® 7.0 (or 8.0 in Compatibility View mode)
  • A file compression utility, such as WinZip
  • A PDF reader (such as Adobe® Acrobat)
Database server(s) In addition to the software listed above for all servers, the server that hosts the Oracle database should have one of the following Compatible software packages installed before starting the OpenPages installation:
  • Oracle 11gR2 (11.2.0.1) and any higher Patch Set.
    Note: Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update.
Application server(s) In addition to the software listed above for all servers, the server that hosts the OpenPages application should have the following Compatible software installed before starting the OpenPages installation:
  • JDK 1.6 or greater, 64-bit
    Note: This is a prerequisite only if your OpenPages products does not include WebLogic Server.
  • Oracle WebLogic Server 10.3.2 and any higher Patch Set. Minimum requirement is Oracle WebLogic Server 10.3.2.
    Note: This is a prerequisite only if your OpenPages products does not include Oracle WebLogic Server.
  • Oracle Database Client 11gR2 (11.2.0.1) and any higher Patch Set.
    Note: Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update (64-bit).
Reporting server In addition to the software listed above for all servers, the server that hosts CommandCenter should have the following Compatible software installed before starting the CommandCenter installation:
  • Microsoft Internet Information Services (IIS) 7.0 or Apache HTTP Server™ 2.2.14 or greater
  • Oracle Database Client 11g R2 (11.2.0.1) and any higher Patch Set.
    Note:
    Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update (32-bit)

In an IBM AIX® / IBM WebSphere® Application Server environment install these software components before starting the OpenPages installation:

Software Requirements: AIX-based Server Systems
Server Software requirements
All servers All servers in the OpenPages environment should have the following Compatible software installed before starting the OpenPages installation:
  • IBM AIX 6.1 (64-bit)
  • A file compression utility, such as the GNU tar utility (gtar)
  • A PDF reader

Note:The AIX default tar command may not be able to uncompress the contents of downloaded media pack images, due to a problem related to long file names.

Database server(s) In addition to the software listed above for all servers, the server that hosts the Oracle database should have the following Compatible software installed before starting the OpenPages installation:
  • Oracle 11gR2 (11.2.0.1) and any higher Patch Set.
    Note: Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update.
Application server(s) In addition to the software listed above for all servers, the server that hosts the OpenPages application should have the following Compatible software installed before starting the OpenPages installation:
  • IBM Websphere Application Server ND 7.0.0.13 and any higher Fix Pack.
    Note: Minimum requirement is Websphere 7.0.0.13
  • JRE 1.4.1 (required for Interstage BPM software installation)
  • Oracle Database Client 11gR2 (11.2.0.1) and any higher Patch Set.
    Note: Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update (64-bit).

IMPORTANT! The IBM OpenPages GRC Platform requires a dedicated LPAR and IBM WebSphere Application Server environment. Sharing the OpenPages LPAR with other applications and IBM WebSphere Application Server environments is not supported.
Reporting server In addition to the software listed above for all servers, the server that hosts CommandCenter should have the following Compatible software installed before starting the CommandCenter installation:
  • Apache HTTP Server™ 2.2.14 or later
  • Oracle Database Client 11gR2 (11.2.0.2) and any higher Patch Set.
    Note: Minimum requirement is Oracle 11.2.0.1 October 2010 Critical Patch Update (32-bit).

Software Installed During the OpenPages Installation Process

The following components will be installed during the OpenPages installation process in both the WebLogic Server and WebSphere Application Server environments:
  • OpenPages application
  • Fujitsu Interstage Business Process Manager (BPM) 10.1
  • IBM Cognos® 8.4.1
  • OpenPages CommandCenter
  • JRE 1.6 or greater

If your OpenPages product includes Oracle WebLogic Server, the following software is installed on an OpenPages application server system:
  • Oracle WebLogic Server 10.3.2

If your OpenPages product includes Oracle Database, the following software is installed:
  • Oracle Database Server Oracle 11G Release 2 (11.2.0.1) Standard Edition with October 2010 CPU Patch (on a database server system)
  • Oracle Database Client 11g Release 2 (11.2.0.1) with October 2010 CPU Patch applied 64-bit (on an application server system)
  • Oracle Database Client 11g Release 2 (11.2.0.1) with October 2010 CPU Patch applied 32-bit (on a reporting server system)

Software to Be Installed on OpenPages Client Systems

Any Windows-based client system that will access the OpenPages application should have the following software installed:
  • Microsoft Internet Explorer 7.0 (or 8.0 in Compatibility View mode)
  • A PDF reader, such as Adobe Reader 7.0 or later (for CommandCenter reporting functions)
  • Microsoft Excel 2003 or later (for CommandCenter reporting functions)
  • Microsoft .NET Framework 2.0 (on systems where IBM Cognos 8 Go! Office will be installed)

Optionally, you may install any of the following:
  • IBM Cognos Go! Office 8.4.1 (provided with the OpenPages product)
  • IBM Cognos 8 Business Intelligence Framework Manager 8.4.1 (provided with the OpenPages product)

Optional Software

IBM OpenPages GRC Platform integrates with the following optional software:
  • IBM Cognos Go! Office 8.4.1 (Windows only)
  • CA SiteMinder® 5.5 or later (for single sign-on)
    Note: SiteMinder is only supported on systems running an English language operating system.
  • VMWare® ESX 3.5.1 or 4.0 (for virtualization)
  • IBM Tivoli® Access Manager (TAM) 6.1 (for user authentication, authorization and Web SSO support)

VMWare Configuration Requirements

A virtualized OpenPages environment consists of one or more virtual machines for the OpenPages application server and the reporting server. Virtualization of the OpenPages database server is not supported. Cloning of OpenPages application server VMs is not supported.

Each VM server machine must meet the following software requirements:
  • VMWare ESX Server 3.5.1 or 4.0
  • VMWare Infrastructure Client 4.0
  • Microsoft Windows 2008 R2

The VMWare performance on a virtualized system is comparable to native hardware. You can use the OpenPages hardware requirements for sizing VM environments.

Related information

OpenPages GRC Platform 6.0.1 FP3 now available for down

Original publication date

2011/5/3

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

OpenPages GRC Platform

Software version:

6.0.1, 6.0.1.1, 6.0.1.2

Operating system(s):

AIX, Windows

Reference #:

7021515

Modified date:

2012-04-11

Translate my page

Machine Translation

Content navigation