Hardware and software prerequisites for IBM Web Interface for Content Management V1.0.4.2 and V1.0.4.3

Product documentation


Abstract

This document contains the hardware and software prerequisites for IBM Web Interface for Content Management (IBM WEBi) Version 1.0.4.2 and 1.0.4.3.

IBM WEBi is a web-based client that you can use with IBM Content Manager OnDemand V8.3 and later and IBM Content Manager V8.3 and later.

Content

Links to IBM WEBi hardware and software requirements documents


Important: All of the components mentioned in this document are required unless specifically noted.

If you do not have a supported version of the required software, you can download it from the IBM Passport Advantage Online Web site.

Legend
Icon Description
Supported Supported
Δ Added or changed information since the last release, modification, or fix pack. This mark in the far left column indicates new or changed information in the row.


About the IBM WEBi server

On the server where you plan to install IBM WEBi, you must install a Web application server and content server connectors before you can install IBM WEBi. For additional information on the IBM WEBi server, see the following topics in the information center:

Recommendation: When configuring the IBM WEBi server, plan for the IBM WEBi configuration tool. The IBM WEBi configuration tool is best viewed with a screen resolution of 1280 x 1024 on AIX, Linux, and Linux for System z and 1024 x 768 on Windows.


Hardware Platforms (IBM WEBi server)

The following table provides a list of the supported hardware platforms for the IBM WEBi server.

Not every operating system is supported for every hardware platform. See the Operating system table for a list of the operating systems that are supported on each platform.

Important: The supported hardware platforms for the IBM WEBi server are not the same as those for WebSphere Application Server (see Article #7007250).

Platform Description
x86 Intel® 32-bit processors, including IBM System x™, eServer™ xSeries®, and BladeCenter® servers.
x86-64 Intel 64-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers.
POWER IBM POWER™-based processors, including IBM System p™, eServer pSeries®, System i™ and eServer iSeries® servers.
zSeries 64-bit System z.

Operating Systems (IBM WEBi server)

The following table specifies the supported operating systems by hardware platform for the IBM WEBi server.

Operating system x86 x86-64 POWER zSeries Notes
AIX® 5L 5.2 (Maintenance level 3 and 32-bit or 64-bit) or later Maintenance levels
AIX 5L 5.3 (32-bit or 64-bit) or later Maintenance levels Supported on POWER

Requires a minimum of 4 GB of RAM.

AIX 6.1 (64-bit) or later Maintenance levels Supported on POWER

Requires a minimum of 4 GB of RAM.

Windows® 2000 Server (32-bit) SP4 Supported on x86 Supported on x86-64

For IBM Content Manager with Information Integrator for Content Version 8.3 Fix Pack 7 or later only.

Requires a minimum of 4 GB of RAM.

Terminal services users must install IBM WEBi and its prerequisite software in Install Mode. For more information, see http://support.microsoft.com/kb/320185 (link resides outside of ibm.com).

Windows 2000 Advanced Server (32-bit) SP4 Supported on x86 Supported on x86-64

For IBM Content Manager with Information Integrator for Content Version 8.3 Fix Pack 7 or later only.

Requires a minimum of 4 GB of RAM.

Terminal services users must install IBM WEBi and its prerequisite software in Install Mode. For more information, see http://support.microsoft.com/kb/320185 (link resides outside of ibm.com).

Windows Server 2003 Standard Edition (32-bit) SP2 or R2 Supported on x86 Supported on x86-64

Requires a minimum of 4 GB of RAM.

Terminal services users must install IBM WEBi and its prerequisite software in Install Mode. For more information, see http://support.microsoft.com/kb/320185 (link resides outside of ibm.com).

Windows Server 2003 Enterprise Edition (32-bit) SP2 or R2 Supported on x86 Supported on x86-64

Requires a minimum of 4 GB of RAM.

Terminal services users must install IBM WEBi and its prerequisite software in Install Mode. For more information, see http://support.microsoft.com/kb/320185 (link resides outside of ibm.com).

Windows Server 2008 (32-bit) Supported on x86 Supported on x86-64

Requires a minimum of 4 GB of RAM.

Terminal services users must install IBM WEBi and its prerequisite software in Install Mode. For more information, see http://support.microsoft.com/kb/320185 (link resides outside of ibm.com).

Red Hat Enterprise Linux 5 or later fixes (64-bit) Supported on x86-64

With WebSphere 32-bit JVM only.

Red Hat Enterprise Linux 5 or later fixes (64-bit) Supported on System z

With WebSphere 64-bit JVM only.

SUSE Linux Enterprise Server 10 or later fixes (64-bit) Supported on x86-64

With WebSphere 32-bit JVM only.

SUSE Linux Enterprise Server 10 or later fixes (64-bit) Supported on System z

With WebSphere 64-bit JVM only.


Web Application Servers (IBM WEBi server)

The following table specifies the supported Web application servers for the IBM WEBi server.

Web application server AIX Linux Linux for System z Windows Notes
WebSphere Application Server (32-bit) 6.0.2.11 and later (Base or Network Deployment only) Supported on AIX Supported on Linux Supported on Windows

Version 6.0.2.23 is recommended.

See Article #4017224.

Important: If you install IBM WEBi Version 1.0.4 Fix Pack 2 for an IBM Content Manager system, you must upgrade to Version 6.0.2.33 or later.

In a WebSphere Application Server Network Deployment environment, only clusters are supported.

WebSphere Application Server (32-bit) 6.1.0.11 and later (Base or Network Deployment only) Supported on AIX Supported on Linux Supported on Windows

Important: If you install IBM WEBi Version 1.0.4 Fix Pack 2 for an IBM Content Manager system, you must upgrade to Version 6.1.0.19 or later.

In a WebSphere Application Server Network Deployment environment, only clusters are supported.

WebSphere Application Server (64-bit) for zLinux 6.1.0.11 and later (Base or Network Deployment only) Supported on Linux for System z

Important: If you install IBM WEBi Version 1.0.4 Fix Pack 2 for an IBM Content Manager system, you must upgrade to Version 6.1.0.19 or later.

ODWEK requires 64-bit.

Requires a minimum of Information Integrator for Content V8.4.2

In a WebSphere Application Server Network Deployment environment, only clusters are supported.

WebSphere Application Server 7.0 (32-bit) and later (Base or Network Deployment only) Supported on AIX Supported on Linux Supported on Windows

The minimum required version is 7.0.0.3

In a WebSphere Application Server Network Deployment environment, only clusters are supported.

WebSphere Application Server 7.0 (64-bit) for zLinux (Base or Network Deployment only) Supported on Linux for System z

The minimum required version is 7.0.0.3

ODWEK requires 64-bit.

Requires a minimum of Information Integrator for Content V8.4.2

In a WebSphere Application Server Network Deployment environment, only clusters are supported.


Content Server Connectors (IBM WEBi server)

The following table specifies the supported content server connectors for the IBM WEBi server. Content server connectors enable IBM WEBi to communicate with IBM Content Manager and IBM Content Manager OnDemand and are supplied with your content server.

Content server connector AIX Linux Linux for System z Windows Notes
OnDemand Web Enablement Kit (ODWEK) V8.3.0.11 (7.1.2.11)
OnDemand Web Enablement Kit (ODWEK) V8.4.1 Supported on AIX Supported on Linux Supported on Linux for System z Supported on Windows

For a complete list of the ODWEK prerequisites, see Article #7012104.

Δ OnDemand Web Enablement Kit (ODWEK) V8.5.0.1 Supported on AIX Supported on Linux Supported on Linux for System z Supported on Windows

For a complete list of the ODWEK prerequisites, see Article #7016455.

DB2 Content Manager Information Integrator for Content DB2 Content Manager Version 8 connector V8.3 FP7 or later Supported on AIX Supported on Linux Supported on Windows

Depending on whether you are using DB2 or Oracle with IBM Content Manager, you must also have the DB2 Runtime Client or Oracle Client, respectively. The recommended minimum version of DB2 Runtime Client is V8.1.14.

Requires WebSphere Application Server V6.0.2.11.

DB2 Content Manager Information Integrator for Content DB2 Content Manager Version 8 connector V8.4.2 Supported on AIX Supported on Linux Supported on Linux for System z Supported on Windows

If you are using Oracle with DB2 Content Manager, you must also have the Oracle Client 10.2.0.3 or later.

Information Integrator for Content Version 8.4.2.2 is recommended if you use the IBM WEBi applet viewer to view multiple versions of documents. See Article #7018894 for additional information.

DB2 Content Manager Information Integrator for Content DB2 Content Manager Version 8 connector V8.4.3 Supported on AIX Supported on Linux Supported on Linux for System z Supported on Windows

If you are using Oracle with DB2 Content Manager, you must also have the Oracle Client 10.2.0.3 patchset 3 or later (Windows) or patch 4722328 and patch 6075949 or later (UNIX) (32-bit).


IBM Content Manager (Content server)

The following table specifies the supported IBM Content Manager servers for IBM WEBi Version 1.0.4.

Content server AIX HP/UX Lin Sol Win i5/OS z/Linux z/OS Notes
DB2 Content Manager V8.3 FP7 and later Supported on AIX Supported on Linux Supported on Solaris Supported on Windows

Article #1264915

DB2 Content Manager for z/OS V8.3 FP7 and later Supported on z/OS

Article #7010315

DB2 Content Manager V8.4 and later Supported on AIX Supported on Linux Supported on Solaris Supported on Window Supported on z/Linux

Article #1260205

DB2 Content Manager for z/OS V8.4 and later Supported on z/OS

Article #1266777


IBM Content Manager OnDemand (Content server)

The following table specifies the supported IBM Content Manager OnDemand servers for IBM WEBi Version 1.0.4.

Content server AIX HP/UX Lin Sol Win i5/OS z/Linux z/OS Notes
DB2 Content Manager OnDemand for Multiplatforms V8.3.0.11 and later (V7.1.2.11 and later) Supported on AIX Supported on HP/UX Supported on Linux Supported on Solaris Supported on Windows Supported on z/Linux
DB2 Content Manager OnDemand for Multiplatforms V8.4.0.1 and later Supported on AIX Supported on HP/UX Supported on Linux Supported on Solaris Supported on Windows Supported on z/Linux
DB2 Content Manager OnDemand for i5/OS® V5.4 and later Supported on i5/OS
DB2 Content Manager OnDemand for z/OS® V7.1 and later Supported on z/OS

Federated search software

If you plan to use IBM WEBi to search across multiple IBM Content Manager servers, multiple IBM Content Manager OnDemand servers, or a combination of content servers, you need IBM Content Integrator.

The following table specifies the supported IBM Content Integrator for the IBM WEBi server.

Federated search application AIX Linux Linux for System z Windows Notes
IBM Content Integrator V8.5 or later Supported on AIX Supported on Linux Supported on Windows

For a complete list of the IBM Content Integrator prerequisites, see Article #7013516


Operating systems (IBM WEBi client machines)

The following table specifies the required and supported operating systems for users of the IBM WEBi client.

The IBM WEBi client can be run on the Windows operating system only.

Operating system 32-bit 64-bit Notes
Windows XP Supported on 32-bit Windows
Windows Vista Supported on 32-bit Windows If you use IBM WEBi in an FDCC environment, see Article #7013932
Windows 7 Supported on 32-bit Windows Supported on 64-bit Windows IBM WEBi is supported on a 64-bit version of Windows 7 only with a 32-bit version of Internet Explorer.

Web browsers (IBM WEBi client machines)

The following table specifies the required and supported browser software for users of the IBM WEBi client. You must have the necessary hardware to support a browser that supports frames and Javascript™.

Recommendations:

Web browser AIX Linux Linux for System z Windows Notes
Mozilla Firefox 3.0 Supported on Windows

You must enable JavaScript in the Web browser.

Mozilla Firefox 3.5 Supported on Windows

You must enable JavaScript in the Web browser.

Mozilla Firefox 3.6
Microsoft® Internet Explorer 6 SP3 Supported on Windows

You must enable JavaScript in the Web browser.

Internet Explorer 7 or later is recommended.

Microsoft Internet Explorer 7 Supported on Windows

You must enable JavaScript in the Web browser.

Microsoft Internet Explorer 8 Supported on Windows

You must enable JavaScript in the Web browser.

If you embed IBM WEBi in a custom application, you must enable Compatibility View in Internet Explorer 8. For more information, see http://support.microsoft.com/kb/956197 (link resides outside of ibm.com).


Java Runtime Environment (IBM WEBi client machines)

The following table specifies the required Java™ Runtime Environments for the IBM WEBi client machines. The Java Runtime Environment is required to view documents, send documents through e-mail, and edit documents.

Important: Keep the following issues in mind when installing the Sun Java Runtime Environment (JRE) on client workstations:

  • IBM WEBi is not automatically compatible with Sun JRE updates. IBM WEBi supports the versions of the Sun JRE that are listed in this document; however, some updates are known to cause problems with IBM enterprise content management clients. Installing a different version or an update of the Sun JRE might resolve the problem. For additional information about issues with the Sun JRE, see Article #1474236.
  • Any issues that are determined to have a root cause in the Sun JRE code are outside the scope of assistance that IBM Software Support can provide. If the root cause is identified as the Sun JRE, it is recommended that you contact Oracle for assistance.
Java Runtime Environment AIX Linux Linux for System z Windows Notes
Sun Java Runtime Environment 1.4.2_03 or later updates Supported on Windows

You must enable JavaScript in the Web browser.

Sun Java Runtime Environment 1.5.0 or later updates Supported on Windows

You must enable JavaScript in the Web browser.

Sun Java Runtime Environment 1.6.0 or later updates Supported on Windows

JRE 1.6.0 is required to use the Edit Document feature.

Important: JRE 1.6.0_17 is the latest JRE update for which no compatibility issues have been identified. For more information see Article #1474236.

Sun Java Runtime Environment 1.6.0_04 or later updates Supported on Windows

JRE 1.6.0_04 is required for FDCC.

Important: JRE 1.6.0_17 is the latest JRE update for which no compatibility issues have been identified. For more information see Article #1474236.


E-mail clients (IBM WEBi client machines)

The following table specifies the required e-mail application software for IBM WEBi client users to send links to documents or to send documents as attachments.

E-mail application AIX Linux Linux for System z Windows Notes
Microsoft Outlook 2003 Supported on Windows
Microsoft Outlook 2007 Supported on Windows
Microsoft Outlook 2010 Supported on Windows
Microsoft Outlook Express Supported on Windows
Lotus Notes V7 Supported on Windows
Lotus Notes V8 Basic Mode Supported on Windows
Lotus Notes V8 Advanced Mode
Lotus Notes V8.5 or later Basic Mode Supported on Windows
Lotus Notes V8.5 or later Advanced Mode

Sizing and capacity planning

The IBM Content Manager and IBM Content Manager OnDemand clients have different functionality and performance characteristics, and drive different performance and load characteristics onto their DB2 Content Manager and DB2 Content Manager OnDemand servers. The amount of necessary CPU processing power, RAM, and disk space vary depending on your specific workload and your desired system capacity and performance. To build the best working system that you can test and then move into production, work with the Techline team to identify the necessary requirements by machine. Your IBM Sales representative can contact Techline for you.


Related documentation
Document Format
Download IBM WEBi Version 1.0.4 Fix Pack 2 HTML
Download IBM WEBi Version 1.0.4 Fix Pack 3 HTML
IBM Web Interface for Content Management Version 1.0.4 publication library HTML
Functionality comparison of DB2 Content Manager V8.3 clients HTML
Functionality comparison of DB2 Content Manager V8.4 clients HTML
Functionality comparison of IBM Content Manager OnDemand clients HTML


Change history
History Date Change
Release March 2011 Created for IBM WEBi Version 1.0.4.2 and Version 1.0.4.3


Product Alias/Synonym

IBM WEBi
IBM WEBi V1.0.4.2
IBM WEBi V1.0.4.3
IBM Web Interface for Content Management
IBM Web Interface for Content Management V1.0.4.2
IBM Web Interface for Content Management V1.0.4.3.

Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Web Interface for Content Management
WEBi

Software version:

1.0.4

Operating system(s):

AIX, Linux, Windows

Reference #:

7021285

Modified date:

2013-10-10

Translate my page

Machine Translation

Content navigation