Detailed system requirements for Version 9.1

Product documentation


Abstract

This page describes the supported operating systems for IBM® InfoSphere MDM Server for PIM, Version 9.1. Please note the minimum product levels that you must install before opening a problem report. Your entitlement to support is dependent upon your license and maintenance agreements for the InfoSphere MDM Server for PIM.

Content

The following information is for the InfoSphere MDM Server for PIM system only. If you run other applications on the same system, make appropriate adjustments.

InfoSphere MDM Server for PIM bundles some of the software that is required. You might need to apply certain fix packs to the version provided, as described in these detailed system requirements or in the product and support documentation.

The system requirements for InfoSphere MDM Server for PIM vary based on the scope and scale of your PIM system. The exact configuration you need to support your environment with satisfactory performance will vary depending on multiple factors such as server speed, memory, disk I/O, data volumes, and network and server workload.

The minimum recommended configurations need to be evaluated and adjusted according to your unique requirements and the complexity of the InfoSphere MDM Server for PIM solution. Disk space recommendations are for the product installation and working space only. The actual hard disk space that is required varies, depending upon your installation.

The hardware requirements represent the minimum hardware requirements for a small InfoSphere MDM Server for PIM system with less than 50,000 items supporting 10-20 concurrent users. The minimum recommended configurations need to be evaluated and adjusted according to your unique requirements and the complexity of the InfoSphere MDM Server for PIM solution. Disk space recommendations are for the product installation and working space only. The actual hard disk space that is required varies, depending upon your installation. IBM professional services or your sales representative can help determine the appropriate hardware requirements for your InfoSphere MDM Server for PIM system.

You must set up both a client system and one or more server systems. The application server, database server, and HTTP server can all be on the same server machine, they can be combined together on server machines, or they can each be on their own server machine. The HTTP server is recommended, but is optional.

There are a limited number of combinations of operating system and hardware platforms that will be supported. InfoSphere MDM Server for PIM supports both 32-bit and 64-bit architectures, depending on what the underlying hardware platform, operating system, or application server software and database server software supports.

You cannot run the InfoSphere MDM Server for PIM database or services on Microsoft Windows systems. Microsoft Windows system is only used as client machine to access the product user interfaces. Furthermore, Rational Software Architect plugins for Script Workbench and User Interface Generator, which are supplied with the program also run on Windows client system. You can also access the product Information Center on the client system.

Important:
These requirements represent the minimum system requirements. The product supports the specified version only and any subsequent fix packs, service packs, or service refreshes that are released for the specified version. Earlier or later versions or releases are not supported.

Detailed System Requirements for Version 9.1

*NAME FOR INTERNAL USE:IBM InfoSphere Master Data Management Server for Product Information Management 9.1

Tab navigation

Tab navigation



Hardware Requirements
Group Applicable OS Notes
Disk Space All Applicable AIX OS

Application Server:  50 GB

Database Server: 100-200 GB, in a RAID configuration

Note: See the hardware requirements table for details.

Memory All Applicable AIX OS

Application Server:  6 GB

Database Server:  8 GB

Note:See the hardware requirements table for details.

Processor All Applicable AIX OS

Application Server:  2 - 4 processor cores (based on CPU speed)

Database Server:  4 processor cores (based on CPU speed)

Note:See the hardware requirements table for details.

Operating Systems
Operating System Attributes Notes
AIX Platform listing of supported OS
AIX 5.3 POWER System Bitness: 64 Bit Exploit
Deployment Role: Agent/End-point, Server
Hardware platform: POWER System
AIX 6.1 POWER System Bitness: 64 Bit Exploit
Deployment Role: Agent/End-point, Server
Hardware platform: POWER System
Software Requirements
Group Product Applicable OS Notes
Collaborative WebSphere MQ 7.0.1 and future fix packs (overview) (support) All Applicable AIX OS

InfoSphere MDM Server for PIM can be configured to use messaging software, as described in the information center. However, the optional Global Data Synchronization feature of InfoSphere MDM Server for PIM requires the following messaging software to run correctly.

IBM WebSphere MQ, Version 7.0.1 client

IBM WebSphere MQ, Version 7.0.1 server

Note: The IBM WebSphere MQ, Version 7.0.1 client version must be installed on the application server only, however the IBM WebSphere MQ, Version 7.0.1 server can be installed on any server.

Operating System Runtimes Open Source Perl 5 All Applicable AIX OS

InfoSphere MDM Server for PIM requires Perl version 5.8, although version 5.10 is preferred. InfoSphere MDM Server for PIM also requires several Perl modules. For more information, see the information center.

Optional Supported Software
Group Product Applicable OS Notes
Application Servers WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable AIX OS
Application Servers - 64-bit WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable AIX OS
Databases DB2 Enterprise Server Edition 9.5 and future fix packs (overview) (support) All Applicable AIX OS

Requires IBM DB2® Client, version 9.5, including the DB2 Universal JDBC Driver, or later.

DB2® for RedHat Linux is supported on System z10® hardware as product database only.

DB2 Enterprise Server Edition 9.7 and future fix packs (overview) (support) All Applicable AIX OS

Requires IBM DB2® Client, version 9.7, including the DB2 Universal JDBC Driver, or later.

DB2® for RedHat Linux is supported on System z10® hardware as product database only.

Oracle Database 10g Enterprise Edition Release 2 10.2.0.4 and future fix packs All Applicable AIX OS

Important:  Although the database server can use Oracle 10g, the database client must use Oracle 11g. Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later

Oracle Database 11g Enterprise Edition Release 2 11.2.0.1 and future fix packs AIX 5.3 POWER System,
AIX 6.1 POWER System

Requires Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later.

Java SDK IBM Runtime Environment ,Java Technology Edition 6.0 and future mod levels and their fix packs All Applicable AIX OS

IBM Java SDK 6.0 on Windows, which is supplied with Rational Software Architect, is required if using User Interface Generator and Script Workbench with InfoSphere MDM Server for PIM.

Virtualization IBM PowerVM Hypervisor (LPAR, DPAR, Micro-Partition) any supported version and future fix packs All Applicable AIX OS
Web Servers Apache HTTP Server 2.0 and future fix packs All Applicable AIX OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

Apache HTTP Server, Version 2.0 or later

IBM HTTP Server 2.0 and future fix packs (overview) (support) All Applicable AIX OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

IBM HTTP Server, Version 2.0 or later


Tab navigation



Hardware Requirements
Group Applicable OS Notes
Disk Space All Applicable HP OS

Application Server:  50 GB

Database Server: 100-200 GB, in a RAID configuration

Note:See the hardware requirements table for details.

Memory All Applicable HP OS

Application Server:  6 GB

Database Server:  8 GB

Note:See the hardware requirements table for details.

Processor All Applicable HP OS

Application Server:  2 - 4 processor cores (based on CPU speed)

Database Server:  4 processor cores (based on CPU speed)

Note:See the hardware requirements table for details.

Operating Systems
Operating System Attributes Notes
HP Platform listing of supported OS
HP-UX 11i v3 PA-RISC Bitness: 64 Bit Exploit
Deployment Role: Agent/End-point, Server
Hardware platform: PA-RISC

Requires HP-UX 11i (11.31) B.11.31.0803.318a Base Quality Pack Bundle for HP-UX 11i v3, March 2008 or higher for Oracle/BEA WebLogic Server 11g support.

Software Requirements
Group Product Applicable OS Notes
Collaborative WebSphere MQ 7.0.1 and future fix packs (overview) (support) All Applicable HP OS

InfoSphere MDM Server for PIM can be configured to use messaging software, as described in the information center. However, the optional Global Data Synchronization feature of InfoSphere MDM Server for PIM requires the following messaging software to run correctly.

IBM WebSphere MQ, Version 7.0.1 client

IBM WebSphere MQ, Version 7.0.1 server

Note: The IBM WebSphere MQ, Version 7.0.1 client version must be installed on the application server only, however the IBM WebSphere MQ, Version 7.0.1 server can be installed on any server.

Operating System Runtimes Open Source Perl 5 All Applicable HP OS

InfoSphere MDM Server for PIM requires Perl version 5.8, although version 5.10 is preferred. InfoSphere MDM Server for PIM also requires several Perl modules. For more information, see the information center.

Optional Supported Software
Group Product Applicable OS Notes
Application Servers Oracle/BEA WebLogic Server 11g Release 1 and future fix packs All Applicable HP OS

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

Application Servers - 64-bit Oracle/BEA WebLogic Server 11g Release 1 and future fix packs HP-UX 11i v3 PA-RISC

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

Databases Oracle Database 10g Enterprise Edition Release 2 10.2.0.4 and future fix packs All Applicable HP OS

Important:  Although the database server can use Oracle 10g, the database client must use Oracle 11g. Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later

Oracle Database 11g Enterprise Edition Release 2 11.2.0.1 and future fix packs HP-UX 11i v3 PA-RISC

Requires Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later.

Java SDK HP Java SDK/JRE/JDK 6.0 and future mod levels and their fix packs All Applicable HP OS

Requires HP Java SDK/JRE/JDK 6.0.02 or higher for both 32 bit and 64 bit versions.

Web Servers Apache HTTP Server 2.0 and future fix packs All Applicable HP OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

Apache HTTP Server, Version 2.0 or later

IBM HTTP Server 2.0 and future fix packs (overview) (support) All Applicable HP OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

IBM HTTP Server, Version 2.0 or later



Hardware Requirements
Group Applicable OS Notes
Disk Space All Applicable Linux OS

Application Server:  50 GB

Database Server: 100-200 GB, in a RAID configuration

Note:See the hardware requirements table for details.

Memory All Applicable Linux OS

Application Server:  6 GB

Database Server:  8 GB

Note:See the hardware requirements table for details.

Processor All Applicable Linux OS

Application Server:  2 - 4 processor cores (based on CPU speed)

Database Server:  4 processor cores (based on CPU speed)

Note:See the hardware requirements table for details.

Operating Systems
Operating System Attributes Notes
Linux Platform listing of supported OS
Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform POWER System Bitness: 64 Bit Tolerate
Deployment Role: Agent/End-point, Server
Hardware platform: POWER System
Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-32 Bitness: 32 Bit
Deployment Role: Agent/End-point, Server
Hardware platform: x86-32

Requires RHEL 5.0 x86-32 UL3 or higher to support Oracle/BEA WebLogic Server 11g.

Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-64 Bitness: 64 Bit Tolerate, 64 Bit Exploit
Deployment Role: Agent/End-point, Server
Hardware platform: x86-64

Requires RHEL 5.0 x86-64 UL3 or higher to support Oracle/BEA WebLogic Server 11g.

Software Requirements
Group Product Applicable OS Notes
Collaborative WebSphere MQ 7.0.1 and future fix packs (overview) (support) All Applicable Linux OS

InfoSphere MDM Server for PIM can be configured to use messaging software, as described in the information center. However, the optional Global Data Synchronization feature of InfoSphere MDM Server for PIM requires the following messaging software to run correctly.

IBM WebSphere MQ, Version 7.0.1 client

IBM WebSphere MQ, Version 7.0.1 server

Note: The IBM WebSphere MQ, Version 7.0.1 client version must be installed on the application server only, however the IBM WebSphere MQ, Version 7.0.1 server can be installed on any server.

Operating System Runtimes Open Source Perl 5 All Applicable Linux OS

InfoSphere MDM Server for PIM requires Perl version 5.8, although version 5.10 is preferred. InfoSphere MDM Server for PIM also requires several Perl modules. For more information, see the information center.

Optional Supported Software
Group Product Applicable OS Notes
Application Servers Oracle/BEA WebLogic Server 11g Release 1 and future fix packs Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-32,
Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-64

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable Linux OS
Application Servers - 64-bit Oracle/BEA WebLogic Server 11g Release 1 and future fix packs Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-32,
Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-64

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable Linux OS
Databases DB2 Enterprise Server Edition 9.5 and future fix packs (overview) (support) All Applicable Linux OS

Requires IBM DB2® Client, version 9.5, including the DB2 Universal JDBC Driver, or later.

DB2® for RedHat Linux is supported on System z10® hardware as product database only.

DB2 Enterprise Server Edition 9.7 and future fix packs (overview) (support) All Applicable Linux OS

Requires IBM DB2® Client, version 9.7, including the DB2 Universal JDBC Driver, or later.

DB2® for RedHat Linux is supported on System z10® hardware as product database only.

Oracle Database 10g Enterprise Edition Release 2 10.2.0.4 and future fix packs All Applicable Linux OS

Important:  Although the database server can use Oracle 10g, the database client must use Oracle 11g. Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later

Oracle Database 11g Enterprise Edition Release 2 11.2.0.1 and future fix packs Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-32,
Red Hat Enterprise Linux (RHEL) 5.0 Update 2 Advanced Platform x86-64

Requires Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later.

Java SDK IBM Runtime Environment ,Java Technology Edition 6.0 and future mod levels and their fix packs All Applicable Linux OS

IBM Java SDK 6.0 on Windows, which is supplied with Rational Software Architect, is required if using User Interface Generator and Script Workbench with InfoSphere MDM Server for PIM.

Sun Java SDK/JRE/JDK 6.0/1.6 and future fix packs All Applicable Linux OS

Sun Java SDK/JRE/JDK 6.0/1.6 is only supported when using Oracle/BEA WebLogic Server.

Sun Java SDK/JRE/JDK 6.0/1.6 Update 12 or later is required for 64-bit Oracle/BEA WebLogic Server.

Virtualization IBM PowerVM Hypervisor (LPAR, DPAR, Micro-Partition) any supported version and future fix packs All Applicable Linux OS
Red Hat Enterprise Virtualization Hypervisor (RHEV-H) / KVM 5.4 and future mod levels and their fix packs All Applicable Linux OS
VMware ESX 4.0 and future mod levels and their fix packs All Applicable Linux OS
VMware ESXi 4.0 and future mod levels and their fix packs All Applicable Linux OS
Web Servers Apache HTTP Server 2.0 and future fix packs All Applicable Linux OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

Apache HTTP Server, Version 2.0 or later

IBM HTTP Server 2.0 and future fix packs (overview) (support) All Applicable Linux OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

IBM HTTP Server, Version 2.0 or later


Tab navigation



Hardware Requirements
Group Applicable OS Notes
Disk Space All Applicable Solaris OS

Application Server:  50 GB

Database Server: 100-200 GB, in a RAID configuration

Note:See the hardware requirements table for details.

Memory All Applicable Solaris OS

Application Server:  6 GB

Database Server:  8 GB

Note:See the hardware requirements table for details.

Processor All Applicable Solaris OS

Application Server:  2 - 4 processor cores (based on CPU speed)

Database Server:  4 processor cores (based on CPU speed)

Note:See the hardware requirements table for details.

Operating Systems
Operating System Attributes Notes
Solaris Platform listing of supported OS
Solaris 10 SPARC Bitness: 32 Bit, 64 Bit Exploit
Deployment Role: Agent/End-point, Server
Hardware platform: SPARC
Software Requirements
Group Product Applicable OS Notes
Collaborative WebSphere MQ 7.0.1 and future fix packs (overview) (support) All Applicable Solaris OS

InfoSphere MDM Server for PIM can be configured to use messaging software, as described in the information center. However, the optional Global Data Synchronization feature of InfoSphere MDM Server for PIM requires the following messaging software to run correctly.

IBM WebSphere MQ, Version 7.0.1 client

IBM WebSphere MQ, Version 7.0.1 server

Note: The IBM WebSphere MQ, Version 7.0.1 client version must be installed on the application server only, however the IBM WebSphere MQ, Version 7.0.1 server can be installed on any server.

Operating System Runtimes Open Source Perl 5 All Applicable Solaris OS

InfoSphere MDM Server for PIM requires Perl version 5.8, although version 5.10 is preferred. InfoSphere MDM Server for PIM also requires several Perl modules. For more information, see the information center.

Optional Supported Software
Group Product Applicable OS Notes
Application Servers Oracle/BEA WebLogic Server 11g Release 1 and future fix packs All Applicable Solaris OS

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable Solaris OS
Application Servers - 64-bit Oracle/BEA WebLogic Server 11g Release 1 and future fix packs All Applicable Solaris OS

Note: If you use Oracle/BEA WebLogic Server, you must use an Oracle database.

WebSphere Application Server Network Deployment 7.0 and future fix packs (overview) (support) All Applicable Solaris OS
Databases Oracle Database 10g Enterprise Edition Release 2 10.2.0.4 and future fix packs All Applicable Solaris OS

Important:  Although the database server can use Oracle 10g, the database client must use Oracle 11g. Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later

Oracle Database 11g Enterprise Edition Release 2 11.2.0.1 and future fix packs Solaris 10 SPARC

Requires Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later.

Java SDK Sun Java SDK/JRE/JDK 6.0/1.6 and future fix packs All Applicable Solaris OS

Sun Java SDK/JRE/JDK 6.0/1.6 is only supported when using Oracle/BEA WebLogic Server.

Sun Java SDK/JRE/JDK 6.0/1.6 Update 12 or later is required for 64-bit Oracle/BEA WebLogic Server.

Virtualization Sun Solaris 10 Global/Local Zones (SPARC) 10 and future mod levels and their fix packs All Applicable Solaris OS

InfoSphere MDM Server for PIM is supported for installation on local zones only.  Branded (or non-native) zones are not supported.

Web Servers Apache HTTP Server 2.0 and future fix packs All Applicable Solaris OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

Apache HTTP Server, Version 2.0 or later

IBM HTTP Server 2.0 and future fix packs (overview) (support) All Applicable Solaris OS

Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.

IBM HTTP Server, Version 2.0 or later


Outline


Hardware Requirements
Group Applicable OS Notes
Display All Applicable Windows OS

Minimum resolution:  1024 x 768 pixels

Note: This applies to client system used to access the product user interface.

Memory All Applicable Windows OS

RAM:  2GB or higher

Note:  This applies to client system used to access the product user interface.

Processor All Applicable Windows OS

System with standard business configuration with at least dual core processor.

Note:  This applies to client system used to access the product user interface.

Operating Systems
Operating System Attributes Notes
Windows Platform listing of supported OS
Windows 7 Professional x86-32 Bitness: 32 Bit
Deployment Role: Desktop
Hardware platform: x86-32
Windows 7 Professional x86-64 Bitness: 64 Bit Tolerate, 32 Bit
Deployment Role: Desktop
Hardware platform: x86-64
Windows Vista Professional x86-32 Bitness: 32 Bit
Deployment Role: Desktop
Hardware platform: x86-32
Windows Vista Professional x86-64 Bitness: 64 Bit Tolerate, 32 Bit
Deployment Role: Desktop
Hardware platform: x86-64
Windows XP Professional x86-32 Bitness: 32 Bit
Deployment Role: Desktop
Hardware platform: x86-32
Windows XP Professional x86-64 Bitness: 64 Bit Tolerate, 32 Bit
Deployment Role: Desktop
Hardware platform: x86-64
Optional Supported Software
Group Product Applicable OS Notes
Browser (Information center) Microsoft Internet Explorer 6.0 SP3 and future fix packs All Applicable Windows OS

Internet Explorer 6.0 is only supported for product information center.


 

Microsoft Internet Explorer 7.0 and future fix packs All Applicable Windows OS

Internet Explorer 7.0 is supported for product information center.

 

Mozilla Firefox 2.0 and future releases, mod levels and fix packs All Applicable Windows OS

FireFox browser is only supported for product information center.


 

Browser (product components) Microsoft Internet Explorer 7.0 and future fix packs All Applicable Windows OS

Supported but not recommended especially when using new business user interfaces.

Note:  New business user interfaces are displayed when the user selects "Single and multi-edit with rich search simplified" for the "For editing and entering data" user setting.

The User Interface Generator component only supports Internet Explorer 7.0.

 

Microsoft Internet Explorer 8.0 and future fix packs All Applicable Windows OS

Recommended especially when using new business user interfaces.

Note:  New business user interfaces are displayed when the user selects "Single and multi-edit with rich search simplified" for the "For editing and entering data" user setting.

Java SDK IBM Runtime Environment ,Java Technology Edition 6.0 and future mod levels and their fix packs Windows XP Professional x86-32,
Windows XP Professional x86-64

IBM Java SDK 6.0 on Windows, which is supplied with Rational Software Architect, is required if using User Interface Generator and Script Workbench with InfoSphere MDM Server for PIM.


Notes


Rate this page:

(0 users)Average rating

Document information


More support for:

InfoSphere Master Data Management Server for Product Information Management

Software version:

9.1

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

7021215

Modified date:

2012-09-06

Translate my page

Machine Translation

Content navigation