IBM Support

SPSS Statistics 19.0 Fix Pack 1 Fix List

Release notes


Abstract

A comprehensive list of defect corrections for the SPSS Statistics 19.0 Fix Pack 1. Details of the fixes are listed below under the tab for the respective Fix Pack. If you have questions about a particular defect, please contact Customer Support.

Note: each successive Fix Pack is comprehensive and contains the material from the earlier Fix Packs for that Release, as well as all Interim Fixes made available since the previous Fix Pack or full Release. In other words, If you have installed Statistics 19.0.0.0, you do not need to apply Fix Pack 1 before applying Fix Pack 2.

Also, These lists contain some internal defect numbers. This was necessitated to provide a complete list of corrected defects as we continue to transition our internal defects to APARs. Future Fix Lists will only contain APAR references.

Content

SPSS Statistics 19.0 FP1 Downloads

SPSS Statistics 19.0 FP1

Issues corrected since SPSS Statistics 19.0 Release
Number Description
ECM00144682 ODBC data sources containing Japanese characters can now be read in the Database Wizard.
ECM00145363 Rows are no longer lost after exporting a long table.
ECM00145538 Multiple Japanese translation issues were corrected.
ECM00146877 Caret (^) delimited text files can now be opened.
ECM00146919 The DATE command now generates the correct TSPLOT labels for merged files.
ECM00146988 MANOVA no longer issues an error about reserved keywords when none are used in the command.
ECM00147372 Python scripting performance is improved.
ECM00147377 On Mac OS, when using the File Chooser (e.g., File Open Data), the controls in the dialog were sometimes not fully visible.
ECM00147542 With some types of data and the Save option, Categorical Principal components (from the menu Analyze->Dimension Reduction->Optimal) could cause the application to close suddenly. That has been fixed.
ECM00147716 You can now insert multiple footnotes into a pivot table.
ECM00148051 The Database Wizard no longer displays errors when the accessed database contains a large number of tables.
ECM00148475 T-TEST with Multiple Imputation now produces all of the appropriate statistics.
ECM00149150, ECM00149035 While in Distributed Mode, rendering tables faster now works when you are connected to a Unix Server.
ECM00149175 Paste now works correctly when "Display Table by Rows limit" is selected.
ECM00149683 SAS files can now be saved either through the user interface or with syntax.
ECM00149861 When Bootstrapping Regression estimates, performance is improved.
ECM00149870 Saving and then re-opening an output file that contained tables rendered faster caused the application to close suddenly. That has been fixed.
ECM00149871, ECM00150949 NPTESTS Mann-Whitney significance values and interpretation of the results are now consistent. A similar problem with Median tests on large samples was also fixed.
ECM00149996 Copy and paste now works correctly in the Data Editor Data View.
ECM00149998 In non-English languages the Data Editor sometimes added a zero to a pasted number. That has been fixed.
ECM00150100 NPTESTS now produces a one-sample K-S test when appropriate.
ECM00150126 TSMODEL would sometimes fail with automatic outlier detection and ARIMA models. That has been fixed.
ECM00150389 The Complex Samples Sampling Wizard Plan Summary dialog sometimes did not show previously entered stage(s) when editing a plan file. That has been fixed.
ECM00150405, ECM00150406 CROSSTABS now renders tables faster, or with full features, even when the tables have a lot of rows.
ECM00150410 When very large data files were retrieved from the Collaboration and Deployment Services Repository, the Data Editor sometimes could not correctly display the file. That has been fixed.
ECM00150616, ECM00150869 When using version 4.1 of Collaboration and Deployment Services and version 8.0 of Internet Explorer to save a pivot table (from a published SPW report) as a CSV file, and error could occur if the pivot table title contained Polish characters. That has been fixed. Another problem when “Downloading as CSV file” containing Polish characters was also fixed.
ECM00150786 You can now open an Excel 2007 file while in Distributed Mode.
ECM00150809 A warning was displayed prematurely when the Data Editor tried to access more rows than its maximum. The warning is now displayed at the correct time.
ECM00150823 When you change the display of decimal places (Number Format Decimal Places) for the y-axis on an error bar chart, the decimals now correctly display.
ECM00150844 In Distributed Mode, using the Output Management System to create tables rendered faster now works correctly. The tables are rendered in the Output.
ECM00150887 Setting locale to Traditional Chinese English Windows XP now displays the text correctly.
ECM00150911, ECM00151717 Under some conditions requesting a Custom Table that included empty variables could result in an incorrect table. That has been fixed.
ECM00150996 The Data File Comment dialog would not reopen when the comment contained certain languages. That has been fixed.
ECM00151017 Syntax created in versions 16 and earlier now displays correctly in the Syntax Editor.
ECM0015030, ECM00151496 The Model Viewer output for NPTESTS displayed x-axis labels as 0 and 1 when it should have displayed actual values or value labels. That has been fixed. Value labels are now shown when they are specified in the data file.
ECM00151067 A licensing problem was resolved so that now launching the application on a hyper-threaded machine works correctly.
ECM00151116 Excel worksheets with an apostrophe (‘) in the name now load correctly.
ECM00151128 In the Syntax Editor, all occurrences are now replaced with Edit->Replace Replace all.
ECM00151218 PRINT EJECT now inserts page breaks appropriately into printed output.
ECM00151355 Layered tables sometimes exported empty cells when the cell had content. That has been fixed.
ECM00151410 Importing a text file with Czech characters sometimes shifted values inappropriately. That has been fixed.
ECM00151411 Exporting tables to PowerPoint now exports all content.
ECM00151431 Custom tables now display a percent sign (%) for computed categories when a percent format is used.
ECM00151436 When a pivot table with long text was exported to Word, content was sometimes truncated at page breaks. That has been fixed.
ECM00151491 On Mac OS saving multiple datasets when exiting the application now works.
ECM00151505 Saving syntax when the Syntax Template was opened from the … button in the Custom Dialog builder now works.
ECM00151510 The spelling of Kolmogorov-Smirnov in the Non-parametric tests Two or More Independent Samples dialog box is now correct.
ECM00151546 Spurious zero counts sometimes appeared in Bar Chart data labels. That has been fixed.
ECM00151587 The dialogs for Analyze>Mixed Models>Linear now allow bootstrapping with random covariates.
ECM00151614 Performance is improved when accessing a DB2 data source on Linux System Z.
ECM00151618 Replace All would sometimes result in a message “SetCellValueHandler: bad variable ID”. That has been fixed.
ECM00151621 Downloading output files as RTF or XLS from Collaboration and Deployment Services Repository sometimes created an empty file. That has been fixed.
ECM00151637 You can now access a newly-created XLSX file in the Database Wizard.
ECM00151645 Exporting double-byte characters to PDF no longer adds extraneous text to the Output Log.
ECM00151652 Kaplan-Meier Survival Analysis output now shows cases that were censored prior to first event time.
ECM00151701 The MERGE subcommand in Custom Tables would sometimes add an extra line for super- and subscripts instead of merging onto existing summary statistic. That has been fixed.
ECM00151713 SAS files that contain string variables no longer issue Warning 7254.
ECM00151771 Variable names that contained non-English characters were sometimes truncated when an Excel file was imported via the ODBC Excel driver. That has been fixed.
ECM00151812 Some Excel 2007 files displayed “Error (2063)” when they were opened. That has been fixed.
ECM00151835 All decimal values are now read when an XLSX file is opened.
ECM00151922 When binning decimal values for Histograms, the values were sometimes placed in the wrong bix. That has been fixed.
ECM00151989 Hebrew names are now printed and exported correctly in Frequency Tables.
ECM00152006 With some data Ordinal regression with /SAVE caused the application to close suddenly. That has been fixed.
ECM00152017 Copy Special sometimes did not have all formats available. That has been fixed.
ECM00152026 Tables rendered faster sometimes did not export all data values to Excel. That has been fixed.
ECM00152136 Select All Pivot Tables now works for tables rendered faster.
ECM00152285 Certain MULTIPLE IMPUTATION models could not be built due to a computational error. That has been fixed.
ECM00150757 The GENLIN procedure sometimes failed when the application was running on a 64-bit operating system. That has been fixed.

Related information

Download the SPSS Statistics 19.0 Fix Pack 1

Document information

More support for: SPSS Statistics

Software version: 19.0

Operating system(s): Platform Independent

Reference #: 7020606

Modified date: 22 November 2011


Translate this page: