Rational Rhapsody Software, Version 7.5.3 Release Information

Release notes


Abstract

IBM Rational Rhapsody Software, Version 7.5.3 contains new features, enhancements, and fixes to the version 7.5 release.

Content

What's new

Download

Last-minute information

Fixed defects

Migration issues

Linux platform information

Known problems

System requirements

Supported RTOSes

Supported IDEs

Supported Compilers

Integration with IBM Rational products

Supported third-party applications

Environments for which Webify Toolkit is supported

IBM Rational Software Support

 

What's new

For information about the new features and enhancements in Rational Rhapsody 7.5.3, see Rational Rhapsody Software Version 7.5 Releases: New Features and Enhancements.

 

Download

Download version 7.5.3

 

Last-minute information

  • Debugging when using platform integration with Eclipse 3.6

    Eclipse 3.6 uses the GDB protocol by default. Currently, Rational Rhapsody only supports the standard debugger. To select this debugger:

    1. In the Debug Configurations dialog in Eclipse, select the type of application and click Select Other... at the bottom of the dialog. The Select Preferred Launcher dialog is displayed.
    2. In the Select Preferred Launcher dialog:
      1. Make sure the Use configuration specific settings option is selected.
      2. Select Standard Create Process Launcher.
      3. Click OK.
  • Using Rational Rhapsody with Workbench 3.0 (VxWorks 6.6)

    If you are using Rational Rhapsody with Workbench 3.0 (VxWorks 6.6), make the following changes:

    • Open the file [installation directory]\Share\etc\Vx6make.bat, and replace the line set vxver=6.8 with set vxver=6.6
    • Change the value of the Rational Rhapsody property OSVersion for the VxWorks environment from 6.8 to 6.6.
    • Change the value of the Rational Rhapsody property IDEInterfaceDLL for the VxWorks environment from $OMROOT/DLLs/WorkbenchDebuggerIDE.dll to $OMROOT/DLLs/Workbench30DebuggerIDE.dll.
  • Documentation for previous releases of the product:
    The Information Center (documentation) included with the installation of Rational Rhapsody 7.5.3 is applicable to this version of the product. However, you can always view the documentation for previous versions of the product by viewing the Information Center for that release on the Web. Help content for previous product releases can be found here.

 

Fixed defects

For a list of the APARs resolved in this release, see the Fixed APAR list for IBM Rational Rhapsody Software version 7.5.x.

Migration issues

For detailed information on migrating existing projects to the new version of Rational Rhapsody, see the Migrating topics in the Information Center.

Linux platform information

Certain Rational Rhapsody features are only available in the Windows version of the product. A list of the features not included in the Linux version can be found here.

Known problems

For a list of known problems / limitations in the current release of Rational Rhapsody, see Known Problems and Limitations in IBM Rational Rhapsody 7.5.3.

System requirements

For information about hardware and software requirements, see Detailed System Requirements for Rational Rhapsody Software version 7.5.3.

Supported RTOSes

Rational Rhapsody support for different real-time operating systems (RTOSes) is generic and can be customized to most existing systems.

The supported Rational Rhapsody capabilities, platforms, and third-party product integrations have undergone formal testing.

Rational Rhapsody provides pre-customized support for the RTOSes shown below. Pre-customized support in Rational Rhapsody means that a set of preconfigured code generation properties are provided for the environment.

If you are building applications for one of these environments, you must first rebuild the Rational Rhapsody framework libraries by using the Code > Build Framework menu option.

RTOS support is available only in Rational Rhapsody Developer. Rational Rhapsody Designer for Systems Engineers includes makefiles for building the framework on Windows only.

INTEGRITY® (Green Hills)
  • 4.0.8 - Windows version of Rational Rhapsody - C, C++, Ada
  • 5.0.4 - Windows version of Rational Rhapsody - C, C++, Ada
  • 5.0.7 - Linux version of Rational Rhapsody - C and C++ only

The Release version of Integrity was not tested. You can modify the framework and application build files for use in Release mode.

Linux® (MontaVista®)

Professional Edition 5.0 - Rational Rhapsody Developer for C and C++ - only available in Linux version of Rational Rhapsody

Nucleus® (Mentor Graphics®)

1.13.7 - Rational Rhapsody Developer for C and C++

ObjectAda® (Aonix®)

V7.2 (Raven™/PowerPC) - Ada

OSE Delta (Enea)

4.5 - Rational Rhapsody Developer for C++

QNX® Neutrino® (QNX)

Neutrino 6.3.2 (QNX Momentics 6.3.0 Service Pack 3) - Rational Rhapsody Developer for C and C++

Red Hat® (Enterprise Linux®)

4.0, 5.0 - Rational Rhapsody Developer for C and C++

Solaris™ (Sun™)
2.8, 2.9 - Rational Rhapsody Developer for C and C++

Note that Solaris targets are not supported by Rational Rhapsody Developer for Ada.

VxWorks® (WindRiver®)

5.5, 6.5, 6.6, 6.8 - Rational Rhapsody Developer for C and C++

Windows® Embedded CE (Microsoft®)

6.0 - Rational Rhapsody Developer for C++


Supported IDEs

Rational Rhapsody support for different integrated development environments (IDEs) is generic and can be customized to most existing environments.

The supported Rational Rhapsody capabilities, platforms, and third-party product integrations have undergone formal testing.

Eclipse
  • 3.5 (with CDT 6.0)
  • 3.6 (with CDT 7.0)
MULTI® (Green Hills)
  • 3.5 - Windows version of Rational Rhapsody - C++ and Ada only
  • 4.0.5 - Windows version of Rational Rhapsody - C, C++ and Ada
  • 4.2.3 - Linux version of Rational Rhapsody - C and C++ only
Tornado® (Wind River)

2.2 (VxWorks 5.5) - C, C++

Visual Studio (Microsoft)

2008 SP1 - C, C++, C#

Workbench (Wind River)
3.0 (VxWorks 6.6), 3.2 (VxWorks 6.8) - C, C++

Supported compilers

When using compiler versions other than the ones listed in the following table, you must recompile the OXF libraries. See the Frameworks and Operating Systems Reference for details.

Cygwin

1.5, 1.7 - C, C++

Diab Data
  • 4.3f (Nucleus) - Rational Rhapsody Developer for C++ and C
Forte

6.1

Rational Rhapsody Developer for C++ and Rational Rhapsody Developer for Java on Solaris

To properly build an application with the Sun Forte 6.1 compiler, the following patches must be installed with the compiler: 107355-05, 107357-09, 107311-10, 107295-01, and 107289-05.

gcc
  • 2.95.3, 3.4.6 (Solaris)
  • 2.95.3, 3.3.5 (QNX Neutrino) - Rational Rhapsody Developer for C++ on Windows
  • 2.9.6 (Tornado 2.2)
  • 3.4.3 (Red Hat EL4)
  • 4.3.2, 4.3.4 (Cygwin) - Rational Rhapsody Developer for C++ and J
GHS MULTI
  • MultiWin32 - Windows target + Multi 3.5, 4.0 Standard (ANSI/ISO) C, C++
  • Multi Linux - 4.0 - C, C++
  • INTEGRITY - Rational Rhapsody Developer for C++
    • INTEGRITY 4.0 target + INTEGRITY 4.0 Standard (ANSI/ISO) C++ cross-compiler (running on Windows and generating binaries for INTEGRITY)
    • INTEGRITY 5.0 target + INTEGRITY 5.0 Standard (ANSI/ISO) C++ cross-compiler (Windows and Linux, generating binaries for INTEGRITY)

  • AdaMULTI 2000 for native x86
    - Rational Rhapsody Developer for Ada
GNAT

6.0.2 - Rational Rhapsody Developer for Ada

Java 2 SDK
1.4.2, 1.5, Java SE 6, or IBM Java 6.0 - Rational Rhapsody Developer for Java and Rational Rhapsody Developer for Ada
To use the Eclipse integration features, version 1.5 or higher is required.
ObjectAda (Aonix)

7.22 - Rational Rhapsody Developer for Ada only

Visual C++ Studio (Microsoft)

6.0 SP-3

Visual Studio .NET (Microsoft)

Visual Studio .NET 2008

The Microsoft Visual Studio .NET compiler is supported; however, .NET features are not supported.

Integration with IBM Rational products

IBM® Rational® DOORS®
  • Rhapsody DOORS Interface supports: 8.3, 9.2
  • Rhapsody Gateway supports: 8.3, 9.2, 9.3
IBM® Rational® Publishing Engine
1.1.1
IBM® Rational® RequisitePro
7.1
IBM® Rational® SDL Suite
6.2, 6.3
IBM® Rational® Statemate®
4.3, 4.4, 4.5, 4.6, 4.6.1.1
IBM® Rational® Synergy
6.5, 7.1
IBM® Rational® System Architect®
11.2, 11.3, 11.4
IBM® Rational® Tau
4.2, 4.3
IBM® Rational® Team Concert™
2.0, 3.0
Rational Rose Enterprise (IBM®)
7.0 - All editions of Rational Rhapsody except for the ones based on the C language
Rational Rose (IBM®)
Rose® 2003 - All editions of Rational Rhapsody except for the ones based on the C language
Rational® ClearCase® (IBM®)
  • 7.0
  • 7.1

Supported third-party applications

Android SDK
Profile provided supports Android SDK 2.2
Internet Explorer (Microsoft)
5.5, 6.0, 7.0, 8.0
MATLAB, Simulink (The MathWorks)
Matlab 7.1 with Simulink 6.3, Matlab 7.3 with Simulink 6.5, or Matlab 7.5 with Simulink 7.0, with Real-Time Workshop® Embedded Coder component.
Microsoft® Office
ReporterPLUS is supported on Microsoft® Office 2000 and 2002.
Mozilla
1.4.3 - supported in Linux version of Rational Rhapsody only
PVCS Dimensions™ (Serena)
9.1 - supported in Windows version of Rational Rhapsody only
RTI Data Distribution Services
4.4d
Tao
1.4
Teamcenter Systems Engineering (UGS)
8.1
Visual Basic®/VBA (Microsoft)
6.3

Environments for which Webify Toolkit is supported

Webify Toolkit is supported for the following environments:

  • Integrity mbx800
  • Integrity5 mbx800, rpx-cllf
  • Integrity5ESTL mbx800, rpx-cllf
  • IntegrityESTL mbx800
  • Linux Red Hat x86
  • Microsoft Windows
  • Microsoft Windows CE 4.2 x86
  • MultiWin32
  • Nucleus PowerPC
  • QNX Arm
  • QNX Mips
  • QNX PowerPC
  • QNX Windows
  • QNX x86
  • Sun Solaris
  • VxWorks PENTIUM - VxWorks 5.5
  • VxWorks PENTIUM_RTP_diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PENTIUM_RTP_gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PENTIUMdiab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PENTIUMgnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC32_RTP_diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC32_RTP_gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC32diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC32gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC403 - VxWorks 5.5
  • VxWorks PPC403diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC403gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC603 - VxWorks 5.5
  • VxWorks PPC603diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC603gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC604 - VxWorks 5.5
  • VxWorks PPC604diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC604gnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks PPC860 - VxWorks 5.5
  • VxWorks SIMNT - VxWorks 5.5
  • VxWorks SIMNTdiab - VxWorks 6.5, VxWorks 6.6
  • VxWorks SIMNTgnu - VxWorks 6.5, VxWorks 6.6
  • VxWorks SIMPENTIUM_RTP_diab - VxWorks 6.5, VxWorks 6.6
  • VxWorks SIMPENTIUM_RTP_gnu - VxWorks 6.5, VxWorks 6.6

IBM Rational Software Support

For FAQs, lists of known problems and fixes, and other support information, visit the product support page for Rational Rhapsody Software

For contact information and guidelines or reference materials that you will need when you require support, read the IBM Software Support Handbook.

Before you contact IBM Rational Software Support, gather the background information that you will need to describe your problem. When describing a problem to an IBM software support specialist, be as specific as possible and include all relevant background information so that the specialist can help you solve the problem efficiently. To save time, know the answers to these questions:

  • What software versions were you running when the problem occurred?
  • Do you have logs, traces, or messages that are related to the problem?
  • Can you reproduce the problem? If so, what steps do you take to reproduce it?
  • Is there a workaround for the problem? If so, be prepared to describe the workaround.

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Rhapsody
Documentation

Software version:

7.5.3

Operating system(s):

Linux, Windows

Reference #:

7019917

Modified date:

2012-10-24

Translate my page

Machine Translation

Content navigation