Supplement for supported software for Rational Functional Tester version 8.2

Product documentation


Abstract

This document lists the various software that IBM Rational Functional Tester supports for functional testing.

Content



Note: Ensure that you verify compatibility between the operating systems, browsers and JREs before you install Rational Functional Tester.


Table 1: Supported domains
Domain Support
8.2
HTML Support
Mozilla Firefox 3.0
3.5
3.6 (3.6.0 to 3.6.3)
3.0
3.5
3.6 (3.6.0 to 3.6.12)
3.0
3.5 (3.5.0 to 3.5.18)
3.6 (3.6.0 to 3.6.16)
Note:
  • To test applications loaded in Firefox 3.6, 4.0 and 5.0, the next generation JRE plug-ins must be enabled. Supported JRE versions: SUN JRE 1.6 Update 10 to Update 17.
  • You might encounter problems while testing applications that are loaded in Firefox 3.6 that is associated with IBM JRE. Use the recommended SUN JRE with Firefox.
  • Testing applications that are loaded in the Mozilla Firefox 4.0 or 5.0 browsers is supported only on Windows, and not on Linux.
Internet Explorer 6
7
8
6
7
8
64-bit versions are also supported for Internet Explorer 6, 7 and 8.
6
7
8
64-bit versions are also supported for Internet Explorer 6, 7 and 8.
Mozilla Support withdrawn Support withdrawn Support withdrawn
Netscape Support withdrawn Support withdrawn Support withdrawn
Java
IBM JRE
1.4
1.5J1
1.6J2

SUN JRE
1.3J3
1.4
1.5J4
1.6J5
IBM JRE
1.4J1
1.5J2
1.6J3

SUN JRE
1.3J4
1.4J5
1.5J6
1.6J7
IBM JRE
1.4J1
1.5J2
1.6J3

SUN JRE
1.3J4
1.4J5
1.5J6
1.6J7
J1: IBM JRE 5.0 up to Service Refresh 11
J2: IBM JRE 6.0 Service Refresh 6 to 8
J3: SUN JRE 1.3.1 Update 24 (Only on WINDOWS for stand-alone Java applications.)
J4:
SUN JRE 5.0 Update 6 to Update 22 (32-bit mode)
SUN JRE 5.0 Update 22 (64-bit mode)
J5:
SUN JRE 6.0 (32-bit mode) Update 10 to Update 17. Update 18 and later, with Next Generation plug-in disabled.
SUN JRE 6.0 Update 20 (64-bit mode)
J1: IBM JRE 1.4.2 Service Refresh 13
J2: IBM JRE 5.0 up to Service Refresh 11
J3: IBM JRE 6.0 Service Refresh 6 to 8
J4: SUN JRE 1.3.1 Update 24 (Only on WINDOWS for stand-alone Java applications.)
J5: SUN JRE 1.4.2 Update 19
J6:
SUN JRE 5.0 Update 6 to Update 22 (32-bit mode)
SUN JRE 5.0 Update 22 (64-bit mode)
J7:
SUN JRE 6.0 (32-bit mode) Update 10 to Update 17. Update 18 and later, with Next Generation plug-in disabled.
SUN JRE 6.0 Update 20 and Update 22 (64-bit mode)
J1: IBM JRE 1.4.2 Service Refresh 13
J2: IBM JRE 5.0 up to Service Refresh 11
J3: IBM JRE 6.0 Service Refresh 6 to 9 Fix Pack 1
J4: SUN JRE 1.3.1 Update 24 (Only on WINDOWS for stand-alone Java applications.)
J5: SUN JRE 1.4.2 Update 19
J6:
SUN JRE 5.0 Update 6 to Update 22 (32-bit mode)
SUN JRE 5.0 Update 22 (64-bit mode)
J7:
SUN JRE 6.0 (32-bit mode) Update 10 to Update 17. Update 18 and later, with Next Generation plug-in disabled.
SUN JRE 6.0 Update 20, Update 22 (64-bit mode) and Update 24 (32-bit mode)
AWT yes yes yes
SWT yes yes yes
Eclipse 3.0.x
3.1.x
3.2.x
3.3.x
3.4.2
3.5.x
3.6.0
3.0.x
3.1.x
3.2.x
3.3.x
3.4.2
3.5.x
3.6.0
3.0.x
3.1.x
3.2.x
3.3.x
3.4.2
3.5.x
3.6.0
Dojo 1.0
1.1
1.2
1.3.2
1.4.2
1.0
1.1
1.2
1.3.2
1.4.2
1.0
1.1
1.2
1.3.2
1.4.2
WinForm and Windows Presentation Framework based .NET applications 1.0
1.1
2.0
3.0
3.5
4.0
1.0
1.1
2.0
3.0
3.5
4.0
1.0
1.1
2.0
3.0
3.5
4.0
Windows Win32 Win32 Win32
ARM yes yes yes
Ajax yes yes yes
SAP WebDynPro SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s).
SAP - SAPGUI 6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
Siebel 7.7
7.8
8
8.1
7.7
7.8
8
8.1
7.7
7.8
8
8.1
Silverlight Not supported Not supported Not supported
GEF yes yes yes
Flex 2.0
3.0
3.2
3.3
3.4
3.5
4.0
2.0
3.0
3.2
3.3
3.4
3.5
4.0
2.0
3.0
3.2
3.3
3.4
3.5
4.0
PowerBuilder 10.5
11
11.2
11.5
12.0
10.5
11
11.2
11.5
12.0
10.5
11
11.2
11.5
12.0
Visual Basic 5.0
6.0
5.0
6.0
5.0
6.0
Adobe PDF 7.0
8.0
7.0
8.0
7.0
8.0
Functional Tester Extensions for Terminal-based applications Mainframe or zSeries
TN3270
TN3270E

AS/400 or iSeries
TN5250

Virtual Terminals or pSeries
VT default,
VT100
VT101
VT102
VT220-7
VT220-8
VT320
VT420-7
VT420-8
VT52
VT UTF-8
Mainframe or zSeries
TN3270
TN3270E

AS/400 or iSeries
TN5250

Virtual Terminals or pSeries
VT default,
VT100
VT101
VT102
VT220-7
VT220-8
VT320
VT420-7
VT420-8
VT52
VT UTF-8
Mainframe or zSeries
TN3270
TN3270E

AS/400 or iSeries
TN5250

Virtual Terminals or pSeries
VT default,
VT100
VT101
VT102
VT220-7
VT220-8
VT320
VT420-7
VT420-8
VT52
VT UTF-8

Note: If you find any issues with any of the supported versions of the domains that are listed, use the recommended versions. Table 1 lists the recommended patch versions that are validated and have provided optimal results. Refer to the tech. notes to view any known problems with the listed domains.


Table 2: Integration of Rational Functional Tester with other Rational products
Integration of Rational Functional Tester with other Rational products
Rational Functional Tester version 8.2 8.2.0.1, 8.2.0.1 iFix01 8.2.0.2, 8.2.0.2 iFix01 8.2.0.2 iFix02
Rational Team Concert 2.0.0.2 iFix04 Eclipse Extension installer
3.0 3.0 3.0
Rational ClearCase 7.0.1
7.1
7.1.0.x
7.1.1.x
7.1.2
7.1.2.x
7.0.1
7.1
7.1.0.x
7.1.1.x
7.1.2
7.1.2.x
7.0.1
7.1
7.1.0.x
7.1.1.x
7.1.2
7.1.2.x
7.0.1
7.1
7.1.0.x
7.1.1.x
7.1.2
7.1.2.x
Rational Quality Manager 2.0
2.0.0.1
2.0.1
2.0
2.0.0.1
2.0.1
2.0.1.1
2.0
2.0.0.1
2.0.1
2.0.1.1
2.0
2.0.0.1
2.0.1
2.0.1.1
3.0.1
Rational TestManager Support withdrawn Support reinstated
7.0.1
7.0.2
7.0.1
7.0.2
7.0.1
7.0.2
ClearQuest TestManager Support withdrawn Support withdrawn Support withdrawn Support withdrawn

Note: Use the corresponding supported versions of Rational ClearCase Remote Client plug-ins for the Eclipse IDE of Rational Functional Tester. Refer to the Rational ClearCase documentation for more information.



Table 3: Compatible shell sharing products
Compatible shell sharing products
Rational Functional Tester 8.2
Rational Functional Tester 8.2.0.1, 8.2.0.1 iFix01
Rational Functional Tester 8.2.0.2, 8.2.0.2 iFix01 Rational Functional Tester 8.2.0.2 iFix02
Rational Performance Tester 8.2 8.2
8.2.0.1
8.2.0.2
8.2.0.3
8.2.0.4
8.2.0.5
8.2
8.2.0.1
8.2.0.2
8.2.0.3
8.2.0.4
8.2.0.5
8.2.0.6
Rational Software Architect 8.0 8.0
8.0.1
8.0
8.0.1
8.0
8.0.1
Rational Application Developer 8.0 8.0
8.0.1
8.0
8.0.1
8.0
8.0.1

Table 3 lists only the versions that have been tested for compatibility.

Note: Rational Performance Tester, Rational Software Architect and Rational Application Developer can shell share with Rational Functional Tester provided that they share the same Eclipse version.

For details see: 1279139: Information about which IBM Software products can be installed together so that they share a common environment for information on Rational product compatibility.

Note: For information pertaining to the versions and supported features, refer the respective topic notes available in the Rational Functional Tester Information Center.



Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Functional Tester
Documentation

Software version:

8.2, 8.2.0.1, 8.2.0.2

Operating system(s):

Linux, Windows

Reference #:

7019698

Modified date:

2012-01-25

Translate my page

Machine Translation

Content navigation