System Requirements for Rational Software Architect for WebSphere Software, Version 8.x

Product documentation


Abstract

This document serves to supplement the installation and upgrade instructions by summarizing the system requirements for IBM Rational Software Architect for WebSphere Software, Version 8.x

Content

Table of Contents:

Additional documentation:





Minimum Hardware Requirements

Rational Software Architect for WebSphere Software v8.x
Component Minimum Requirements
Processor 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
Display 1024 x 768; 1280 X 1024 recommended
Memory 2 GB RAM miminum; 3GB RAM or more recommended
Disk space 3.5GB for installation; 7.0 GB required when installing from a download
Recommended
Hardware Configuration v8.0.3
64-bit install
Minimum 8 GB RAM with minimum 4 GB Heap

Note: -Xcompressedrefs (IBM VM) or -XX:+UseCompressedOops (Sun) flag, may optimize memory usage for 64-bit machines with less than 32GB


Linux

Rational Software Architect for WebSphere Software v8.x
Hardware Operating System Comments
Review 1263677 for important details about running our 32-bit application on 64-bit OS

New in v8.0.3 - 64-bit mode support added!
See Benefits, requirements, limitations, and known issues for Rational Software Architect v8.0.3 products running as 64-bit applications
Desktop
x86-32
x86-64
SUSE (SLED) Desktop 11
SUSE (SLED) Desktop 10
Ubuntu 10.0.4 LTS The following are not currently supported on Ubuntu:
  • WebSphere Application Server Test Environment (all versions)
  • WebPortal Portal Server (all versions)
Red Hat Enterprise Linux (RHEL) 5
Red Hat Enterprise Linux (RHEL) 6
Server
x86-32
x86-64
Red Hat Enterprise Server 5
Red Hat Enterprise Server 6
SUSE Enterprise Server 11
SUSE Enterprise Server 10


Microsoft Windows

Rational Software Architect for WebSphere Software v8.x
Hardware Operating System Comments
Review 1263677 for important details about running our 32-bit application on 64-bit OS

New in v8.0.3 - 64-bit mode support added!
See Benefits, requirements, limitations, and known issues for Rational Software Architect v8.0.3 products running as 64-bit applications



x86-32
x86-64
Windows 7
Professional, Enterprise, Ultimate Editions
Windows Vista
Professional, Enterprise, Ultimate Editions
Windows XP Professional Not supported
in 64-bit install v8.0.3
technote: 1502701
Windows Server 2003
Standard & Enterprise Editions
Windows Server 2008
Standard & Enterprise Editions


Virtualization

Rational Software Architect for WebSphere Software v8.x
Product Version Comments
Citrix Presentation Server 4.5
Presentation Server 4
Windows Terminal Server Windows Server 2003
Windows Server 2008
VMware VMware Workstation 5.5.x **Correct potential hang
VMware Player 3.0

**Select the VMware " Disable acceleration" option (as described in VMware Options) , if hang occurs when running Rational Software Architect in VMware. (Note: This may occur when navigating multiple level GUI's.)




Eclipse Runtime, Installation & Licensing Requirements

Rational Software Architect for WebSphere Software v8.x
Product Version Comments
Eclipse 3.6 Rational Software Architect for WebSphere Software, v8.0
3.6.1 Rational Software Architect for WebSphere Software, v8.0.1
3.6.2 Rational Software Architect for WebSphere Software, v8.0.2
3.6.2.1 Rational Software Architect for WebSphere Software, v8.0.3
3.6.2.2 Rational Software Architect for WebSphere Software, v8.0.4, 8.0.4.1 (3.6.2.2a) and 8.0.4.2 (3.6.2.2b)
3.6.2.3 Rational Software Architect for WebSphere Software, v8.5
3.6.2.4 Rational Software Architect for WebSphere Software, v8.5.1
3.6.2.5 Rational Software Architect for WebSphere Software, v8.5.5
IBM Installation Manager 1.4.1 or greater Rational Software Architect for WebSphere Software, v8.0, 8.0.1
1.4.2 or greater Rational Software Architect for WebSphere Software, v8.0.2
1.4.4 or greater Rational Software Architect for WebSphere Software, v8.0.3
1.4.4 or greater Rational Software Architect for WebSphere Software, v8.0.4, v8.0.4.1, v8.0.4.2, v8.5 and v8.5.1
1.4.6.3.1 Rational Software Architect for WebSphere Software, v8.5.5
Rational License Key Administrator & Server 8.1.3.3 Rational Software Architect for WebSphere Software v8.5.5
8.1.2-8.1.3 Rational Software Architect for WebSphere Software v8.5 and v8.5.1
8.1.1 Rational Software Architect for WebSphere Software up to v8.0.4.2


Web Browsers

Rational Software Architect for WebSphere Software v8.x
Web Browser Version Comments
Firefox 8 and later
Internet Explorer 9 Minimum browser requirement on 64-bit Rational Software Architect for WebSphere Software v8.0.3
technote: 1502701
8 Not supported on 64-bit Rational Software Architect for WebSphere Software v8.0.3
technote: 1502701
7
6 SP1


Supported Databases

Rational Software Architect for WebSphere Software v8.x
Database Version Comments
CloudScape 5.1
IBM® DB2® Database for Linux®, UNIX®, and Windows® 8.1
8.2
9.1
9.5
9.7
IBM DB2 for i5/OS® 5R2
5R3
5R4
IBM DB2 for z/OS® 7
V8 Compatibility and New Function Modes
V9 Compatibility and New Function Modes.
The new function mode includes the generated data model that has all the new catalog features of DB2 for z/OS V8 and V9. Use the new function mode if you plan to work with the generated data models available in IBM Rational Software Delivery Platform products
Derby 10.0
10.1
10.2
10.3
Generic JDBC 1.0
Informix 9.2
9.3
9.4
10.0
11.1
11.5
MySQL 4.0
4.1
5.0
5.1
Oracle 8
9
10
11g
SQL Server 2000
2005
Sybase 12.x
15
Microsoft SQL Server Enterprise v7
SAP Max DB 7.6
7.7
HSQLDB 1.8


JREs

Rational Software Architect for WebSphere Software v8.x
Product Version Comments
IBM Runtime Environment for Java™ Technology Edition Version 7 7.0 SR5 Rational Software Architect for WebSphere Software, v8.5.5
7.0 SR3 Rational Software Architect for WebSphere Software, v8.5.1
7.0 SR1 Rational Software Architect for WebSphere Software, v8.5
IBM Runtime Environment for Java™ Technology Edition Version 6 6.0 SR11 Rational Software Architect for WebSphere Software, v8.0.4.2
IBM Runtime Environment for Java™ Technology Edition Version 6 6.0 SR10 plus Fix Pack 001 Rational Software Architect for WebSphere Software, v8.0.4.1
IBM Runtime Environment for Java™ Technology Edition Version 6 6.0 SR9 plus Fix Pack 002 and interim fix​ Rational Software Architect for WebSphere Software, v8.0.4
IBM Runtime Environment for Java Technology Edition Version 6 6.0 SR9 plus Fix Pack 001 and interim fix Rational Software Architect for WebSphere Software, v8.0.3
IBM Runtime Environment for Java Technology Edition Version 6 6.0 SR9 Rational Software Architect for WebSphere Software, v8.0.2
IBM Runtime Environment for Java Technology Edition Version 6 6.0 SR8 Rational Software Architect for WebSphere Software v8.0 & 8.0.1
Oracle JRE 6.0 Important: If you install the product into an existing Eclipse instance that does not use the IBM Runtime Environment for Java Technology Edition Version 6 , then you cannot use the following product features:
  • WebSphere Application Server development tools
  • WebSphere Portal Server development tools
  • Java EE Connector (J2C/JCA) development tools


Supported Application Servers

Rational Software Architect for WebSphere Software v8.0.x
Product Version Comments
WebSphere Application Server 6.0.x 6.0.x WebSphere Application Server 6.x is not supported in Rational Software Architect for WebSphere Software, v8.5 and later
Feature Pack for Web 2.0 WEB 2.0 FEP overview
WebSphere Application Server 6.1.x 6.1.x WebSphere Application Server 6.x is not supported in Rational Software Architect for WebSphere Software prior to v8.5. For v8.5 and 8.5.1, only 6.1.0.41 is supported.
Feature Pack for Web 2.0 WEB 2.0 FEP overview
Feature Pack for Web Services WS FEP overview
Feature Pack for EJB 3.0 EJB 3.0 overview
WebSphere Application Server 7.0 7.x
Feature Pack for Web 2.0 WEB 2.0 FEP overview
Feature Pack for Communications Enabled Applications CEA FEP overview
Feature Pack for OSGi Applications and Java Persistence API 2.0 OSGI and JPA 2 FEP overview
Feature Pack for XML XML FEP overview
Feature Pack for Service Component Architecture SCA FEP overview
Feature Pack for Modern Batch Supported on Rational Application Developer v801 and later

Modern Batch FEP overview
WebSphere Application Server 8.0 8.x Rational Software Architect for WebSphere Software v8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.5
WebSphere Application Server 8.5 8.5 Rational Software Architect for WebSphere Software v8.5
Beta Refresh
( March 2011 )
Rational Software Architect for WebSphere Software v8.0.2 and earlier
Beta Only
(unsupported )
WebSphere Portal Server 6.1
6.1.5
7.0.0.x Supported on Rational Software Architect for WebSphere Software v801 and later

Related information

RSA Family of Products Information Centers

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Software Architect for WebSphere Software
Documentation

Software version:

8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.5, 8.5.1, 8.5.5, 8.5.5.1

Operating system(s):

Linux, Windows

Reference #:

7019519

Modified date:

2014-03-28

Translate my page

Machine Translation

Content navigation