Prerequisites for IBM Content Collector for SAP Applications Version 2.2

Product documentation


Abstract

This document gives a detailed overview of the hardware prerequisites and the software prerequisites of IBM Content Collector for SAP Applications Version 2.2, including Fix Pack 1 and Fix Pack 2.

Content

 

IBM Content Collector for SAP Applications, which is abbreviated to 'Content Collector for SAP' in the following sections, consists of the following components: Collector Server, Archiving Client, P8 Client, Utility Client, and Viewing Client.

Legend
Term Description
x86 Intel 32-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers
x86-64 AMD Opteron (AMD64) and Intel Xeon (EM64T) 64-bit processors, including IBM System x, eServer xSeries, and BladeCenter servers
POWER IBM POWER-based processors, including IBM System p and eServer pSeries servers.
SPARC Sun UltraSPARC processors

Hardware requirements

Collector Server

Hardware requirements Minimum
Processor x86-64, POWER, or SPARC
System memory (RAM) 2 GB
Hard disk space
  • 300 MB for the installation
  • Runtime space depends on size of files to archive, trace, and log

Archiving Client

Hardware requirements Minimum
Processor x86 or x86-64
System memory (RAM) 1 GB

P8 Client

Hardware requirements Minimum
Processor See the requirements for FileNet Application Engine and FileNet Workplace XT
System memory (RAM)

Utility Client

Hardware requirements Minimum
Processor
  • If installed from the server package: x86-64, POWER, or SPARC
  • If installed from the client package: x86 or x86-64
System memory (RAM) 1 GB
Hard disk space 20 MB for the installation

Viewing Client

Hardware requirements Minimum
Processor x86 or x86-64
System memory (RAM) 1 GB


SAP prerequisites

Supported versions of SAP

  • SAP ECC 5.0 or later
  • SAP R/3 Release 4.6B (see Note)
  • SAP R/3 Release 4.6C (see Note)
  • SAP R/3 Release 4.7 (see Note)

Note:
In general, all SAP versions are supported that contain SAP ArchiveLink. Due to the Unicode limitations in older SAP releases, full support for SAP is limited to SAP ECC 5.0 or later. You can use SAP R/3 Release 4.6B, Release 4.6C, and Release 4.7 if you want to perform only those tasks that require the standard SAP ArchiveLink functions according to the SAP specification. Content Collector for SAP enhancements, such as the index transfer, are not supported by those releases.

Important: Support requests must be reproducible on SAP ECC 5.0 or later.

Required SAP components

Content Collector for SAP requires the following additional SAP components, which are available from the SAP Service Marketplace. For all supported operating systems, you need the 64-bit version of the SAP component.

  • SAP Java Connector (JCo) Release 3.0.1 or later
    This component is required by Collector Server and Utility Client. Extract the content of the package to the bin directory of Collector Server, to the lib directory of Utility Client, or to both directories.
    Note: If you install Utility Client on a Windows 32-bit operating system, you need the 32-bit version of SAP JCo.
  • SAP RFC SDK
    This library is required by Collector Server. Extract the content of the package to the bin directory of Collector Server.
    The version that you must install depends on your operating system. See SAP note 413708 for the details.
  • SAP Security Library (SAPSECULIB)
    This library is used as a security provider for the SAP ArchiveLink interface. Extract the content of the package to the bin directory of Collector Server.
    This library can no longer be downloaded from the SAP Marketplace. If you do not have this library already, see Technote #1655830 for instructions about how to proceed.


Archive systems

Supported archive systems

You can use the following archive systems:

  • Content Manager:
    • Content Manager Enterprise Edition V8.4.0, V8.4.1, V8.4.2, V8.4.3, or V8.5
    • Content Manager for z/OS V8.4.0, V8.4.1, V8.4.2, V8.4.3, or V8.5
  • Content Manager OnDemand:
    • Content Manager OnDemand for Multiplatforms V8.4 or V8.5
    • Content Manager OnDemand for z/OS V8.4 or V8.5
    • Content Manager OnDemand for i5/OS V6.1
    • Content Manager OnDemand for i V7.1
  • FileNet:
    • FileNet Content Manager V4.0, V4.5.0, V4.5.1, V5.0, V5.1, or V5.2
    • FileNet Image Services V4.1.2 or V4.2
  • Tivoli Storage Manager V5.4 or later

Connector required on Collector Server for the supported archive systems

The following table shows which connector is required on Collector Server for which supported archive system:

Archive system Connector on Collector Server Notes
Content Manager Enterprise Edition V8.4 or V8.5 Content Manager V8 connector Included in DB2 Information Integrator for Content V8.4 or V8.5 depending on your Content Manager version (Use Setup Type Connector).
Content Manager for z/OS V8.4 or V8.5
Content Manager OnDemand for Multiplatforms V8.4 or V8.5 Content Manager OnDemand for Multiplatforms V8.5 (64-bit) For all versions, install the server package of Content Manager OnDemand for Multiplatforms V8.5 on the computer where Collector Server is to be installed. The server package contains the connector between Content Manager OnDemand and Collector Server. You do not have to configure the installed server package.
Content Manager OnDemand for z/OS V8.4 or V8.5
Content Manager OnDemand for i5/OS V6.1 or for i V7.1
Content Manager OnDemand for Multiplatforms V9.0 Content Manager OnDemand for Multiplatforms V9.0 (64-bit)

Starting with Fix Pack 1: Content Manager OnDemand for Multiplatforms V9.0.0.1 (64-bit)

Install the server package of Content Manager OnDemand for Multiplatforms V9.0 on the computer where Collector Server is to be installed. The server package contains the connector between Content Manager OnDemand and Collector Server. You do not have to configure the installed server package.
Content Manager OnDemand for z/OS V9.0
FileNet Content Manager V4.0, V4.5.0, V4.5.1, V5.0, or V5.1
  • Content Engine Client API
  • Process Engine Client API
The APIs must be installed on the same computer as Collector Server. In addition, the P8_CLASSPATH keyword in the server configuration profile must specify the JAR files that contain the respective APIs (see the sample archint.ini file for P8).
FileNet Content Manager V5.2 Content Engine Client API Content Engine Client API must be installed on the same computer as Collector Server. In addition, the P8_CLASSPATH keyword in the server configuration profile must specify the JAR files that contain the API (see the sample archint.ini file for P8).
FileNet Image Services V4.1.2 or V4.2
  • Content Engine Client API
  • Process Engine Client API
FileNet Image Services repositories must be connected through a FileNet Content Manager repository, and federated by using FileNet Content Federation Services for FileNet Image Services (CFS-IS).

Important:

  • If you want to use FileNet P8 Version 4.0.1, install Fix Pack 13, or later, or install the fix that is described in APAR PJ37874.
  • If you want to use FileNet Content Manager V5.2, you need only the Content Engine Client API because Process Engine Client is integrated in Content Engine Client.
Tivoli Storage Manager 5.4 or later Tivoli Storage Manager Client API V5.4 or later (64-bit)


Software requirements

Collector Server

The following table shows the operating systems where Collector Server can be installed:

Operating system Other software
  • AIX 5.3, 6.1, or 7.1
  • Red Hat Enterprise Linux Server 5.0 or 6
  • SUSE Linux Enterprise Server 10.0 or 11.0
  • Solaris 9 or 10 Operating Environment (SPARC only)
  • Windows Server 2008 or Windows Server 2008 R2

All operating systems must be in 64-bit mode.

  • See Connector for the list of connectors that are required for the individual archive systems
  • SAP Java Connector (JCo) 3.0.1 or later
  • SAP RFC library
  • SAP Security Library (see also Technote #1655830)

Windows only:

  • Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.
  • To use Fix Pack 1 of Content Collector for SAP, install Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update (vcredist_x64.exe).

    For more information, refer to Security Bulletin: MS11-025 / Knowledge Base Article: KB2538242.

Archiving Client

Archiving Client requires the installation of Collector Server. The following table shows the operating systems where Archiving Client can be installed:

Operating system Other software, including the latest service packs
  • Windows Server 2008 or Windows Server 2008 R2
  • Windows XP Professional Edition SP3 or later
  • Windows Vista Business Edition, Enterprise Edition, or Ultimate Edition
  • Windows 7 Professional Edition, Enterprise Edition, or Ultimate Edition
  • Microsoft Internet Explorer 7 or later

    Internet Explorer plug-ins for certain document types

  • Mozilla Firefox 3 or later

Important:

  • Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.
  • If you install Archiving Client on the same computer as Collector Server and if you do not use the default installation paths, ensure that Archiving Client and Collector Server are installed in different paths.
  • To use Fix Pack 1 of Content Collector for SAP, install Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update (vcredist_x64.exe).

    For more information, refer to Security Bulletin: MS11-025 / Knowledge Base Article: KB2538242.

P8 Client

P8 Client requires the installation of Collector Server. The following table shows the operating systems where P8 Client can be installed:

Operating system Other software, including the latest service packs
See the requirements for FileNet Application Engine and FileNet Workplace XT
  • FileNet Application Engine V4.0, V4.5.0, V4.5.1, V5.1, or V5.2 (depending on your FileNet Content Manager version)
  • FileNet Workplace XT V1.1.4 or V1.1.5
  • Microsoft Internet Explorer 7 or later

    Internet Explorer plug-ins for certain document types

  • Mozilla Firefox 3 or later

Utility Client

Utility Client requires the installation of Collector Server. The following table shows the operating systems where Utility Client can be installed:

Operating system Other software, including the latest service packs
  • AIX 5.3, 6.1, or 7.1
  • Red Hat Enterprise Linux Server 5.0 or 6
  • SUSE Linux Enterprise Server 10.0 or 11.0
  • Solaris 9 or 10 Operating Environment (SPARC only)
  • Windows Server 2008 or Windows Server 2008 R2
  • Windows XP Professional Edition SP3 or later
  • Windows Vista Business Edition, Enterprise Edition, or Ultimate Edition
  • Windows 7 Professional Edition, Enterprise Edition, or Ultimate Edition
  • For installation on the Solaris Operating Environment: Java Runtime Environment (JRE) version 1.5.2 or later.
  • SAP Java Connector (JCo) 3.0.1 or later

Important:

  • The required temporary disk space during operation varies with the workload and the size of the log and trace files, and can thus be higher than the initial installation size.
  • Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.


Viewing Client

Viewing Client requires the installation of Collector Server. The following table shows the operating systems where Viewing Client can be installed:

Operating systems Other software, including the latest service packs
  • Windows Server 2008 or Windows Server 2008 R2
  • Windows XP Professional Edition SP3 or later
  • Windows Vista Business Edition, Enterprise Edition, or Ultimate Edition
  • Windows 7 Professional Edition, Enterprise Edition, or Ultimate Edition
  • Microsoft Internet Explorer 7 or later

    Internet Explorer plug-ins for certain document types

  • Mozilla Firefox 3 or later


Important:

  • Before you install a Windows service pack, check the Microsoft information sources for possible problems with existing applications. Decide if you want to install the service pack if there are known problems.
  • If you install Viewing Client on the same computer as Collector Server and if you do not use the default installation paths, ensure that Viewing Client and Collector Server are installed in different paths.
  • To use Fix Pack 1 of Content Collector for SAP, install Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update (vcredist_x64.exe).

    For more information, refer to Security Bulletin: MS11-025 / Knowledge Base Article: KB2538242.



Product Alias/Synonym

iccsap
icc sap
icc for sap
icc4sap
iccforsap
cssap
acsap

Rate this page:

(0 users)Average rating

Document information


More support for:

Content Collector for SAP Applications

Software version:

2.2

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

7019178

Modified date:

2013-11-18

Translate my page

Machine Translation

Content navigation