Rational Software Architect RealTime Edition version 8.0 releases: new features and enhancements

Product documentation


Abstract

This document provides an overview of the new features and enhancements in the version 8.0 releases of IBM Rational Software Architect RealTime Edition.

Content

Version 8.0.4
Version 8.0.3
Version 8.0.2
Version 8.0.1
Version 8.0

Version 8.0.4
Download Version 8.0.4


This release of Rational Software Architect RealTime Edition contains new features and enhancements in the following areas:
  • IBM Runtime Environment for Java Technology updates
  • Updates to supported web browsers
  • Eclipse platform updates
  • Code View/Editor
  • Java domain modeling
  • RealTime C++ transformation
  • RealTime Java modeling
  • RealTime modeling
  • UML Action Language (UAL)
  • UML development console
  • UML modeling




  • IBM Runtime Environment for Java Technology updates
    IBM Runtime Environment for Java Technology is updated to the following versions:
    • IBM 32-bit Runtime Environment for Windows, Java Technology Edition, Version 1.6 Service Release 9 Fix Pack 002
    • IBM 32-bit Runtime Environment for Linux, Java Technology Edition, Version 1.6 Service Release 9 Fix Pack 002

    Back to top



    Updates to supported web browsers
    Beginning with version 8.0.4, the following additional web browser versions are supported:
    • Mozilla Firefox 5.0, 6.0, and 7.0

    Back to top


    Eclipse platform updates
    The following additional Eclipse 3.6.2.2 patches and fixes are included in this release:
    Back to top



    Code View/Editor
    • When editing a generated C++ file using the code view or code editor, several CDT commands have now been made available in the context menu:
      • Open Declaration
      • Open Model Element (like Open Declaration but navigating to the UML element instead)
      • References
      • Add/Remove block comment
      • Toggle comment
      • Format selection
      • Open call hierarchy
      • Open type hierarchy
      • Quick outline
      Other related improvements are:
      • Incremental Find is now supported.
      • Java and C++ font settings now take effect in the code editor.
    • The performance of the Load Generated Source command in the code view and code editor has been significantly improved. Also, a new preference "Auto load generated source when focus gained" makes it possible to automatically load generated source code as soon as the code view/editor gains focus.
    • A new information label in the code view and code editor now shows whether the model or generated source code is currently being edited. In the latter case the label also provides a hyperlink which will open the generated source file in an editor.
    • The Show Source in Editor pop-up menu is now available from the Project Explorer view for elements that have at least one code snippet. You can now select which code snippet to edit (in case the selected element has many) and then opens a code editor showing that code snippet.
    • The Show In pop-up menu is now available from the code editor. You can navigate to the Project Explorer view and the Properties view of the element that owns the currently edited code snippet.
    • The code view now shows code snippets for elements that are selected in the Search view.
    • Default values of attributes, parameters and enumeration literals can now be edited using the code view or code editor.
    Back to top



    Java domain modeling
    • Java classes and operations which have @deprecated annotations are shown differently (strikethrough) on diagrams just like in Java editors.
    • Mixed modeling relations from Java domain modeling elements to UML elements can now be preserved as annotations inside comments in the Java file.

    Back to top



    RealTime C++ transformation
    • Support has been added for using makefiles and external build systems to simultaneously build real-time C++ models: The real-time C++ transformation builds code models by completing the following high-level steps:
      • Generating a makefile for each of the inherited and prerequisite transformations that you specify in the top-level transformation configuration
      • Generating a top-level makefile by using the information in the top-level transformation configuration
      • Invoking the "‘make" command on the top-level makefile
      While the transformation runs, the model cannot be modified; the model can only be modified after the transformation runs and the code is generated.
      With this feature, you can disable the Build Automatically preference because the "make" command builds everything starting from the top-level makefile. You can also now specify an external library in a transformation configuration: When the transformation builds a configuration that depends on an external library, that external library is built.

    Back to top



    RealTime Java modeling
    • A new launch shortcut UML Capsule Java Application has been added. The shortcut makes it easier to launch generated RealTime Java applications. The shortcut is available on Java projects generated by the RealTime Java transformation and provides a possibility to specify the top capsule on the fly.

    Back to top



    RealTime modeling
    • Project Explorer view:
      • The capsule development viewpoint has been extended to show transitions and states for state machines in the project explorer. New preferences have been added to control what information to display about states.
      • A new command "Refresh All" has been added. You can use this command to refresh all projects in the workspace.
    • Search view:
      The search view now shows result element as a flat list where each top-level element can be navigated (by double click). Also, the code editor is now opened when navigating to a search result for a "simple text match".
    • Sequence diagram editor:
      • In the Properties view, protocol events can now have more than one parameter. Preferences have been added to control how the sequence diagram editor should visualize the parameters.
        Validation rules have been added to the RealTime transformations since multiple parameters are not supported by the transformations.
      • A new Behavior Execution Specification can now be attached to an existing message. When placing a new Behavior Execution Specification on top of a message end, a dialog appears asking if the Behavior Execution Specification should be attached to that message.
    • Build:
      The Build Active Transformation Configuration button now supports a command for locking the button to a particular project. When it is locked, the button becomes insensitive to the selection, which makes it possible to build a project without making a selection in the Project Explorer view.
    • Find command:
      A new command Find Named Element has been added. This command opens a dialog that lets you find elements whose name matches a given regular expression. Several options exists to filter the search to look only in certain parts of the model, and to look only for certain kinds of named elements.

    Back to top



    UML Action Language (UAL)
    • A new preference "Enable Semantic Analysis" has been added to the Modeling > UML Action Language > Editor preference page. You can turn on or turn off semantic analysis of UAL code snippets.

    Back to top



    UML development console
    • The UML development console now includes a time stamp before each entry to make it easier to read build logs. Also, a message is now printed to the console when a UML development project is cleaned.

    Back to top



    UML modeling
    • A new preference option "Copy referenced models" is now available. When the option is not selected, using a existing model as the template to create a new UML model does not create a copy of models referenced by the template model.

    Back to top

    Version 8.0.3
    Download Version 8.0.3


    This release of Rational Software Architect RealTime Edition contains new features and enhancements in the following areas:
    • Support of operating systems running in 64-bit mode
    • Additional supported operating system versions
    • IBM Runtime Environment for Java Technology updates
    • Updates to supported Web browsers
    • Eclipse platform updates
    • Code review
    • Compare and merge
    • RealTime C++ transformation
    • State machine diagrams
    • UML modeler




    • Support of operating systems running in 64-bit mode
      Beginning with version 8.0.3, you can choose to install and run the product in 64-bit mode on supported Windows and Linux operating systems. For more information about the benefits, requirements, limitations, and known issues for the product running in 64-bit mode, see http://www.ibm.com/support/docview.wss?uid=swg27021665.

      Back to top



      Additional supported operating system versions
      Beginning with version 8.0.3, the following additional operating system versions are supported:
      • Microsoft Windows 7 Service Pack 1
      • Microsoft Windows Server 2008 Release 2 Service Pack 1
      • Red Hat Enterprise Linux 6 Update 1
      • Red Hat Enterprise Linux 5 Update 6
      • Red Hat Enterprise Linux 4 Update 9
      • SUSE Linux Enterprise Server 10 Service Pack 4
      • SUSE Linux Enterprise Desktop 10 Service Pack 4

      Back to top



      IBM Runtime Environment for Java Technology updates
      IBM Runtime Environment for Java Technology is updated to the following versions:
      • IBM Runtime Environment for Windows, Java Technology Edition, Version 1.6 Service Release 9 plus Fix Pack 001 and interim fix
      • IBM Runtime Environment for Linux, Java Technology Edition, Version 1.6 Service Release 9 plus Fix Pack 001 and interim fix
      • IBM Runtime Environment for Solaris, Java Technology Edition, Version 1.6 Service Release 9 plus Fix Pack 001 and interim fix

      Back to top



      Updates to supported Web browsers
      Beginning with version 8.0.3, the following additional Web browser versions are supported:
      • Mozilla Firefox 4.0
      • Microsoft Internet Explorer 9

      Back to top



      Eclipse platform updates
      The following additional Eclipse 3.6.2 patches and fixes are included in this release:
      Back to top



      Code review
      Improvements have been made to code review, including:
      • Improved Save functionality
      • Display of UML properties
      • Improved navigation to code editors

      Back to top



      Compare and merge
      Merging changes in the documentation field is now supported.

      Back to top



      RealTime C++ transformation
      Support has been added for adding link targets to generated Makefiles.

      Back to top



      State machine diagrams
      A new Format > Arrange > Transitions action has been added for arranging imported state machine diagrams.

      Back to top



      UML modeler
      • Support for adding and removing columns and rows to tables in rich text for models and diagrams has been added.
      • Support for diagram layers to the show related elements action has been added. A context menu command to allow the selection of same typed elements has also been added.
      • An extension point to allow profile providers to advertise their profiles as "pre-loadable" has been added. Profiles that are configured to "pre-load" can now be loaded at application start-up and their constraints can now be individually enabled or disabled through the existing UML validation preferences.

      Back to top

      Version 8.0.2
      Download Version 8.0.2


      This release of Rational Software Architect RealTime Edition contains new features and enhancements in the following areas:
      • Additional supported operating system versions
      • IBM Runtime Environment for Java Technology updates
      • BPMN transformations
      • Code Review
      • Compare and merge
      • Java domain modeling
      • Java transformations
      • Microsoft .NET support
      • Model execution and simulation
      • Sketching
      • Structured Data Importer for deployment modeling
      • Structured Data Importer for UML
      • UML modeler
      • UML-to-JPA transformation
      • User assistance




      • Additional supported operating system versions
        Beginning with version 8.0.2, the following additional operating system version is supported:
        • Red Hat Enterprise Linux 6

        Back to top



        IBM Runtime Environment for Java Technology updates
        IBM Runtime Environment for Java Technology is updated to the following versions for Windows and Linux operating systems:
        • IBM 32-bit Runtime Environment for Windows, Java Technology Edition, Version 1.6 service release 9 with interim fix 002
        • IBM 32-bit Runtime Environment for Linux, Java Technology Edition, Version 1.6 service release 9 with interim fix 002
        • IBM 32-bit Runtime Environment for Solaris, Java Technology Edition, Version 1.6 service release 9

        Back to top



        BPMN transformations
        • Support has been added for transforming references to UML interfaces and operations in a BPMN model:
          • The BPMN-to-Service-Model transformation transforms references into corresponding UML service model elements.
          • The BPMN-to-BPEL transformation transforms references into corresponding BPEL artifacts.

        Back to top



        Code Review
        • Code View related launched editors that are displaying generated source will no longer be closed if the generated source file is deleted (or owning project removed, etc). Instead the source will switch back to the pure 'model source' and the editor will remain open.
        • The code view will no longer assume that generated sources should be force loaded upon focus gained. A preference is now available to turn auto loading off. Also, a new button in the code view tool bar, an action in the context menu of the code view and launched editors, and a keybinding exists so that users can take control over loading the generated sources so that 'full content assist' is available.

        Back to top



        Compare and merge
        • A new option is now available in the Preference page under Window > Preferences > General > Compare/Patch > Modeling Compare/Merge > UML Compare for the display order of model elements in the model compare editor.

        Back to top



        Java domain modeling
        • Java visual references are now resolved based on the containing Java project's references. This can be controlled by the new preference option under Window > Preferences > Modeling > Java, that is not enabled by default.

        Back to top



        Java transformations
        • Support for UML Action Language translation has been added to the UML-to-Java transformation. You can now translate UAL code in operations/passive class state machines into Java code.

        Back to top



        Microsoft .NET support
        • You can now use the "Show Related Elements" feature to navigate through the cross project references and locate related elements in different .Net projects.
        • You can use this feature to generate and capture "Nullable" types as short hand notation (such as <Type Name>? ) instead of generic representation of "Nullable" types.

        Back to top



        Model execution and simulation
        • Simulation of BPMN models are now supported. It is also possible to visualize service communications in a topology diagram that is associated with BPMN model service tasks.
        • Simulation of structured activity nodes in activity diagrams are now supported.
        • Animation of topology diagrams is supported when the topology diagram is connected to a UML sequence diagram, activity diagram, or BPMN diagram.


        Sketching
        • You can use this feature to quickly create free-form drawings to capture initial high-level thoughts on architectural requirements and solutions. Then, you can select specific thoughts as sketch elements and formalize them as elements of semantic models. The formalization capability is supported in the UML modeling and deployment planning domains, when those features are also installed.

        Back to top



        Structured Data Importer for deployment modeling
        • You can use JET transformation projects to import information from structured data such as spreadsheets (.csv) files into topologies.

        Back to top



        Structured Data Importer for UML
        • JET tags have been added for importing the following UML model elements:
        • URL links
        • UML components
        • Apply Profile, Apply Stereotype, and Set Stereotype properties

        Back to top



        UML modeler
        • Project Explorer view
          • A "Links" folder (similar to that for associations) has been added. Links are displayed in the "Links" folder. If a link is modified such that it is no longer a link (e.g. changing its classifier from an association to a class), it will be moved out of the Links folder.
          • Clicking the + (plus sign) next to a fragmented package will now load and expand the fragmented package.
        • Ability is now supported to convert BPMN elements of one type into elements of another type.
        • Improved XMI import, specifically for Interactions in models exported by Sparks EA.
        • Includes the affected closed model files in the Preview dialog for the Refactor Rename operation.
        • Default Value field is added to the Properties view General tab for the selected Parameter object.
        • Able to type in the Default Value field in Properties view Parameters tab for selected Operation object.
        • The Value field is added to the Properties view General tab for easily changing the value of the Literal object.
        • Support for the UML 2.3 'isConjugated' property for ports has been added.
          Now, when you use the service modeling tooling create a new request, the tooling automatically applies the "isConjugate" property to the port that underlies the request. As a result, the new request's provided and required interfaces will be the mirror images (the "conjugates") of the realized and used interfaces of the UML element that is used to type the request. The tooling does not automatically apply the "isConjugate" property to pre-existing requests. Thus, designers who have previously manually created conjugated types and used those to type their requests will not be adversely impacted by the new support for "isConjugate".
        • UML Diagrams can now display:
          • Dot notation for associations navigability
          • Attribute and role qualifier decoration (e.g. static, ordered, non-unique, redefined properties, subsettable properties, etc.)
        • You now have the option to upgrade all the models in the workspace at once. You are notified when the upgrade completes.
        • A new validation rule will mark relationship edges in diagrams that do not correctly represent the actual relationship. A quick fix is provided to automatically repair or remove invalid edges.
          The existing Unresolved Relationships decoration can now be disabled by a preference in Modeling > Appearance.

        Back to top



        UML-to-JPA transformation
        • Additional JPA 2.0 support was added to the UML-to-JPA transformation:
          • Enhanced support for maps: Map key and map value can each be a basic type, an embedable type, or an entity
          • JPA 2.0 support for collections of embedable types
          • Support for Order By and Order Column annotations
        Back to top



        User assistance
        • The Local Help Updater now supports installing single features. It no longer requires features to be part of a category.
        • The radio buttons were removed from the help content preference page which were causing confusion both internally and from the customer end. Now default is set to remote help having priority over local help, instead of letting users choose.
        • Automatic Updates job starts right as local help server is started, rather than forcing users to kick off an update from the Local Help Updater.

        Back to top

        Version 8.0.1
        Download Version 8.0.1


        This release of Rational Software Architect RealTime Edition contains new features and enhancements in the following areas:


        Additional supported operating system versions
        Beginning with version 8.0.1, the following additional operating system versions are supported:
        • SUSE Linux Enterprise Server 11 Service Pack 1
        • SUSE Linux Enterprise Desktop 11 Service Pack 1

        Back to top



        Eclipse platform updates
        The following additional Eclipse 3.6 patches and fixes are included in this release:
        • Eclipse platform: Bugzilla fixes 325125325797, 326152
        • Eclipse Data Tools Platform (DTP): Bugzilla fix 328294
        • Eclipse Equinox p2: Bugzilla fix 312254
        • Eclipse Java Development Tools (JDT): Bugzilla fix 325161
        • Remote System Explorer (RSE) framework: Bugzilla fixes 317541, 323299, 328157
        • Rich Client Platform (RCP): Bugzilla fix 330133
        • Test and Performance Tools Platform (TPTP) Project: Bugzilla fixes 326428, 327686

        Back to top


        Model execution
        • The UML Action Language (UAL) model execution functionality has been enhanced to support breakpoints in UAL code snippets. You can use this functionality to insert breakpoints in code view and step over UAL code during a model execution session.

        Back to top



        Rational Rose RealTime model import
        • An option to suffix "_cv" is now added to package names contained within the Component view.

        Back to top



        RealTime C++ transformation
        • The UML-to-RealTime C++ transformation now supports generating static constant initializers.

        Back to top



        RealTime Java transformation
        RealTime Java transformation now supports:
        • The "Generate target project from Target Configuration" option
        • Adding multiple entries for the classpath property in the TC similar to the Java BuildPath configuration. JAR/ZIP entries in workspace/filesystem and variable entries are supported. Entries listed under this property are added to the classpath of the target project when the transformation is run.

        Back to top



        RealTime modeling
        • The Modeling References functionality has been enhanced to search for text occurrences in the opaque expressions as well. This functionality is enabled by default as the Include matches for text occurrences in action bodies option on the UML Development > Real Time preferences page.

        Back to top




        Back to top

        Version 8.0
        Download Version 8.0


        This release of Rational Software Architect RealTime Edition contains new features and enhancements since the last release in the following areas:


        C++ domain modeling
        New features
        • Newly added attributes and methods to a visualized C++ element are now grouped based on their visibility.
        • Supplier and client queries are now available on C++ visualized elements. This option is available under the Impact Analysis group on the Explorer tab in the Tool Palette.
        • C++ specialized template classes and template instances can now be visualized in class diagrams. Binding relation is now available as one of the relations which can be selected for the showing related elements.
        • Refactor change on a C++ element will now trigger an update on its visualized references in diagrams. The existing facility to update visualized references on a simple rename in C++ source is now removed. The visualized references will not be updated when a simple text rename is done on C++ elements in the source.

        Back to top



        Code view
        Enhancement
        • Search results for code associated with operations now match to the corresponding operations in the code view and navigate to the operation in the Project Explorer view. Multiple search hits in opaque expressions are shown in the Search view as multiple search hits.

        Back to top



        Compare and merge
        New feature
        • Six wizards have been added to generate code to enable compare and merge extensibility, including a compare and merge client and extensions.
        Enhancements
        • An alias change now shows up as one single change instead of an add change and a delete change when performing a compare and merge.
        • Compare and merge view filters are respected in the exported log file.

        Back to top



        Model execution and simulation
        New features
        • Model execution engines have been added to execute UML Capsule C++ Development models and UML Capsule Java Development models. During simulation, UML diagrams will be animated with run-time information. Traditional debugger-like features such as breakpoints, restart, fine and coarse grained stepping, suspend/resume are available, as well as modeling specific features such as the ability to inject events into ports.
        • It is now possible to simulate UML behavior models. All kinds of UML behaviors are supported (activities, interactions, state machines and UAL opaque behaviors). During simulation UML diagrams will be animated with runtime information, such as the next element to execute, already executed elements, the location of activity tokens, the active state etc. Traditional debugger-like features such as breakpoints, restart, suspend/resume are available, as well as modeling specific features such as the ability to define events to be injected into simulated event-driven models.

        Back to top



        Model execution and RealTime C++ model simulation
        New features
        • For RealTime C++ applications, the following capabilities have been introduced for debugging:
          • Launching a RealTime-C++ application
          • Animation of state diagrams
          • Debug view showing the instances of ports, capsules in running application
          • Variables view showing the variables in the model
          • Insertion of breakpoints in State Machines and structure diagrams
          • Injecting signals into the ports
          • Tracing the data on the ports

        Back to top



        Model execution and RealTime-UAL model simulation
        New features
        • It is now possible to simulate RealTime-UAL models created by using the product. The following capabilities are available for the RealTime-UAL models:
          • Launching a RealTime-UAL model
          • Animation of state machine and structure diagrams
          • Debug view showing the instances of ports, capsules in running application
          • Debug stack in debug view for the state machines
          • Variables view showing the variables in the model
          • Insertion of breakpoints in state machine and structure diagrams
          • Injecting signals into the ports
          • Tracing the data on the ports

        Back to top



        Model execution and RealTime C++ model simulation
        New features
        • For RealTime C++ applications, the following capabilities have been introduced for debugging:
        • Launching a RealTime-C++ application
        • Animation of state diagrams
        • Debug view showing the instances of ports, capsules in running application
        • Variables view showing the variables in the model
        • Insertion of breakpoints in State Machines and structure diagrams
        • Injecting signals into the ports
        • Tracing the data on the ports

        Back to top



        Passive C transformation
        New features
        • The following new passive C transformation features are now available:
        • Support to the Rational Rose RealTime import to import passive C models from Rational Rose RealTime
        • A new transformation to generate C language passive class code from UML models

        Back to top



        Profile tooling
        New features
        • Profile tooling code is now generated to permit the creation of tooling elements through the Project Explorer menu.
        • It is now possible to create tooling for stereotypes on association classes.

        Back to top



        Rational License Key Server
        Update
        Rational License Key Server, Version 8.1.1 is now available for the version 8.0 release of the product. You must upgrade your license server to Rational License Key Server, Version 8.1.1, before installing the product, if you use FLEXlm floating license for your product. Rational License Key Server, Version 8.1.1 is backward compatible. You can use Rational License Key Server, Version 8.1.1 with earlier versions of the product. For information about how to upgrade from v7.1.x or an earlier Rational License Key Server to v8.1.1, see http://publib.boulder.ibm.com/infocenter/rational/v0r0m0/index.jsp?topic=/com.ibm.rational.license.doc/topics/r_migration.html.

        Back to top



        Rational Rose model import
        New feature
        • To import subunits incrementally into the Rational UML modeling products, on the Rational Rose model Subunit Conversion page select the Import subunits incrementally check box.
          By using this import option, you can use less memory to import subunits of a large Rational Rose model and remap the model to the existing model or package faster.
          Note: If you have a large Rational Rose model with no subunit, try breaking the model into subunits and use the incremental import option.

        Back to top



        Rational Rose RealTime model import
        Enhancements
        • An option is now available to select default project names for packages during import.
        • Importer does not generate a behavior execution specification if there is no corresponding focus of control in the Rose RealTime model.

        Back to top



        Rational Tau model import
        New feature
        • This new importing feature simplifies the reuse of Rational Tau models by creating model projects from Rational Tau project files. The import process includes many common model elements and diagrams. Some manual cleanup and remodeling is required after you import a model.

        Back to top



        RealTime modeling
        New feature
        • The support is now available to move, copy/paste and duplicate protocol events.
        Enhancements
        • A number of enhancements are introduced to sequence diagrams, including: Support to create message from the borders of sequence diagrams or collaborations, support to select unwired ports when editing messages, and treating target RTS protocols as user protocols. The ability to draw Asynchronous Signal Messages is available for RealTime modeling sequence diagrams.

        Back to top



        RealTime transformations
        Enhancement
        • The progress bar for real-time transformations has been improved to indicate the amount of work that the transformation has completed.

        Back to top



        Transformation core
        New feature
        • A new transformation, called the composite transformation, is available to run multiple transformation configurations in one action. You can create a transformation configuration for the composite transformation and specify a list of other transformation configurations to run. When you run the composite transformation configuration, the transformation runs all the transformation configurations in the list.

        Back to top



        UML Action Language (UAL)
        New feature
        • UML Action Language (UAL) is a surface language for UML Action Semantics. You can now create a model with a default language set as UAL and have a package import to one of the UAL model libraries. UAL Editor has a typical modern IDE editor features such as syntax coloring, compilation error markers, and model based content assist for code completion. It can be used to add or edit UAL action code snippets to opaque elements (behavior, expression, action).
          You can use UAL compilation and translation framework to compile and validate the UAL code snippets in the context of a model. You can also use it to create extensions to UML transformations for various target languages (such as C++, Java, C#) to translate the UAL code snippets to the target language.

        Back to top



        UML Capsule Development
        New features
        • You can now create UML action language (UAL) capsule models (platform independent models) and target language (C++, Java) specific marking models (platform specific models) by using new model templates. You can also translate UAL code snippets while using UML-to-RealTime C++ and UML-to-RealTime Java transformations.
        • You can now create Java capsule models and transform them into runnable applications based on the RealTime Java RTS. As a part of this feature, templates are available that allow users to create a Java Capsule model and a new transformation, the UML-to-RealTime-Java transformation, is available that generates Java code from the model. A Java snippet editor is also available that allows you to add Java code to various model elements, and includes capabilities such as content assist, syntax coloring, and more. Navigation from code to model elements and from model to generated code is made possible through the use of mapping markers.

        Back to top



        UML modeler
        New features
        • Support for diagram layers has been added. The relevant UI is in the new Layers view. It is possible to lock or unlock layers to prevent editing, hide or show layers, select shapes on layer, and reorder layers (to reorder the z-order of shapes on the layer).
        • In the Project Explorer view, preferences have been added to allow displaying the workspace path and to show models and profiles under the corresponding file.
        • Decorations for validation results now appear on the diagram in addition to the existing decorations in the Project Explorer view. Hovering over the decorator displays a tool tip with an explanation.
        • A Problems dialog box on Selection dialog box has been added to show problems on the selection and optionally its children. The dialog box allows performing multiple quick fixes at once or displaying multiple constraint definitions at once.
        • Marking models have been introduced to support different views of the same model. Profiles applied to the marking model are available in the targeted ("marked") model. The stereotype applications are stored in the marking and not in the marked model even though the element itself resides in the marked model. This enables different views of the same model depending on which marking model is open.
        • Stereotype properties can be shown on the diagram in either a separate compartment or in a Stereotype Attribute Note.
        • Support for Property Sets has been added to work with a group of stereotype properties.
        • A default active language can be specified for a viewpoint.
        • Viewpoints can be exported and imported.
        • Support for Interaction Overview diagrams has been added.
        • Support for timing diagrams has been added.
        • Support for lost messages and found messages has been added to sequence diagrams.
        • A validation rule has been added for sequence diagrams: Message signature operation should be contained in the target lifeline classifier.
        • A validation rule has been added for sequence diagrams: Private operation call.
        • A Message can be renamed even when an operation has been defined for its signature.
        • Support for Start Object Behavior Action has been added to activity diagrams.
        • Support for Entry Points and Exit Points has been added to Composite States and Orthogonal States in state machine diagrams.
        • Support for Any Receive Event has been added to the state machine diagrams.
        • Public API for alias support was added to com.ibm.xtools.uml.core.IUMLHelper.
        • The com.ibm.xtools.modeler.ui.repairReferences extension point was added to enable: 1) fix broken URIs to external resources like imported libraries and 2) fix a broken set of IDs in an external resource.
        Enhancements
        • The Modeling perspective has been redesigned. It is streamlined to contain 4 views: the Project Explorer view, the Layers view, the Properties view, and the Outline view. Other less commonly used views are available as Fast Views. The old perspective layout has been renamed to Classic Modeling.
        • In the Project Explorer view, diagrams are grouped by type (instead of only alphabetically)
        • The integration of element imports has been improved. The way the context is determined has been enhanced. Properties are displayed for the imported element, not the Element Import. In the Project Explorer view, when adding or deleting elements under the Element Import, the focus is not lost (i.e. focus does not jump back to the original element). In addition, in the Project Explorer view, sorting is performed by the name of the imported element.
        • The Repair Workspace References dialog box has been enhanced to provide an option to search the entire workspace and an option to dirty the model that allows to save the fixed model.
        • You can specify the refactoring scope of model, project, or workspace for the standard refactoring operations.
        • When a model fragment is reloaded, focus is preserved in the Project Explorer view. In addition, only the changed fragment is reloaded for better performance.
        • You can select multiple sub-fragments to open.
        • Deleting a message’s referenced signal or operation will set the name of the message to Unspecified on a sequence diagram in addition to removing the referenced signal or operation.

        Back to top



        UML modeling
        New features
        • The navigation to related elements and other representations of elements is improved with the new linking and navigation functionality. Hovering over diagram elements, for example an attribute in a class, displays a pop-up dialog allowing to show the properties of the related element such as the type of the attribute in the class. When editing types in the properties view, a button allows to navigate to the type. In the properties view pop-up, you can navigate to the element in the Project Explorer view. More elements support the navigation to the Project Explorer. The public application programming interface (API) is updated to support the defining of link targets and the related elements for a given element.
        • A name filter has been added in the Project Explorer view. The name filters elements and allows quick navigation to locate elements in the Project Explorer view. Public API to support custom name filtering has been added.
        • A pop-up properties dialog is available for elements in the Project Explorer view and elements on the diagram. The pop-up properties dialog is resizable and does not occupy screen space.
        • Themes and appearances are supported by the modeling platform to enable the quick and simple application of a consistent look and feel to diagram elements.
        • Other GMF enhancements are supported by the modeling platform. For example, transparency and enhanced gradient control, rounded bendpoints on rectilinear connections have been added.
        Enhancements
        • Rich text is now supported directly for notes and comments on a diagram surface. Preferences are available for default settings in both rich and plain text modes.
        • Search has been enhanced. You can drag and drop results from the Search view onto the diagram surface. Search has been simplified, eliminating the radio buttons for declarations & references. Instead, search results can be expanded to show references. The concept of search sets (which could not be deleted, renamed, or edited) has now been replaced with the standard Eclipse working sets (which can be deleted, renamed, or edited). Two new columns have been added, Modified date and Resource. Public API has also been added to support contributing to the search results.
        • Diagrams have been redesigned with new colors, gradients and shading.
        • Diagram feedback has been improved to make clear the target of the drag operation. First, the target of the connector will highlight to avoid confusion. Second, clicking connectors will cause labels to highlight. Third, clicking labels will cause connectors to highlight. Finally, a pop-up message will be displayed when dragging a connector to an unsupported element.

        Back to top



        UML Profile-based Integrated Architecture (UPIA) (IAM2)
        New feature
        • The UML Profile-based Integrated Architecture (UPIA) feature has been upgraded to improve usability and to further support Department of Defense Architecture Framework (DoDAF) 2. Export and import support has been added for the DoDAF 2.01 Physical Exchange Specification (PES). For detailed information, see the Rational support document, "Changes to the IBM Rational UML Profile-based Integrated Architecture (UPIA) feature in v8.0.0," at http://www.ibm.com/support/docview.wss?uid=swg27019000.

        Back to top



        UML-to-C++/C++-to-UML transformations
        New features
        • The C++-to-UML transformation now supports cross-project references amongst UML models. You can specify cross-project references by creating associations in a C++-to-UML transformation configuration.
        • The C++-to-UML transformation now synchronizes C++ code and the corresponding UML model. After you run the C++-to-UML transformation, view the contents of the Model merge window.
        • The UML-to-C++ transformation now preserves code that you add, including pre-processor directives.
        • The C++-to-UML transformation now captures file names of different C++ types as part of a mapping model. This functionality preserves the user code and files the next time that you run the UML-to-C++ transformation.
        Enhancements
        • The UML-to-C++ transformation provides enhanced support for C++ globals: You can add C++ globals to a global container in a UML model and apply the <<cpp_globals>> stereotype to the container.
        • You can now model non-type template parameters and their default values. The C++-to-UML transformation also now transforms default template parameters.

        Back to top



        UML-to-Java transformation
        New feature
        • An extension to the UML-to-Java transformation is now available to generate code for passive class state machines. To generate this code, when you create a UML-to-Java transformation configuration, in the transformation configuration editor, on the Extensions page, select the com.ibm.xtools.transform.uml2java.sm.PassiveClassStatemachineExtension check box. After the transformation runs, you can run the generated state machine code as a Java application.

        Back to top



        Additional Eclipse patches and fixes
        The following additional Eclipse 3.6 patches and fixes are included in this release:
        • Eclipse platform: Bugzilla fix 315839
        • Eclipse Equinox p2: Bugzilla fix 313905
        • Eclipse Graphical Modeling Framework (GMF): Bugzilla fixes 319191319433
        • Eclipse Graphical Editing Framework (GEF): Bugzilla fix 307720
        • Eclipse user assistance: Bugzilla fixes 314324316824

        Back to top


        Rate this page:

        (0 users)Average rating

        Add comments

        Document information


        More support for:

        Rational Software Architect RealTime Edition
        General Information

        Software version:

        8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4

        Operating system(s):

        Linux, Solaris, Windows

        Reference #:

        7019128

        Modified date:

        2011-11-18

        Translate my page

        Machine Translation

        Content navigation