System Requirements for Rational Host On-Demand

Detailed system requirements


Abstract

The tables below identify supported operating systems along with their supported sever and client software for Rational Host On-Demand 11.

Content

Host On-Demand Supported Server Requirements


Host On-Demand Supported Client Requirements
Host On-Demand Supported Client Browser Versions
Miscellaneous Supported Software and Limitations


Host On-Demand Supported Server Requirements

AIX
Versions
  • 5.2*
  • 5.3*
  • 6.1*
  • 7.1*

*(32-bit and 64-bit versions)
Disk Space (installp image)
  • 482 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed (including the additional security files)
Supported Web Servers
  • Apache HTTP Server V1.3, V2.0, V2.2 and V2.2.11
  • Apache HTTP Server V2.4.2 (HOD 11.0.6)
  • IBM HTTP Server V6.0**, V6.1, and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • iPlanet Web Server(formerly Sun Java System Web Server) V6.0 and V7
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration required)
Supported Web Application Servers
  • iPlanet Application Server V6.0 (manual configuration of servlet required)
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (HOD 11.0.1 and higher)
  • WebSphere Application Server 8.0 in AIX 6.1 (HOD 11.0.6 and higher)
C/C++ Runtime Libraries
  • AIX Version 5.x requires level 6.0.0.3
C/C++ runtime libraries are available for download at:
ftp://www7b.boulder.ibm.com/aix /fixes/byCompID/5765F5600/
Java Installed with Host On-Demand


HP Itanium
Versions
  • B.11.23 U ia64 for HOD 11.0.0 and above
Disk Space
  • 580 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed
Supported Web Servers
  • IBM HTTP Server V1.3.28, V2.0.42, V2.0.47, V6.0, V6.1 and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
Supported Web Application Servers
  • WebSphere Application Server 6.1
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
C++ Runtime Libraries
  • HPUX IA Version requires the a C++/C Version A.06.10 (This is the a CC Compiler Version)
Java Installed with Host On-Demand




HP-UX
Versions
  • 11
  • 11i
  • 11i v2
  • 11i v3
  • HP-UX B.11.23 U 9000/800 (32 bit Kernel). (Architecture PARISC 32 bit) (HOD 11.0.6)
Disk Space
  • 580 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed
Supported Web Servers
  • Apache HTTP Server V1.3, V2.0, V2.2 and V2.2.11
  • Apache HTTP Server V2.4.2 (HOD 11.0.6)
  • IBM HTTP Server V6.0**, V6.1 and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • iPlanet Web Server(formerly Sun Java System Web Server) V6.0 and V7
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration required)
Supported Web Application Servers
  • iPlanet Application Server V6.0 (manual configuration of servlet required)
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
Java Installed with Host On-Demand

Linux
Versions
  • Red Hat Enterprise Linux 3.0,4.0, and 5.0*
  • SuSE Linux Enterprise Server 9.0, 10.0 and 11*
  • SuSE Linux Enterprise Desktop 8.2, 9.0.
  • SuSE Linux Enterprise Desktop 10.0 (Host On-Demand v11.0.1 and higher)
  • TurboLinux 8.0 Workstation and Server
  • Turbo Linux 10*
  • zLinux – RHEL AS release 3 (Taroon Update 9); kernel level 2.4.21, 32(1) bit OS with IBM HTTP server 7 (H/W is system z 31 bit) (HOD 11.0.6)
  • PPC Linux - Red Hat Enterprise Linux Server release 5.4 (Tikanga), 32 bit OS with Apache 2.2.3 (H/W is 64 bit architecture, OS is installed in 32 kernel) (HOD 11.0.6) *(32-bit and 64-bit versions)
  • RHEL Server 6.2 32 bit with IBM HTTP Server 8.0 in HOD 11.0.6 and higher
  • zLinux - RHEL 6.4 (Apache 2.2.15) in HOD 11.0.8 and higher
Disk Space
  • 520 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed
Supported Web Servers
  • Apache HTTP Server V1.3, V2.0, V2.2 and V2.2.11
  • Apache HTTP Server V2.4.2 (HOD 11.0.6)
  • IBM HTTP Server V6.0**, V6.1 and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • iPlanet Web Server(formerly Sun Java System Web Server) V6.0 and V7.0
  • Lotus Domino R6.5**, R7, R8, and R8.5 (manual configuration required)
  • IBM HTTP Server 8.5.0 (RHEL 6.2 and SLES 11) on HOD 11.0.8 and higher
  • IBM HTTP Server 8.5.0.2 (RHEL 6.2 and SLES 11) on HOD 11.0.8 and higher
Supported Web Application Servers
  • iPlanet Application Server V6.0 (manual configuration of servlet required)
  • Lotus Domino R6.5**, R7, R8, and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
Java Installed with Host On-Demand

z/OS
For a complete list of OS/390 and z/OS requirements, see the Program Directory




OS/400 and i5/OS
Versions
  • i5/OS V5R4
  • i5/OS V6R1
  • i5/OS V7R1

Disk Space
  • 363 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed
Supported Web Servers
  • Apache-based HTTP Server for IBM System i5 V1.3, V2.0, V2.2 and V2.2.11
  • Apache HTTP Server V2.4.2 (HOD 11.0.6)
  • IBM HTTP Server for IBM System i5 V6.0**, V6.1, and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • Lotus Domino for IBM System i5 R6.5**, R7, R8 and R8.5 (manual configuration required)
Supported Web Application Servers
  • Lotus Domino for IBM System i5 R6**, R6.5**, R7, R8 and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
Java Toolbox for Java

Java Developer's Kit Version 1.5

All Other Requirements TCP/IP Connectivity Utilites for IBM System i5
QShell Interpreter




Solaris
Versions
  • Solaris 8
  • Solaris 9
  • Solaris 10
Disk Space
  • 650 MB for an English-only installation
Add 4 to 8 MB for each additional national language to be installed.
Supported Web Servers
  • Apache HTTP Server V1.3 V2.0, 2.2, and V2.2.11
  • Apache HTTP Server V2.4.2 (HOD 11.0.6)
  • IBM HTTP Server V6.0**, V6.1, and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • iPlanet Web Server(formerly Sun Java System Web Server) V6.0 and V7
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration required)
Supported Web Application Servers
  • iPlanet Application Server V6.0 (manual configuration of servlet required)
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
Java Installed with Host On-Demand


Windows
Versions
  • Windows 2000 Professional, Server, and Advanced Server**
  • Windows XP Professional Edition*
  • Windows Server 2003 (Standard and Enterprise Editions)*
  • Windows Server 2003 R2 (Standard and Enterprise Editions)*
  • Windows Vista (Business,Enterprise and Ultimate Editions)*
  • Windows Server 2008 (Standard and Enterprise Editions)*
  • Windows Server 2008 R2 (Standard and Enterprise Editions - only 64-bit)
  • Windows 7 (Professional, Enterprise and Ultimate Editions)*

*(32-bit and 64-bit versions)
Disk Space
  • 602 MB for an English-only installation. Add 4 to 8 MB for each additional national language to be installed
Supported Web Servers
  • Apache HTTP Server V1.3, V2.0, V2.2 and V2.2.11
  • Apache HTTP Server V2.2.22 (HOD 11.0.6)
  • IBM HTTP Server (IHS) V6.0**, V6.1, and V7.0
  • IBM HTTP Server V8 (HOD 11.0.6)
  • iPlanet Web Server(formerly Sun Java System Web Server) V6.0 and V7.0
  • Lotus Domino R6.5**, R7, R8 and R8.5 (manual configuration required)
  • Microsoft IIS 5, 5.1, 6, 7 and 7.5
  • IBM HTTP Server 8.5.0 for HOD 11.0.8 and higher
  • IBM HTTP Server 8.5.0.2 for HOD 11.0.8 and higher
Supported Web Application Servers
  • iPlanet Application Server V6.0 (manual configuration of servlet required)
  • Lotus Domino R6.5**, R7, R8, and R8.5 (manual configuration of servlet required)
  • WebSphere Application Server 6.1 and
  • WebSphere Application Server 7.0 (Host On-Demand v11.0.1 and higher)
  • WebSphere Application Server 8.0 (Host On-Demand v11.0.6)
  • WebSphere Application Server 8.5 (Host On-Demand v11.0.8)
Java Installed with Host On-Demand



Host On-Demand Supported Client Requirements
Operating Systems: Supported client versions:
AIX
  • 5L 5.2**
  • 5L 5.3
  • 6.1
  • 7.1
Citrix
  • Citrix Metaframe 1.8 for Windows Terminal Server 4.0 and 1.8 for Windows 2000 Server**
  • Citrix Metaframe XP Presentation Server (Versions S,A, and E) for Windows Feature Release V2 and V3**
  • Citrix XenApp V5.0, V6.0
HP-UX
  • 11
  • 11i
  • 11i V2
  • 11i V3
Linux
  • Red Hat Enterprise Linux 3.0, 4.0 and 5.0 (WS, ES, and AS)*
  • SuSE Linux Enterprise Server 8.0, 9.0, 10.0, and 11
  • SuSE Linux Enterprise Desktop 8.2, 9.0 and 10.0
  • TurboLinux 8.0 Workstation and Server
  • TurboLinux 10*
  • RHEL 6.3 (Client side testing with Sun JRE 1.6_45, 1.7_21, IBM JRE 1.7_SR4FP2 and Firefox 21.0) with HOD 11.0.8 and higher
Macintosh
  • Mac OS X 10.2.1,10.3, and 10.4
  • Mac 10.7.5 with Safari 6.0.3 and HOD 11.0.8
  • Mac 10.8.3 with Safari 6.0.3 and HOD 11.0.8
Solaris
  • Solaris 8
  • Solaris 9
  • Solaris 10
Windows
  • Windows 2000 (Professional and Advanced) Server**
  • Windows XP Professional Edition*
  • Windows XP Home Edition (32-bit version)
  • Windows Server 2003 (Enterprise, Standard, and Web)*
  • Windows Server 2003 R2 (Standard and Enterprise Editions)*
  • Windows Vista (Business, Enterprise, and Ultimate Editions)*
  • Windows Fundamentals for Legacy PC IPV6
  • Windows Terminal Services for Windows 2003*
  • Windows Server 2008 (Standard and Enterprise Editions)*
  • Windows 2008 R2 (Standard and Enterprise Editions - only 64-bit)
  • Windows 7 (Professional, Enterprise and Ultimate Editions)*
  • Windows 8 Pro 32 and 64 bit with HOD 11.0.8 and higher
  • Windows 8 Enterprise 32 and 64 bit with HOD 11.0.8 and higher
  • Windows 8 32 bit and 64 bit with HOD 11.0.8 and higher
Notes:
*(32-bit and 64-bit versions)
**Support for Host On-demand with other software that is no longer supported
  • Host On-Demand does not support Netscape on Mac OS X
  • Host On-Demand supports a local client on Windows 2000, Windows 2003, Windows XP and Windows Vista


Host On-Demand Supported Client Browsers and Java 2 plug-ins

The supported browsers run either a Host On-Demand local client (that is, a download client or cached client downloaded to the workstation from a Host On-Demand server, see Using Host On-Demand emulator clients) or a Host On-Demand locally installed client (see Using locally installed clients).
Supported Java 2 enabled browsers and Java 2 plug-ins
Internet Explorer (with a Java 2 plug-in installed)
  • 6.0
  • 7.0
  • 8.0
  • 9.0 (HOD 11.0.4 and higher)
  • 10 (HOD 11.0.8 and higher)
Firefox
  • 1.5
  • 2.0
  • 3.0
  • 3.5
  • 3.6 (HOD 11.0.4 and higher)
  • 4.x (HOD 11.0.4 and higher)
  • 14.0.1 (HOD 11.0.6 and higher)
  • 17 (HOD 11.0.6.1 and higher)
  • 18 (HOD11.0.6.1 and higher)
Safari (Mac only)
  • 1.0
  • 2.0
  • 3.2.2
  • 6.0.3 (HOD 11.0.8 and higher)
  • 6.0.4 (HOD 11.0.8 and higher)
Notes:
  • Host On-Demand supports the Operating System only if the JRE supports it.
  • A Java 2 enabled browser requires a Java 2 plug-in. Supported Java 2 plug-ins include the following:
    • Sun, IBM, and HP Java plug-ins 1.5.0. Sun 1.6.0
    • IBM 32-bit runtime Environment for Java 2, 1.5 and 1.6 and 1.7 (11.0.6 and higher)
  • For more information about Java 2 enabled browsers and Java 2 plug-ins, refer to Planning for Java 2 on the client.
  • For more information about supported Java levels with Host On-Demand, refer to Supported Java 2 plug-ins for each release of Host On-Demand.
  • On 64-bit platforms, only 32-bit browsers and 32-bit JREs are supported by Host On-Demand.


Miscellaneous Supported Software and Limitations
Software
LDAP Servers
  • IBM Tivoli Directory Server V6.0, 6.1, and 6.2
  • IBM LDAP Server running on z/OS V1R8 and higher
For instructions on using LDAP with Host On-Demand, see Configuring Host On-Demand Server to use LDAP.
Miscellaneous Software
  • IBM WebSphere Portal for Multiplatforms V6.1
  • IBM WebSphere Portal for Multiplatforms 7.0 for HOD 11.0.5 and higher
  • CICS Transaction Gateway
  • Acrobat Reader (Acrobat) Version 6.0,7.0, and 8.0
  • CA (Netegrity) Siteminder 5.5
  • Tivoli Access Manager for e-business 5.1, 6.0 and 6.1
  • Virtualization – VMware ESX/ESXi Server 3.0, 4.0
  • VM Ware Workstation 6.5 (Only for Windows OS)
  • Hyper V on Windows 2008 (**Tested with Win 2008 32 bit and Win 7 32 bit) with HOD 11.0.8 and higher
  • VMWare Workstation 9.0 (**Tested with Win 2003 32 bit and Win 7 32 bit) with HOD 11.0.8 and higher
  • Portal 8.0 (**Tested with Windows) with HOD 11.0.8 and higher
  • TDS 6.3 (Tested with Windows) with HOD 11.0.8 and higher
Additional Host On-Demand supported Client Environments
Client Integration
  • Lotus Expeditor V6.1 and higher
  • Eclipse v3.2 and higher
HOD Container Support
  • Lotus Expeditor V6.2.1
  • Lotus Expeditor V6.2.2 & V6.2.3 (HOD 11.0.6)
  • Lotus Notes V8.5.1

Disclaimer
IBM reserves the right to change specifications and other product information without prior notice. This publication could include technical inaccuracies or typographical errors. References herein to IBM products and services do not imply that IBM intends to make them available in other countries. IBM PROVIDES THIS PUBLICATION AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Host On-Demand
Documentation

Software version:

11.0, 11.0.1.0, 11.0.2.0, 11.0.3.0, 11.0.4.0, 11.0.5.0, 11.0.5.1, 11.0.6, 11.0.6.1, 11.0.7, 11.0.8, 11.0.9

Operating system(s):

AIX, HP Itanium, HP-UX, Linux, OS/400, Solaris, Windows, i5/OS, z/OS

Reference #:

7018969

Modified date:

2014-07-03

Translate my page

Machine Translation

Content navigation