System requirements for IBM InfoSphere Information Server, Version 8.5 on Linux

Product documentation


Abstract

System requirements for the server-side components of InfoSphere Information Server on Linux.

Content

Tab navigation


Important: All of the requirements in this document are required for the computers running on Linux operating systems unless specifically noted.

Legend
Icon Description
Supported Supported
Δ Added or changed information since the last release, modification, or fix pack. This mark in the far left column indicates new or changed information in the row.


About the system requirements

InfoSphere Information Server product modules are installed in logical tiers: client tier, engine tier, services tier, and metadata repository tier. A tier is a logical group of components within InfoSphere Information Server and the computers on which those components are installed. For more information about tiers, see Understanding tiers and components.

Before you install the IBM InfoSphere Information Server suite product modules and components, you must ensure that each computer meets the system requirements for the logical tiers that you plan to install on that computer. The easiest way to verify that your computer meets the system requirements is to use one of the following tools:

This document describes the system requirements in detail.


Operating system requirements

The engine tier, services tier, and metadata repository tier are supported on 32-bit and 64-bit Linux operating systems.

The following table specifies the supported Linux operating systems.

Operating system 32-bit 64-bit Processors Notes
Δ Red Hat Enterprise Linux 5 Supported on 32-bit Supported on 64-bit

AMD processors or Intel processors

You can use Version 5.2 or any subsequent release of Version 5

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 5 Supported on 64-bit

IBM System z

You can use Version 5.2 or any subsequent release of Version 5

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 5 Advanced Platform Supported on 32-bit Supported on 64-bit

AMD processors or Intel processors

You can use Version 5.2 or any subsequent release of Version 5

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 5 Advanced Platform Supported on 64-bit

IBM System z

You can use Version 5.2 or any subsequent release of Version 5

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 6 Supported on 64-bit

AMD processors or Intel processors

You can use Version 6.0 or any subsequent release of Version 6

InfoSphere Information Server V8.5 Fix Pack 1 or any subsequent release of Version 8.5 is required

Installing on Red Hat Linux 6

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 6 Supported on 64-bit

IBM System z

You can use Version 6.0 or any subsequent release of Version 6

InfoSphere Information Server V8.5 Fix Pack 1 or any subsequent release of Version 8.5 is required

Installing on Red Hat Linux 6

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 6 Advanced Platform Supported on 64-bit

AMD processors or Intel processors

You can use Version 6.0 or any subsequent release of Version 6

InfoSphere Information Server V8.5 Fix Pack 1 or any subsequent release of Version 8.5 is required

Installing on Red Hat Linux 6

Security Enhanced Linux is not supported.

Δ Red Hat Enterprise Linux 6 Advanced Platform Supported on 64-bit

IBM System z

You can use Version 6.0 or any subsequent release of Version 6

InfoSphere Information Server V8.5 Fix Pack 1 or any subsequent release of Version 8.5 is required

Installing on Red Hat Linux 6

Security Enhanced Linux is not supported.

SUSE Linux Enterprise Server 10 Supported on 32-bit Supported on 64-bit

AMD or Intel processors

IBM System z

Service Pack 1, Service Pack 2, or Service Pack 3 is required.

SUSE Linux Enterprise Server 11 Supported on 32-bit Supported on 64-bit

AMD processors or Intel processors

IBM System z

Service Pack 1 is also supported, but is not required.

Memory requirements

The minimum amount of memory for installing the InfoSphere Information Server engine tier, services tier, and metadata repository tier is as follows:

Memory requirements depend on the type of processing, the volume of parallel processing, the size and number of simultaneously running jobs, and the memory requirements of the operating system and other applications (such as relational databases).

Evaluate the following factors to determine the memory requirements for your system:


Disk space requirements

See the disk space requirements for the engine tier, services tier, and metadata repository tier.


Engine tier disk space requirements

The following table specifies the minimum disk space requirements for the engine tier installation. These disk space requirements are the minimum requirements for installation. Operational requirements are significantly larger than these minimum installation disk space requirements.

Engine tier component Minimum disk space Notes
Installation 2 GB The system temporary directory requires 1 GB of available free space during installation.
Product components 1.7 GB

Services tier disk space requirements

The following table specifies the minimum disk space requirements for the services tier installation. These disk space requirements are the minimum requirements for installation. Operational requirements are significantly larger than these minimum installation disk space requirements.

Services tier component Minimum disk space Notes
Installation 2 GB The system temporary directory requires 1 GB of available free space during installation.
WebSphere Application Server 2.1 GB
Product components 1.1 GB

Metadata repository tier disk space requirements

The following table specifies the minimum disk space requirements for the metadata repository tier installation. These disk space requirements are the minimum requirements for installation. Operational requirements are significantly larger than these minimum installation disk space requirements.

Metadata repository tier component Minimum disk space Notes
Installation 2 GB The system temporary directory requires 1 GB of available free space during installation.
DB2 database software 1 GB Optionally installed with Version 8.5.
Metadata repository database 1 GB to 2.5 GB

Disk space requirements vary based on your database software. DB2 requires 2.5 GB, Oracle requires 1 GB, and SQL Server requires 1.2 GB

InfoSphere Information Analyzer analysis database 1.2 GB

Kernel parameters and user limits

To view minimum kernel parameter and user limit requirements, see the IBM InfoSphere Information Server Planning, Installation, and Configuration Guide. You can view this same information in the information center.


Networking requirements

The client tier, engine tier, services tier, and metadata repository tier must be able to communicate with each other over the network on all ports that are used by the software. The host computer must be able to resolve its host name to an IP address.


Database server requirements

The database server must be installed on the same computer that the services tier is installed on, or on the metadata repository tier computer with high-speed network connectivity to the services tier computer. This requirement might not be met when the computers are not on the same network segment or if a firewall is installed between the two computers.

Note: The Version 8.5 installation program can install a new instance of DB2 Enterprise Server Edition (ESE) Version 9.7, or you can use an existing DB2 ESE Version 9.5 or DB2 ESE Version 9.7 installation.

The following table specifies the database servers that are supported for the metadata repository database and the InfoSphere Information Analyzer analysis database:

Database server software Notes
Microsoft SQL Server 2005 Enterprise Edition
Microsoft SQL Server 2008 Enterprise Edition
Δ IBM DB2 Enterprise Server Edition Version 9.5

Fix Pack 2a or a subsequent fix pack of this version is required.
Exception For Red Hat Enterprise Linux 6 (and subsequent releases of Version 6), Fix Pack 7 or a subsequent fix pack for IBM DB2 Version 9.5 is required.

High-availability disaster recovery (HADR) is supported.

Partitioned databases are not supported.

64-bit: IBM DB2 Enterprise Server Edition Version 9.7

32-bit: IBM DB2 Workgroup Server Edition Version 9.7

A fix pack is not required.
Exception For Red Hat Enterprise Linux 6 (and subsequent releases of Version 6), Fix Pack 4 or a subsequent fix pack for IBM DB2 Version 9.7 is required.

Partitioned databases are not supported.

IBM DB2 Version 9.1 for z/OS

Version 9.1 or a subsequent fix pack for this version is required.

Oracle 10g Release 2

Advanced Security option is not supported.

Real Application Clusters (RAC) is supported only for the metadata repository database.

Installation on the same subnet as WebSphere Application Server is recommended.

Oracle 11g Release 2

Advanced Security option is not supported.

Real Application Clusters (RAC) is supported only for the metadata repository database.

Installation on the same subnet as WebSphere Application Server is recommended.


Application server requirements

IBM WebSphere Application Server Network Deployment (ND) is required for the services tier.

The following table specifies the WebSphere Application Server Network Deployment (ND) requirements.

Application server software Notes
Δ WebSphere Application Server Network Deployment, Version 6.1

Fix Pack 29 or a subsequent fix pack for this version is required.
Exception For Red Hat Enterprise Linux 6 (and subsequent releases of Version 6), Fix Pack 37 or a subsequent fix pack for WebSphere Application Server Version 6.1 is required.

If you use an existing installation of WebSphere Application Server, additional iFixes might also be required. See http://www.ibm.com/support/docview.wss?uid=swg27019072.

A supported web server is required. See the WebSphere Application Server system requirements document for your operating system:

Δ WebSphere Application Server Network Deployment, Version 7.0

Fix Pack 11 or a subsequent fix pack for this version is required.
Exception For Red Hat Enterprise Linux 6 (and subsequent releases of Version 6), Fix Pack 17 or a subsequent fix pack for WebSphere Application Server Version 7.0 is required.

If you use an existing installation of WebSphere Application Server, additional iFixes might also be required. See http://www.ibm.com/support/docview.wss?uid=swg27019072.

A supported web server is required. See the WebSphere Application Server system requirements document for your operating system:


Package requirements for 64-bit Red Hat Enterprise Linux 5

Δ The following packages are required to install and operate Version 8.5 on 64-bit Red Hat Enterprise Linux 5 and 64-bit Red Hat Enterprise Linux 5 Advanced Platform.

Package name Notes
audit-libs-1.7.13.2.el5 (x86_64)
compat-libstdc++-33-3.2.3.61 (x86_64)
glibc-2.5.42.el5_4.2 (x86_64)
glibc-common-2.5.42.el5_4.2 (x86_64)
libaio-0.3.106.3.2 (x86_64)
libgcc-4.1.2.46.el5_4.2 (x86_64)
libstdc++-4.1.2.46.el5_4.2 (x86_64)
libXp-1.0.0.8.1.el5 (x86_64)
pam-0.99.6.2.6.el5 (x86_64)

Package requirements for 64-bit Red Hat Enterprise Linux 6

Δ The following packages are required to install and operate Version 8.5.0.1 on 64-bit Red Hat Enterprise Linux 6 and 64-bit Red Hat Enterprise Linux 6 Advanced Platform.

Package name Notes
glibc-2.12-1.25.el6.i686 See * below
libXp-1.0.0-15.1.el6.i686
libXau-1.0.5-1.el6.i686.rpm
libXext-1.1-3.el6.i686.rpm
libX11-1.3-2.el6.i686.rpm
libxcb-1.5-1.el6.i686.rpm
libXmu-1.0.5-1.el6.x86_64.rpm
nss-softokn-freebl.i686

* For more information about the glibc packages, see Incomplete Information Server installation caused by memcpy() change in glibc.


Package requirements for 32-bit Red Hat Enterprise Linux

The following packages are required to install and operate Version 8.5 on 32-bit Red Hat Enterprise Linux 5 and 32-bit Red Hat Enterprise Linux 5 Advanced Platform.

Package name Notes
audit-libs-1.7.17-3.el5
compat-libstdc++-33-3.2.3-61
compat-libstdc++-296-2.96-138
compat-glibc-2.3.4-2.26
glibc-common-2.5-49.el5_5.4
glibc-common-2.5-49.el5_5.4
libaio-0.3.106-5
compat-libgcc-296-2.96-138
libgcc-4.1.2-48.el5
libstdc++-4.1.2-48.el5
libXp-1.0.0-8.1.el5
pam_pkcs11-0.5.3-23

Package requirements for 64-bit SUSE Linux Enterprise Server 10

The following packages are required to install and operate Version 8.5 on 64-bit SUSE Linux Enterprise Server 10.

Package name Notes
audit-libs-32bit-1.2.9-6.9
expat-32bit-2.0.0-13.2
glibc-2.4-31.30
glibc-32bit-2.4-31.30
libaio-32bit-0.3.104-14.2
libgcc-4.1.2_20070115-0.11
libstdc++-4.1.2_20070115-0.11
pam-32bit-0.99.6.3-28.8
xorg-x11-libs-32bit-6.9.0-50.45

Package requirements for 64-bit SUSE Linux Enterprise Server 11

The following packages are required to install and operate Version 8.5 on 64-bit SUSE Linux Enterprise Server 11.

Package name Notes
audit-libs-1.7.7-5.16-x86_64
expat-2.0.1-88.26.1-x86_64
glibc-2.9-13.3.1-x86_64
glibc-32bit-2.9-13.3.1-x86_64
libaio-0.3.104-140.22-x86_64
libgcc43-4.3.3_20081022-11.18-x86_64
libstdc++43-devel-4.3.3_20081022-11.18-x86_64
libstdc++43-4.3.3_20081022-11.18-x86_64
pam-1.0.2-20.1-x86_64
xorg-x11-7.4-9.18.1-x86_64

Package requirements for 32-bit SUSE Linux Enterprise Server 11

The following packages are required to install and operate Version 8.5 on 32-bit SUSE Linux Enterprise Server 11.

Package name Notes
audit-libs-1.7.7-5.16
expat-2.0.1-88.26.1
glibc-2.11.1-0.17.4
libaio-0.3.109-0.1.46
libaio-0.3.104-140.22-x86_64
libgcc43-4.3.4_20091019-0.7.35
libstdc++43-4.3.4_20091019-0.7.35
libstdc++33-3.3.3-11.9
pam-1.0.4-0.5.12
xorg-x11-7.4-9.24.15

InfoSphere DataStage and QualityStage requirements

InfoSphere DataStage and QualityStage uses a C++ compiler to compile jobs. The engine tier computer supports the following versions of C++ compilers: GNU 4.1.2, GNU 4.3, and GNU 4.4. The following tables specify the compiler versions that are supported for each Linux platform. If you want to set up a compiler, refer to Setting up a C++ compiler for InfoSphere DataStage and QualityStage on Linux.


InfoSphere Information Server, Version 8.5

Version 8.5 supports GNU 4.1.2 C++ complier.

Operating system GNU 4.1.2 C++ compiler GNU 4.3 C++ compiler GNU 4.4 C++ compiler
Red Hat Enterprise Linux 5 (any processor)
Red Hat Enterprise Linux 5 Advanced Platform (any processor)
SUSE Linux Enterprise Server 10 (any processor)


InfoSphere Information Server, Version 8.5.0.1 (Fix Pack 1) or any subsequent fix pack for Version 8.5

Fix Packs for Version 8.5 support GNU 4.1.2, GNU 4.3, and GNU 4.4 versions of the C++ compiler. However, not all platforms support all versions of the compiler. The following table specifies the compiler versions that each platform supports.

Operating system GNU 4.1.2 C++ compiler GNU 4.3 C++ compiler GNU 4.4 C++ compiler
Red Hat Enterprise Linux 5 (any processor)
Red Hat Enterprise Linux 5 Advanced Platform (any processor)
Δ Red Hat Enterprise Linux 6 (any processor)
Δ Red Hat Enterprise Linux 6 Advanced Platform (any processor)
SUSE Linux Enterprise Server 10 (any processor)
Δ SUSE Linux Enterprise Server 11 (any processor)

InfoSphere Business Glossary requirements

To use the business lineage feature of InfoSphere Business Glossary, InfoSphere Metadata Workbench must be installed on the services tier.


Related information and additional requirements
Document Format
Download Version 8.5 Fix Pack 2 HTML
Updating InfoSphere Information Server, Version 8.5, and installating additional products HTML
Version 8.5 fixes that require post-installation steps HTML
Release notes and documentation HTML
Download Version 8.5 Fix Pack 1 HTML
Download Version 8.5 HTML
Download IBM Support Assistant Lite HTML
System requirements for MetaBrokers and bridges HTML
System requirements and component compatibility for InfoSphere DataStage connectivity to InfoSphere Change Data Capture HTML
System requirements for other versions HTML
Support for IBM software products in VMware environments HTML
Virtualization Policy for IBM Software HTML
Operating system and disk space requirements for InfoSphere QualityStage modules on Version 8.5 HTML


Change history
History Date Change
Release 15 October 2010 Created for IBM InfoSphere Information Server, Version 8.5.
Update 30 November 2010 Maintenance update to add 32-bit Linux, Red Hat Linux on IBM System z, DB2 for z/OS, and web server support.
Release 17 December 2010 Maintenance update to refine link to Version 8.5 Linux download document and add description with link to ISA Lite.
Release 15 April 2011 Clarified the supported versions of database servers and application servers. Adding support for additional C++ compiler versions for InfoSphere DataStage and QualityStage.
Release 11 August 2011 Added support for Red Hat Enterprise Linux, Version 5 (and subsequent releases of that version) and Version 6 (and subsequent releases of that version).
Release 14 September 2011 Added that InfoSphere Information Server V8.5 Fix Pack 1 or any subsequent release of Version 8.5 is required to install on RedHat, Version 6 platforms.
Release 11 October 2011 Added a link to the IBM Support Portal about the virtualization policy of IBM Software. This document includes a list of virtualization environments.
Release 21 November 2011 Updated the package requirements for Red Hat Linux, Version 6.
Release 30 November 2011 Added a link to the download document for Version 8.5 Fix Pack 2 and added links to the instructions for installing fix packs and patches to InfoSphere Information Server, Version 8.5.


Rate this page:

(0 users)Average rating

Document information


More support for:

InfoSphere Information Server

Software version:

8.5, 8.5.0.1, 8.5.0.2

Operating system(s):

Linux

Reference #:

7018815

Modified date:

2014-10-27

Translate my page

Machine Translation

Content navigation