IBM Support

IBM WebSphere Process Server Hypervisor Edition Version 6.2 for AIX, hardware and software requirements

Product documentation


Abstract

This document lists the hardware and software requirements for IBM WebSphere Process Server Hypervisor Edition Version 6.2 for AIX.

Content

This page describes the minimum product levels that must be installed before opening a problem report with the WebSphere Process Server Hypervisor Edition support team. Because other products frequently ship fixes, updates, and new releases, testing every configuration is not possible. In general, you can install and run with minor updates to supported products if those updates are forward compatible.

Supporting software (for example LDAP servers) can run, but does not need to run, on the same computer or operating system where the product runs. For additional information:


This document identifies supporting software that runs on the AIX operating system on POWER platforms.

Operating Systems
Hardware Requirements

Application Server
JavaTM
  • Java Runtime Environment: Java Runtime Environment (JRE) 6.0
    Note: For JRE provided by IBM, use 6.0 SR3 or later.
Databases
(Compatible with but not required)
  • IBM DB2 Workgroup Server Edition for Linux, UNIX and Windows 9.5 IBM DB2 product site
    Note: Business Process Choreographer minimum requirement is DB2 9.5 FP1
  • Oracle 11g Standard Edition Release 1 - 11.1.0.6.0 Oracle product site
    Note: Supports Oracle Real Application Cluster (RAC) on Oracle 10g and Oracle 11g.
  • Currency certification: Microsoft SQL Server 2008 SP1 with Microsoft SQL Server JDBC Driver 2.0, is certified and recommended on WebSphere Process Server V6.2.0 Fix Pack 2.
    Note: Supports Common Event Infrastructure (CEI) databases
Java Database Connectivity (JDBC) Drivers
(Compatible with but not required)
  • IBM WebSphere embedded Connect JDBC (XA) 3.5 build 37 (type 4)
    Note: Support for this driver is deprecated and will be removed in a future release.
LDAP servers
(Compatible with but not required)
  • OpenLDAP 2.2.17 Build 20040923
    Notes:
    • Refer to the 'Supported LDAP servers' section of the appropriate supported operating system to see the LDAPs supported remotely on that Operating System.
Web Servers
(Compatible with but not required)
Web Browsers
(Compatible with but not required)
  • Mozilla 1.7.13
    Notes:
    • A Web browser is required for administration and configuration, sample program execution, and the launchpad. There is no restriction or certification of Web browsers on clients that connect to the server to display content.
JMS Provider
(Compatible with but not required)
Clients
(Compatible with but not required)

For WebSphere Process Server only:
  • IBM WebSphere Process Server Client 6.2.0

    Note: The WebSphere Process Server Client 6.2.0 can be installed on WebSphere Application Server 6.1 and supported on the same set of platforms supported by WebSphere Process Server 6.2.0. Customer applications using or based on the WebSphere Process Server Client 6.0.2, 6.1 or 6.1.2 and higher will work against WebSphere Process Server 6.2.0
Security
(Compatible with but not required)
Resource Adapters
(Compatible with but not required)
Business-to-business integration
(Compatible with but not required)
For WebSphere Process Server only:
License use management
(Compatible with but not required)
Service Registries
(Compatible with but not required)
  • IBM WebSphere Service Registry and Repository 6.2
    IBM WebSphere Service Registry and Repository product site

    Note:
    1. To use WebSphere Process Server policy driven mediations the minimum support level is WebSphere Service Registry and Repository 6.2 FP2
    2. Remote connections to earlier versions of WebSphere Service Registry and Repository are supported.
Tools & Utilities
(Compatible with but not required)

WebSphere Process Server Hypervisor Edition Related information
WebSphere Process Server Hypervisor Edition Support Page
WebSphere Process Server Hypervisor Edition Information Center

Document information

More support for: WebSphere Process Server Hypervisor Edition for AIX
General

Software version: 6.2

Operating system(s): AIX

Reference #: 7018525

Modified date: 20 April 2010