IBM WebSphere Process Server Hypervisor Edition Version 7.0 for Novell SUSE Linux Enterprise Server for x86 (32-bit), hardware and software requirements

Product documentation


Abstract

This document lists the hardware and software requirements for: IBM WebSphere Process Server Hypervisor Edition Version 7.0 for Novell SUSE Linux Enterprise Server for x86 (32-bit).

Content

This page describes the minimum product levels that must be installed before opening a problem report with the WebSphere Process Server Hypervisor Edition support team. Because other products frequently ship fixes, updates, and new releases, testing every configuration is not possible. In general, you can install and run with minor updates to supported products if those updates are forward compatible.
Supporting software (for example LDAP servers) can run, but does not need to run, on the same computer or operating system where the product runs. For additional information:

  • Check supporting software requirements to determine whether the supporting software runs locally or is connected remotely to the product.

This document identifies supporting software that runs on the Linux operating system on x86 platforms.

Operating Systems
Hardware Requirements

  • IBM System xSeries with VMWare ESX
  • Processor: Intel Pentium at 3Ghz for single core system, 2.4GHz for dual cores or faster; Intel EM64T or AMD Opteron (32-bit kernel support only)
  • Disk Space: Minimum 40 GB physical space
  • Memory: Minimum 2 GB physical memory
Application Server
Java™
  • Java 2 SE: IBM Java SDK 6.0 SR6
  • Java Runtime Environment: Java Runtime Environment(JRE) 6.0
    Note: For JRE provided by IBM, use 6.0 SR3 or later.
Databases
(Compatible with but not required)
  • Apache Derby 10.3
  • IBM DB2 UDB for UNIX/Linux and Windows 8.2 FP6
    Note: Only Enterprise Server Edition and Workgroup Server Edition supported
  • IBM DB2 Enterprise Server Edition 9.1
  • IBM DB2 Workgroup Server Edition 9.1
  • IBM DB2 Enterprise Server Edition 9.5
  • IBM DB2 Workgroup Server Edition 9.5
    Note: Business Process Choreographer minimum requirement is DB2 9.5 FP1
  • IBM DB2 Workgroup Server Edition 9.7
  • IBM DB2 Enterprise Server Edition for Linux, UNIX and Windows 9.7 IBM DB2 product site
  • IBM DB2 for i V5R4
  • IBM DB2 for i V6R1
    Note: Only supported for remote systems
  • IBM Informix Dynamic Server 10.00.xC6
  • IBM Informix Dynamic Server 11.10.xC1
  • IBM Informix Dynamic Server 11.50.xC1IBM Informix Dynamic Server product site
    Notes:
    • Not supported for the reporting function in Business Process Choreographer
    • Not supported for the Business Space component.
    • Informix IDS 10.00.xC6 Query Table capability of Business Process Choreographer is not supported due to IDS SQL limitation of 'no support of sub-selects as part of the from-clause'.
  • Oracle 10g Enterprise Edition Release 1 - 10.1.0.4
  • Oracle 10g Standard Edition Release 1 - 10.1.0.4
  • Oracle 10g Enterprise Edition Release 2 - 10.2.0.1
  • Oracle 10g Standard Edition Release 2 - 10.2.0.1
  • Oracle 11g Enterprise Edition Release 1 - 11.1.0.6
  • Oracle 11g Standard Edition Release 1 - 11.1.0.6 Oracle product site
    Note: Supports Oracle Real Application Cluster (RAC)
Java Database Connectivity (JDBC) Drivers
(Compatible with but not required)
  • Derby 10.3 JDBC 3.0
  • Derby 10.3 JDBC 4.0
  • IBM DB2 Driver for JDBC and SQLJ 3.4.65 (type 2/4)
  • IBM DB2 Universal JDBC Provider 2.10.72 (type 2/4)
  • Data Direct Connect for JDBC 4.0 (type 4)
  • IBM Application Connectivity to DB2 for z/OS Feature
  • IBM Data Server Driver for JDBC and SQLJ 3.51 (type 3)
  • IBM Data Server for JDBC and SQLJ 4.1 (type 4) (Note: DB/2 for z/OS requires PK41236, PK89820)
  • IBM Informix JDBC Driver 3.00 JC3 (type 4)
  • IBM Informix JDBC Driver 3.10 JC1 (type 4)
  • IBM Informix JDBC Driver 3.50.JC5 (type4) (Note: Required for Informix Dynamic server 11.50) IBM Informix JDBC product site
  • Microsoft SQL Server 2005 JDBC Driver 1.2
LDAP servers
(Compatible with but not required)
Web Servers
(Compatible with but not required)
  • Sun Java System Web Server 6.1 SP1
  • Sun Java System Web Server 7.0 SP1 Sun product site
Web Browsers
(Compatible with but not required)
  • Mozilla Firefox 3.0
    Note: A Web browser is required for administration and configuration, sample program execution, and the launchpad. There is no restriction or certification of Web browsers on clients that connect to the server to display content.
JMS Provider
(Compatible with but not required)
Clients
(Compatible with but not required)
  • IBM Message Service Client for C/C++ 2.0.1
    For WebSphere Process Server only:
  • IBM WebSphere Process Server Client 6.1.0
  • IBM WebSphere Process Server Client 6.1.2
  • IBM WebSphere Process Server Client 6.2.0
  • IBM WebSphere Process Server Client 7.0.0
    Note: The WebSphere Process Server Client can be installed on WebSphere Application Server and supported on the same set of platforms supported by WebSphere Process Server. Customer applications using or based on the WebSphere Process Client 6.x work against WebSphere Process Server 7.0.0
Security
(Compatible with but not required)
Resource Adapters
(Compatible with but not required)
  • IBM CICS Transaction Gateway 6.0
  • IBM CICS Transaction Gateway 7.0
  • IBM IMS TM Resource Adapter 10  
  • IBM IMS TM Resource Adapter 9.1.0.2  
Business-to-business integration
(Compatible with but not required)
  • IBM Lotus Forms Server 3.5.1

Note: For WebSphere Process Server only
  • IBM WebSphere Partner Gateway Advanced Edition 6.2  
  • IBM WebSphere Partner Gateway Enterprise Edition 6.2 
License use management (Compatible with but not required)
  • IBM Tivoli License Compliance Manager 2.2 
Service Registries
(Compatible with but not required)
  • IBM WebSphere Service Registry and Repository 6.1
  • IBM WebSphere Service Registry and Repository 6.2
  • IBM WebSphere Service Registry and Repository 6.3
  • IBM WebSphere Service Registry and Repository 7.0
    IBM WebSphere Service Registry and Repository product site
    Notes:
    • To use WebSphere Process Server policy driven mediations the minimum support level is WebSphere Service Registry and Repository 6.2 FP2
    • Remote connections to earlier versions of WebSphere Service Registry and Repository are supported.
Tools & Utilities
(Compatible with but not required)

WebSphere Process Server Hypervisor Edition Related information
WebSphere Process Server Hypervisor Edition Support Page
WebSphere Process Server Hypervisor Edition Information Center

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere Process Server Hypervisor Edition for Novell SUSE Linux Enterprise Server for x86 (32-bit)
General

Software version:

7.0

Operating system(s):

Linux

Reference #:

7018524

Modified date:

2010-04-20

Translate my page

Machine Translation

Content navigation