System Requirements for IBM InfoSphere Master Data Management Server for Product Information Management, Version 9.0, on RedHat Linux

Product documentation


Abstract

This document contains system requirements for IBM® InfoSphere MDM Server for PIM, Version 9.0, on the RedHat Linux® operating system.

Content

This document describes the minimum product levels that need to be installed before opening a problem report with the InfoSphere MDM Server for PIM support team.

The system requirements for InfoSphere MDM Server for PIM vary based on the scope and scale of your PIM system.

Note: The hardware requirements represent the minimum hardware requirements for a small PIM system with less than 50,000 items supporting 10-20 concurrent users. The minimum recommended configurations need to be evaluated and adjusted according to your unique requirements and the complexity of the InfoSphere MDM Server for PIM solution. Disk space recommendations are for the product installation and working space only. The actual hard disk space that is required varies, depending upon your installation. You need to work with the IBM professional services team to determine the appropriate hardware requirements for your specific environment and PIM system.

You must set up both a client system and one or more server systems. The application server, database server, and HTTP server can all be on the same server machine, they can be combined together on server machines, or they can each be on their own server machine. The HTTP server is recommended, but is optional.

The following lists identify the products that are supported when IBM InfoSphere MDM Server for PIM runs on the RedHat Linux operating system. Some platforms are limited to either 32-bit or 64-bit, but where 32-bit and 64-bit platforms are possible on a single platform it is to be assumed that both will be supported.

Important: These requirements represent the minimum system requirements. The product supports the specified version only and any subsequent fix packs, service packs, or service refreshes that are released for the specified version. Earlier or later versions or releases are not supported.

Application Server Requirements

Operating Systems
  • RedHat Enterprise Linux Version 5 with Update 1 to 5
Hardware Requirements (see note above)
  • x86 or x86-64 system, or POWER processor system, with at least 2 - 4 processor cores (based on CPU speed)
    Note: Itanium based systems are not supported
  • RAM: 6 GB
  • Disk space: 50 GB
Application Server
  • IBM WebSphere® Application Server Network Deployment, Version 7.0, Fix Pack 7 (See the documentation)
  • Oracle/BEA WebLogic Server 11g Release 1 (10.3.2) and future fix packs (See the documentation)
    Note: If you use Oracle WebLogic Server, you must use an Oracle database.
Java™ Development Kit
  • IBM Developer Kit for AIX, Java™ Technology Edition Version 6.0, which is shipped with WebSphere Application Server
  • Java Development Kit that is shipped with Oracle WebLogic Server
Database client (including Java Database Connectivity (JDBC) Drivers)
  • IBM DB2® Client, version 9.7 and 9.5, including the DB2 Universal JDBC Driver, or later
  • Oracle Client, version 11g Rel 1, including the Oracle JDBC driver 11.1.0.7, or later
    Important: Although the database server can use Oracle 10g, the database client must use Oracle 11g
HTTP Server
  • IBM HTTP Server, Version 2.0 or later
    Note: The WebSphere Application Server plug-in must match the version of WebSphere Application Server that you use for InfoSphere MDM Server for PIM.
  • Apache HTTP Server, Version 2.0 or later
Perl Recommended: InfoSphere MDM Server for PIM requires Perl version 5.8, although version 5.10 is preferred. InfoSphere MDM Server for PIM also requires several Perl modules. For more information, see the information center.
Web Browser To run the FirstSteps or Launchpad installation programs, use Firefox 2.0 or later.
Messaging Software InfoSphere MDM Server for PIM can be configured to use messaging software, as described in the information center. However, the optional Global Data Synchronization feature of InfoSphere MDM Server for PIM requires the following messaging software to run correctly.
  • IBM WebSphere MQ, Version 7.0.1 client
  • IBM WebSphere MQ, Version 7.0.1 server
    Note: The IBM WebSphere MQ, Version 7.0.1 client version must be installed on the application server only, however the IBM WebSphere MQ, Version 7.0.1 server can be installed on any server.


Database Server Requirements

Operating Systems
  • Red Hat Enterprise Linux, Version 5 with Update 1
Hardware Requirements (see note above)
  • x86 or x86-64 system, or POWER processor system, with at least 2 - 4 processor cores
  • System z10
  • RAM: 8 GB
  • Disk space: 100-200 GB, in a RAID configuration
Database Server

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

InfoSphere Master Data Management Server for Product Information Management

Software version:

9.0

Operating system(s):

Linux

Reference #:

7018394

Modified date:

2011-03-30

Translate my page

Machine Translation

Content navigation