Supplement for supported software for Rational Functional Tester versions 8.0 and 8.1

Product documentation


Abstract

This document lists the various software that IBM Rational Functional Tester supports for functional testing. It also lists the recommended patch versions that are validated and have provided optimal results. The domains are linked to the latest topics in the Information Centre.

Content


Table 1: 8.1 Supported domains
8.1 Supported domains
Domain Support
8.1
8.1.1
HTML Support
Mozilla Firefox
1.5
2.0
3.0
1.5
2.0
3.0
1.5
2.0
3.0
2.0
3.0
3.5
2.0
3.0
3.5
2.0
3.0
3.5
3.6 F1
2.0
3.0
3.5
3.6 F1
F1: To test applications loaded in Firefox 3.6, the next generation JRE plug-ins must be enabled. Supported JRE versions: SUN JRE 1.6 Update 10 to Update 17.
Note: You might encounter problems while testing applications that are loaded in Firefox 3.6 that is associated with IBMJRE. Use the recommended SUN JRE association with FireFox instead.
Internet Explorer
5.5
6
7 *
8
5.5
6
7 *
8
5.5
6
7 *
8
6
7 *
8
6
7 *
8
6
7 *
8
6
7 *
8
* Internet Explorer 7 (with protected mode)
Mozilla
1.5
1.6
1.7
1.5
1.6
1.7
1.5
1.6
1.7
Support withdrawn
Netscape
7.01 or later
7.1
7.2
7.01 or later
7.1
7.2
7.01 or later
7.1
7.2
Support withdrawn
Java
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
IBM JRE
1.3
1.4
1.5
1.6

SUN JRE
1.3
1.4
1.5
1.6
IBM JRE
1.3
1.4
1.5
1.6

SUN JRE
1.3
1.4
1.5
1.6
IBM JRE
1.3
1.4
1.5
1.6

SUN JRE
1.3
1.4
1.5
1.6
IBM JRE 1.4
1.5J1
1.6J2

SUN JRE
1.3J3
1.4
1.5J4
1.6J5
IBM JRE 1.4
1.5J1
1.6J2

SUN JRE
1.3J3
1.4
1.5J4
1.6J5
J1: IBM JRE 5.0 up to Service Refresh 11
J2: IBM JRE 6.0 Service Refresh 6 to 8
J3: SUN JRE 1.3.1 Update 24 (Only on WINDOWS for stand-alone Java applications.)
J4:
SUN JRE 5.0 Update 6 to Update 22 (32-bit mode)
SUN JRE 5.0 Update 22 (64-bit mode)
J5:
SUN JRE 6.0 (32-bit mode) Update 10 to Update 17. Update 20 with Next Generation plug-in disabled.
SUN JRE 6.0 Update 20 (64-bit mode)
AWT yes yes yes yes yes yes yes
SWT yes yes yes yes yes yes yes
Eclipse 3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.2
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.2
3.5.x
Dojo 1.0
1.1
1.0
1.1
1.0
1.1
1.0
1.1
1.2
1.0
1.1
1.2
1.3.2
1.0
1.1
1.2
1.3.2
1.4.2
1.0
1.1
1.2
1.3.2
1.4.2
WinForm and Windows Presentation Framework based .NET applications 1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
1.0
1.1
2.0
3.0
3.5
4.0
Windows Win32 Win32 Win32 Win32 Win32 Win32 Win32
ARM yes yes yes yes yes yes yes
Ajax yes yes yes yes yes yes yes
SAP WebDynPro SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s). SAP Netweaver Enterprise Portal Client 7.0 (2004s) SAP Netweaver Enterprise Portal Client 7.0 (2004s).
SAP - SAPGUI 6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
Siebel 7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
8.1
7.7
7.8
8
8.1
GEF yes yes yes yes yes yes yes
Flex 2.0
3.0
3.2
2.0
3.0
3.2
3.3
2.0
3.0
3.2
3.3
3.4
2.0
3.0
3.2
3.3
3.4
2.0
3.0
3.2
3.3
3.4
3.5
2.0
3.0
3.2
3.3
3.4
3.5
4.0
2.0
3.0
3.2
3.3
3.4
3.5
4.0
PowerBuilder 10.5
11
11.2
11.5
10.5
11
11.2
11.5
10.5
11
11.2
11.5
10.5
11
11.2
11.5
10.5
11
11.2
11.5
10.5
11
11.2
11.5
12.0
10.5
11
11.2
11.5
12.0
Visual Basic no no 5.0
6.0
5.0
6.0
5.0
6.0
5.0
6.0
5.0
6.0
Adobe PDF 7.0
8.0
7.0
8.0
7.0
8.0
7.0
8.0
7.0
8.0
7.0
8.0
7.0
8.0
Functional Tester Extensions for Terminal-based applications Mainframe or zSeries
TN3270
TN3270E

AS/400 or iSeries
TN5250

Virtual Terminals or pSeries
VT default,
VT100
VT420-7
VT420-8
VT UTF-8

Note: If you find any issues with any of the supported versions of the domains that are listed, use the recommended versions. Refer to the technotes to view any known problems with the listed domains. http://www.ibm.com/software/awdtools/tester/functional/support/



Table 1b: 8.0 Supported domains
8.0 Supported domains
Domain Support
8.0
HTML Support
Mozilla Firefox
1.5
2.0
1.5
2.0
1.5
2.0
1.5
2.0
F1: To test applications loaded in Firefox 3.6, the next generation JRE plug-ins must be enabled. Supported JRE versions: SUN JRE 1.6 Update 10 to Update 17.
Internet Explorer
5.5
6
7
5.5
6
7
5.5
6
7
5.5
6
7 *
* Internet Explorer 7 (with protected mode)
Mozilla
1.5
1.6
1.7
1.5
1.6
1.7
1.5
1.6
1.7
1.5
1.6
1.7
Netscape
7.01 or later
7.1
7.2
7.01 or later
7.1
7.2
7.01 or later
7.1
7.2
7.01 or later
7.1
7.2
Java
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
IBM JRE 1.4
1.5
1.6

SUN JRE
1.4
1.5
1.6
J1: IBM JRE 5.0 up to Service Refresh 11
J2: IBM JRE 6.0 Service Refresh 6 to 8
J3: SUN JRE 1.3.1 Update 24 (Only on WINDOWS for stand-alone Java applications.)
J4:
SUN JRE 5.0 Update 6 to Update 22 (32-bit mode)
SUN JRE 5.0 Update 22 (64-bit mode)
J5:
SUN JRE 6.0 (32-bit mode) Update 10 to Update 17. Update 20 with Next Generation plug-in disabled.
SUN JRE 6.0 Update 20 (64-bit mode)
AWT yes yes yes yes
SWT yes yes yes yes
Eclipse 3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
3.0.x
3.1.x
3.2.x
3.3.x
3.4.x
3.5.x
Dojo 1.0 1.0 1.0 1.0
WinForm and Windows Presentation Framework based .NET applications 1.0
1.1
2.0
3.0
1.0
1.1
2.0
3.0
1.0
1.1
2.0
3.0
1.0
1.1
2.0
3.0
Windows Win32 Win32 Win32 Win32
ARM yes yes yes yes
Ajax yes yes yes yes
SAP WebDynPro no no no no
SAP - SAPGUI 6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
6.20
6.40
7.1
Siebel 7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
7.7
7.8
8
GEF yes yes yes yes
Flex 2.0
3.0
2.0
3.0
2.0
3.0
3.2
2.0
3.0
3.2
PowerBuilder 11 11 11 11
Visual Basic no no no no
Adobe PDF no no no no
Functional Tester Extensions for Terminal-based applications Mainframe or zSeries
TN3270
TN3270E

AS/400 or iSeries
TN5250

Virtual Terminals or pSeries
VT default,
VT100
VT420-7
VT420-8
VT UTF-8

Table 3: Integration of Rational Functional Tester with other Rational products
Integration of Rational Functional Tester with other Rational products
Integration information 8.0
8.0.0.2
8.1
8.1.0.2
8.1.1
8.1.1.1
8.1.1.2
8.1.1.3
Rational Team Concert no no 2.0 2.0 2.0 2.0
2.0.0.1
2.0.0.2
2.0
2.0.0.1
2.0.0.2
2.0
2.0.0.1
2.0.0.2
Rational ClearCase 7.0.1
7.1
7.0.1
7.1
7.0.1
7.1
7.0.1
7.1
7.0.1
7.1
7.1.0.2
7.1.1
7.0.1
7.1
7.1.0.2
7.1.1
7.0.1
7.1
7.1.0.2
7.1.1
7.1.1.1
7.0.1
7.1
7.1.0.2
7.1.1
7.1.1.1
Rational Quality Manager 1.0 1.0
1.0.1
1.0
1.0.1
1.0
1.0.1
2.0
2.0
2.0.0.1
2.0.1
2.0
2.0.0.1
2.0.1
2.0
2.0.0.1
2.0.1
2.0
2.0.0.1
2.0.1
TestManager 7.0.1 7.0.1 7.0.1
7.0.2
7.0.1
7.0.2
7.0.1
7.0.2
7.0.1
7.0.2
7.0.1
7.0.2
7.0.1
7.0.2
ClearQuest TestManager 7.1 7.1 7.1 7.1 7.1.1 7.1.1 7.1.1 7.1.1
ITCAM no no 6.2.1 6.2.1 6.2.1 6.2.1 6.2.1 6.2.1

Note: If you find any issues with any of the supported versions of the domains that are listed, use the recommended versions. Refer to the tech. notes to view any known problems with the listed domains.

Table 4: Compatible shell sharing products
Compatible shell sharing products
Rational Functional Tester
8.0
8.0.0.2
8.1
8.1.0.1
8.1.1
8.1.1.1
8.1.1.2
8.1.1.3
Rational Performance Tester 7.0.1.2
8.0
8.0 8.1 8.1.0.1 8.1.1 8.1.1
8.1.1.1
8.1.1
8.1.1.1
8.1.1
8.1.1.1
Rational Software Architect 7.0.0.6
7.5
7.5 7.5.3 7.5.3 7.5.5 7.5.5 7.5.5 7.5.5
Rational Application Developer 7.0.0.6
7.5
7.5 7.5.3 7.5.3 7.5.5 7.5.5
7.5.5.1
7.5.5
7.5.5.1
7.5.5
7.5.5.1

Table 4 lists only the versions that have been tested for compatibility.

Note: Rational Performance Tester, Rational Software Architect and Rational Application Developer can shell share with Rational Functional Tester provided that they share the same Eclipse version.

For details see: 1279139: Information about which IBM Software products can be installed together so that they share a common environment for information on Rational product compatibility.

Note: For information pertaining to the versions and supported features, refer the respective topic notes available in the Rational Functional Tester Information Centre.




Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Functional Tester
Documentation

Software version:

8.0, 8.0.0.1, 8.0.0.2, 8.0.0.3, 8.1, 8.1.0.1, 8.1.0.2, 8.1.0.3, 8.1.1, 8.1.1.1, 8.1.1.2, 8.1.1.3

Operating system(s):

Linux, Windows

Reference #:

7017504

Modified date:

2012-05-31

Translate my page

Machine Translation

Content navigation