Content Manager OnDemand for i requirements

Product documentation


Abstract

This document describes the minimum system requirements for IBM® Content Manager OnDemand for i, Version 7.1. For installation requirements, refer to the product-specific readme files.

Content

The exact configuration you need to support your environment with satisfactory response time will vary, depending on the size of the objects you are working with and other factors. Individual display response times vary depending on workstation speed, memory, size of objects, and network and server workload. The minimum recommended configurations that follow need to be evaluated and adjusted according to your unique requirements. Disk space recommendations are for the product installation and working space only. The actual hard disk space required varies, depending upon your installation. See the hardware and software requirements and announcement letter links below for more information about the IBM Content Manager portfolio.

In addition to the details below, also note this important prerequisite information:

Tab navigation

Tab navigation


Tab navigation


Client end user requirements



Important: All of the components mentioned in this document are required unless specifically noted.

If you do not have a supported version of the required software, you can download it from the IBM Passport Advantage Online Web site.

Legend
Icon Description
Supported Supported
Δ Added or changed information since the last release, modification, or fix pack. This mark in the far left column indicates new or changed information in the row.


Hardware platforms for the Content Manager OnDemand for i server

The following table provides a list of the supported hardware platforms for the Content Manager OnDemand for i server.

Any IBM System i™ processor capable of running IBM i Version 7.1

Operating systems for the IBM Content Manager OnDemand for i server

The following table specifies the supported operating systems by hardware platform for the Content Manager OnDemand for i server.

Content Manager OnDemand for i Version 7.1 server requires IBM i Version 7.1 (5770-SS1)

Additional software supported with Content Manager OnDemand for i

The following table specifies additional supported software for the Content Manager OnDemand for i.

Software IBM i (5770-SS1) product option number Notes
IBM i Access Version 7.1 (for administrative client functions; 5770-XE1) N/A N/A
Qshell Version 7.1 30 N/A
International Components for Unicode Version 7.1 (required even if you do not use Unicode ) 39 N/A
If the locale that you require must be created from source code: Extended NLS Support Version 7.1 21 This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
If you plan to use the text search function for AFPDS documents: Portable Application Solutions Environment (PASE) Version 7.1 33 This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
If you plan to use the OnDemand server print function for AFP documents or if you plan to use the server fax function for any documents in OnDemand: PSF for IBM i Version 7.1 36, 37, or 38 (depending on the number and speed of your printers) This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
Highly recommended if you use an IBM tape library: IBM Backup, Recovery and Media Services for i Version 7.1 (5770-BR1) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
If you plan to use ODWEK support for Java servlets or Java APIs: IBM WebSphere® Application Server (5733-W61 or later) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
If you plan to use ODWEK support for Java servlets or Java APIs: IBM Developer Kit for Java (5761-JV1) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
If you plan to use Tivoli Storage Manager: Tivoli Storage Manager APIs (5733-197) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
IBM Facsimile Support for i (5798-FAX) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
IBM Advanced Function Printing Utilities Version 7.1 (5770-AF1) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.
DB2® Query Manager and SQL Development Kit Version 7.1 (5770-ST1) or Query for i Version 7.1 (5770-QU1) N/A This software is recommended for certain environments, and must be at a release level that is compatible with IBM i Version 7.1.

Client/server protocols for the IBM Content Manager OnDemand for i server

The following table specifies the supported client and server protocols for Content Manger OnDemand for i server.

TCP/IP

Content Manager OnDemand end user hardware requirements

The following table specifies the supported hardware requirements for Content Manager OnDemand for i end user software.

Hardware requirements Windows Client Windows administration client ODWEK Web Viewer (AFP/Image) ODWEK applets
All Intel and AMD processors capable of running the supported Windows operating systems (32-bit and 64-bit based systems) Supported Supported Supported Supported

Content Manager OnDemand end user software requirements

The following table specifies the supported software requirements for Content Manager OnDemand client software.

Software requirements Windows Client Windows administration client ODWEK Web Viewer (AFP/Image) ODWEK applets Additional requirements/notes
Windows XP SP3 or later; Windows Vista SP2 or later; or Windows 7 SP1 or later Supported Supported Supported Supported
Microsoft Internet Explorer V8.0 or later; or Mozilla Firefox V10.0 or later Supported Supported Supports only 32-bit versions of the browsers.
Adobe Acrobat Supported(For embedded viewer within client) Supported(For PDF graphical indexer)
Adobe Reader Supported(Launched as external MIME-type viewer)
Java V1.6 or later (32-bit only) Supported

Java servlet supported for the IBM Content Manager OnDemand for i server

The following table specifies the supported Java servlet for Content Manger OnDemand for i server.

A Java™-enabled IBM i configured IBM WebSphere® Application Server that uses IBM i Version 7.1 and Java Version 1.5 or later

Java applet supported for the IBM Content Manager OnDemand for i server

The following table specifies the supported Java applet for Content Manger OnDemand for i server.

Java Version 1.5 or later

Java applet supported for the IBM Content Manager OnDemand for i server

The following table specifies the supported Java applet for Content Manger OnDemand for i server.

Java Version 1.5 or later

Browsers supported for the IBM Content Manager OnDemand for i server

The following table specifies the supported browsers for Content Manger OnDemand for i server.

Any browser listed in the client software requirements section that can write cookie data on the client. Configure the Web browser to accept all cookies. Ensure that UTF-8 is enabled.

Change history
History Date Change
Release June 2011 Updated V7.1 with new standards.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Content Manager OnDemand for i

Software version:

7.1

Operating system(s):

IBM i

Software edition:

All Editions

Reference #:

7016180

Modified date:

2014-05-01

Translate my page

Machine Translation

Content navigation