System requirements for IBM Optim Development Studio Version 2.2.x

Product documentation


Abstract

This document describes the system requirements for IBM® Optim™ Development Studio Version 2.2.x.

Content

Ensure that your computer meets the system requirements before you install IBM Optim Development Studio Version 2.2.x.


Hardware requirements


Component Requirements
Memory Minimum of 1 GB RAM. Recommended 2 GB RAM
Disk space Minimum of 1 GB of disk space is required for product package installation. Additional disk space is required for the resources that you develop.

Fix packs require additional disk space for download and extraction. See the download document for each fix pack for detailed requirements.
Display 1024 x 768 display minimum using 256
Colors (or higher for best results)
Other hardware MicrosoftR mouse or compatible
pointing device



Software requirements

The product supports the following operating systems:

Linux
Operating system Hardware Comments
Red Hat Enterprise Linux Desktop 4.0 x86-32
Red Hat Enterprise Linux Desktop 5.0 x86-32 Version 2.2.1
Red Hat Enterprise Linux Server 4.0
  • AS Edition
  • ES Edition
x86-32
Red Hat Enterprise Linux Server 4.0
  • AS Edition
  • ES Edition
x86-64 Version 2.2.1
Product runs in 32-bit mode.
Red Hat Enterprise Linux Server 5.0
  • AS Edition
  • ES Edition
x86-32
Red Hat Enterprise Linux Server 5.0
  • AS Edition
  • ES Edition
x86-64 Product runs in 32-bit mode.
SUSE Linux Enterprise Server 9.0 x86-32
SUSE Linux Enterprise Server 9.0 x86-64 Version 2.2.1
Product runs in 32-bit mode.
SUSE Linux Enterprise Server 10 x86-32
SUSE Linux Enterprise Server 10 x86-64 Version 2.2.1
Product runs in 32-bit mode.
SUSE Linux Enterprise Desktop 10 x86-32


Windows
Operating system Hardware Comments
Microsoft Windows Server 2003
  • Enterprise Edition (SP1)
  • Standard Edition (SP1)
x86-32
Microsoft Windows Server 2003
  • Standard Edition
x86-64 Product runs in 32-bit mode.
Microsoft Windows Server 2003 R2
  • Enterprise Edition
  • Standard Edition
x86-32
Microsoft Windows Server 2008
(Vista Longhorn Server)
x86-32
Microsoft Windows Server 2008
  • Enterprise Edition
  • Standard Edition
x86-32 SP2 supported in version 2.2.0.2 and later
Microsoft Windows XP Professional (SP2) x86-64 Product runs in 32-bit mode.
Microsoft Windows XP Professional (SP2) x86-32
Microsoft Windows Vista
  • Business Edition
  • Enterprise Edition
  • Ultimate Edition
x86-32
Microsoft Windows Vista
  • Business Edition
  • Enterprise Edition
  • Ultimate Edition
x86-64 Product runs in 32-bit mode.
Windows 7
  • Enterprise Edition
  • Professional Edition
  • Ultimate Edition
x86-32 Version 2.2.0.2 and later

Requires Installation Manager 1.3.2 or later
Windows 7
  • Enterprise Edition
  • Professional Edition
  • Ultimate Edition
x86-64 Version 2.2.1
Product runs in 32-bit mode.

Requires Installation Manager 1.3.2 or later


This version of the product was developed for use with the following Eclipse and JDK versions. These Eclipse and JDK levels are included with the product, but if you are extending an existing Eclipse environment, they are prerequisites.

Eclipse level JDK level ODS version
Eclipse 3.4.2 IBM JDK 1.6 SR 7 Version 2.2.0.2 and later
Eclipse 3.4.2 IBM JDK 1.6 SR 5 Versions 2.2. and 2.2.0.1

Ensure that you have one of the following Web browsers to view
the readme file and the installation guide:

  • Microsoft Internet Explorer 6.0 with Service Pack 1 (available on Microsoft Windows only)
  • Mozilla 1.6 or 1.7
  • Firefox 2.0 or later


Supported data sources

The product supports the following data sources:

Database Version Comments
DB2 for Linux, UNIX, and Windows 1, 5 9.1
9.5
9.7
9.8 Version 2.2.1

Toleration mode
DB2 for iSeries V5R4
DB2 for z/OS 1 8.1
9.1 Version 2.2.0.3 and later

Version 2.2.0.3 supports compatibility mode and new function mode
10.1 Version 2.2.1
IBM Informix data server 3, 4 10.0 2
11.1 2
11.5 2
11.7 Version 2.2.1
Oracle 1 10g
10g R2
11g
Sybase ASE 15.0 Version 2.2.1.1

Notes:

  1. Supported for SQL management repository.
  2. Supported for Optim pureQuery Runtime, not supported for routine development and debugging.
  3. Stored procedure debugging supported for supported for Informix 11.7 and later.
  4. Visual Explain supported for Informix 11.5 and later.
  5. Optim Development Studio Version 2.2.1.1 supports using the ANTs Software product IBM® DB2 SSacSA with a DB2 for Linux, UNIX, and Windows database to connect to the database as a Sybase database. You can view the database objects and develop and test SQL stored procedures on the database.


Driver support

IBM Optim Development Studio, Version 2.2.1 requires the following drivers:

  • Oracle clients:
    Oracle Database Version 11g Release 1 JDBC Drivers
      ojdbc5.jar
      ojdbc6.jar
      datadirect Version 4.0
    Oracle Database Version 10g R2
      ojdbc5.jar
      datadirect Version 4.0
  • JDBC application clients:
    IBM Data Server Driver for JDBC and SQLJ v4.7 or later for JDBC 4.0 applications
    IBM Data Server Driver for JDBC and SQLJ v3.57 or later or corresponding DB2 Connect version level) for JDBC 3.0 applications
    JAVA Runtime Environment 1.6

IBM Optim Development Studio, Version 2.2.1.1 requires ANTs software to connect to a DB2 for Windows, UNIX and Windows database as a Sybase database.


Hosted development environments

IBM Optim Development Studio, Version 2.2.x supports the following hosted development environments:

Software Version Comments
Citrix Presentation Server 4.5 Supported in Version 2.2.1.1
Citrix XenApp 5 Supported in Version 2.2.1.1



Other requirements

  • To deploy pureQuery applications to another computer: IBM Optim pureQuery Runtime Version 2.2.1
  • To view database performance data from an Optim Performance Manager repository database with Optim Development Studio Version 2.2.1.1, Optim Performance Manager Version 4.1, Version 4.1.0.1, or Version 4.1.1 must be installed. InfoSphere Optim Performance Manager Version 5.1 is not supported.
    Use IBM Data Studio Version 3.1 to view database performance data from InfoSphere Optim Performance Manager Version 5.1 repository database.


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Optim Development Studio

Software version:

2.2, 2.2.0.1, 2.2.0.2, 2.2.0.3, 2.2.1, 2.2.1.1

Operating system(s):

Linux, Windows

Reference #:

7015710

Modified date:

2011-12-09

Translate my page

Machine Translation

Content navigation