InfoSphere Federation Server Version 9.7 data source requirements

Product documentation


Abstract

The supported data sources of IBM® InfoSphere™ Federation Server are shown in the following tables.

Content

The first table specifies support from 32-bit operating systems and lists the requirements for data client software. The second table specifies support from 64-bit operating systems.

The client software must be acquired separately unless specified otherwise. You must install the client software for the data sources that you want to access on the same system as IBM InfoSphere Federation Server. You also need the appropriate Java™ SDK to use some tools such as the DB2® Control Center and to create and run Java applications, including stored procedures and user-defined functions.

Table 1. Supported data sources, client software requirements, and support from 32-bit operating systems.

32-bit hardware architecture
and
operating system
X86-32
X86-32
Data Source
Supported Versions
Client Software
Linux ,
RedHat Enterprise Linux (RHEL),
SUSE
Windows
BioRS 5.2, 5.3 None
Y
Y
DB2 for Linux®, UNIX®, and Windows® 8.1.x, 8.2.x, 9.1, 9.5, 9.7, 9.8 None
Y
Y
DB2 for z/OS® 7.x, 8.x, 9.x, 10 DB2 Connect™ V9.7
Y
Y
DB2 for System i® 5.2, 5.3, 5.4, 6.1, 7.1 DB2 Connect V9.7
Y
Y
DB2 Server for VSE and VM 7.2, 7.4 DB2 Connect V9.7
Y
Y
Flat files None
Y
Y
Informix® Informix XPS 8.50, 8.51 and Informix IDS 7.31, 9.40, 10.0, 11.1, 11.5, 11.7 Informix Client SDK version 2.81 TC2 or later; 3.0 or higher required for SLES 10 on Power
Y
Y
JDBC 3.0 or later JDBC drivers that comply with JDBC 3.0 or later
Y
Y
Microsoft® Excel 2000, 2002, 2003, 2007 None
Y
Microsoft SQL Server Microsoft SQL Server 2000 SP4, 2005, 2008, 2008R2, 2012 For Windows, Microsoft SQL Server Client ODBC 3.0 (or later) driver.

For UNIX, DataDirect ODBC 5.3, 6
Y
Y
MQ MQ7 MQ7
Y
Y
ODBC 3.0 ODBC drivers that comply with ODBC 3.0 or later 1
Y
Y
OLE DB 2.7, 2.8 OLE DB 2.0 or later
Y
Y
Oracle 10g, 10gR2, 11g, 11gR1, 11gR2 Oracle NET client 10.0 - 10.1, 10.2.0.1 with patch 3807408, 10.1.0.3 with patch 3807408, 11.1.0.6.0
Y
Y
Sybase Sybase ASE 12.5, 15.0, 15.5 Sybase Open Client 12.5 - 15.5
Y
Y
Teradata 2.5, 2.6, 12, 13 Shared Common Components for Internationalization for Teradata (tdicu) version 1.01 or later, Teradata Generic Security Services (TeraGSS) version 6.01 or later, and the software on the following operating systems:

For Windows, Teradata API library Call-Level Interface Version 2, release 4.8.0 or later

For UNIX and Linux, Teradata Call-Level Interface Version 2, Release 4.8.0 or later
Y
Y
Web Services WSDL 1.0, 1.1
SOAP 1.0, 1.1
None
Y
Y
XML XML1.0, XML1.1 None
Y
Y
1 ODBC can be used to access RedBrick 6.20.UC5 and 6.30, InfoSphere Classic Federation for z/OS V8.2 and later, among other data sources.

Table 2. Support from 64-bit operating systems.

64-bit hardware architecture
X86-64
X86-64
Power
Itanium ®
Power
Sparc
zSeries ®
Operating system
Linux
RHEL
SUSE
Windows
AIX ®
HP-UX
Linux
RHEL
SUSE
Solaris
Linux
RHEL
SUSE
Data Source
BioRS
Y
Y
Y
Y
Y
Y
Y
DB2 for Linux, UNIX, and Windows
Y
Y
Y
Y
Y
Y
Y
DB2 for z/OS
Y
Y
Y
Y
Y
Y
Y
DB2 for iSeries
Y
Y
Y
Y
Y
Y
Y
DB2 Server for VSE and VM
Y
Y
Y
Y
Y
Y
Y
Informix
Y
Y
Y
Y
Y
Y
JDBC
Y
Y
Y
Y
Y
Y
Y
Microsoft Excel
Microsoft SQL Server
Y
Y
Y
Y
Y
Y
MQ
Y
Y
Y
Y
Y
Y
ODBC
Y
Y
Y 2
Y
Y 2
Y
OLE DB
Y
Y
Oracle
Y
Y
Y
Y
Y
Y
Y
Script
Y
Y
Y
Y
Y
Y
Y
Sybase
Y
Y
Y
Y
Y
Y
Teradata
Y
Y
Y
Y
Y
Web Services
Y
Y
Y
Y
Y
Y
Y
XML
Y
Y
Y
Y
Y
Y
Y
2 ODBC can be used to access RedBrick 6.20.UC5 and 6.30 and InfoSphere Classic Federation for z/OS V8.2 and later using 32-bit and 64-bit clients.

Original publication date

2009/7/24

Rate this page:

(0 users)Average rating

Document information


More support for:

InfoSphere Federation Server
Federated Server

Software version:

9.7

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

7015299

Modified date:

2010-10-04

Translate my page

Machine Translation

Content navigation