System requirements: Software requirements for IBM DB2 Content Manager Enterprise Edition Version 8.4.1 Fix Pack 1

Product documentation


Abstract

This page describes the minimum system requirements for the software to operate IBM® DB2® Content Manager Enterprise Edition V8.4.1 Fix Pack 1.

Important:
Because other products frequently ship fixes, updates, and new releases, testing every configuration is not possible. In general, you can install and run with updates to supported products if those updates are forward compatible. For detailed examples about what is supported, see the IBM Content Manager prerequisite support policy at http://www.ibm.com/support/docview.wss?uid=swg27018047.

DB2 Content Manager Enterprise Edition V8.4.1 Fix Pack 1 hardware requirements did not change from V8.4.1. See the Related information link at the bottom of this document.

Requirements for DB2 Content Manager for z/OS® V8.4.1 Fix Pack 1 are listed separately. See the Related information link at the bottom of this document.

Content


Legend
Supported
Supported
Δ
Added or changed information since the last fix pack. This mark in the far left column indicates new or changed information in the row. This mark in a particular cell within a row further identifies a specific change within an existing row.
x86 Intel® 32-bit processors, including IBM System x®, eServer™ xSeries®, and BladeCenter® servers.
x86-64 64-bit AMD® Opteron® (AMD64) and Intel Xeon® (EM64T) processors, including IBM System x® and BladeCenter® servers
SPARC Sun SPARC-based processors
POWER IBM POWER® based processors, including IBM System p®, eServer pSeries®, System i® and eServer iSeries® servers.
IA64 64-bit Intel® Itanium® 2 processors including HP Integrity Servers
zSeries 64-bit System z®

 

Operating system (servers)

The following table specifies the operating system for any machine on which you install one or more of the following components:

  • Library server
  • Resource manager
  • Information Integrator for Content
  • eClient application
Operating system (Required) Hardware platform: Notes
x86
x86-64
POWER
SPARC
zSeries
IA64
AIX® 5L™ 5.2 (64-bit) (Technology level 9, 10)
Supported on POWER
AIX 5L 5.3 (64-bit) (Technology level 5, 6, 7)
Supported on POWER
AIX 6.1
Supported on POWER
HP-UX 11i v2 11.23.0609 (64-bit)
Supported on IA64
For HP-UX, see Article #7014360
HP-UX 11i v3 B.11.31 (64-bit)
Supported on IA64
For HP-UX, see Article #7014360
Red Hat Enterprise Linux® AS/ES/WS 4.0 (32-bit) Kernel 2.6.9-5 (update 3)
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 4.0 (64-bit) Kernel 2.6.9-5 (update 3)
Supported on x86-64
Supported on zSeries
Article #7011062
Red Hat Enterprise Linux AS/ES/WS 5.0 (32-bit) Kernel 2.6.18-8.el5xen
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 5.0 (64-bit) Kernel 2.6.18-8.el5xen
Supported on x86-64
Supported on zSeries
Article #7011062
SUSE Linux Enterprise Server 9 (32-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 9 (64-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86-64
Supported on zSeries
SUSE Linux Enterprise Server 10 SP1 (32-bit) Kernel 2.6.16.21-0.8-default
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 10 SP1 (64-bit) Kernel 2.6.16.21-0.8-default
Supported on x86-64
Supported on zSeries
On zSeries, you need Bugzilla patch for 49038
(s390-sles10sp2-26-03-qeth-osncheck.patch)
SUSE Linux Enterprise Server 10 SP2 (32-bit)
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 10 SP2 (64-bit)
Supported on x86-64
Supported on zSeries
On zSeries, you need Bugzilla patch for 49038
(s390-sles10sp2-26-03-qeth-osncheck.patch)
Solaris 9 (64-bit)
Supported on SPARC
Solaris 10 (64-bit)
Supported on x86
Supported on x86-64
Supported on SPARC
Windows Server 2003 Standard Edition (32-bit) or with SP1 or SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 Standard Edition (64-bit) or with SP1 or SP2
Supported on x86-64
Article #1378080

Information Integrator for Content system administration database is not supported.
Windows Server 2003 Enterprise Edition (32-bit)or with SP1 or SP2 Supported on x86
Supported on x86-64
Δ Windows Server 2003 Enterprise Edition (64-bit)or with SP1 or SP2
Supported on x86-64
Article #1378080

Information Integrator for Content system administration database is not supported.
Windows Server 2003 R2 (32-bit) or with SP2 Supported on x86
Supported on x86-64
Δ Windows Server 2003 R2 (64-bit) or with SP2
Supported on x86-64
Article #1378080

Information Integrator for Content system administration database is not supported.
Windows Server 2008 (32-bit)
Supported on x86
Supported on x86-64
The eClient advanced workflow function, which uses WebSphere MQ workflow, is not supported.

The C++ API and the Client for Windows user exit are not supported.

The library server user exit compiled on Win2003/VS2005 is supported.
Δ Windows Server 2008 (64-bit)
Supported on x86-64
Article #1378080

Information Integrator for Content system administration database is not supported.

The eClient advanced workflow function, which uses WebSphere MQ workflow, is not supported.

The C++ API and the Client for Windows user exit are not supported.

The library server user exit compiled on Win2003/VS2005 is supported.

Back to top

Operating system (system administration client)

The following table specifies the operating system for any machine on which you install the system administration client.

Operating system (Required) Hardware platform: Notes
x86
x86-64
POWER
SPARC
zSeries
IA64
AIX 5L 5.2 (64-bit) (Technology level 9, 10)
Supported on POWER
AIX 5L 5.3 (64-bit) (Technology level 5, 6, 7)
Supported on POWER
AIX 6.1
Supported on POWER
HP-UX 11i v2 11.23.0609 (64-bit)
Supported on IA64
HP-UX 11i v3 B.11.31 (64-bit)
Supported on IA64
Red Hat Enterprise Linux AS/ES/WS 4.0 (32-bit) Kernel 2.6.9-5 (update 3)
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 4.0 (64-bit) Kernel 2.6.9-5 (update 3)
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 5.0 (32-bit) Kernel 2.6.18-8.el5xen
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 5.0 (64-bit) Kernel 2.6.18-8.el5xen
Supported on x86-64
SUSE Linux Enterprise Server 9 (32-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 9 (64-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86-64
SUSE Linux Enterprise Server 10 SP1 (32-bit) Kernel 2.6.16.21-0.8-default
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 10 SP1 (64-bit) Kernel 2.6.16.21-0.8-default
Supported on x86-64
SUSE Linux Enterprise Server 10 SP2 (32-bit)
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 10 SP2 (64-bit)
Supported on x86-64
Solaris 9 (64-bit)
Supported on SPARC
Solaris 10 (64-bit)
Supported on x86
Supported on x86-64
Supported on SPARC
Windows Server 2003 Standard Edition (32-bit) or with SP1 or SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 Standard Edition (64-bit) or with SP1 or SP2
Supported on x86-64
Article #1378080
Windows Server 2003 Enterprise Edition (32-bit) or with SP1 or SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 Enterprise Edition (64-bit) or with SP1 or SP2
Supported on x86-64
Article #1378080
Windows Server 2003 R2 (32-bit) or with SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 R2 (64-bit) or with SP2
Supported on x86-64
Article #1378080
Windows Server 2008 (32-bit)
Supported on x86
Supported on x86-64
Δ Windows Server 2008 (64-bit)
Supported on x86-64
Article #1378080
Windows XP Professional (32-bit) SP2 or SP3
Supported on x86
Windows Vista Business Edition (32-bit)or SP1
Supported on x86
Windows Vista Ultimate Edition (32-bit) or SP1
Supported on x86
Windows Vista Enterprise Edition (32-bit) or SP1
Supported on x86

Back to top

Operating system (DB2 Information Integrator for Content Connectors & Toolkits)

The following table specifies the operating system for any machine on which you install DB2 Information Integrator for Content connectors and toolkits. Note that all connectors are not supported on all operating systems. See Connectors for operating system support details.

Restriction: The Information Integrator for Content system administration database does not support 64-bit Windows, see Article #1378080.

Operating system (Required) Hardware platform: Notes
x86
x86-64
POWER
SPARC
zSeries
IA64
AIX 5L 5.2 (64-bit) (Technology level 9, 10)
Supported on POWER
AIX 5L 5.3 (64-bit) (Technology level 5, 6, 7)
Supported on POWER
AIX 6.1
Supported on POWER
HP-UX 11i v2 11.23.0609 (64-bit)
Supported on IA64
HP-UX 11i v3 B.11.31 (64-bit)
Supported on IA64
Red Hat Enterprise Linux AS/ES/WS 4.0 (32-bit) Kernel 2.6.9-5 (update 3)
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 4.0 (64-bit) Kernel 2.6.9-5 (update 3)
Supported on x86-64
Supported on zSeries
Red Hat Enterprise Linux AS/ES/WS 5.0 (32-bit) Kernel 2.6.18-8.el5xen
Supported on x86
Supported on x86-64
Red Hat Enterprise Linux AS/ES/WS 5.0 (64-bit) Kernel 2.6.18-8.el5xen
Supported on x86-64
Supported on zSeries
SUSE Linux Enterprise Server 9 (32-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86
Supported on x86-64
SUSE Linux Enterprise Server 9 (64-bit) Kernel 2.6.5-7.97 (SP3)
Supported on x86-64
Supported on zSeries
SUSE Linux Enterprise Server 10 SP1 (32-bit) Kernel 2.6.16.21-0.8-default
Supported on x86
Supported on x86-64
XML import/export, XML SDK and XML Beans are not supported.
SUSE Linux Enterprise Server 10 SP1 (64-bit) Kernel 2.6.16.21-0.8-default
Supported on x86-64
Supported on zSeries
XML import/export, XML SDK and XML Beans are not supported.
SUSE Linux Enterprise Server 10 SP2 (32-bit)
Supported on x86
Supported on x86-64
XML import/export, XML SDK and XML Beans are not supported.
SUSE Linux Enterprise Server 10 SP2 (64-bit)
Supported on x86-64
Supported on zSeries
XML import/export, XML SDK and XML Beans are not supported.
Solaris 9 (64-bit)
Supported on SPARC
Solaris 10 (64-bit)
Supported on x86
Supported on x86-64
Supported on SPARC
Windows Server 2003 Standard Edition (32-bit)or with SP1 or SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 Standard Edition (64-bit)or with SP1 or SP2
Supported on x86-64
Article #1378080
Windows Server 2003 Enterprise Edition (32-bit)or with SP1 or SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 Enterprise Edition (64-bit)or with SP1 or SP2
Supported on x86-64
Article #1378080
Windows Server 2003 R2 (32-bit) or with SP2
Supported on x86
Supported on x86-64
Δ Windows Server 2003 R2 (64-bit) or with SP2
Supported on x86-64
Article #1378080
Windows Server 2008 (32-bit)
Supported on x86
Supported on x86-64
Δ Windows Server 2008 (64-bit)
Supported on x86-64
Article #1378080
Windows XP Professional (32-bit) SP2 or SP3
Supported on x86
Windows Vista Business Edition (32-bit) or SP1
Supported on x86
Windows Vista Ultimate Edition (32-bit) or SP1
Supported on x86
Windows Vista Enterprise Edition (32-bit) or SP1
Supported on x86

Back to top

Operating system (Client for Windows)

The following table specifies the operating system for any machine on which you install the Client for Windows.

Operating system (Required) Hardware platform: otes
x86
x86-64
POWER
SPARC
IA64
Windows Server 2003 Standard Edition (32-bit) or with SP1 or SP2
Supported on x86
Supported on x86-64
Windows Server 2003 Standard Edition (64-bit) or with SP1 or SP2 Article #1378080
Windows Server 2003 Enterprise Edition (32-bit) or with SP1 or SP2
Supported on x86
Supported on x86-64
Windows Server 2003 Enterprise Edition (64-bit) or with SP1 or SP2 Article #1378080
Windows Server 2003 R2 (32-bit) or with SP2
Supported on x86
Supported on x86-64
Windows Server 2003 R2 (64-bit) or with SP2 Article #1378080
Windows Server 2008 (32-bit)
Supported on x86
Supported on x86-64
Windows Server 2008 (64-bit) Article #1378080
Windows XP Professional (32-bit) or with SP2 or SP3
Supported on x86
Windows Vista Business Edition (32-bit) or SP1
Supported on x86
Windows Vista Ultimate Edition (32-bit) or SP1
Supported on x86
Windows Vista Enterprise Edition (32-bit) or SP1
Supported on x86

Back to top

Database server

The following table specifies the database server required for each of the following components:

  • Library server
  • Resource manager
  • Information Integrator for Content
  • Information Integrator for Content system administration database

Restriction: The Information Integrator for Content system administration database does not support 64-bit Windows.

Database (Required) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
DB2 Universal Database™ Enterprise Server Edition V8.2 FP 8 (8.1 FP 15) or later (32-bit)
Supported on AIX
Supported  on Linux
Supported on Solaris
Supported on Windows
Not supported on Windows 2008.
DB2 Universal Database Enterprise Server Edition V8.2 FP 8 (8.1 FP 15) or later (64-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Solaris x86-64
For DB2 V8.1 FP 15 (64-bit) users on Solaris and Linux:
  • If you want to stay on FP15, you must apply the workaround for DB2 APAR IZ08133
  • If you move to FP16, APAR IZ08133 is included.
DB2 Enterprise Server Edition V9.1 FP3 or later (32-bit)
Supported  on Linux
Supported on Windows
For Windows 2008, see DB2 Enterprise Server V9.5 (32-bit)

Article #1289946
DB2 Enterprise Server Edition V9.1 FP3 or later (64-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Solaris x86-64
Δ Supported on Windows
Article #1378080


Article #1289946

Windows 2003 requires Fix Pack 6 or later.

Windows 2008 requires Fix Pack 8 or later.

For HP-UX V2 and V3, the minimum level is FP3A.
Δ
DB2 Enterprise Server Edition V9.5 FP3A or later (32-bit)
Supported on Windows
Δ
DB2 Enterprise Server Edition V9.5 FP3A or later (64-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Solaris x86-64
Δ Supported on Windows
Article #1378080

Windows 2008 requires APAR JR32152.

AIX users:
  • AIX 6.1: You must apply APAR IZ17493 (minimum level that contains this APAR is AIX 6.1 TL0 SP4)
  • AIX 5.3 TL7: You must apply APAR IZ14991 (minimum level that contains this APAR is AIX 5.3 TL7 SP3)
  • AIX 5.3 TL6: You must apply APAR IZ07615 (minimum level that contains this APAR is SP6)
Oracle Database Enterprise Edition 10.2.0.3 with patch 3 or later (Windows) (32-bit)

Oracle Database Enterprise Edition 10.2.0.3 with patch 4722328 or later (UNIX®) (32-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Windows
Windows 2008 requires Oracle Database Enterprise Edition 10.2.0.4 or later.

Linux users using Oracle: If you support LDAP user authentication, you must manually install Tivoli Directory Server V6.1 client and its 32-bit library. See instructions.

HP-UX users using Oracle: Oracle 10.2.0.4 is not supported at this time due to Oracle defect SR 7193872.994.

Norwegian customers: You must additionally apply Oracle Metalink patch #743191 to any Oracle client that will run DB2 Content Manager clients.
Δ Oracle Database Enterprise Edition 10.2.0.3 with patch 3 or later (Windows) (64-bit)

Oracle Database Enterprise Edition 10.2.0.3 with patch 4722328 or later(UNIX) (64-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Solaris x86-64
Article #1378080
Oracle 11g Not supported.

Back to top

Text search capability (library server)

The following table specifies the required software for implementing the optional text search capability for installation on the library server.

HP-UX only: If you need an upgrade path from 8.3 to 8.4.1, then contact IBM service.

Text search (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
DB2 Net Search Extender 8.2 or later
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Fix pack level of DB2 Net Search Extender must match the DB2 fix pack level: Article #1222986

For DB2 V8.1 FP15 on Windows, DB2 Net Search Extender must be 8.2.7 (8.1 FP14).
Δ DB2 Net Search Extender 9.1 FP3 or later
Supported on AIX
Δ Supported  on HP-UX
Supported on Linux
Supported on Solaris
Supported on Windows
Article #1397516
Δ DB2 Net Search Extender 9.5 or later
Supported on AIX
Δ Supported  on HP-UX
Supported on Linux
Supported on Solaris
Supported on Windows
You must apply APAR IC58550.

Article #1397516
Oracle Database Enterprise Edition 10.2.0.3 with patch 3 or later (Windows) (32-bit)

Oracle Database Enterprise Edition 10.2.0.3 with patch 4722328 or later (UNIX®) (32-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris Supported on Windows For HP-UX, see Article #7014360
Δ Oracle Database Enterprise Edition 10.2.0.3 with patch 3 or later (Windows) (64-bit)

Oracle Database Enterprise Edition 10.2.0.3 with patch 4722328 or later (UNIX®) (64-bit)
Supported on AIX
Supported  on HP-UX
Supported  on Linux
Supported on Solaris
Supported on Solaris x86-64
Article #1378080

For HP-UX, see Article #7014360

Back to top

Connection to a remote database

The following table specifies the required software from any of the following components to a remote database (if the database is on a different machine):

  • Client for Windows

The following components no longer require the DB2 Run-Time Client when configured to use the JDBC driver in Type 4 mode. However, the Run-Time Client is required when the JDBC driver is run in type 2 mode. For more details on configuring for type 4, see IBM DB2 driver for JDBC and SQLJ support in DB2 Content Manager Version 8.4. The table below specifies the required software when these components are run using JDBC type 2 mode. HP-UX and Solaris x86-64 support only Type 4 JCC.

  • Resource manager application
  • Information Integrator for Content
  • System administration client

For more information on 32-bit and 64-bit information, refer to Article #1293849.

Database connection (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
DB2 Run-Time Client V8.2 (8.1 FP 7a) or later fixpack
Supported on Windows
Minimum level for Client for Windows and DB2 Content Manager connector only.
DB2 Run-Time Client V9.1 FP 3 or later fixpack (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Minimum level for resource manager, system administration client, and Java connectors.
DB2 Run-Time Client V9.1 FP6 or later fixpack (32-bit)
Supported on Windows
This applies to Windows 2008 only. See Article 1321616.
DB2 Run-Time Client V9.5 or later fixpack
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
DB2 Connect Personal Edition V9.1 FP3 or later fixpack
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Required for connecting to the library server on z/OS
DB2 Connect Personal Edition V9.5 or later fixpack
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Required for connecting to the library server on z/OS
Oracle 10g R2 Client 10.2.0.3 patchset 3 or later (Windows) or patch 4722328 or later (UNIX) (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ Oracle 10g R2 Client 10.2.0.3 patchset 3 or later (Windows) or patch 4722328 or later (UNIX) (64-bit) Supported on AIX Supported on Linux
Supported on Solaris
Supported on Solaris x86-64 Article #1378080

Back to top

Web application server

The following table specifies the application server required for the following components:

  • Resource manager application
  • eClient application

Connector: The eClient application also requires DB2 Content Manager V8 connector to connect to your content server or servers. Use the DB2 Information Integrator for Content installation program to install the DB2 Content Manager V8 connector.

WebSphere Application Server with IBM HTTP Server (IHS) is supported.

Restriction: You must use a 32-bit instance of WebSphere® Application Server, see Article #1293849. Exception: Solaris Opteron must use a 64-bit instance.

Web application server (Required) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
WebSphere Application Server V6.1.0 Fix Pack 11 or later (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
For Windows 2008, the minimum supported level is Fix Pack 19
WebSphere Application Server V6.1.0 Fix Pack 11 (64-bit)
Supported on Solarisx86-64
WebSphere Application Server Network Deployment V6.1.0 Fix Pack 11 or later (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
WebSphere Application Server Network Deployment V6.1.0 Fix Pack 11 or later (64-bit)
Supported on HP-UX
Supported on Solarisx86-64
WebSphere Application Server V7.0 or later (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
  • Not supported on Oracle.
  • Not supported for DB2 Content Manager Web services on DB2.
  • Before configuring the eClient, you must install IFix 548744.
WebSphere Application Server Network Deployment V7.0 or later (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
  • Not supported on Oracle.
  • Not supported for DB2 Content Manager Web services on DB2.
  • Before configuring the eClient, you must install IFix 548744.

Back to top

Lightweight Directory Access Protocol (LDAP) (library server)

The following table specifies the required software for the optional LDAP capability on the library server.

LDAP (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
Tivoli® Directory Server 6.0
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Tivoli Directory Server 6.1
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Δ Tivoli Directory Server 6.2
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Novell eDirectory 8.8
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Novell eDirectory 8.8.1
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus® Domino® Directory 6.2
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus Domino Directory 6.5
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus Domino Directory 7.0
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus Domino Directory 7.0.1
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus Domino Directory 7.0.2
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Lotus Domino Directory 8
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Sun Java System Directory Server 5.2
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Sun Java System Directory Server Enterprise Edition 6.0
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Active Directory 2000 SP4
Supported on Windows
Active Directory 2003
Supported on Windows
Active Directory 2008
Supported on Windows
If you support LDAP user authentication:
  • You must install the IDS SDK client. DB2 Content Manager V8.4.1 support IDS SDK V5.2 and V6.0 for all platforms.
  • Linux users using Oracle: you must manually install Tivoli Directory Server V6.1 client and its 32-bit library. See instructions.

Back to top

Business Process Manager (BPM) integration (optional)

The following table specifies the required software for the Business Process Manager integration.

Software Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
WebSphere® MQ V6.0
Supported on AIX
Supported on HP
Supported on Linux
Supported on Solaris SPARC
Supported on Solaris x86-64
Supported on Windows
See footnote*



WebSphere MQ support information
Tivoli® Directory Server 6.0
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris SPARC
Supported on Solaris x86-64
Supported on Windows
Tivoli Directory Server 6.1
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris SPARC
Supported on Solaris x86-64
Supported on Windows
LDAP For IBM DB2 Content Manager and FileNet Business Process Manager (BPM) integration PlusOne adoption route, see Article 7013871.
P8 BPM V4.5.0 Process Engine (PE) client
Supported on AIX
Supported on HP
Supported on Linux
Supported on Solaris SPARC
Supported on Windows
The PE component is not supported on z/OS and Solaris x86-64.
Information Integrator for Content
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris SPARC
Supported on Solaris x86-64
Supported on Windows
Event Monitor
Event Handler
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris SPARC
Supported on Windows
These components are not supported on z/OS and Solaris x86-64.
* MQ/JMS 64-bit libraries for a 64-bit JVM

MQ_JAVA_LIB_PATH is the environemnt variable for the MQ Java library path. On AIX or Solaris, use either the 32-bit libraries or the 64-bit libraries. Use the 64-bit libraries only if you are running your application in a 64-bit Java virtual machine (JVM) on a 64-bit platform. Otherwise, use the 32-bit libraries.

AIX:
/usr/mqm/java/lib (32-bit libraries)
/usr/mqm/java/lib64 (64-bit libraries)

Solaris:
/opt/mqm/java/lib (32-bit libraries)
/opt/mqm/java/lib64 (64-bit libraries)

Reference: WebSphere MQ Using Java,Version 6.0 SC34-6591-02

Back to top

Long-term storage (resource manager)

The following table specifies the required software for implementing the optional long-term storage capability on the resource manager. Note that you must use a 32-bit Tivoli Storage Manager API Client.

Long-term storage (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
Tivoli Storage Manager API Client 5.3.4 or later fixpacks (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Tivoli Storage Manager API Client 5.4 or later fixpacks (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Solaris: Minimum required level is 5.4.1.2
Tivoli Storage Manager API Client 5.5 or later fixpacks (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Tivoli Storage Manager Server 5.3.4 or later fixpacks (32-bit or 64-bit)
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Windows: Not supported on Windows 2008
Tivoli Storage Manager Server 5.4 (32-bit or 64-bit)
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Windows: Not supported on Windows 2008
Tivoli Storage Manager Server 5.5 (32-bit or 64-bit)
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows

Back to top

Features

The following table specifies the required software for optional features for DB2 Information Integrator for Content.

Features (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
WebSphere MQ Workflow 3.6 client
Supported on AIX
Supported on HP-UX
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Requires MQ Workflow Server and WebSphere MQ V6.0 software.

Windows: WebSphere MQ is not supported on Windows 2008

Back to top

Browser (eClient)

The following table specifies the required browser software for users of the eClient.

eClient browser (Required) Operating system: Notes
AIX
HP-UX
Linux
Mac OS
Solaris
Win
Microsoft Internet Explorer 6 SP1
Supported on Windows
Microsoft Internet Explorer 7
Supported on Windows
Supported on Windows XP and Windows Vista.
Firefox 2.0.0.11
Supported on Windows
Firefox 3.0
Supported on Windows
Safari 1.2
Supported on Mac
Supported on Mac OS X 10.3.

You must have a minimum of 300 MHz G3 with 128 MB RAM to use the eClient on a Macintosh.
Safari 2.0
Supported on Mac
Supported on Mac OS X 10.3.

You must have a minimum of 300 MHz G3 with 128 MB RAM to use the eClient on a Macintosh.
Safari 3.1
Supported on Mac
Supported on Mac OS X 10.3.

You must have a minimum of 300 MHz G3 with 128 MB RAM to use the eClient on a Macintosh.

Back to top

Browser Java plug-in (Java Applet Viewer)

The following table specifies the required Java plug-in for the following components:

  • eClient
  • Java applet viewer toolkit

In addition, the viewer requires 50 MB of free disk space, and a minimum of 256 MB RAM on each user machine to handle documents such as RTF, Microsoft® Office, or Lotus® SmartSuite files.

Restriction: Microsoft Virtual Machine plug-in for Internet Explorer is not supported.

eClient browser Java plug-in (Required) Operating system: Notes
AIX
HP-UX
Linux
Solaris
Win
Sun Java plug-in 5
Supported on Windows
Δ
Sun Java plug-in 6
Supported on Windows
Sun JRE V1.6.0.18 is compatible with the eClient Java Applet Viewer, but not all future releases of Sun JRE are. See technote 1431266 for details.

Back to top

Browser (Information center)

The following table specifies the required browser software for the information center. On the system administration client machine, the information center is required in order to display the online help. On other machines, the information center is optional, but highly recommended.

Information center (Required) Operating system: Notes
AIX
HP-UX
Linux
Mac OS
Solaris SPARC
Solaris x86-64
Win
Microsoft Internet Explorer 6 SP1
Supported on Windows
Microsoft Internet Explorer 7
Supported on Windows
Mozilla 1.7
Supported on AIX
Supported on HP-UX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Firefox 1.0
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Firefox 2.0
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Firefox 3.0
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Safari 1.2
Supported on Mac OS
Supported on Windows

Back to top

Tools for developing applications with the OO APIs

The following table specifies the required compiler for optional development with application programming interfaces for Information Integrator for Content.

API development tools (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
IBM JDK 5.0 SR4 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ IBM JDK 5.0 SR4 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.
IBM JDK 6.0 SR2 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Supported for Federated connector, Content Manager connector, and JavaBeans.
Δ IBM JDK 6.0 SR2 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.
Sun JDK 5.0 U13 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ Sun JDK 5.0 U13 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.

XML import/export, XML SDK and XML Beans are not supported on SUSE Linux 10.
Sun JDK 6.0 U3 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ Sun JDK 6.0 U3 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.

XML import/export, XML SDK and XML Beans are not supported on SUSE Linux 10.
XL C/C++ Enterprise Edition 7.0 with February 2007 XL c/C++ Enterprise Edition V7.0 for AIX PTF
Supported on AIX
Article #4015035
XL C/C++ Enterprise Edition 8.0
Supported on AIX
XL C/C++ Enterprise Edition 9.0
Supported on AIX
HP-UX 5.0 JDK
Supported on HP-UX
Visual C++ .NET 2003
Supported on Windows
Visual C++ 2005
Supported on Windows
Outside In 8.2 or later requires Visual C++ 2005 SP1 Redistributable Package, see Article #7015396.
Visual C++ 2008 Not supported

Back to top

Compilers (library server)

The following table specifies the required compiler for optional development of user exit routines on the library server.

Compilers (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
XL C/C++ Enterprise Edition 7.0 with February 2007 XL c/C++ Enterprise Edition V7.0 for AIX PTF
Supported on AIX
Article #4015035
XL C/C++ Enterprise Edition 8.0
Supported on AIX
XL C/C++ Enterprise Edition 9.0
Supported on AIX
HP C/aC++ Developer's Bundle
Supported on HP-UX
GNU C Library (glibc) 2.3.2-95
Supported on Linux
gcc (GCC) 3.3.3 (SuSE Linux)
Supported on Linux
gcc (GCC) 3.4.6.20060404 (Red Hat 3.4.6-3)
Supported on Linux
gcc (GCC) 4.1.0.20060404 (SUSE Linux)
Supported on Linux
gcc (GCC) 4.1.1.20060404 (RHEL 5) (64-bit)
Supported on Linux
Sun Studio 10, C++ Compiler 5.7
Supported on Solaris
Supported on Solaris x86-64
Sun Studio 11, C++ Compiler 5.8
Supported on Solaris
Supported on Solaris x86-64
Sun Studio 11, C++ Compiler 5.9
Supported on Solaris
Supported on Solaris x86-64
Visual C++ .NET 2003
Supported on Windows
Visual C++ 2005
Supported on Windows
Outside In 8.2 or later requires Visual C++ 2005 SP1 Redistributable Package, see Article #7015396.
Visual C++ 2008 Not supported

Back to top

Compilers (Client for Windows)

The following table specifies the required compilers for optional development of user exit routines on the Client for Windows.

Compilers (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris
Win
Visual C++ 2005
Supported on Windows
Outside In 8.2 or later requires Visual C++ 2005 SP1 Redistributable Package, see Article #7015396.
Visual C++ 2008 Not supported

Back to top

Run-time environments for the OO APIs

The following table specifies the required run-time environments for running applications which use the application programming interfaces for DB2 Information Integrator for Content.

For C++ applications, the level of runtime environment library used should match the compiler used; refer to the documentation and support statements provided by the vendor of the compiler software.

Note: Java support for DB2 Content Manager uses the JRE default network properties. On HP-UX, the Java system property default is javanet.preferIPv4Stack=true. This disables IPv6 on this platform. On other JREs, this property is not set and IPv6 is enabled.

API development tools (Optional) Operating system: Notes
AIX
HP-UX
Linux
Solaris SPARC
Solaris x86-64
Win
HP-UX 5.0 JRE
Supported on HP-UX
Recommendation: Use the -d64 option when invoking java to use 64-bit.
IBM JRE 5.0 SR4 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ IBM JRE 5.0 SR4 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.
IBM JRE 6.0 SR2 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Supported for Federated connector, Content Manager connector, and JavaBeans.
Δ IBM JRE 6.0 SR2 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.
Sun JRE 5.0 U13 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ Sun JRE 5.0 U13 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.

XML import/export, XML SDK and XML Beans are not supported on SUSE Linux 10.
Sun JRE 6.0 U3 (32-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Windows
Δ Sun JRE 6.0 U3 (64-bit)
Supported on AIX
Supported on Linux
Supported on Solaris
Supported on Solaris x86-64
Supported on Windows
Supported for Content manager connector, JavaBeans, and XML SDK.

XML import/export, XML SDK and XML Beans are not supported on SUSE Linux 10.
XL C/C++ Enterprise Edition 7.0 with February 2007 XL c/C++ Enterprise Edition V7.0 for AIX PTF
Supported on AIX
Article #4015035
XL C/C++ Enterprise Edition 8.0
Supported on AIX
XL C/C++ Enterprise Edition 9.0
Supported on AIX
Supported only for use with DB2 V9.1 and DB2 V9.5.
Visual C++ .NET 2003
Supported on Windows
Visual C++ 2005
Supported on Windows
Outside In 8.2 or later requires Visual C++ 2005 SP1 Redistributable Package, see Article #7015396.
Visual C++ 2008 Not supported

Back to top



Change history

History Date Change
Revision 12 Jul 2011 Client for Windows is not supported in JDBC type 4.
Revision 11 Feb 2011 The system administration client is not supported on Linux for System z.
Revision 9 Feb 2011 Added a link to an important Net Search Extender article.
Revision 18 May 2010 Removed requirement for JR32152 on DB2 9.1 fix pack 8, and added compatibility statement for eClient and Sun JRE.
Revision 23 October 2009 Updated for CM 8.4.1 Fix Pack 1A.
Revision 4 August 2009 Updated DB2 9.5 support to FP3A
Revision 23 April 2009 Added link for important DB2 9.1 information
Created 30 March 2009 Created

Related information

Content Manager for z/OS Version 8.4.1 Fix Pack 1
Content Manager hardware requirements
Content Manager Information Center
DB2 CM EE 8.4 support for 32-bit/64-bit for LUW

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Content Manager

Software version:

8.4.1, 8.4.1.1

Operating system(s):

AIX, HP-UX, Linux, OS/2, Solaris, UNIX, Windows

Reference #:

7015270

Modified date:

2013-11-11

Translate my page

Machine Translation

Content navigation