System Requirements for WebSphere MQ for Windows v5.3

Product documentation


Abstract

This document contains system requirements for WebSphere MQ for Windows v5.3.

Content

Operating Systems
  • Microsoft Windows NT V4.0, to include TCP/IP, NetBIOS, and SPX with Service Pack 6a
  • Microsoft Windows 2000 (Professional or Server Edition) or Windows 2000 Advanced Server
  • Microsoft Windows XP (Professional) [See note 2]
  • Microsoft Windows 2003 Standard and Enterprise edition [See note 2]
    (Read the notes in the product README before attempting to install.)
  • Windows Terminal Services technology
    • Microsoft Windows 2000 with Service Pack 2, Microsoft Windows XP (Professional) or Microsoft Windows 2003
    • In Remote Administration Mode only
    • Requires WebSphere MQ CSD03 (U200187) or higher.
Connectivity
  • TCP/IP provided by operating system
  • NetBIOS provided by operating system
  • SPX provided by operating system
  • IBM Communications Server for Windows NT, V5.0 or V6.1.1
  • IBM Personal Connectivity
  • IBM Personal Communications V5 (V5.6 on Windows XP)
  • Microsoft SNA Server, V4.0
  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server (XP)
  • Attachmate Extra! Personal Client, V6.7
  • Attachmate Extra! Enterprise 2000
  • SSL
    • Supported Cryptographic Hardware
      • Operating system provides the cryptographic hardware support.
  • WebSphere MQ client applications (built using WMQ V6.0 or WMQ V5.3 FP10 refresh or later client libraries) are supported on the Citrix MPS V3.0
Databases Where IBM WebSphere MQ is acting as the transaction manager - see note under Transaction Monitors.
  • Non-Java applications using MQBEGIN or equivalent
    • Oracle 8iR3, Oracle 9iR1, Oracle 9iR2
      (Both 32-bit and 64-bit databases are supported when using Oracle's 32-bit client libraries)
    • IBM DB2 V7.2
    • IBM DB2 V8.1 + FP2 (at L030120 or later)
    • IBM DB2 V8.2
    • Sybase 12 or 12.5
  • Java™ applications using qmgr.begin and JDBC
    • IBM DB2 V7.2
    • IBM DB2 V8.2
    • Oracle 8.1.6
    • Oracle 8.1.7
    • Oracle 9.2.0.4, JDK 1.4.1, Windows 2000, WebSphere MQ CSD06
    • Oracle 9.2.0.4, JDK 1.4.1, Windows XP Professional, WebSphere MQ CSD06
    • Oracle 10gR1 (FP12 must be applied with Oracle 10gR1)
Compilers
  • Microsoft Visual C++ V6.0
  • Microsoft Visual C++ for .NET V7.0
  • Microsoft Visual Studio .NET 2003 (for C and C++, C# and VB.NET programs)
  • IBM VisualAge COBOL Enterprise, V3.0.1
  • IBM VisualAge PL/I for Windows, V2.1
  • Micro Focus Net Express V3.0, V3.1
  • Microsoft Visual Basic V6
Java
  • IBM Developer Kit for Windows, Java Technology Edition, V1.3.1
    (Provided that the IBM 32-bit SDK for Windows, Java 2 Technology Edition, Version 1.3.1 plus the addition of IBM JSSE classfiles can be obtained as included within an alternate IBM product, this is a suitable environment under which SSL support using Java can be run with the exception of certificate checking against Certificate Revocation Lists (CRLs) which requires full JDK implementation at V1.4.)
  • IBM Developer Kit for Windows, Java Technology Edition, V1.4.0, V1.4.1 and V1.4.2.
    (IBM 32-bit SDK for Windows, Java 2 Technology Edition, Version 1.4.0 is supplied with the WebSphere MQ product and is required for SSL support using Java as it provides the necessary IBM JSSE classfiles.)
  • IBM Developer Kit for Windows, Java 2 Technology Edition V5.0 (SR1 or above) [Only if the JDK is supplied with another IBM product]
  • Java 2 Platform, Standard Edition version 1.4.2 from Sun Microsystems with CSD08
Application Servers
  • IBM WebSphere Application Server V5.1
  • IBM WebSphere Application Server V6.0.2
  • IBM WebSphere Application Server V6.1 (see this page for more details)
  • BEA WebLogic Server 8.1 + SP3 on WebSphere MQ v5.3 + FP10 on Windows 2000 and Sun's JDK 1.4x to support EJB's (including MDB's) and JMS only.
Transaction Managers Where one of these transaction monitor products is acting as the transaction manager and IBM WebSphere MQ is acting as a resource manager, it is recommended that you contact the transaction monitor vendor in the first instance for support.
  • WebSphere MQ V5.3 provides an extended transactional client for this platform.
  • The minimum supported level of TXSeries (CICS) is V5.0, plus PTF 1 and e-fix 6
  • TXSeries V4.3, TXSeries V5.0 & TXSeries V5.1
    (Note: COBOL transactions are only supported with TXSeries 5.0 when the applied maintenance is CSD05 or later. See this page for more details).
  • BEA Tuxedo, V6.4 or V6.5
  • BEA Tuxedo 8.1 (32-bit only) - WebSphere MQ Fix Pack 11 (CSD11) required
(The above are the minimum required supported levels. See general notes below.)
  • MTS/COM+
DCE
  • IBM DCE V2.1 (Not Windows XP)

To enable users to run the WebSphere MQ supplied DCE send, receive or message exits, this must be the US domestic version supporting DES encryption.

Notes:

  1. Where patches for a product are specified, this means that these patches were required to resolve problems found during testing and should therefore be considered as the minimum necessary maintenance level. Further maintenance should be applied in accordance with the guidance of the relevant software manufacturer.
  2. Only 32-bit (NOT 64-bit) operating systems are supported.


Change History
Last updated: 30 August 2006
  • 16 August 2005: Added support for using Windows Terminal Services on Windows 2003
  • 5 September 2005: Added support for BEA Tuxedo 8.1 & TXSeries V5.1
  • 2 December 2005: Modifications to the format.
  • 18 January 2006: References to WebSphere MQ 5.3 FP8 & FP9 have been changed to FP10.
  • 9 February 2006: Added support for Oracle 10gR1.
  • 6 March 2006: Added support for Citrix MPS V3.0.
  • 30 August 2006: Added Note 2 (64-bit clarification).
  • 14 June 2007; Added IBM Java 5 support.
  • 22 November 2007: Added support for IBM WebSphere Application Server V6.1.

Related information

WebSphere MQ System requirements
Recommended Updates

Original publication date

2005/6/30

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere MQ
Documentation

Software version:

5.3

Operating system(s):

Windows

Reference #:

7006285

Modified date:

2006-03-06

Translate my page

Machine Translation

Content navigation