IBM Support

7.1.1-TIV-TDI-LA0015

Downloadable files


Abstract

JRE Upgrade for TDI 7.1.1 and TDI 7.1.0.

Download Description

+-----------------------------------------------------+

Interim Fix 7.1.1-TIV-TDI-LA0015 README
Tivoli Directory Integrator 7.1.1 (Also applicable to TDI v7.1.0)
LA Interim Fix 15
(All platforms)
JRE Level: Java 1.6 SR 15 FP1
Date: April 2014
+-----------------------------------------------------+

COPYRIGHT STATEMENT
====================
April 2014

References in this publication to IBM products, programs, or services do
not imply that IBM intends to make these available in all countries in
which IBM operates. Any reference to an IBM program product in this
publication is not intended to state or imply that only IBM's program
product may be used. Any functionally equivalent program may be used
instead.

IBM is a trademark of the International Business Machines Corporation.

Copyright International Business Machines Corporation 2014. All rights
Reserved.

Fix For
========

APAR - NA
PMR - NA


General Description:
====================
This Limited Availability Interim Fix contains JRE's for Java vulnarability CVE-2014-0411 (CVSS 4)

Details:
========
UPGRADING TDI JRE BECAUSE OF CVE-2014-0411 (CVSS 4) JRE VULNERABILITIES


Prerequisites:
==============
Tivoli Directory Integrator v7.1.1 or v7.1.0 with or without any fixpack must be installed.


Platforms:
==========
All supported Platforms


Downloading the Fix:
====================
- Under the Download options section, Click on the "Change Download options" link.
- Set the "Include prerequisites and co-requisite fixes (you can select the ones you need later)" checkbox to true.



Applying the Fix:
=================
- Shutdown TDI.

- Unzip the fix package to a temporary directory. The LA contains platform specific JRE's, copy the .zip or the .tar.gz to respective platforms.

- Extract the .zip /.tar.gz files.

- Copy the jre dir from the extracted .zip / .tar.gz into a dir called jvm.

- Backup the older JVM dir under <TDI_Install_Dir\jvm>. For this, rename the older dir by changing its name to anything other than JVM

- Replace the existing JVM dir which was backed up earlier with the fix files ( newly created JVM dir ).

- Apply command 'chmod -R 755 JVM' under JVM dir for non windows platform.


Confirming the Fix has been applied successfully:
=================================================
CVE-2014-0411 (CVSS 4) JRE vulnerabilities will be resolved.


NOTE: The 6.0.15.1-JavaSE-JRE-SolarisSPARC64 is applicable for TDI 7.1.0 release only. This JRE is not supported for TDI 7.1.1 yet.

Prerequisites

Tivoli Directory Integrator v7.1.1 or v7.1.0 with or without any fixpack must be installed.

Installation Instructions

Refer readme for details

Download package


Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
What is Fix Central(FC)?
7.1.1-TIV-TDI-LA0015 29 Apr 2014 English 2453 FC

Product Alias/Synonym

TDI IDI ITDI SDI

Document information

More support for: IBM Security Directory Integrator
General

Software version: 7.1, 7.1.1

Operating system(s): Platform Independent

Reference #: 4037329

Modified date: 14 May 2014


Translate this page: