Downloadable files
Abstract
This interim fix provides updates to the problems identified in the "Download Description" section below in addition to those fixed in previous interim fixes.
Download Description
Click here for information on all related 5.1.1.3-IF00004 technotes. There maybe zero results returned if no technotes are available.
Click here for information on all related 5.1.1.3 technotes. There maybe zero results returned if no technotes are available.
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Created / Revised by
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Date of Creation / Revision
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Summary of Changes
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SC
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2010/11/30
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Document created |
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SC
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2010/12/28
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-------------------------
APARs Fixed in IF00001
-------------------------
IC66167
PUBLISHING OF SOFTWARE TO A DEPOT DOES NOT CONTINUE AFTER TCA RESTART
IC66638
TPM5112 INSTALL TCA HAS GUID ERROR ON SLES10 64BIT
IZ51084
FAIL TO HAVE POSITIVE INDICATION OF REBOOT WRITTEN IN THE SWDIST LOGS ON THE TARGET
IZ63785
NIM_INSTALL_CLONE_IMAGE.WKF PING TO DEFAULT GATEWAY OF NIM CLIENT ALWAYS FAILS
IZ63927
BAD GUI PERFORMANCE WHILE DISPLAYING THE LIST OF ZONES
IZ64665
IFIX 02 ON SOLARIS 9 CANNOT BE INSTALLED DUE TO AN OUTOFMEMORY JAVA ERROR
IZ64681
FAIL TO DISPLAY A PROPER MESSAGE IF COPYFILE FAILS
IZ65387
WSUS WUA SCAN FAILS DUE TO KB976749
IZ65515
ONE FAILED TPM LOGIN MAKES 4 FAILED LOGIN ATTEMPTS ON MSAD
IZ65675
A SPB THAT IS SAVED TO THE CUSTOM FILE REPOSITORY ON THE TPM SERVER SAY "MISSINGINPUTPARAMETER EXCEPTION" ON PUBLISH
IZ65740
RXA TIMEOUT AS SET IN INITIAL DISCOVERY IS NOT HONOURED
IZ67401
ENABLE/DISABLE COMPLIANCE INFORMATION FROM THE SERVER GENERAL PAGE
IZ67452
PERFORMANCE ISSUE WHEN NAVIGATING TO THE "MANAGE COMPUTER" PAGE
IZ68161
MISSING SOFTWARE MODULE FOR "SLES 10 SP3" IN TPM 5113
IZ68295
A SPB INSTALLATION WITH UNATTENDED REBOOT SHOWS AS SUCCESS EVEN THE INSTALL FAILS
IZ68353
"SHOW COMPUTERS MISSING ANY SELECTED SOFTWARE" CHECK BOX DOESN'T WORK
IZ68652
TPM PERFORMANCE PROBLEM ON THE COMPUTER LIST
IZ68667
OUTOFMEMORY ISSUE ON TPM SERVER
IZ68809
TPM 5.1.1 INSTALLER STOPS IF CYGWIN 1.7.1 IS USED
IZ70129
CREATE CLEANUP UTILITY FOR ORPHANED SRTS
IZ70359
AGENT_UNIQUE_NAME DOES NOT SHOW IN IN THE CONSOLE.LOG MESSAGE
IZ70705
TPM TCA IP ADDRESS CHANGES ARE NOT REFLECTED IN THE DCM
IZ70763
DCMINSERT DOES NOT SOURCE VARIABLE FOR ELEMENT
IZ71097
SOFTWARE INSTALLATION STATUS IN TPM GUI IS NOT RELIABLE
IZ71104
ALL NETWORK RESOURCES DISAPPEARING WHEN ELIMINATING NIC FROM THE RESOURCES ASSIGNED TO THE ESX SERVER TO THE VM
IZ72404
INSTALLATION OF A REBOOT SPB DOES NOT WORK AFTER APPLYING TPM 5113
IZ72579
REMAINING DEPOTS ARE NOT FUNCTIONAL AFTER DELETING ONE DEPOT FROM TPM
IZ73164
DEPLOYEAR.CMD FAILS TO GET CORRECT STATUS OF WAS_DEPLOY_ONLY.CMD IN THE INSTALLATION UPGRADE
IZ73262
LEVELS FOR CAS AND CDS DOES NOT CHANGE AFTER UPGRADING TPM5112 TO TPM 5113
IZ73565
SSLHANDSHAKE EXCEPTION IS LOGGED IN RPCLOG0
IZ73570
CANCEL-ALL-IN-PROGRESS DOES NOT CANCEL ALL JOBS
-------------------------
APARs Fixed in IF00002
-------------------------
IZ57878
TPM END USER INTERACTION SERVICE 5.1.1.4 FAILS ON POLISH XP
IZ63180
TPM UI DOES NOT SHOW SOURCE DEPOT WHEN CDS_DYNAMICPUBLISHENABLE VARIABLE IS SET TO FALSE
IZ65008
AFTER REMOVING THE TCA MANUALLY IT STILL APPEARS AS RUNNING IN INVENTORY10 REPORT
IZ66714
"ENDPOINT REBOOT DELAY IN MINUTES" INVOKES THE DEFER BUTTON BUT DOES NOT OBEY THE VALUE
IZ70341
APDE CREATES "WORKFLOW" DEVICE MODEL EVEN NOT EXPLICITLY CREATED BY USER
IZ70705
TPM TCA IP ADDRESS CHANGES ARE NOT REFLECTED IN DCM
IZ72165
SLOW LOADING IN THE TPM COMPLIANCE TAB AFTER ENABLING INSTANCE SECURITY
IZ72561
TPM 5.1.1.2 SOFTWARE STACK IS LIMITED TO 32 ENTRIES
IZ74004
TPM 5.1.1 THROWS OSGI AGENT BUNDLE EXCEPTION
IZ74229
TPM TCWEBUI FAILS AFTER PORT CHANGE
IZ74763
TPM 5.1.1 THE ITM AGENT DOES NOT PROPERLY HANDLE THE TPM TASKS STATUS
IZ74974
TPM 5.1.1 REMOVEDEPLOYMENTREQUESTS COMMAND DOES NOT CHECK SYNTAX OF ARGUEMENT
IZ75085
MISSING SIGNATURE FOR RHEL 5.5
IZ75114
TPM 5.1.1.2 PACKAGELOGS.SH COMMAND FAILS WITHOUT THE -CLEAN FLAG IN THE COMMAND STRING
IZ75792
TIMEOUT FOR SCRIPLETS DOES NOT WORK AFTER UPGRADE TO 5113
IZ76009
VB SCRIPT ERROR INSTALLING MS PATCH "SECURITY UPDATE FOR WINDOWS SERVER 2003 X64 EDITION (KB978601)"
-------------------------
APARs Fixed in IF00003
-------------------------
IZ83466
SAME PACKAGE CANNOT BE INSTALLED IN PARALLEL ON ENDPOINTS
-------------------------
APARs Fixed in IF00004
-------------------------
IZ76413
RXA_ EXECUTE_COMMAND FAILS TO EXECUTE 'XCOPY' ON WINTEL SERVERS
IZ76969
TPM DOES NOT DELETE SUBAGENT PROPERTY FILES AFTER TCA INSTALLATION
IZ77415
SOFTWARE STACK INSTALLATION HANGS WITH LARGE NUMBER OF SOFTWARE TEMPLATE PARAMETERS
IZ77504
TPM FAILS TO DELIVER LARGE SOFTWARE PACKAGE BLOCKS
IZ77647
RXA DISCOVERY HANGS LEAVING JOBS IN A STATE OF IN-PROGRESS
IZ78004
TPM NEEDS SOFTWARE CATALOG UPDATE FOR VERITAS NETBACKUP CLIENT 6.5
IZ80234
NON-ADMIN USERS CAN NOT UNINSTALL SOFTWARE PACKAGES
IZ80242
TPM NEEDS TO TRACK CDS UPDATE FOR CDS SERVER
IZ81149
TPM PATCHING REMEDIATION FAILS WITH ERROR CODE OF N/A BECAUSE OF LARGE VOLUME OF SDI JOB RESULTS
IZ81199
AGENTLESS CIT INVENTORY SCAN FAILS ON WINDOWS 2008 AND WINDOWS 2008 R2 TARGET MACHINES
IZ82702
DE INSTRUCTION CACHING FOR BETTER PERFORMANCE AND RELIABILITY
IZ82796
TRACK TASKS PERFORMANCE ISSUE
IZ83062
TPM SHOWS CONCURRENT MODIFICATION EXCEPTIONS IN RCP LOG FILES
IZ83425
WINDOWS CONFIGURATION DISCOVERY FAILS TO UPDATE SRT OF OS INSTALLATION
IZ83531
TPM SHOWS JSON ERROR BECAUSE DMS EXCEEDS DATABASE COLUMN LENGTH
IZ83549
TPM DE WORKFLOW HANGS DURING A SOAP CALL
IZ83750
TPM THROWS EXEPTION WHILE DELETING A USER ASSOCIATED WITH FAVORITE TASK
IZ84011
TPM CUSTOM INVENTORY EXTENSION DISCOVERY GENERATES INCORRECT CHARACTERS DURING CONVERSION OF XML FILE INTO MIF FILE
IZ84080
TPM FAILS TO PATCH WINDOWS SDI AS IT IS UNABLE TO FIND LOCALSTACKFILE NAME
IZ84316
SOFTWARE UPGRADE UI DOES NOT LOAD DUE TO LARGE VOLUME OF DATA
IZ84502
TPM SDI JOBS HANG DUE TO DATABASE LOCK
IZ86839
DEPLOYMENT ENGINE SHOWS WRONG RUNNING STATUS
IZ87323
TPM CAN NOT CREATE STATIC TPM GROUPS
IZ91303
COMPONENT UPGRADE INSTALL FAILS ON THE UNIX/LINUX MACHINES AND THE README DOESN'T TELL TO USE XMLIMPORT COMMAND INSTEAD OF THE MISSING TCA WORKFLOW
Prerequisites
This update requires IBM Tivoli Intelligent Orchestrator, version 5.1.1.3
Updates provided in this interim fix are cumulative, that is, an interim fix with a higher number replaces all previous versions.
Installation Instructions
Contents
1.0 Update Installation Instructions
1.1 Pre-Installation Steps
1.2 Installation Instructions
1.3 Post-Installation Instructions (Mandatory)
1.4 Un-Installation Instructions
2.0 Known Problems
3.0 Troubleshooting
4.0 About this fixpack
------------------------------------------------------------------------------
1.0 Update Installation Instructions
These installation instruction apply to the Tivoli Intelligent Orchestrator,
Tivoli Provisioning Manager or Tivoli Provisioning Manager for Software.
1.1 Pre-Installation Steps
--------------------------
1. Verify that Tivoli Provisioning Manager 5.1.1.3 server is operational.
On the web interface, ensure that you can run the workflow named "no_operation".
If the workflow was successful, the deployment engine is working correctly and
you can continue with the next step in the preinstallation tasks.
If the workflow was not successful, check the workflow log and see the Tivoli
Provisioning Manager Troubleshooting Guide to resolve the error before you proceed
with the next step in the preinstallation tasks
2. For AIX, Linux or Solaris:
Log on to the system as root as follows, su - root
For Windows:
Log on to the system with the tioadmin user.
Before applying the update, ensure that TIO_HOME is set then ensure JAVA_HOME is set by executing the following:
For AIX, Linux or Solaris:
. $TIO_HOME/tools/setupCmdLine.sh
For Windows:
%TIO_HOME%\tools\setupCmdLine.cmd
3. Before applying the update, ensure that the Tivoli Intelligent Orchestrator, Tivoli Provisioning Manager,
or Tivoli Provisioning Manager for Software, WebSphere Application Server(WAS), and Tivoli Directory
Server are stopped. Refer to the documentation provided with each of these
products for detailed starting and stopping instructions.
4. Before applying the update, ensure the md5sum of the downloaded jar file matches the md5sum specified
on the download page.
a. Ensure that you have downloaded the .md5 file that corresponds to each .zip or tar file from the upgrade download page.
b. For Windows:
Open a Cygwin window
c. Ensure that the .zip and .md5 files must be in the same directory when the md5sum check is run.
To validate the file 5.1.1.3-TIV-TPM-IF00004.jar, run the command:
For Windows:
md5sum -c 5.1.1.3-TIV-TPM-IF00004.md5
For Linux or Aix :
To validate the file 5.1.1.3-TIV-TPM-IF00004.jar, run the command:
Linux: md5sum -c 5.1.1.3-TIV-TPM-IF00004.md5
AIX: csum -i 5.1.1.3-TIV-TPM-IF00004.md5
5. Space requirements for this ifix, where <temp_dir> is the location you will copy and unjar the ifix binary:
AIX, Linux or Solaris:
<temp_dir> - 1.5Gb
$TIO_HOME - 1.5Gb
/tmp - 0.5Gb
Windows:
<temp_dir> - 1.5Gb
%TIO_HOME% - 1.5Gb
%TMP% - 0.5Gb
6. If you have already applied APAR IZ82702 (as LA Patch), then you will need to do the following steps before applying this ifix:
For DB2 database:
-----------------
1. Connect to the TPM database using command:
db2 connect to <database_name> user <database_user> using <database_password>
2. Run the following sql statements to roll back the schema changes caused by APAR IZ82702 LA patch:
a. db2 drop index XIE3DEPLOYMENT_REQ
b. db2 select fk_name from sysibm.sqlforeignkeys where fktable_schem='SCHEMA_NAME' and fktable_name='DEPLOYMENT_REQUEST' and fkcolumn_name='PARENT_DEPLOYMENT_REQUEST_ID'
(to determine the foreign key name, please replace SCHEMA_NAME with your schema name)
c. db2 alter table DEPLOYMENT_REQUEST drop foreign key <FOREIGN_KEY_NAME>
(to drop the foreign key, please replace <FOREIGN_KEY_NAME> with the value found at step b)
d. db2 alter table DEPLOYMENT_REQUEST drop column PARENT_DEPLOYMENT_REQUEST_ID
(to drop the parent_deployment_request_id column)
e. db2 alter table DEPLOYMENT_REQUEST_AUD drop column PARENT_DEPLOYMENT_REQUEST_ID
(to drop the parent_deployment_request_id column from the audit table)
f. db2 reorg table DEPLOYMENT_REQUEST
(to reorg the table)
g. db2 reorg table DEPLOYMENT_REQUEST_AUD
(to reorg the table)
3. Reset the database connection:
db2 connect reset
For Oracle database:
--------------------
1. Connect to the TPM database using command:
sqlplus <database_user>/<database_password>@<database_name>
2. Run the following sql statements to roll back the schema changes caused by APAR IZ82702 fix
a. alter table deployment_request drop column PARENT_DEPLOYMENT_REQUEST_ID;
b. alter table deployment_request_aud drop column PARENT_DEPLOYMENT_REQUEST_ID;
7. See below for known issues before proceeding the IFIX installation.
1.2 Installation Instructions
-----------------------------
1. Installation user:
For AIX, Linux or Solaris:
Log on to the system as root as follows, su - root. Make sure tioadmin and root user have 0022 umask during installation time.
For Windows:
Log on to the system with the tioadmin user.
2. Create a temp directory and download the update package into this directory, where <temp_dir> is the
newly created directory. Ensure that you create this temp directory outside of TIO_HOME directory,
in order for the install process to successfully complete.
3. Using the jar command, expand the package as follows:
For example:
jar -xvf 5.1.1.3-TIV-TPM-IF00004.jar
4. If you are installing the update on AIX, Linux or Solaris:
From the temp directory in which you have expanded the package, run the command:
For AIX, Linux or Solaris:
chmod -R 755 <temp_dir>/installer
chown -R tioadmin:tioadmin <temp_dir>/installer
chmod -R 755 <temp_dir>/components
chown -R tioadmin:tioadmin <temp_dir>/components
5. From the <temp_dir>/installer directory, run the updateSilent.bat/updateSilent.sh command,
depending on your platform.
updateSilent.bat/sh -fix -install <TIO_HOME> <IFix Number> <FIX_LOCATION>
where:
<TIO_HOME> is the fully qualified path to your Tivoli Intelligent Orchestrator or Provisioning Manager server installation
<IFix Number> is the name of the ifix you wish to install
<FIX_LOCATION> is <temp_dir>/installer
For example:
updateSilent.sh -fix -install /opt/ibm/tivoli/tpm IF00004 /tmp/installer
** You will receive an pre-req check error message here if your are not on the latest fixpack.
Ensure you have the latest fixpack of the product installed and try again. **
6. If you are installing the update on AIX, Linux or Solaris, run the command:
For AIX, Linux or Solaris:
chmod -R 775 $TIO_HOME
chown -R tioadmin:tioadmin $TIO_HOME
1.3 Post-Installation Instructions (Mandatory)
----------------------------------------------
1. Start the Tivoli Directory Server. Refer to the documentation provide for details
2. Stop the WebSphere Application Server. Refer to the documentation provide for details
3. Log in as tioadmin and deploy the application using the following command:
For AIX, Linux or Solaris:
a) Change the directory to:
cd <temp_dir>/installer/utils
b) Run the postinstall.sh script
./postinstall.sh <WAS username> <WAS password> <servername> <java_temp_path>
Where <WAS username> is wasadmin for ITDS authentication or tioadmin for OS authentication.
<WAS password> is the password for wasadmin or tioadmin.
<java_temp_path> is optional. you can specify it if you do not want to use default java temp path.
For Windows, using a CMD (**) prompt:
a) Change the directory to:
chdir <temp_dir>\installer\utils
b) Run the postinstall.bat script
postinstall.bat <WAS username> <WAS password> <servername> <java_temp_path>
Where <WAS username> is wasadmin for ITDS authentication or tioadmin for OS authentication.
<WAS password> is the password for wasadmin or tioadmin.
<java_temp_path> is optional. you can specify it if you do not want to use default java temp path.
4. Upgrade for components:
For AIX, Linux or Solaris, log in as root user:
a) Change the directory to:
cd <temp_dir>/components
b) Run the ComponentUpgrade.sh script
If Oracle server:
./ComponentUpgrade.sh -WASadmin <WAS username> -WASadminPWD <WAS user password> -DBAdmin <DB admin username> -DBAdminPWD <DB admin user password> -CDSOraclePWD <CDSOraclePWD>
Where <WAS username> is wasadmin for ITDS authentication or tioadmin for OS authentication.
<WAS password> is the password for wasadmin or tioadmin.
<DB admin username> is tioadmin or db2admin as set during installation.
If using DB2 server:
./ComponentUpgrade.sh -WASadmin <WAS username> -WASadminPWD <WAS user password> -DBAdmin <DB admin username> -DBAdminPWD <DB admin user password>
Where <WAS username> is wasadmin for ITDS authentication or tioadmin for OS authentication.
<WAS password> is the password for wasadmin or tioadmin.
<DB admin username> is tioadmin or db2admin as set during installation.
For Windows, log in as tioadmin user and using a CMD (**) prompt:
a) Change the directory to:
chdir <temp_dir>\components
b) Run the ComponentUpgrade.bat script
ComponentUpgrade.bat -WASadmin <WAS username> -WASadminPWD <WAS user password> -DBAdmin <DB admin username> -DBAdminPWD <DB admin user password>
Where <WAS username> is wasadmin for ITDS authentication or tioadmin for OS authentication.
<WAS password> is the password for wasadmin or tioadmin.
<DB admin username> is tioadmin or db2admin as set during installation.
5. Start the Tivoli Intelligent Orchestrator or Tivoli Provisioning Manager server.
Refer to the documentation provide for details.
** This step requires a Command Prompt. Do not use a Cygwin prompt
6. If you have upgraded TPM from TPM 5.1.1.3 IFIX3, please check for a software product called TCA 1.3.2.31:
Software Management -> Manage Software Catalog -> Software Products
Search using tca*
If you do not see a software product called TCA 1.3.2.31 then import the file $TIO_HOME/eclipse/plugins/TivoliCommonAgent-core/xml/TCA_JRE15_Windows.xml using xmlimport.cmd/.sh in $TIO_HOME/tools directory.
1.4 Un-Installation Instructions
--------------------------------
1. Start the Tivoli Directory Server. Refer to the documentation provide for details
2. Stop the WebSphere Application Server. Refer to the documentation provide for details
3. From the <temp_dir>/installer directory, run the updateSilent.bat/updateSilent.sh command,
depending on your platform.
updateSilent.bat/sh -fix -uninstall <TIO_HOME> <IFix Number>
where:
<TIO_HOME> is the fully qualified path to your Intelligent Orchestrator or Provisioning Manager server installation
<IFix Number> is the name of the ifix you wish to install
For example:
updateSilent.sh -fix -uninstall /opt/ibm/tivoli/tpm IF00004
4. Deploy the application using the following command:
For AIX, Linux or Solaris:
<temp_dir>/installer/utils/postinstall.sh <WAS username> <WAS password> <servername>
For example, <temp_dir>/installer/utils/postinstall.sh wasadmin wasadmin server1
For Windows, using a CMD (**) prompt:
<temp_dir>\installer\utils\postinstall.bat <WAS username> <WAS password> <servername>
For example, <temp_dir>\installer\utils\postinstall.bat wasadmin wasadmin server1
5. Start the Tivoli Intelligent Orchestrator, Tivoli Provisioning Manager or Tivoli Provisioning Manager for Software server.
Refer to the documentation provide for details.
** This step requires a Command Prompt. Do not use a Cygwin prompt
------------------------------------------------------------------------------
2.0 Known Problems
Changing the WebSphere Application Servers timeout value
In some situations, you may see a timeout if the command does not complete in a particular amount of time.
This situation is caused by the SOAP connection (which is needed in order to run the process) not successfully
connecting to the server. This is most likely caused by a network configuration problem or if the processor is
very slow. This section provides instructions on changing the com.ibm.SOAP.requestTimeout property of the
soap.client.props file, which would possibly provide a workaround to this situation.
The program default value for the request timeout is 180 seconds. Follow the instructions below to change the
value to 1800, only if you encounter an timeout related error while running the postinstall script.
Open the soap.client.props file located in the properties directory of the WebSphere Application Server.
Specify the value of 1800 seconds for the property, com.ibm.SOAP.requestTimeout as indicated below.
Note:
The value that you choose depends on a number of factors such as the size and the number of the applications
that are installed on the server, the speed of your machine, and the level of usage of your machine.
Known Issues
Problems
Cygwin login greeting message breaks IFIX installation.
Causes
This is caused by custom greeting messages added inside Cygwin's .bashrc or .bash_profile.
Resolving the problem
Remove the custom login greeting messages inside the .bashrc or .bash_history before IFIX installation
--------------------------------------------------------------------------------
3.0 Troubleshooting
--------------------------------------------------------------------------------
4.0 About this fixpack
--------------------------------------------------------------------------------
What's new in 5.1.1.3-IF00002
-----------------------------
* The newly supported platforms for endpoints include:
Microsoft Windows Server 2008 R2 x64 Enterprise Edition
Microsoft Windows Server 2008 R2 x64 Standard Edition
Microsoft Windows 7 Professional Edition
Microsoft Windows 7 Enterprise Edition
Microsoft Windows 7 x64 Enterprise Edition
Microsoft Windows 7 x64 Professional Edition
The functions added for the newly supported platforms include only:
Network Discovery
Custom Discovery
Inventory Scans
SDI
Patching
* Workflow TCA_CleanAgentFromDCM is added in 5.1.1.3-IF00002. This workflow helps clean all references of agent from DCM.
What's new in 5.1.1.3-IF00004
-----------------------------
* The subagent version has been changed in 5.1.1.3 IFIX04 as mentioned below:
TCA-Subagent JES - 5.1.3002
TCA-Subagent CDS Axis - 1.3.2103
TCA-Subagent CDS Client URL Handler - 1.3.2103
TCA-Subagent CDS Depot - 1.3.2103
* Java Runtime Environment(JRE)Upgrade for Window TCA agents:
Windows TCA agents will now be installed at version 1.3.2.31 and with Java 1.5.
When a Windows agent is installed from TPM GUI it will show the version as TCA
1.3.2.30. However, the version at the endpoint will be TCA 1.3.2.31. After a
TCA discovery the agent version will be updated to TCA 1.3.2.31.
If your Windows agent is at TCA 1.3.2.30 you have three choices of what to
upgrade:
1. Upgrade the JRE only. You have two choices of how to upgrade:
a. Use the workflow TCA_Upgrade_Windows_JRE
b. Use the stand-alone install by generating a new TCA image
using prepareTCAImage and install.bat on the endpoint itself.
2. Upgrade just the subagents using the workflow TCA_Upgrade_Subagents
3. Upgrade the agent to TCA 1.3.2.31. This will also upgrade the
JRE to Java 1.5 and the subagents as well. Use the workflow
TCA_Device_Upgrade. Before you upgrade the agent verify that the
TCAupgrade_CreateSPB's workflow ran successfully.
Republish the TCA-1.3.2.30 Windows Upgrade Installable again.
If your Windows agent is at TCA 1.3.2.25 or TCA 1.3.2.29. You need to
upgrade your agent.
You have three choices of how to upgrade:
1. Use the Upgrade Software Product page. Search for TCA and then
select TCA 1.3.2.25 or TCA 1.3.2.29 and computer which needs to
be upgraded. Note: No validation is performed on the target
computers to check if it is at TCA 1.3.2.25 or TCA 1.3.2.29.
Use dynamic groups to filter the targets.
2. Use the workflow TCA_Device_Upgrade- This will also upgrade the JRE
to Java 1.5 and the subagents as well.
3. Use the stand-alone install by generating a new TCA image using
prepareTCAImage and install.bat on the endpoint itself.
* Known Uninstall issue on endpoint:
If you have upgraded your existing agent from TCA 1.3.2.25, TCA 1.3.2.29 or
TCA 1.3.2.30 to 1.3.2.31 or upgraded the JRE on TCA 1.3.2.30, use the following
command to uninstall the agent on the endpoint:
%TCA_HOME%\jre\bin\java.exe -jar %TCA_HOME%\_uninst\uninstall.jar
(By default %TCA_HOME%=C:\Program Files\tivoli\ep)
Note:You will not be able to uninstall the agent on the endpoint using
Add/Remove Program or running uninstall.exe from the %TCA_HOME%\_uninst
directory.
* Upgrade Software UI behavior has been changed to accommodate a large scale data
Certain validation routines were revisited (modified or removed) with the intent of
having a rapid agent version selection and target selection with no risk of hanging
threads. As a result, following change in behavior needs to be considered:
1. The initial screen to appear with an empty list and upon the user specifying a
search for the software (e.g. TCA*), a list of the software matching the search string
will be presented.
2. User selects (using radio-button) from the search results
3. In case the user selects a software that can NOT be upgraded - following message
is displayed:
"Select a valid software that can be upgraded"
4. In the "Select Computers" table (down the page) - by default the list of Groups is
displayed
5. In case the user switch the drop-down selection to "By Computer" - a list of computers is
displayed; the user can search the computers by name; there is NO validation on this computer
list if the selected software is installed or not on them (as that was a bottleneck).
The validation will be done after the task submission, at runtime.
6. There is NO validation done when the check-boxes are used to mark the groups or computers that
are selected (that validation is not functional for large scale data)
Note:For convenience, the user can define groups of computers that have a certain
TCA version installed - candidate for upgrade - and just use the groups as targets
7. After the user press submit - following validations are performed:
- a software selection is made
- a group or a computer selection is made
8. Upgrade task performs successfully and the agent is upgraded on the endpoints
* UI Performance improvements in the following areas:
| UI Pages Addressed | Special Considerations |
| 1. Publish Software Packages | The initial screen to appear with an empty list and upon the user specifying a search for the installation files (e.g. *solaris*), a list of the software installables matching the search string will be presented. Further on, the behaviour is the same like before (select the installables and the depots) |
| 2. Unpublish Software Packages | The initial screen to appear with an empty list and upon the user specifying a search for the installation files to be unpublished, a list of the software installables matching the search string that are published to depots will be presented. Further on, the behaviour is the same like before. |
| 3. Creating Dynamic groups using 'Inventory reports’ | Global variable to disable group validation to be set to reduce the load of the dynamic group listing to seconds. Static group creation to keep functioning with this variable. (Variable Key: disable-reports-filtering-based-on-group-type, Component: Entire System, Value: true ) By using this variable - all the reports of a certain type will be presented in the list for picking with no expensive validation if the results translate on objects of the declared type or with failures in case there are accidental bad sql reports - when the picking list is presented. The validation is performed only after the report is selected, for that one single report of interest . |
| 4. Listing TPM Users | Search by user name introduced in parallel with fetching from db and apply db-truncation |
| 5. Removing Software from Compliance | Changing the n/n number next to the compliance check (which gives you a machine score) to a simple YES/NO. Global settings variable needs to be defined as (Key:compliance-summary-ui, Component: Compliance Configuration, Value: true) |
| 6. Computer 'General' tab | A high level overall compliance status to be displayed in the general tab in the form of YES/NO/Configuration required. Global settings variable needs to be defined >> SAME variable as previously mentioned for item 5. (Key: compliance-summary-ui, Component: Compliance Configuration, Value: true) |
| 7. Upgrade Software | The validation routines for upgradeable software on the endpoints were a major source of performance degradation for very large scale data (e.g. over one milion records in the software resource db table). Please see the details in the above section "Upgrade Software UI behaviour has been changed to accommodate a large scale data" |
Mandatory Post-Installation Steps to verify the IFIX installation
------------------------------------------------------------------
After ifix is updated, please verify the IFIX
a. Start TPM server
b. Run tioStatus.cmd/tioStatus.sh
c. Login to TPM UI
d. Run a workflow (i.e. no_operation)
Trademarks and Service Marks
The following are trademarks or registered trademarks of IBM Corporation in the
United States and other countries:
IBM WebSphere Tivoli DB2
Windows is a trademark of Microsoft Corporation in the United States, other
countries, or both.
Other company, product, or service names may be trademarks or service marks
of others.
| URL | LANGUAGE | SIZE(Bytes) |
|---|---|---|
| 5.1.1.3-TIV-TIO-IF00004.README | English | 17950 |
Download package
| Download | RELEASE DATE | LANGUAGE | SIZE(Bytes) | Download Options |
|---|---|---|---|---|
| 5.1.1.3-TIV-TIO-IF00004.jar | 12/2/2010 | English | 980145930 | HTTP |
| 5.1.1.3-TIV-TIO-IF00004.md5 | 12/2/2010 | English | 62 | HTTP |
Technical support
http://www-306.ibm.com/software/sysmgmt/products/support/IBMTivoliIntelligentOrchestrator.html
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Copyright and trademark information
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