IBM Fault Analyzer Plug-in for Eclipse (V10)

Downloadable files


Abstract

IBM Fault Analyzer Plug-in for Eclipse provides a graphical user interface to IBM Fault Analyzer for z/OS, V10 or V11.

Download Description

NOTE: To download the latest Fault Analyzer Plug-in go to the Latest IBM Problem Determination Tools Plug-ins Combined Packages page.

IBM Fault Analyzer Plug-in for Eclipse provides easy access through a graphical user interface (GUI) on the workstation to Fault Analyzer for z/OS. The GUI provides access to problem reports for diagnosing mainframe application errors and ABENDs. Key features include:

  • An interface to manage views and multiple fault history files.
  • The ability to browse fault entries that were created during real-time analysis of abending programs.
  • A browser for browsing the dump storage associated with a fault entry.
  • A source listing of abending programs using side files.

Here is a screenshot of the Fault Analyzer GUI plug-in in action:



What's new
  • V10.1.0.8 (14 Jun 2013)
    • Fixed requirement of Java 1.7 in v10.1.0.7
  • V10.1.0.7 (3 May 2013)
    • Column filter settings are now case-insensitive
  • V10.1.0.6
    • Save columns and restore on restart
  • V10.1.0.5 (21 Mar 2012)
    • Fix minidump save in Eclipse workbench toolbar and key shortcut
  • V10.1.0.4 (4 Jan 2012)
    • Quick column configuration through context menu
    • History file refreshes by default after Eclipse startup
    • Fixed defect that prevents workspaces from being copied
    • Option to securely save password
    • Fix LPEX dependency issue (18 Jan 2012)
  • V10.1.0.3 (29 Sep 2011)
    • Fixed mixed case password defect
  • V10.1.0.2 (13 Jun 2011)
    • Faster Eclipse editor-based browsing
    • Bookmarks and task markers
    • Find and text search capability
    • Option to use default sidefiles
    • Option to choose the client's outgoing port
  • V10.1.0.1 (19 Oct 2010)
    • List of Last Accessed History Files is now always downloaded from the host, instead of being read from the cache.
    • Now receive messages from the main Fault Analyzer module, IDIDA.
    • Easier to understand diagnostic message when no mini-dump is present.
  • V10.1.0.0 (14 May 2010)
    • Initial release

Prerequisites

The following minimum hardware levels are required:

  • CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
  • RAM - 2.0 GB minimum, 3.0 GB recommended
  • Hard disk - at least 500 MB available space

    The following software is also required:
    • One of the following levels of the Microsoft Windows operating system:
      • Windows XP 32-bit
      • Windows Vista 32-bit
      • Windows Server 2008 32-bit
      • Windows 7 32-bit
    • One of the following Eclipse-based platforms:
  • Installation Instructions

    IBM Fault Analyzer for z/OS V10.1 or V11.1 users should download and install the V10 plug-in.
    1. To install the V10 plug-in:

    1. Review the "System requirements and prerequisites" section in the FA Plug-in V10 Readme PDF (available below) and verify that you have met all the requirements and installed all the prerequisites.
    2. Click on the HTTP link (in Download table, below) and save the compressed file for the V10 plug-in to your local machine.
    3. Extract the saved file to a temporary directory on your target machine. This will create the necessary installation files.
    4. Review the "Installing Fault Analyzer Plug-in for Eclipse...into CICS Explorer" section of the FA Plug-in V10 Readme PDF for instructions on how to complete the installation.
    URL LANGUAGE SIZE(Bytes)
    FA Plug-in V10 Readme PDF US English 1867776

    Download package

    Note that, aside from the LANGUAGE column defined in the download table below, this plug-in supports the following languages:

  • US English
  • Japanese
  • Korean
  • Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
    FA Plug-in V10 14 Jun 2013 US English 23150592 HTTP

    Technical support

    This plug-in is available at no charge to all licensed users of IBM Fault Analyzer for z/OS V10, or later. It is supplied under the standard terms and conditions of the IBM International Program License Agreement (IPLA) and of the associated License Information and other documentation, and provides a defect correction entitlement for those licensed users entitled to service for IBM Fault Analyzer for z/OS V10, or later. Service is available for this plug-in for as long as the IBM Fault Analyzer for z/OS product with which the plug-in is to be used is generally supported by IBM. In addition, IBM reserves the right to discontinue service on this plug-in when it is withdrawn from marketing by IBM. Please reference "IBM Fault Analyzer for z/OS" as the entitled product when contacting IBM and requesting support for this plug-in.

    Cross reference information
    Segment Product Component Platform Version Edition
    Host Transaction Processing CICS Transaction Server Explorer Windows 4.2, 4.1, 3.2, 3.1

    Product Alias/Synonym

    Fault Analyzer
    FA


    Rate this page:

    (0 users)Average rating

    Add comments

    Document information


    More support for:

    Fault Analyzer for z/OS
    Plug-in

    Software version:

    10.1, 11.1, 12.1

    Operating system(s):

    Windows, z/OS

    Reference #:

    4026607

    Modified date:

    2013-10-18

    Translate my page

    Machine Translation

    Content navigation