January 2006 IBM C++ Runtime Environment Components for AIX

Downloadable files


Abstract

January 2006 IBM C++ Runtime Environment Components for AIX

Download Description

If you need to run an application developed using the IBM XL C/C++ Enterprise Edition V7.0 or V8.0 for AIX compiler, or the IBM VisualAge C++ Professional V6.0 for AIX (on AIX 5L only), and if you do not have the compiler installed, then you will need to install the IBM C++ Runtime Environment Components for AIX ("the Runtime") package.

The following APARs were fixed in this Runtime PTF:


    IY78873 - Users of std::list<...>::erase
    IY79071 - istream::getline() behaves incorrectly
    IY79422 - Performance issues of munch component
    IY80656 - Memory leak using newer run-time
    IY80737 - January 2006 XL C/C++ V8.0 for AIX Runtime PTF


The following files are included in the Runtime PTF package:

    xlC.aix50.rte.8.0.0.0
    xlC.aix50.rte.8.0.0.2
    xlC.msg.Ja_JP.rte.8.0.0.0
    xlC.msg.en_US.rte.8.0.0.0
    xlC.msg.ja_JP.rte.8.0.0.0
    xlC.rte.8.0.0.0
    xlsmp.aix50.rte.1.6.0.0
    xlsmp.msg.EN_US.rte.1.6.0.0
    xlsmp.msg.JA_JP.rte.1.6.0.0
    xlsmp.msg.Ja_JP.rte.1.6.0.0
    xlsmp.msg.ZH_CN.rte.1.6.0.0
    xlsmp.msg.Zh_CN.rte.1.6.0.0
    xlsmp.msg.en_US.rte.1.6.0.0
    xlsmp.msg.ja_JP.rte.1.6.0.0
    xlsmp.msg.zh_CN.rte.1.6.0.0
    xlsmp.rte.1.6.0.0


Note: on AIX 5L the V8 Runtime has superseded the V7 Runtime. The final V7 Runtime PTF can be obtained from the URL below. The V6 Runtime PTFs will continue to be published until further notice for use with applications built with VisualAge C++ V6 on AIX 4.3 only.


Terms and Conditions
This Runtime is to be used only with applications developed with IBM VisualAge C++ Professional V6.0 for AIX and IBM XL C/C++ Enterprise Edition V7.0 and V8.0 for AIX. You may not use any part of this software with other applications or programs. For further details regarding the terms and conditions for using this software please refer to LicenseAgreement.pdf and LicenseInformation.pdf in the Download Package section.

Prerequisites

The Runtime requires AIX 5L with the following level of the bos.rte.libc fileset (depending on your AIX 5L version):


  • AIX 5.1: bos.rte.libc 5.1.0.62 (APAR IY58419)

  • AIX 5.2: bos.rte.libc 5.2.0.41 (APAR IY58421)

  • AIX 5.3: bos.rte.libc 5.3.0.3 (APAR IY58143)



These filesets can be downloaded from IBM eServer Support Fix Central:
http://www.ibm.com/support/fixcentral/

Installation Instructions

Click below for installation instructions.

URL LANGUAGE SIZE(Bytes)
Installation Instructions English 1

Download package

Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
xlc.rte.aix50.jan2006.ptf.tar.Z 1/31/2006 English 33606667 FTP
LicenseAgreement.pdf 1/31/2006 English 1724155 FTP
LicenseInformation.pdf 1/31/2006 English 789115 FTP
README 1/31/2006 English 1 HTTP

Technical support

The C++ Runtime Environment for AIX is not supported as a stand-alone software product.

Support for questions and problems relating to installation of the C++ Runtime Environment is available as part of AIX Software Maintenance (SWMA).

If you suspect a problem with the C++ Runtime Environment while using it with a third-party application, contact your application provider for support.

Full support (installation, defect support and general questions) for the C++ Runtime Environment is available with the software maintenance agreement for the XL C++ Compilers. A suitable test case is required for defect support; click here for details.

Latest updates
Click here for the list of latest product updates for IBM C and C++ compilers.

Cross reference information
Segment Product Component Platform Version Edition
Software Development XL C/C++ for AIX C/C++ Runtime AIX All Versions Not applicable


Problems (APARS) fixed
IY78873, IY79071, IY79422, IY80656, IY80737, IY73096, IY73588, IY73811, IY75005, IY75632, IY76552, IY76555, IY78922, IY78923, IY78924, IY78930, IY78932, IY78933

Rate this page:

(0 users)Average rating

Document information


More support for:

XL C/C++
C/C++ Runtime

Software version:

6.0, 7.0, 8.0

Operating system(s):

AIX

Reference #:

4011532

Modified date:

2008-05-15

Translate my page

Machine Translation

Content navigation