LotusScript samples used to recover corrupt documents

Downloadable files


Abstract

This document contains a link to an IBM Lotus Word Pro document that contains two sample scripts.

Download Description

This document contains a link to an IBM Lotus Word Pro document that contains two sample scripts. Sometimes corrupt files crash the application a number of seconds after opening the file. Because a crash can occur quickly, there may not be time to do a File --> Save or File --> Save As before the crash, especially if the crash is unexpected. This is where LotusScript can help, since it's much faster than manually saving the file. This document contains a link to a Word Pro document that contains two sample scripts. You can use the scripts to open a file and either save it in Word Pro format, or save it as a Microsoft Word file. For more information, refer to Document #7002671, "Diagnosing and recovering corrupt or damaged files," http://www.ibm.com/support/docview.wss?rs=899&uid=swg27002671 NOTE: It is very important that the install instructions listed below be followed in order for the files to work.

Prerequisites

Existing install of Word Pro.

URL LANGUAGE SIZE(Bytes)
Diagnosing and recovering corrupt or damaged files US English 5000

Installation Instructions

IMPORTANT: By downloading and using this Code, you agree to these terms and conditions: The software samples, updates and fixes ("Code") available in this archive or on this web site for this Program are copyrighted materials. By clicking the download link below, you agree that the Code is provided under, and is subject to, the terms and conditions of the license agreement(s) which accompanied or were contained in the copy or copies of the Program for which you are obtaining the Code. You are not authorized to install or use the Code except as part of a Program for which you have a valid Proof of Entitlement or other authorization as specified in such license agreement(s). You further agree that you will comply with all applicable laws and export regulations. 1. Click the following link and download the file to your computer: ftp://public.dhe.ibm.com/software/lotus/fixes/SmartSuite/WP_FilesRecov.zip 2. Unzip the file and detach it to the directory containing your Word Pro files (by default, c:\lotus\work\wordpro). NOTE: The files you want to recover should be located in your default Word Pro documents directory. 3. Open the detached file and, from the Edit menu, choose Scripts & Macros --> Show Script Editor. 4. In the Script Editor, do one of the following: -- In the Script list, choose OpenSaveClose and modify this script with the corrupt file name. This script will immediately open the file, save it and close it. -- In the Script list, choose OpenSaveAsClose and modify this script with the corrupt file name. This script will immediately open the file, save it and export it to MS Word. 5.From the Script menu, choose Run Current Sub.

Download package

Download RELEASE DATE LANGUAGE SIZE(Bytes) Download Options
WP_FilesRecov.zip 07/24/2000 US English 11400 FTP

Cross reference information
Segment Product Component Platform Version Edition
Applications - Desktop & Enterprise Lotus SmartSuite Lotus SmartSuite for Windows Windows 9.8, 9.7, 9.6, 9.5, 9.1, 9.0

Product Alias/Synonym

Lotus SmartSuite
Lotus Word Pro


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Lotus SmartSuite
Lotus Word Pro for Windows

Software version:

9.0, 9.1, 9.5, 9.6, 9.7, 9.8

Operating system(s):

Windows

Reference #:

4003972

Modified date:

2003-10-06

Translate my page

Machine Translation

Content navigation