IBM Support

IBM FileNet Content Manager and IBM Content Foundation might encounter corrupt file errors while indexing a specific document format.

Technote (troubleshooting)


Problem(Abstract)

IBM FileNet Content Manager and IBM Content Foundation might encounter corrupt file errors when indexing older 1997-2003 Microsoft Word documents.

Symptom

When using OIT to index older Microsoft Word 1997 - 2003 documents, a "file is corrupt" error might occur.

Example error in the p8_server_error.log and p8_server_trace.log files:

2018-04-30T09:33:03.812 70A4D9E0 CBR FNRCE0000W - WARN Failed to convert C:\\CPE_storage\\os1_storage1\\content\\FN14\\FN2\\01AD250B-B75B-4A91-9C4D-74DA861EDFAD{71AD413E-FEA3-C871-87F4-631781A00000}0 for object:{71AD413E-FEA3-C871-87F4-631781A00000} class:CSSDocClass export error:9 file is corrupt \n


Note: "class:CSSDocClass" is dependent on the Doc Class in use.


Releases with the problem OIT version OIT Release date
5.2.1.7-P8CPE-IF001
5.2.1.7-P8CSS-IF001
OIT 8.5.3 p26438252 July 2017
5.5.0.0-P8CPE
5.5.0.0-P8CSS
OIT 8.5.3 p26438252 July 2017
5.2.1.7-P8CPE-IF002
5.2.1.7-P8CSS-IF002
OIT 8.5.3 p27695571 April 2018
5.5.1.0-P8CPE
5.5.1.0-P8CSS
OIT 8.5.3 p27695571 April 2018

Cause

The initial Oracle Outside In Technology (OIT) 8.5.3 release (p25456339), did not have this problem. All subsequent OIT 8.5.3 releases (p2643825 - July 2017) and higher, might encounter the Microsoft Word file corruption error.

Diagnosing the problem

To the best of our knowledge the failure occurs with indexing some Microsoft Word 1997-2003 formatted documents. Customers ingesting documents in that format may see "Failed to convert" warnings, with an "export error: 9 file is corrupt" message appended, in the P8 trace logs.

For example...


2018-03-21T14:34:34.724 A27821C8 CBR FNRCE0000W - WARN Failed to convert C:\\IBM\\WebSphere\\AppServer\\profiles\\AppSrv01\\FileNet\\CE1\\CSSTemp\\OS{55109D49-0DBB-44EE-91BC-5602C7C59F23}\\FN18\\FN7\\FN14\\FN{90AB4A62-0000-C1C7-B43A-ED5C484C0D9C}{DC3C116D-6DEA-4697-BE76-D263A76C7CDE}-0.doc for object:{90AB4A62-0000-C1C7-B43A-ED5C484C0D9C} class:CBRDocClass export error:9 file is corrupt


Resolving the problem

If already running a release that is known to have this problem, the only known work around is to re-save Microsoft Word 1997-2003 documents exhibiting this problem in a newer version of Microsoft Word (e.g. docx format) and to re-index those documents.

This issue has been reported to Oracle Outside In Technology (OIT) and is being tracked by Oracle Service Request SR 3-17127039481.

When Oracle releases an OIT fix for this problem, IBM will provide the fix in new IBM FileNet Content Manager and IBM Content Foundation releases.


Cross reference information
Segment Product Component Platform Version Edition
Enterprise Content Management FileNet Content Manager Content Search Services AIX, Linux, Solaris, Windows 5.5.0, 5.2.1
Enterprise Content Management Content Foundation Content Engine 5.5.1, 5.2.1
Enterprise Content Management Content Foundation Content Search Services 5.5.1, 5.2.1

Document information

More support for: FileNet Content Manager
Content Engine

Software version: 5.2.1, 5.5.0

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Reference #: 2015948

Modified date: 06 June 2018


Translate this page: