IBM Support

Disable Instant Messaging Chat Feature on IBM Control Desk

Question & Answer


Question

I would like to disable the IM Chat Feature on my IBM Control Desk product because I do not use it and it fills logfiles with error messages leading to some performance degradation. Error Messages such as GET /maximo/undefined HTTP/1.1" 404 fill up the logfiles.

Cause

IM Chat feature sending constant messages

Answer

You can disable this from the applications you are not using it in. e.g. To disable from Service Requests Application you can do so with the following steps:


1. Export the SR application xml (and save a copy) using Application Designer
2. Update the xml as follows:
Change all occurrences of
<imicon applink="
to
<textbox applink=

3. Import the updated SR.xml using Application Designer
4. Restart all the jvms and the http server

You can also do so on Incident, Problem with the same steps.

It is a good idea to keep a back up of the xml in case you would like to reactivate the IM Chat Feature again in the future. To do this you revert to using the 'imicon applink"

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSWT9A","label":"IBM Control Desk"},"ARM Category":[{"code":"a8m500000008b55AAA","label":"SRM Category (Service Desk, Service Catalog, Solutions and Surveys)->SRM - Service Desk Category->SRM - SD - Tickets (SR, Incidents, Problems)"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"All Version(s)","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
12 August 2020

UID

swg22015114