IBM Support

Content Store Deployment takes a very long time

Troubleshooting


Problem

When performing a Content Store Deployment export in Cognos 10.2 versions, it may take hours or even days to complete

Cause

This is possibly caused by a corrupted report which significantly delays the exporting process. Often, there are no errors recorded when this happens making it very difficult to narrow down the issue if performing a large export.

Note that exports can take a long time if the amount of data being exported is very large. However, it should still not take days to complete unless there are serious resource issues on the machine.

Resolving The Problem

Split the the export process to try to narrow down the issue.

When choosing the deployment method, select the "select public folders, directory and library content" section as the deployment method.

Then select the individual folders/packages and test these. This should enable you to break up the deployment process to further narrow down the issue.

Continue to narrow it down until the problem folder or package has been identified

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
13 February 2020

UID

swg22012573