Troubleshooting
Problem
After the installation of InfoSphere MDM V11.6.0.3, the Web Reports UI and Enterprise Viewer UI cannot be opened.
Symptom
The Enterprise Viewer UI and WebReports UI do not open.
Cause
This failure to open the virtual MDM user interfaces can be caused by the presence of a higher version of a JAR file in the same profile and loaded by the same server.
Environment
All environments
Resolving The Problem
To resolve this problem:
- Copy xmlsec-2.0.8.jar from <WAS_PROFILE_DIR>\installedApps\<CELL>\MDM-web-services-virtual-<INSTANCE_ID>.ear\ibminitiatews.war\WEB-INF\lib
to
<WAS_PROFILE_DIR>\installedApps\<CELL>\webreports-<INSTANCE_ID>.ear\webreports.war\WEB-INF\lib - Remove xmlsec-1.4.5.jar from <WAS_PROFILE_DIR>\installedApps\<CELL>\webreports-<INSTANCE_ID>.ear\webreports.war\WEB-INF\lib
- Copy xmlsec-2.0.8.jar from <WAS_PROFILE_DIR>\installedApps\<CELL>\MDM-web-services-virtual-<INSTANCE_ID>.ear\ibminitiatews.war\WEB-INF\lib
to <WAS_PROFILE_DIR>\installedApps\<CELL>\viewer-<INSTANCE_ID>.ear\viewer.war\WEB-INF\lib - Remove xmlsec-1.4.5.jar from <WAS_PROFILE_DIR>\installedApps\<CELL>\viewer-<INSTANCE_ID>.ear\viewer.war\WEB-INF\lib
[{"Product":{"code":"SSWSR9","label":"IBM InfoSphere Master Data Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.6.0.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
27 April 2022
UID
swg22011590